Witam,
chciałbym się podzielić informacjami odnośnie podglądu parametrów łącza w technologii GPON.
Posiadacze ONT Huawei HG8010 mogą się dostać na niego przez przeglądarkę internetową na adresie 192.168.4.254, ale jak to zrobić będąc za routerem z OpenWRT? Musimy stworzyć nowy interfejs.
W moim przypadku jest to interfejs ONT stworzony na routerze TP-link WDR 3600:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'xxxxxxxxxxx'

config interface 'lan'
        option type 'bridge'
        option igmp_snooping '1'
        option ifname 'eth0.1'
        option force_link '1'
        option proto 'static'
        option ipaddr '10.0.0.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option mtu '1492'

config interface 'wan'
        option proto 'pppoe'
        option ifname 'eth0.35'
        option ipv6 'auto'
        option keepalive '0'
        option mtu '1492'
        option username 'xxxxxxx@neostrada.pl'
        option password 'xxxxxxxx'

config interface 'ONT'
        option ifname 'eth0.3'
        option proto 'static'
        option ipaddr '192.168.4.253'
        option netmask '255.255.255.0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '5 4 3 2 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '35'
        option ports '1t 0t'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option vid '3'
        option ports '1 0t'

Jak widzicie WAN jest na eth0.35, czyli VLAN 35 na którym jest internet od pomarańczy i nie dało się zmusić ONT na tym interfejsie do współpracy, musiałem stworzyć nowy VLAN specjalnie dla ONT.

Na koniec trzeba dodać jeszcze ONT do wpisów w firewall:

uci set firewall.@zone[1].network='wan ONT'
uci commit firewall
fw reload

Dostęp do HG8010:
nazwa użytkownika - root
hasło - admin

Wszelkie sugestie i uwagi mile widziane

Pozdrawiam

Tu masz konfigurację dla Orange światłowód na TP-Link TL-WDR3600.

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdc4:1700:3fef::/48'

config interface 'lan'
        option type 'bridge'
        option igmp_snooping '1'
        option ifname 'eth0.1'
        option force_link '1'
        option proto 'static'
        option ipaddr '10.0.0.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option mtu '1492'

config interface 'wan'
        option proto 'pppoe'
        option ifname 'eth0.35'
        option ipv6 'auto'
        option keepalive '0'
        option mtu '1500'
        option username 'xxxxxx@neostrada.pl'
        option password 'xxxxxxx'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'
        option mirror_source_port '0'
        option mirror_monitor_port '0'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '2 3 4 5 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '35'
        option ports '1t 0t'

A jak ją wgrać dowiesz się z tego forum.

Powodzenia

Czyli masz ONT przed funboxem? Jeśli tak to wyrzuć funboxa i ustaw swój router jako podstawowy. Konfigurację na ten router Ci wyślę.

Witam,
mam pytanie do Ciebie, w jakiej technologii masz internet od dostawcy, bo fanbox występuje w 3 wersjach.
Jak się tego dowiem to będę miał pewne rozwiązanie dla Ciebie.

Pozdrawiam

Ja mam TP-Link TL-WDR3600, czyli prawie to samo, na najnowszym Openwrt wyciąga prawie 600 Mb/s.

Tu masz konfigurację:

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fd4a:7869:1114::/48'

config interface 'lan'
    option force_link '1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '10.0.0.1'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option ifname 'eth0.1'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option vid '1'
    option ports '0 2 4 6t'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option vid '35'
    option ports '5 6t'

config interface 'wan'
    option ifname 'eth0.35'
        option ipv6 'auto'
        option keepalive '0'
        option mtu '1500'
        option username 'xxxxxxx@neostrada.pl'
        option password 'xxxxxxx'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

Witaj,
ten router za dużo nie wyciąga, testowany na światełku max. ok. 100 Mb/s.

8

(41 odpowiedzi, napisanych Oprogramowanie)

Witam,
sprawdź na ichniejszym modemie czy nie ma gdzieś info na jakim VLAN ID idzie ich internet, w funbox od OPL jest taka informacja, to może i u nich się znajdzie.
Potem zasugeruj się ustawieniami dla FTTH od pomarańczy i skonfiguruj podobnie zmieniając VLAN.

Pozdrawiam

9

(1,271 odpowiedzi, napisanych Oprogramowanie)

Cezary,
a coś dla posiadaczy TP-LINK TD-W8970? Planujesz swoje obrazy?

10

(399 odpowiedzi, napisanych Oprogramowanie)

Coś mi się zdaje, że statystyki zostały objęte ochroną przez RODO...

...MAC adres lub IP stanowi daną osobową. W świetle RODO – tak.

https://datamakesales.pl/rodo-czyli-rew … osobowych/

11

(0 odpowiedzi, napisanych Oprogramowanie)

Witam,
mam pytanie, czy jest możliwość ustawienia modulacji ma tym routerze?
Aktualnie mam auto, a chciałbym wymusić g.dmt, ponieważ na długiej linii ta modulacja sprawdza się lepiej od adsl2+.

Pozdrawiam

12

(651 odpowiedzi, napisanych Oprogramowanie)

Pytanie do Cezarego,
czy można liczyć na Twoje obrazy LEDE na ten router? O Gargoyle nawet nie marzę...

13

(3 odpowiedzi, napisanych Oprogramowanie)

Cezary, jeśli chodzi o linie adsl to wszystko może mieć wpływ na jej działanie, ja jako technik PT OPL spotkałem się już z różnego rodzaju przypadkami o których wydawało by się, że nie maja prawa wpływać na tą usługę. Zasilacze w TP-Linkach są tak badziewne, że one na 99% są odpowiedzialne za pojawiające się błędy na linii.

Pozdrawiam

14

(112 odpowiedzi, napisanych Oprogramowanie)

TP-Link TD-W8970 v1

Ilość portów USB 2

https://wiki.openwrt.org/toh/tp-link/td-w8970

15

(13 odpowiedzi, napisanych Oprogramowanie)

Cezary, a może to jest wina tego, że ja mam ten port jako WAN, a mkkm2 ma jako zwykły LAN.
Zobacz, ja mam port 4 nie podniesiony, a on ma, a znowu ja mam port 5 podniesiony i fizycznie to jest LAN4/WAN.

16

(13 odpowiedzi, napisanych Oprogramowanie)

Wszystkie porty podłączone, port LAN4/WAN wydzielony jako WAN2.

17

(13 odpowiedzi, napisanych Oprogramowanie)

Proszę bardzo:

swconfig dev switch0  show | grep link
        link: port:0 link:up speed:1000baseT full-duplex auto
        link: port:1 link:down
        link: port:2 link:up speed:100baseT full-duplex auto
        link: port:3 link:down
        link: port:4 link:down
        link: port:5 link:up speed:100baseT full-duplex auto
        link: port:6 link:up speed:1000baseT full-duplex auto

Wersja v1.2

18

(651 odpowiedzi, napisanych Oprogramowanie)

Raczej nie powinno być innej wersji sprzętowej, ponieważ OPL dostarczało tylko tą wersje dla klientów w Polsce.

A tak na marginesie pytanie do Cezarego, czy jest szansa na Twojego nowego gargulca na ten router?

19

(12 odpowiedzi, napisanych Oprogramowanie)

Poszukaj sobie na pewnym znanym portalu aukcyjnym Sagema F@st 2704, ja widziałem za 19 PLN.

Wrócisz normalnie do oryginalnego softu, tu masz soft orange do tego modelu: https://dl.dropboxusercontent.com/u/603 … _5_38_6a4N

A w configu mwan3 gdzie wstawiłeś tą sekcje, przed domyślnymi trasami czy za?

22

(3 odpowiedzi, napisanych Oprogramowanie)

I jak ma wgrany obraz Cezarego to jeszcze wyłączyć WAN na eth4:)

23

(16 odpowiedzi, napisanych Oprogramowanie)

Router: Sagemcom F@st 2704 + modem ADSL
Łącza: Linia ADSL oraz lokalny operator w technologii WiMAX
Konfiguracja: Router w multiwanie z wykorzystaniem pakietu MWAN3, na Fast wydzielone dwa wany na porcie 1 i 2 switcha. Stworzony interfejs "modem" w celu możliwości wchodzenia na modem i sprawdzania aktualnych statystyk łącza adsl.

wynik polecenia uci show network dla Sagemcom F@ST 2704:

root@OpenWrt:~# uci show network
network.loopback=interface
network.loopback.ifname='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.lan=interface
network.lan.ifname='eth0.1'
network.lan.force_link='1'
network.lan.type='bridge'
network.lan.proto='static'
network.lan.ipaddr='10.0.0.1'
network.lan.netmask='255.255.255.0'
network.@switch[0]=switch
network.@switch[0].name='eth0'
network.@switch[0].reset='1'
network.@switch[0].enable_vlan='1'
network.@switch_vlan[0]=switch_vlan
network.@switch_vlan[0].device='eth0'
network.@switch_vlan[0].vlan='1'
network.@switch_vlan[0].ports='2 3 8t'
network.@switch_vlan[1]=switch_vlan
network.@switch_vlan[1].device='eth0'
network.@switch_vlan[1].vlan='2'
network.@switch_vlan[1].ports='0 8t'
network.wan=interface
network.wan.proto='pppoe'
network.wan.ifname='eth0.2'
network.wan.username='xxxxxxx@neostrada.pl'
network.wan.password='xxxxxxx'
network.wan.keeoalive='3 5'
network.wan.metric='1'
network.wan.dns='194.204.159.1 194.204.152.34'
network.modem=interface
network.modem.ifname='eth0.2'
network.modem.proto='static'
network.modem.ipaddr='192.168.10.1'
network.modem.netmask='255.255.255.0'
network.@switch_vlan[2]=switch_vlan
network.@switch_vlan[2].device='eth0'
network.@switch_vlan[2].vlan='3'
network.@switch_vlan[2].ports='1 8t'
network.wan2=interface
network.wan2.proto='dhcp'
network.wan2.ifname='eth0.3'
network.wan2.metric='2'
network.wan2.dns='217.8.168.244 157.25.5.18'
root@OpenWrt:~# 

Z f@st robisz router, jak zainstalujesz obrazy Cezarego to WAN masz na porcie 4 switcha, z tendy robisz modem czyli ustawiasz go w tryb bridge, WAN na fast konfigurujesz jako pppoe. I wcale nie jest to słabe urządzenie, http://wiki.openwrt.org/toh/sagem/fast2704.

25

(651 odpowiedzi, napisanych Oprogramowanie)

Witam,
po wgraniu obrazu CC rc3 Cezarego, router nie wstaje, czeka mnie zabawa z serialem.