1

(404 odpowiedzi, napisanych Sprzęt)

Będę pamiętała na przyszłość, a tymczasem zrobiłam ręcznie.
OpenWrt VPE: https://chomikuj.pl/ZuzannaCK/ROUTERY/E … 39428.json
OpenWrt SMP: https://chomikuj.pl/ZuzannaCK/ROUTERY/E … 86055.json

2

(404 odpowiedzi, napisanych Sprzęt)

Dziękuję. Jak znaleźć ten soft w Twojej bazie/wyszukiwarce https://dl.eko.one.pl/firmware ?

3

(404 odpowiedzi, napisanych Sprzęt)

@Cezary, możesz uaktualnić obrazy u siebie https://dl.eko.one.pl/projekty/easybox904xdsl/ ?

Revovery-VPE: https://github.com/zuzia-dev/Easybox-90 … ge.img-VPE
Opis: https://chomikuj.pl/ZuzannaCK/ROUTERY/E … wersja+VPE

Recovery-SMP: https://github.com/zuzia-dev/Easybox-90 … ge.img-SMP
Opis: https://chomikuj.pl/ZuzannaCK/ROUTERY/E … wersja+SMP

OpenWrt VPE: https://github.com/zuzia-dev/Easybox-90 … pgrade.bin
Opis: https://chomikuj.pl/ZuzannaCK/ROUTERY/E … SL-WAN)-v5

OpenWrt SMP: https://github.com/zuzia-dev/Easybox-90 … pgrade.bin
Opis: https://chomikuj.pl/ZuzannaCK/ROUTERY/E … SL-WAN)-v5

Zrobione na bazie forka: https://github.com/Plonkbong/openwrt/tree/xrx200-1 tzn. biorę patche i nakładam na master.

4

(404 odpowiedzi, napisanych Sprzęt)

@kipronar, Encrypted SNI zostało wycofane przez Mozillę od FF85 i zastąpione przez ECH. W FF78 esr  SNI nada działa. Tak w ogóle można całkiem wyłączyć DNS over HTTPS w przeglądarce, wystarczy to co robi router - wszystkie zapytania idą via DNS over TLS i są szyfrowane. Dla zaawansowanych użytkowników jest skrypt: /etc/DNS-crypt-test
Z przeglądarkowych warto sprawdzić te:
https://dnssec.vs.uni-due.de
https://dnsleaktest.com

Masz rację, Disks-Info przepadł, bo coś się pokręciło, ale można go doinstalować:

opkg install luci-app-disks-info

Kopia programów jest też tu: https://chomikuj.pl/ZuzannaCK/Programy+OpenWrt/mips
Skoro reszta działa nie będę już nic ruszać. Dziękuję za uwagi.

5

(404 odpowiedzi, napisanych Sprzęt)

@kipronar, dziękuję za sprawdzenie, naniosłam poprawki.

Udostępniłam wersję SMP.

OpenWrt 19.07 Easybox 904 [SMP] (kernel 5.4.116) - wersja mini

Link:  https://chomikuj.pl/ZuzannaCK/ROUTERY/E … SL-WAN)-v5

Domyślnie port DSL działa jako WAN, jednym kliknięciem można przekonfigurować na xDSL. Wersja dość funkcjonalna, ale lekka, bez zbędnego softu, szyfrowania DNS, brak telefonii VoIP (SMP nie ma takiej możliwości).

6

(404 odpowiedzi, napisanych Sprzęt)

OpenWrt 19.07 Easybox 904 [VPE] (kernel 5.4.116) - wersja mini

Link:  https://chomikuj.pl/ZuzannaCK/ROUTERY/E … SL-WAN)-v5

Domyślnie port DSL działa jako WAN, ale można prosto przekonfigurować na xDSL. Wersja bardziej zgodna z duchem OpenWrt, bez zbędnego softu, szyfrowania DNS, brak Asteriska (ale można zmienić jednym kliknięciem).

Zachowałam jednak pewną funkcjonalność więc jest obsługa nośników danych i modemów oraz kilka lekkich i przydatnych dodatków z githuba Rafała:
https://github.com/4IceG/luci-app-disks-info
https://github.com/4IceG/luci-app-internet-detector
https://github.com/4IceG/luci-app-diskman
https://github.com/4IceG/luci-app-3ginfo
https://github.com/4IceG/luci-app-sms-tool
https://github.com/4IceG/luci-app-atinout-mod
https://github.com/4IceG/luci-app-timecontrol
Dodałam nowszą wersję parted: https://github.com/openwrt/packages/pull/15484 i zaktualizowałam skrypt Sysinfo od Cezarego. Pliki ipk z tymi apkami są w moim repozytorium online więc można sobie je reinstalować. Natomiast poniższe dodatki są w repozytorium, ale nie w obrazie, można doinstalować:
https://github.com/4IceG/luci-app-cpu-status-mini
https://github.com/gSpotx2f/luci-app-cpu-status
https://github.com/openwrt/luci/pull/4651 (luci-app-throughput-measurements)
https://github.com/openwrt/luci/pull/4595 (luci-app-packet-capture)

PS. Wkrótce udostępnię wersję SMP.

7

(404 odpowiedzi, napisanych Sprzęt)

Dziękuję Wam za wszelkie uwagi smile @kipronar, ficzer od skanowania WiFi zniknął, bo jest błąd związany z libiwinfo, który można prosto naprawić poleceniem:

ln -s /usr/lib/libiwinfo.so.20210420 /usr/lib/libiwinfo.so

Dla nowszej wersji:

ln -s /usr/lib/libiwinfo.so.20210430 /usr/lib/libiwinfo.so

To nie jedyny błąd w tym dodatku, niestety, ale jest już dodany w oficjalnej wersji OpenWrt więc trzeba się z tym męczyć.

PS. Kolejna prośba do Ciebie o przetestowanie wersji mini, w sensie, czy Twoje łącze działa poprawnie.

Wszystko wróciło, znowu można pobierać smile

Adblock v4 zawiera KAD: https://kadantiscam.netlify.app/  który ma listę od Cert. Wystarczy włączyć w Adblocku wally3k.

10

(404 odpowiedzi, napisanych Sprzęt)

@gbanachewicz749
OpenWrt można wgrywać przy zablokowanym bootloaderze, ale zalecam wgranie odblokowanego, można to zrobić w dowolnym momencie, Instrukcja: https://chomikuj.pl/ZuzannaCK/ROUTERY/E … bootloader

11

(404 odpowiedzi, napisanych Sprzęt)

Witam po dłuższej przerwie smile Ponieważ nikt nie chce aktualizować firmware do naszego routera odświeżam temat.

OpenWrt 19.07 Easybox 904 [VPE] (kernel 5.4.115) - wersja rozszerzona

Link:  https://chomikuj.pl/ZuzannaCK/ROUTERY/E … iFi_USB)v5

OpenWrt SNAPSHOT r16595-f4473baf6e. Nowy kernel i Asterisk 18.3.0 LTS oraz Dnsmasq 2.85. Dwie wersje, xDSL oraz WAN dla kablówki.

Kernel 5.4.115, Dmsmasq 2.85 oraz Asterisk 18.3.0 LTS nie weszły jeszcze oficjalnie do OpenWrt, ale załączyłam do obrazu, bo rozwiązują kilka problemów i zawierają poprawki bezpieczeństwa. Wersja WAN przetestowana. Wersję ADSL/VDSL należy sprawdzić, bo trochę pozmieniało się w obsłudze tego typu łącz dla Lantiq. Dodane su, sudo oraz: https://github.com/4IceG/luci-app-timecontrol
Reszta apek od  4IceG/IceG została zaktualizowana do najnowszych wersji. Ablock jest skonfigurowany i aktywny.

PS. Transfer darmowy. Jak znajdę czas zrobię obrazy SMP. W sumie wyjdzie cztery wersje obrazów, ale to jedyne sensowne rozwiązanie.

Edit:

OpenWrt 19.07 Easybox 904 [SMP] (kernel 5.4.115) - wersja rozszerzona

Link:  https://chomikuj.pl/ZuzannaCK/ROUTERY/E … iFi_USB)v5

Bez VoIP  oraz Asteriska, z obsługą dwóch rdzeni CPU. W stosunku do wersji VPE odczuwalny jest wzrost wydajności, ale telefonia nie będzie działać.

12

(404 odpowiedzi, napisanych Sprzęt)

@meierhans. Thanks, very helpful comments and suggestions smile Support for SMP version is in progress, please be patient.
@ziko, trwa porządkowanie, dam znać jak zawartość wróci.

13

(404 odpowiedzi, napisanych Sprzęt)

@kipronar
Podjęłam jeszcze jedną próbę, bo jak mówią do trzech razy sztuka smile Teraz wydaje się działać. Musiałam cofnąć pakiety adsl/vdsl do wcześniejszych wersji i trochę poprawić ręcznie. Dorzuciłam pakiet whois. Link ten sam: https://chomikuj.pl/ZuzannaCK/ROUTERY/E … iFi_USB)v4

14

(404 odpowiedzi, napisanych Sprzęt)

@kipronar, dziękuję za test, jest problem z tym pakietem:

opkg install ltq-vdsl-app_4.17.18.6-5_mips_24kc.ipk
Unknown package 'ltq-vdsl-app'.
Collected errors:
 * pkg_hash_fetch_best_installation_candidate: Packages for ltq-vdsl-app found, but incompatible with the architectures configured
 * opkg_install_cmd: Cannot install package ltq-vdsl-app.

15

(404 odpowiedzi, napisanych Sprzęt)

Dziękuję za uwagi, skasowałam wszystko, obrazy i repo poszły do kosza, pobrałam źródła od nowa i są dostępne nowe pliki, link ten co wyżej: https://chomikuj.pl/ZuzannaCK/ROUTERY/E … iFi_USB)v4

Mam nadzieję, że wersja xDSL będzie funkcjonowała poprawnie, wersję WAN wgrywam do swojego egzemplarza i po wstępnych testach udostępniam więc jest sprawdzona.

Dodałam graficzną nakładkę na Tcpdump i taki ficzer:

PunBB bbcode test

Przydatne jak ktoś korzysta z dodatkowej karty na USB. Aktualizowałam też pakiet luci-app-sms-tool do najnowszej wersji 1.8.2.

16

(404 odpowiedzi, napisanych Sprzęt)

Nowy kernel i Asterisk 18.01 LTS. Dwie wersje, xDSL oraz WAN dla kablówki.

OpenWrt 19.07 Easybox 904 [VPE] (kernel 5.4.77)

Link:  https://chomikuj.pl/ZuzannaCK/ROUTERY/E … iFi_USB)v4

Asterisk 18.01 LTS nie wszedł jeszcze oficjalnie do OpenWrt, ale udostępniam obraz, bo rozwiązuje kilka problemów nienaprawionych w wersji 16. Moja dość zaawansowana konfiguracja z poprzedniej wersji przeniosła się bez żadnych zmian.

Zrób jeszcze jedno podejście:

opkg update
opkg remove wpad*
opkg install wpad ca-certificates ca-bundle libopenssl

Zrestartuj router i sprawdź, czy możesz się połączyć.

W Luci łatwo sprawdzisz, czy EAP jest w systemie, wystarczy kliknąć na listę rozwijaną przy szyfrowaniu dla sieci bezprzewodowej. Jeśli jest WPA2-EAP wszystko zainstalowało się poprawnie. Tę konfigurację można wyklikać, ustawienia takie jak na zrzutach.

Aktualizacja i konfiguracji dla OpenWrt 19.07.

opkg update
opkg remove wpad*
opkg install wpad-wolfssl libwolfssl ca-bundle

Pobrać certyfikat (plik LGI_Root_CA.cer): https://www.unitymedia.de/content/dam/d … oot_CA.cer i skopiować programem winscp albo z Linuksa poleceniem:

scp LGI_Root_CA.cer root@192.168.1.1:/etc/ssl/certs/


I można już wyklikać konfigurację.

https://i.postimg.cc/G9t6r8SP/Skanowanie-i-do-aczenie-sieci.jpg

https://i.postimg.cc/Y4tyPhWW/1-Ustawienia-og-lne.jpg

https://i.postimg.cc/Y48yBM6y/2-Ustawienia-zaawansowane.jpg

https://i.postimg.cc/1nt792MR/3-Zabezpieczenia-sieci-bezprzewodowych.jpg


Tekstowo jako wzór dla konsolowców.

/etc/config/wireless

config wifi-iface 'wifinet0'
    option device 'radio0'
    option mode 'sta'
    option network 'upcwifree'
    option ssid 'UPC Wi-Free #SprawdzUPCMobile!'
    option encryption 'wpa2'
    option eap_type 'ttls'
    option auth 'MSCHAPV2'
    option ca_cert '/etc/ssl/certs/LGI_Root_CA.cer'
    option identity 'LOGIN'
    option password 'HASŁO'
    option disabled '0'

*Sekcja config wifi-iface 'wifinet0' może mieć inną nazwę nazwę: config wifi-iface.

/etc/config/network

config interface 'upcwifree'
    option proto 'dhcp'
    option ipv6 '0'
    option auto '1'

/etc/config/firewall

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option conntrack '1'
        option masq '1'
        option mtu_fix '1'
        option network 'wan wan6 upcwifree'

20

(498 odpowiedzi, napisanych Oprogramowanie)

Dziękuję za informację. Poczekam, aż master poradzi sobie z tematem.

21

(498 odpowiedzi, napisanych Oprogramowanie)

Lada moment naprawią: https://github.com/openwrt/openwrt/pull/3561

22

(498 odpowiedzi, napisanych Oprogramowanie)

Pytanie stąd, że kompiluję z mastera i nie chcę narobić się na darmo.

23

(498 odpowiedzi, napisanych Oprogramowanie)

Pytanie do wszystkich użytkowników, jak obecnie wygląda wsparcie w OpenWrt dla WiFi i wydajność LAN-WAN? Nada się pod łącze 1 Gbps?

24

(404 odpowiedzi, napisanych Sprzęt)

Sporo poprawek, aktualizacja softu, nowy kernel, dodany protokół  MBIM do Luci oraz apka od @IceG do wysyłania komend AT. Obrazy skompilowane na bazie pracy jednego z deweloperów: https://forum.openwrt.org/t/lantiq-xrx2 … uild/77105
Jeśli ktoś chce się bawić w samodzielną kompilację, źródła są tu: https://github.com/Plonkbong/openwrt/tree/xrx200-1

Dwie wersje, xDSL oraz WAN dla kablówki. Router wydaje się działać sprawniej, ale to wymaga dłuższych testów. Wszelkie uwagi mile widziane.

OpenWrt 19.07 Easybox 904 [VPE] (kernel 5.4.72)

Link:  https://chomikuj.pl/ZuzannaCK/ROUTERY/E … iFi_USB)v3

OpenWrt 19.07 Easybox 904 [SMP] (kernel 5.4.72)

Link:  https://chomikuj.pl/ZuzannaCK/ROUTERY/E … iFi_USB)v3

25

(51 odpowiedzi, napisanych Oprogramowanie)

Przydatne. Mały błąd:
https://i.postimg.cc/QKTfsV15/error.jpg
Pomaga:

chmod +x /usr/bin/luci-app-atinout