1

Temat: Działające konfiguracje xDSL

Ustawienia xDSL dla różnych linii. Proszę podać:
- model routera (np. TP-LINK TD-W8970)
- dokładną nazwę lini/usługi (np. Orange VDSL2 Neostrada Fiber)
- wynik

uci show network
Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

2 (edytowany przez Scotch 2016-03-20 23:45:22)

Odp: Działające konfiguracje xDSL

Routery: TP-Link TD-W8970, Zyxel P2812HNU-F3
Linia vdsl2, operator Orange (annex A):

Modyfikujemy 3 sekcje ('atm', 'wan', 'dsl') w pliku /etc/config/network

#config atm-bridge 'atm' - tą sekcję można usunąć
    #option vpi '1'
    #option vci '32'
    #option encaps 'llc'
    #option payload 'bridged'

config interface 'wan'
    option ifname 'ptm0.35'
    option proto 'pppoe'
    option username 'nazwa@użytkownika'
    option password 'hasło'
    option ipv6 '0'

config vdsl 'dsl'
    option firmware '/lib/firmware/vdsl.bin'
    option tone 'av'
    option xfer_mode 'ptm'

Wynik polecenia    uci show network dla TD-W8970:   

root@TD-W8970:~# uci show network
network.loopback=interface
network.loopback.ifname=lo
network.loopback.proto=static
network.loopback.ipaddr=127.0.0.1
network.loopback.netmask=255.0.0.0
network.globals=globals
network.globals.ula_prefix=fd5b:659d:811a::/48
network.lan=interface
network.lan.force_link=1
network.lan.type=bridge
network.lan.proto=static
network.lan.netmask=255.255.255.0
network.lan.ip6assign=60
network.lan.ifname=eth0.1
network.lan.macaddr=14:cc:20:57:57:e0
network.lan.ipaddr=192.168.1.100
network.@switch[0]=switch
network.@switch[0].name=switch0
network.@switch[0].reset=1
network.@switch[0].enable_vlan=1
network.@switch_vlan[0]=switch_vlan
network.@switch_vlan[0].device=switch0
network.@switch_vlan[0].vlan=1
network.@switch_vlan[0].ports=0 2 4 5 6t
network.wan=interface
network.wan.ifname=ptm0.35
network.wan.proto=pppoe
network.wan.username=nazwa@użytkownika
network.wan.password=hasło
network.wan.vci=35
network.wan.vpi=0
network.wan.ipv6=0
network.wan6=interface
network.wan6.proto=static
network.wan6.ifname=@wan
network.dsl=vdsl
network.dsl.annex=a
network.dsl.firmware=/lib/firmware/vdsl.bin
network.dsl.tone=av
network.dsl.xfer_mode=ptm
root@TD-W8970:~#

3

Odp: Działające konfiguracje xDSL

Router: Sagemcom F@st 2704 + modem ADSL
Łącza: Linia ADSL oraz lokalny operator w technologii WiMAX
Konfiguracja: Router w multiwanie z wykorzystaniem pakietu MWAN3, na Fast wydzielone dwa wany na porcie 1 i 2 switcha. Stworzony interfejs "modem" w celu możliwości wchodzenia na modem i sprawdzania aktualnych statystyk łącza adsl.

wynik polecenia uci show network dla Sagemcom F@ST 2704:

root@OpenWrt:~# uci show network
network.loopback=interface
network.loopback.ifname='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.lan=interface
network.lan.ifname='eth0.1'
network.lan.force_link='1'
network.lan.type='bridge'
network.lan.proto='static'
network.lan.ipaddr='10.0.0.1'
network.lan.netmask='255.255.255.0'
network.@switch[0]=switch
network.@switch[0].name='eth0'
network.@switch[0].reset='1'
network.@switch[0].enable_vlan='1'
network.@switch_vlan[0]=switch_vlan
network.@switch_vlan[0].device='eth0'
network.@switch_vlan[0].vlan='1'
network.@switch_vlan[0].ports='2 3 8t'
network.@switch_vlan[1]=switch_vlan
network.@switch_vlan[1].device='eth0'
network.@switch_vlan[1].vlan='2'
network.@switch_vlan[1].ports='0 8t'
network.wan=interface
network.wan.proto='pppoe'
network.wan.ifname='eth0.2'
network.wan.username='xxxxxxx@neostrada.pl'
network.wan.password='xxxxxxx'
network.wan.keeoalive='3 5'
network.wan.metric='1'
network.wan.dns='194.204.159.1 194.204.152.34'
network.modem=interface
network.modem.ifname='eth0.2'
network.modem.proto='static'
network.modem.ipaddr='192.168.10.1'
network.modem.netmask='255.255.255.0'
network.@switch_vlan[2]=switch_vlan
network.@switch_vlan[2].device='eth0'
network.@switch_vlan[2].vlan='3'
network.@switch_vlan[2].ports='1 8t'
network.wan2=interface
network.wan2.proto='dhcp'
network.wan2.ifname='eth0.3'
network.wan2.metric='2'
network.wan2.dns='217.8.168.244 157.25.5.18'
root@OpenWrt:~# 

4

Odp: Działające konfiguracje xDSL

TP-LINK TD-W8970 v1
Netia LLU ADSL2+ annex A

network.loopback=interface
network.loopback.ifname='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.globals.ula_prefix='fd43:df0a:71f3::/48'
network.lan=interface
network.lan.force_link='1'
network.lan.type='bridge'
network.lan.proto='static'
network.lan.netmask='255.255.255.0'
network.lan.ip6assign='60'
network.lan.macaddr='14:cc:20:ac:8b:b6'
network.lan.ipaddr='192.168.2.1'
network.lan._orig_ifname='eth0.1 wlan0 wlan0-1'
network.lan._orig_bridge='true'
network.lan.ifname='eth0.1'
network.@switch[0]=switch
network.@switch[0].name='switch0'
network.@switch[0].reset='1'
network.@switch[0].enable_vlan='1'
network.@switch_vlan[0]=switch_vlan
network.@switch_vlan[0].device='switch0'
network.@switch_vlan[0].vlan='1'
network.@switch_vlan[0].ports='0 2 4 5 6t'
network.wan=interface
network.wan._orig_ifname='nas0'
network.wan._orig_bridge='false'
network.wan.proto='pppoa'
network.wan.encaps='vc'
network.wan.atmdev='0'
network.wan.vci='35'
network.wan.vpi='0'
network.wan.username='uzytkownik@net24.com.pl'
network.wan.password='haslo'
network.wan.peerdns='0'
network.wan.dns='208.67.220.220 208.67.222.222'
network.wan.mtu='1478'
network.wan.metric='1'
network.wan6=interface
network.wan6.ifname='@wan'
network.wan6.proto='dhcpv6'
network.wan6.type='bridge'
network.dsl=vdsl
network.dsl.annex='a'
network.dsl.firmware='/lib/firmware/vdsl.bin'
network.dsl.tone='av'
network.dsl.xfer_mode='atm'
network.mobile=interface
network.mobile.proto='wwan'
network.mobile.apn='internet'
network.mobile.metric='2'
network.mobile.peerdns='0'
network.mobile.dns='208.67.220.220 208.67.222.222'
network.wlan=interface
network.wlan.type='bridge'
network.wlan.proto='static'
network.wlan.ipaddr='192.168.10.1'
network.wlan.netmask='255.255.255.0'
network.wlan.ip6assign='60'

5

Odp: Działające konfiguracje xDSL

TP-Link TD-W8970
Neostrada ADSL2+ (Annex A) Opcja 20480

Line State: showtime_tc_sync [0x801]
Line Speed: 19.204 Mb/s / 980 Kb/s
Line Attenuation: 15.1 dB / 7.8 dB
Noise Margin: 6.3 dB / 7.4 dB

network.loopback=interface
network.loopback.ifname='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.globals.ula_prefix='fd24:8df8:6a8e::/48'
network.lan=interface
network.lan.force_link='1'
network.lan.type='bridge'
network.lan.proto='static'
network.lan.ipaddr='192.168.1.1'
network.lan.netmask='255.255.255.0'
network.lan.ifname='eth0.1'
network.lan.macaddr='14:cc:20:ac:89:4e'
network.lan.delegate='0'
network.lan.ipv6='0'
network.guest=interface
network.guest.proto='static'
network.guest.ipaddr='10.10.10.1'
network.guest.netmask='255.255.255.0'
network.guest.delegate='0'
network.guest.ipv6='0'
network.@switch[0]=switch
network.@switch[0].name='switch0'
network.@switch[0].reset='1'
network.@switch[0].enable_vlan='1'
network.@switch_vlan[0]=switch_vlan
network.@switch_vlan[0].device='switch0'
network.@switch_vlan[0].vlan='1'
network.@switch_vlan[0].ports='0 2 4 5 6t'
network.wan=interface
network.wan._orig_ifname='nas0'
network.wan._orig_bridge='false'
network.wan.proto='pppoa'
network.wan.delegate='0'
network.wan.encaps='vc'
network.wan.atmdev='0'
network.wan.vci='35'
network.wan.vpi='0'
network.wan.username='xxx@neostrada.pl'
network.wan.password='xxx'
network.wan.pppd_options='holdoff 6'
network.wan.ipv6='0'
network.wan.peerdns='0'
network.wan.dns='208.67.220.220 208.67.222.222'
network.dsl=vdsl
network.dsl.annex='a'
network.dsl.firmware='/lib/firmware/vdsl.bin'
network.dsl.tone='av'
network.dsl.xfer_mode='atm'

6 (edytowany przez kurwicycek 2016-04-14 11:05:30)

Odp: Działające konfiguracje xDSL

ZyXEL P-2812HNU-F1
ADSL2+, Annex A, Netia, Linia TP/Orange długości ok 3km

Line State: showtime_tc_sync [0x801]
Line Speed: 11.464 Mb/s / 892 Kb/s
Line Attenuation: 41.9 dB / 22.5 dB
Noise Margin: 7 dB / 7.5 dB

http://www.speedtest.net/result/5249926700.png

network.loopback=interface
network.loopback.ifname='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.globals.ula_prefix='fd43:82a9:3b29::/48'
network.lan=interface
network.lan.force_link='1'
network.lan.type='bridge'
network.lan.proto='static'
network.lan.ipaddr='192.168.1.1'
network.lan.netmask='255.255.255.0'
network.lan.ip6assign='60'
network.lan.ifname='eth0.1'
network.lan.macaddr='00:01:02:03:04:05'
network.@switch[0]=switch
network.@switch[0].name='switch0'
network.@switch[0].reset='1'
network.@switch[0].enable_vlan='1'
network.@switch_vlan[0]=switch_vlan
network.@switch_vlan[0].device='switch0'
network.@switch_vlan[0].vlan='1'
network.@switch_vlan[0].ports='0 1 2 4 5 6t'
network.wan=interface
network.wan._orig_ifname='nas0'
network.wan._orig_bridge='false'
network.wan.proto='pppoa'
network.wan.encaps='vc'
network.wan.atmdev='0'
network.wan.vci='35'
network.wan.vpi='0'
network.wan.username='xxx@webnet24.pl'
network.wan.password='xxx'
network.dsl=vdsl
network.dsl.annex='a'
network.dsl.firmware='/lib/firmware/vdsl.bin'
network.dsl.tone='av'
network.dsl.xfer_mode='atm'

7

Odp: Działające konfiguracje xDSL

male pytanie, wszedzie macie ustawiony adres firmware na /lib/firmware/vdsl.bin
w LEDE niestety nie ma tego symlinka a upgrade (17.01) za kazdym razem go usuwa
poza tym howto nie opisuje ze trzeba wogole firmware zainstalować, a bywa
roznie - obrazy LEDE potrafily byc nawet z firmwarem annex B.

jak to powinno wygladac poprawnie?

8

Odp: Działające konfiguracje xDSL

W przypadku LEDE nie trzeba nic kombinować z firmware xdsl (zawiera firmware dla obu annexów).

Wystarczy jedynie odpowiednio skonfigurować parametry połączenia,
dla vdsl:

config dsl 'dsl'
    option xfer_mode 'ptm'
    option line_mode 'vdsl'
    option annex 'a'
    option tone 'av'

config interface 'wan'
    option ifname 'ptm0.35'
    option proto 'pppoe'
    option username 'xxx@neostrada.pl'
    option password 'xxx'
    option ipv6 '0'
    option delegate '0'

config device 'wan_dev'
    option name 'ptm0'
    option macaddr 'xx:xx:xx:xx:xx:xx'

dla adsl wg przykładu:   
https://lede-project.org/docs/user-guid … connection

9 (edytowany przez olek210 2019-12-26 18:16:11)

Odp: Działające konfiguracje xDSL

BT Home Hub 5A
Neostrada VDSL 80mb:

network.loopback=interface
network.loopback.ifname='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.globals.ula_prefix='fdbc:54aa:3bd2::/48'
network.dsl=dsl
network.dsl.annex='a'
network.dsl.tone='av'
network.dsl.xfer_mode='ptm'
network.dsl.line_mode='vdsl'
network.dsl.ds_snr_offset='-35'
network.lan=interface
network.lan.type='bridge'
network.lan.ifname='eth0.1'
network.lan.proto='static'
network.lan.netmask='255.255.255.0'
network.lan.ip6assign='60'
network.lan.ipaddr='192.168.2.2'
network.lan_dev=device
network.lan_dev.name='eth0.1'
network.lan_dev.macaddr='xx:xx:xx:xx:xx:xx'
network.wan=interface
network.wan.ifname='dsl0.35'
network.wan.proto='pppoe'
network.wan.password='xxxxxxxxx'
network.wan.ipv6='0'
network.wan.username='xxxxxxx@neostrada.pl'
network.wan_dev=device
network.wan_dev.name='dsl0'
network.wan_dev.macaddr='xx:xx:xx:xx:xx:xx'
network.wan6=interface
network.wan6.ifname='@wan'
network.wan6.proto='dhcpv6'
network.@switch[0]=switch
network.@switch[0].name='switch0'
network.@switch[0].reset='1'
network.@switch[0].enable_vlan='1'
network.@switch_vlan[0]=switch_vlan
network.@switch_vlan[0].device='switch0'
network.@switch_vlan[0].vlan='1'
network.@switch_vlan[0].ports='0 1 2 4 6t'
network.@switch_vlan[1]=switch_vlan
network.@switch_vlan[1].device='switch0'
network.@switch_vlan[1].vlan='2'
network.@switch_vlan[1].ports='5 6t'

Statystyki:

root@OpenWrt:~# /etc/init.d/dsl_control dslstat
ATU-C Vendor ID:                          Broadcom 164.125
ATU-C System Vendor ID:                   Broadcom
Chipset:                                  Lantiq-VRX200
Firmware Version:                         5.8.1.8.1.6
API Version:                              4.17.18.6
XTSE Capabilities:                        0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x2
Annex:                                    B
Line Mode:                                G.993.2 (VDSL2)
Profile:                                  17a
Line State:                               UP [0x801: showtime_tc_sync]
Forward Error Correction Seconds (FECS):  Near: 970 / Far: 276
Errored seconds (ES):                     Near: 0 / Far: 3
Severely Errored Seconds (SES):           Near: 0 / Far: 0
Loss of Signal Seconds (LOSS):            Near: 0 / Far: 0
Unavailable Seconds (UAS):                Near: 133 / Far: 133
Header Error Code Errors (HEC):           Near: 0 / Far: 0
Non Pre-emtive CRC errors (CRC_P):        Near: 8765 / Far: 0
Pre-emtive CRC errors (CRCP_P):           Near: 0 / Far: 0
Power Management Mode:                    L0 - Synchronized
Latency [Interleave Delay]:               8.0 ms [Interleave]   8.0 ms [Interleave]
Data Rate:                                Down: 59.866 Mb/s / Up: 6.015 Mb/s
Line Attenuation (LATN):                  Down: 14.6 dB / Up: 11.8 dB
Signal Attenuation (SATN):                Down: 14.6 dB / Up: 9.8 dB
Noise Margin (SNR):                       Down: 5.5 dB / Up: 7.8 dB
Aggregate Transmit Power (ACTATP):        Down: -18.0 dB / Up: 14.6 dB
Max. Attainable Data Rate (ATTNDR):       Down: 64.255 Mb/s / Up: 6.384 Mb/s
Line Uptime Seconds:                      596
Line Uptime:                              9m 56s

10

Odp: Działające konfiguracje xDSL

router: BT Home Hub 5a
usługa: NETIA Szybki Internet MAX 50  (na drutach DIALOGu)
długość łącza (w/g umowy) 2085m

DSL     Status: UP
Line State: showtime_tc_sync [0x801]

Line Mode: G.993.2 (VDSL2)
Annex: B
Profile: 17a
Data Rate: 60.000 Mb/s / 6.000 Mb/s
Max. Attainable Data Rate (ATTNDR): 68.807 Mb/s / 24.747 Mb/s
Latency: 8.0 ms / 4.0 ms
Line Attenuation (LATN): 15.6 dB / 16.7 dB
Signal Attenuation (SATN): 15.6 dB / 16.5 dB
Noise Margin (SNR): 9.7 dB / 22.3 dB
Aggregate Transmit Power(ACTATP): 8.5 dB / 14.5 dB
Forward Error Correction Seconds (FECS): 649429 / 144
Errored seconds (ES): 115 / 6
Severely Errored Seconds (SES): 0 / 0
Loss of Signal Seconds (LOSS): 0 / 0
Unavailable Seconds (UAS): 31 / 31
Header Error Code Errors (HEC): 0 / 0
Non Pre-emtive CRC errors (CRC_P): 243 / 0
Pre-emtive CRC errors (CRCP_P): 0 / 0
Line Uptime: 3d 4h 22m 4s
ATU-C System Vendor ID: Broadcom 164.140
Power Management Mode: L0 - Synchronized

wynik:::::
root@LEDE:~# uci show network
network.loopback=interface
network.loopback.ifname='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.globals.ula_prefix='fd59:1d18:dd8d::/48'
network.atm=atm-bridge
network.atm.encaps='llc'
network.atm.payload='bridged'
network.atm.nameprefix='dsl'
network.atm.vci='35'
network.atm.vpi='8'
network.dsl=dsl
network.dsl.firmware='/lib/firmware/lantiq-vrx200-b.bin'
network.dsl.annex='b'
network.dsl.line_mode='vdsl'
network.dsl.ds_snr_offset='0'
network.dsl.xfer_mode='ptm'
network.lan=interface
network.lan.type='bridge'
network.lan.ifname='eth0.1'
network.lan.proto='static'
network.lan.netmask='255.255.255.0'
network.lan.ip6assign='60'
network.lan.dns='208.67.222.222'                                                                                                                                                     
network.lan.ipaddr='192.168.0.1'                                                                                                                                                     
network.lan_dev=device                                                                                                                                                               
network.lan_dev.name='eth0.1'                                                                                                                                                       
network.lan_dev.macaddr='xx:xx:xx:xx:xx:xx'                                                                                                                                         
network.wan=interface                                                                                                                                                               
network.wan.proto='pppoe'                                                                                                                                                           
network.wan.ipv6='auto'                                                                                                                                                             
network.wan.username='XXXXXXXXXXXX@dialnet.pl'                                                                                                                                       
network.wan.password='XXXXXXXXXXXXX'                                                                                                                                                       
network.wan.peerdns='0'                                                                                                                                                             
network.wan._orig_ifname='ptm0'                                                                                                                                                     
network.wan._orig_bridge='false'                                                                                                                                                     
network.wan.ifname='dsl0.35'                                                                                                                                                         
network.wan.mtu='1500'                                                                                                                                                               
network.wan_dev=device                                                                                                                                                               
network.wan_dev.macaddr='xx:xx:xx:xx:xx:xx'                                                                                                                                         
network.wan_dev.name='dsl0'                                                                                                                                                         
network.wan6=interface                                                                                                                                                               
network.wan6.ifname='pppoe-wan'                                                                                                                                                     
network.wan6.proto='dhcpv6'                                                                                                                                                         
network.wan6.reqaddress='try'                                                                                                                                                       
network.wan6.reqprefix='auto'                                                                                                                                                       
network.wan6.peerdns='0'                                                                                                                                                             
network.@switch[0]=switch                                                                                                                                                           
network.@switch[0].name='switch0'                                                                                                                                                   
network.@switch[0].reset='1'                                                                                                                                                         
network.@switch[0].enable_vlan='1'                                                                                                                                                   
network.@switch_vlan[0]=switch_vlan                                                                                                                                                 
network.@switch_vlan[0].device='switch0'                                                                                                                                             
network.@switch_vlan[0].vlan='1'                                                                                                                                                     
network.@switch_vlan[0].ports='0 1 2 4 5 6t'                                                                                                                                         
network.@switch_vlan[0].vid='1'                                                                                                                                                     
network.@switch_vlan[1]=switch_vlan                                                                                                                                                 
network.@switch_vlan[1].device='switch0'                                                                                                                                             
network.@switch_vlan[1].vlan='2'                                                                                                                                                     
network.@switch_vlan[1].ports='6t'                                                                                                                                                   
network.@switch_vlan[1].vid='2'

11

Odp: Działające konfiguracje xDSL

Poprosze o pomoc w ustawieniu konfiguracji dla:
- VODAFONE HG553
- pod Netia z ustawieniami: VC (w technologii BSA i WLR)
- internet Szybki Internet MAX 20

Wynik:

network.loopback=interface
network.loopback.ifname='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.globals.ula_prefix='fdb4:0ca9:b288::/48'
network.lan=interface
network.lan.ifname='eth0.1'
network.lan.force_link='1'
network.lan.type='bridge'
network.lan.proto='static'
network.lan.ipaddr='192.168.1.1'
network.lan.netmask='255.255.255.0'
network.lan.ip6assign='60'
network.wan6=interface
network.wan6._orig_ifname='eth0.2'
network.wan6._orig_bridge='false'
network.wan6.ifname='eth0.2'
network.wan6.proto='dhcp'
network.wan6.auto='0'
network.@switch[0]=switch
network.@switch[0].name='eth0'
network.@switch[0].reset='1'
network.@switch[0].enable_vlan='1'
network.@switch_vlan[0]=switch_vlan
network.@switch_vlan[0].device='eth0'
network.@switch_vlan[0].vlan='1'
network.@switch_vlan[0].ports='0 1 2 4 5t'
network.@switch_vlan[1]=switch_vlan
network.@switch_vlan[1].device='eth0'
network.@switch_vlan[1].vlan='2'
network.@switch_vlan[1].ports='3 5t'
network.wwan=interface
network.wwan.proto='dhcp'
network.wan=interface
network.wan.ifname='ppp0'
network.wan.proto='pppoa'
network.wan.encaps='vc'
network.wan.vpi='0'
network.wan.vci='35'
network.wan.username='******@webnet24.pl'
network.wan.password='*******'
network.wan.atmdev='0'

12

Odp: Działające konfiguracje xDSL

W tym broadcomie nie działa adsl.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

13

Odp: Działające konfiguracje xDSL

Proszę o pomoc w ustaleniu konfigu dla EaxyBox 904 xDLS
Wgrany openwrt-19.07
Neostrada 20Mb/s
ADSL_2plus
Annex A/L

Obecny wynik:
root@EasyBOX:~# uci show network
network.loopback=interface
network.loopback.ifname='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.atm=atm-bridge
network.atm.vpi='1'
network.atm.vci='32'
network.atm.encaps='llc'
network.atm.payload='bridged'
network.atm.nameprefix='dsl'
network.dsl=dsl
network.dsl.annex='a'
network.dsl.tone='av'
network.dsl.line_mode='adsl'
network.dsl.ds_snr_offset='0'
network.lan=interface
network.lan.type='bridge'
network.lan.proto='static'
network.lan.ipaddr='192.168.1.1'
network.lan.netmask='255.255.255.0'
network.lan.ipv6='0'
network.lan.ifname='eth0.1' 'eth0.66'
network.lan_dev=device
network.lan_dev.name='eth0.1'
network.wan=interface
network.wan.ifname='dsl0'
network.wan.proto='pppoe'
network.wan.ipv6='0'
network.wan.metric='20'
network.wan.peerdns='0'
network.wan.dns='127.0.0.1'
network.wan.username='xxxxxxxx@neostrada.pl/ipv6'
network.wan.password='xxxxxxxx'
network.wan.keepalive='0'
network.wan.force_link='1'
network.wan.mtu='1525'
network.wan_dev=device
network.wan_dev.name='dsl0'
network.wan_dev.peerdns='0'
network.wan_dev.dns='127.0.0.1'
network.@switch[0]=switch
network.@switch[0].name='switch0'
network.@switch[0].reset='1'
network.@switch[0].enable_vlan='1'
network.@switch_vlan[0]=switch_vlan
network.@switch_vlan[0].device='switch0'
network.@switch_vlan[0].vlan='1'
network.@switch_vlan[0].ports='0 6t'
network.@switch_vlan[1]=switch_vlan
network.@switch_vlan[1].device='switch0'
network.@switch_vlan[1].vlan='2'
network.@switch_vlan[1].ports='4 6t'
network.@switch[1]=switch
network.@switch[1].name='switch1'
network.@switch[1].reset='1'
network.@switch[1].enable_vlan='1'
network.@switch_vlan[2]=switch_vlan
network.@switch_vlan[2].device='switch1'
network.@switch_vlan[2].vlan='1'
network.@switch_vlan[2].ports='0 1 2 3 6t'
network.inic_dev=device
network.inic_dev.name='eth0.3'
network.inic=interface
network.inic.proto='none'
network.inic.ifname='eth0.3'
network.@switch_vlan[3]=switch_vlan
network.@switch_vlan[3].device='switch0'
network.@switch_vlan[3].vlan='3'
network.@switch_vlan[3].vid='3'
network.@switch_vlan[3].fid='3'
network.@switch_vlan[3].ports='5 6t'
network.wlan_dev=device
network.wlan_dev.name='eth0.66'
network.guest_wlan_dev=device
network.guest_wlan_dev.name='eth0.71'
network.@switch_vlan[4]=switch_vlan
network.@switch_vlan[4].device='switch0'
network.@switch_vlan[4].vlan='4'
network.@switch_vlan[4].vid='66'
network.@switch_vlan[4].fid='4'
network.@switch_vlan[4].ports='5t 6t'
network.@switch_vlan[5]=switch_vlan
network.@switch_vlan[5].device='switch0'
network.@switch_vlan[5].vlan='5'
network.@switch_vlan[5].vid='71'
network.@switch_vlan[5].fid='5'
network.@switch_vlan[5].ports='5t 6t'
network.hilink=interface
network.hilink.proto='dhcp'
network.hilink.ifname='eth2'
network.hilink.ipv6='0'
network.hilink.metric='10'
network.hilink.delegate='0'
network.hilink.peerdns='1'
network.hilink.dns='192.168.8.1'
network.upcwifree=interface
network.upcwifree.proto='dhcp'
network.upcwifree.ipv6='0'
network.wwan=interface
network.wwan.proto='dhcp'
network.wwan.ifname='usb0'
network.wwan.ipv6='0'
network.umts=interface
network.umts.proto='3g'
network.umts.device='/dev/ttyUSB0'
network.umts.service='umts'
network.umts.apn='internet'
network.umts.dialnumber='*99***1#'
network.umts.ipv6='0'
network.umts.auto='0'
network.umts.metric='30'
network.PPTP=interface
network.PPTP.proto='pptp'
network.PPTP.server='pl02.vpnonline.eu'
network.PPTP.keepalive='0'
network.PPTP.auto='0'
network.PPTP.username='twoj login'
network.PPTP.password='twoje haslo'
network.TUN=interface
network.TUN.ifname='tun0'
network.TUN.proto='none'
network.TUN.delegate='0'
network.wg0=interface
network.wg0.proto='wireguard'
network.wg0.listen_port='55055'
network.wg0.addresses='10.9.0.1/24'
network.wg0.private_key='aNcfPPirZGQrgFDHw07dgRqoSnP/Kni45ITneZlFFng='
network.wg0.ipv6='0'
network.wg0.auto='0'
network.@wireguard_wg0[0]=wireguard_wg0
network.@wireguard_wg0[0].public_key='Axn5g0cb0eYEc8utzM/2FXZ0vSdIE8AwxmUGfQBwzEY='
network.@wireguard_wg0[0].route_allowed_ips='1'
network.@wireguard_wg0[0].allowed_ips='10.9.0.3/32'
network.@wireguard_wg0[0].persistent_keepalive='25'
network.@wireguard_wg0[0].description='android'
network.@wireguard_wg0[0].ipv6='0'
network.@wireguard_wg0[0].auto='0'
network.ipsec=interface
network.ipsec.ifname='ipsec0'
network.ipsec.proto='none'
network.ipsec.defaultroute='0'
network.ipsec.peerdns='0'
network.ipsec.ipv6='0'
network.ipsec.auto='0'

14 (edytowany przez Zuzia 2019-12-03 14:53:16)

Odp: Działające konfiguracje xDSL

W archiwalnym wątku na forum OpenWrt dotyczącym Easybox 904 ktoś pisał, że teoretycznie Annex A jest obsługiwany, problem w tym, że nikt nie sprawdzał, a deweloperzy używają Anexu B. Ja nie mam dostępu do łącz xDSL więc mogę się tylko domyślać jak taka konfiguracja powinna wyglądać. Z tego co piszą inni Neostrada ADSL+ działa chyba na PPOA więc raczej jakoś tak jak niżej, bez IPv6, bo jest programowo wyłączone. Wpisy DNS są niezbędne, ponieważ w moim obrazie domyślnie działa szyfrowany DNS.

/etc/config/network

config interface 'wan'
    option ipv6 '0'
    option metric '20'
    option peerdns '0'
    option ifname 'dsl0'
    option bridge 'false'
    option proto 'pppoa'
    option delegate '0'
    option encaps 'vc'
    option atmdev '0'
    option vci '35'
    option vpi '0'
    option username 'xxx@neostrada.pl'
    option password 'xxx'
    option pppd_options 'holdoff 1'
    option peerdns '0'
    option dns '127.0.0.1'

config device 'wan_dev'
    option name 'dsl0'
    option peerdns '0'
    option dns '127.0.0.1'

config dsl 'dsl'
    option annex 'a'
    option firmware '/lib/firmware/lantiq-vrx200-b-to-a.bspatch'
    option tone 'av'
    option xfer_mode 'atm'
    option ds_snr_offset '0'

#config atm-bridge 'atm'
#    option vpi '0'
#    option vci '35'
#    option encaps 'vc'
#    option payload 'bridged'
#    option nameprefix 'dsl'

Oczywiście jest to tylko przykład. Być może potrzebny jest wpis vlan. Jeśli komuś powiedzie się  uruchomienie konfiguracji z Annex A dla ADSL+ niech da znać, załączę ją do obrazu.

15

Odp: Działające konfiguracje xDSL

Neostrada działa na PPPoE i PPPoA - czy to ma jakieś znaczenie który się używa to nie wiem ale ja używałem PPPoE i było ok.

16

Odp: Działające konfiguracje xDSL

PPPoA ma niższy narzut o 8 bajtów i powinno być minimalnie szybsze.

17 (edytowany przez nicefile 2020-05-28 10:19:36)

Odp: Działające konfiguracje xDSL

vdsl bridge + LAN ...
W tej konfiguracji W8970 podaje bridge po vlan2 i przyjmuje lan po vlan1 uzywając jednego przewodu wpinanego w port 4/Wan
Daje to możliwosc postawienia apka na W8970  lub czegoś po kablu. Router moze stać znacznie dalej będąc połaczony jedynie pojedynczym przewodem . Po stronie Routera na ktorym jest sesja PPPoE port WAN również musi być tagowany (np option ports '2t 6t') . Wada to niska wydajność ( 140/ 140Mbit ) z powodu skopanej obslugi sterownia ethernet na lantiq .

root@W8970:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd63:9d64:f6b2::/48'

config dsl 'dsl'
        option annex 'a'
        option tone 'av'
        option firmware '/lib/firmware/vdsl.bin'
        option xfer_mode 'ptm'
        option line_more 'vdsl'
        option ds_snr_offset '-25'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.3'
        option dns '192.168.1.2'
        option gateway '192.168.1.2'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'dslbridge'
        option ifname 'dsl0.35 eth0.2'
        option type 'bridge'

config device 'wan_dsl0_dev'
        option name 'dsl0'
        option macaddr 'f8:1a:xx:xx:xx:xx'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 2 4t 5 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4t 6t'

edit: poprawki