1

(110 odpowiedzi, napisanych Sprzęt)

Chiński ROM?

2

(3 odpowiedzi, napisanych Oprogramowanie)

wpad-mesh-openssl oczywiście jest.

3

(3 odpowiedzi, napisanych Oprogramowanie)

Postanowiłem wykorzystać stare gl.inety do mesh i niestety ale nie działa choć powinien ;-) Lecę wg. https://openwrt.org/docs/guide-user/net … esh/80211s

Na pierwszym pudełeczku ustawiłem w /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/ar933x_wmac'
        option htmode 'HT20'
        option disabled '0'
        option country 'PL'

config wifi-iface 'lan'
        option device   radio0
        option network  lan
        option mode     ap
        option ssid     OpenWrt
        option encryption psk2
        option key      'haslodoAP'

config wifi-iface 'mesh'
        option network 'lan'
        option device 'radio0'
        option mode 'mesh'
        option mesh_id 'openwrtMesh'
        option encryption none

Na drugim:

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/ar933x_wmac'
        option htmode 'HT20'
        option country 'PL'

config wifi-iface 'lan'
        option device   radio0
        option network  lan
        option mode     ap
        option ssid     OpenWrt
        option encryption psk2
        option key      'haslodoAP'

config wifi-iface 'mesh'
    option network 'lan'
    option device 'radio0'
    option mode 'mesh'
    option mesh_id 'openwrtMesh'
    option encryption none

Wszystko jest pięknie do momentu:

iw phy phy0 interface add mesh0 type mp mesh_id mymesh

Interfejs powstaje, mogę mu nawet nadać IP przez

ifconfig mesh0 10.0.0.1

, drugiemu daję 10.0.0.2 ale

ip a

pokazuje down nawet po podniesieniu przez ifconfig lub ip link.  Widzę tylko

ifconfig: SIOCSIFFLAGS: No error information

i nic nie ma w logach. Interfejs mesh0 znika po reboocie w ogóle. Może to mieć związek, z tym, że mam na tych pudełkach luci? Nie nadpisuje czegoś?

W opisie mowa o bridge pomiędzy AP, a Mesh. Tylko żeby to w ogóle zrobić musi mi ten interfejs wstać hmm
Samo

iw dev wlan0 station dump

pokazuje, że maszyny się połączyły. Po podpięciu do AP, który ma kabel net śmiga.

4

(20 odpowiedzi, napisanych Oprogramowanie)

http://www.aliexpress.com/item/ORICO-66 … 23849.html

A nie masz tak jak z moją, że dyski są widoczne dopiero jak przycisk na obudowie naciśniesz?

Przejedz ta kamera nmapem.  Ja musze dodatkowo 4 porty przekierowac zeby z moich kamer bylo cos widac z wan.

6

(4 odpowiedzi, napisanych Oprogramowanie)

A to po relayd idą teraz multicasty? DHCP magicznie zaczęłó działać?

7

(4 odpowiedzi, napisanych Oprogramowanie)

a te 2 kreski są przy obciążeniu, czy na jałowym?
Jakie masz transfery po wifi, i czy przy obciążeniu wskazanie nie rośnie?

8

(9 odpowiedzi, napisanych Oprogramowanie)

Czy można prosić o tłumaczenie na polski? Bo nie ogarniam co yoositack napisał.

9

(13 odpowiedzi, napisanych Oprogramowanie)

robo1973 napisał/a:

To nie wiem Gdzieś musi być błąd w mechanizmie drukowania. Po przesłaniu jednej strony będzie ją drukowało w nieskończoność. Nie kończy drukować. Drukuje wolno od czasu przesłania a cały czas

A w windowsie wyłączyłeś port jako bidirectional? U mnie na to pomogło.

10

(5 odpowiedzi, napisanych Oprogramowanie)

Musiałby być przezroczystym mostem, ale w relayd broadcasty są wycinane. Zwróć uwagę, że na tym edimax masz inną podsieć po wifi, a inną w lan.

11

(20 odpowiedzi, napisanych Oprogramowanie)

Podpowiedzcie Panowie gdzie tanio zamówić płytki PCB z airpi (https://airpies.wordpress.com/)?

12

(7 odpowiedzi, napisanych Oprogramowanie)

Cezary, jedyne co wystarczy zrobić to check box dla NC, który zmieni ikony - czyli po off ma być zielona, a po on ma być czerwona.

To nie ma nic wspolnego z rodzajem chinczyka, tylko z tym w jaki sposob podlaczysz kable.

13

(7 odpowiedzi, napisanych Oprogramowanie)

Jeszcze mam pytanie jedno. Plugin nie pozwala wybrać czy mamy do czynienia z NO czy z NC. Ja akurat potrzebuję NC, czyli włączenie powoduje rozpięcie styków. Gdzie mogę odwrócić zachowanie?

Zmiana w skrypcie to średni pomysł IMHO, taka opcja powinna być w pluginie.

14

(7 odpowiedzi, napisanych Oprogramowanie)

Ok, ogarnąłem temat.

#!/bin/sh

# usbrelay.sh polecenie [numer_przekaznika]

# polecenie, pierwszy argument:
# off - wylacza przekaznik nr 5
#   usbrelay.sh off 5
# on - wlacza przekaznik nr 5
#   usbrelay.sh on 5
# status - podaje status wszystkich przekaznikow w postaci numer_przekaznika:on lub numer_przekaznika:off, kazdy w osobnej linii
#   usbrelay.sh status
#   0:on
#   1:on
#   2:off
#   3:off
#   4:off
#   5:off
#   6:off
#   7:off

case "$1" in
        off)
                /sbin/usbrelay off $2
                ;;
        on)
                /sbin/usbrelay on $2
                ;;
        status)
                /sbin/usbrelay get|grep "1"|tr -d ' '|awk '{print tolower($0)}'
                ;;
esac

case "$1" in
        off)
               /sbin/usbrelay off $2
               ;;
        on)
               /sbin/usbrelay on $2
               ;;
        status)
               /sbin/usbrelay get|grep "2"|tr -d ' '|awk '{print tolower($0)}'
               ;;
esac

exit 0

Sam relay kupiłem taki:
http://www.aliexpress.com/item/Drop-Shi … 25320.html

15

(7 odpowiedzi, napisanych Oprogramowanie)

root@wr1043nd:/usr/lib/gargoyle# usbrelay get
 1: OFF
 2: OFF

Nie znam awk więc jak to zmienić żeby nie było "nie wykryto modułu przekaźników"?

usbrelay get >/dev/null | awk '/port/ {printf "%s%s\n", $2, $3}'

Jakie jest wyjscie dla powerswitch status 2? Potrzebuje punktu zaczepienia. Rozumiem, że wykrycie przekazników to odpowiednia interpretacja wyniku "status"

16

(7 odpowiedzi, napisanych Oprogramowanie)

Witam

Właśnie odpaliłem

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=1.5  MxCh= 0
D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=16c0 ProdID=05df Rev= 1.00
S:  Manufacturer=www.dcttech.com
S:  Product=USBRelay2
C:* #Ifs= 1 Cfg#= 1 Atr=80 MxPwr= 20mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=00 Prot=00 Driver=(none)
E:  Ad=81(I) Atr=03(Int.) MxPS=   8 Ivl=20ms

Sterownie odbywa sie przy pomocy pliku
usbrelay znalezionego na forum openwrt
Sterownie jest banalnie proste:

usbrelay on 1
usbrelay off 1
usbrelay get

czyli, wlacz, wylacz, sprawdz status .....

zamiast 1 mozna wpisac numer dowolnego kanalu, akurat mój ma 2.

Teraz .... co mam edytować żeby to podpiąć pod gui gargulca?

Druga sprawa to totalny offtopic. Dlaczego to urzadzenie w win8.1 jest widziane jako:

USB\VID_0000&PID_0002\5&26fbe77f&0&2
A request for the USB device descriptor failed. Code 43.

17

(554 odpowiedzi, napisanych Oprogramowanie)

W sumie to tak mnie naszło .... czy zmiast kupować gotowca nie lepiej kupić arduino nano 5V (z usb) - i dopiąć sterować 8 relayami. Protokół można samemu zrobić jakiś banalny ....

Arduino nano $2.75

8 channel relay board $6.05

żadnych sterowników tam jest ch340 i tylko

if (Serial.available())
    a=Serial.readln();

potem case (a)

i np 11 - czyli wlacz 1 relay
       10 - wylacz 1 relay

Źle myślę? Żadnych driverów tylko serial ustawić na 115000.
Gdzie się mylę?

18

(96 odpowiedzi, napisanych Oprogramowanie)

Firmware do drukarek hp lj1018 i lj1020 z eko nie działa. Tez http://oleg.wl500g.info/hplj/ działają poprawnie.

19

(2 odpowiedzi, napisanych Oprogramowanie)

no właśnie jest ace engine? Nie musiałbym używać valdikss proxy na windzie big_smile Na ARM'y nie ma sad

20

(0 odpowiedzi, napisanych Oprogramowanie)

Zrobilem relayd w luci i dolozylem do niego p9100 mostkuja porty lan i wan (gl.inet) i wszystko jest cacy za wyjatkiem druku po wifi. Poprzednio mialem gargulca i jego mostek - druk byl ok. Za to nie dzialalo za mostem po kablu dhcp. Teraz dhcp dziala, za to dukarka sprawia problemy.

root@Gl:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/ar933x_wmac'
        option htmode 'HT20'
        option country 'PL'
        option txpower '18'
        option disabled '0'
        option channel '4'

config wifi-iface
        option network 'wwan'
        option ssid 'Wifi'
        option encryption 'psk2'
        option device 'radio0'
        option mode 'sta'
        option bssid 'B0:48:7A:DB:26:E6'
        option key 'haslo'
root@Gl:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdb2:2bf2:297b::/48'

config interface 'lan'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.3'
        option netmask '255.255.255.0'
        option gateway '192.168.1.1'
        option dns '192.168.1.1'
        option ip6assign '60'
        option _orig_ifname 'eth1'
        option _orig_bridge 'true'
        option ifname 'eth0 eth1'

config interface 'wwan'
        option proto 'dhcp'

config interface 'stabridge'
        option proto 'relay'
        list network 'lan'
        list network 'wwan'
        option ipaddr '192.168.1.3'

config route
root@Gl:~# cat /etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config include
        option path '/etc/firewall.user'

config include 'miniupnpd'
        option type 'script'
        option path '/usr/share/miniupnpd/firewall.include'
        option family 'any'
        option reload '1'

config zone
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option conntrack '1'
        option log '1'
        option name 'LAN'
        option network 'lan wwan'

config rule
        option target 'ACCEPT'
        option proto 'tcp udp'
        option dest_port '9100'
        option name 'p9100'
        option src '*'
        option dest_ip '192.168.1.3'

config zone
        option input 'ACCEPT'
        option forward 'REJECT'
        option network ' '
        option output 'ACCEPT'
        option name 'WAN'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option dest 'WAN'
        option src 'LAN'
root@Gl:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'
        option ra_management '1'
        option ignore '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'

Przypuszczam, ze gdzies zrobilem blad hmm Ale do 1,5  kombinuje i nie widze hmm

21

(8 odpowiedzi, napisanych Oprogramowanie)

Potestuję z domu.

Na razie podpowiedz mi jak wyłączyć server dhcp v6?

22

(8 odpowiedzi, napisanych Oprogramowanie)

Adres IP poszedł na priv.

23

(8 odpowiedzi, napisanych Oprogramowanie)

Kiedy korzystałem z  AA było na pewno OK, natomiast pierwsze BB wgrałem zaraz jak się pojawiło - niestety nie miałem potrzeby dostać się do urządzania z WAN. Aż do dziś w nocy, teraz zrobiłem update od najnowszego BB z luci i dalej to samo hmm

Most na GPON nie powinien mieć nic do rzeczy.

24

(8 odpowiedzi, napisanych Oprogramowanie)

Przesiadłem się na BB i mam niemiłą niespodziankę. Nie mogę dostać się do routera z WAN, nawet nie odpowiada na ping.  Przekierowania portów też widzę, że nie chodzą.

root@OpenWrt:~# cat /etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fe80::/10'
        option src_port '547'
        option dest_ip 'fe80::/10'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

config include 'miniupnpd'
        option type 'script'
        option path '/usr/share/miniupnpd/firewall.include'
        option family 'any'
        option reload '1'
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd28:9a17:7a74::/48'

config interface 'lan'
        option ifname 'eth0.1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '172.23.198.1'

config interface 'wan'
        option ifname 'eth1'
        option _orig_ifname 'eth1'
        option _orig_bridge 'false'
        option proto 'static'
        option ipaddr 'x.x.x.x'
        option netmask '255.255.255.192'
        option gateway 'x.x.x.y'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'
        option blinkrate '2'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5t'

config switch_port
        option device 'switch0'
        option port '1'
        option led '6'

config switch_port
        option device 'switch0'
        option port '2'
        option led '9'

config switch_port
        option device 'switch0'
        option port '5'
        option led '2'

Problem polega na tym, że wndr3800 podłączony jest do GPON, w trybie mostu i nie mam dostępu do jego konfiguracji żeby cokolwiek sprawdzić. Na WAN mam publiczny adres IP.

25

(90 odpowiedzi, napisanych Oprogramowanie)

Hmmm a gdzie kupiliście archerca c7 v2? Podobno w Polsce jest tylko 1.2.