1 (edytowany przez c0m4r 2016-01-08 18:32:26)

Temat: WDR4300 + CC 15.01 + relayd odmawia współpracy

Witam

Mam problem z ustawieniem mojego routera aby łączył się do głównego routera (swoją drogą też wdr4300 tylko starszy openwrt Garygole) jako klient i udostępniał internet dla urządzeń podpiętych do niego kablem ale oczywiście aby dostawały one IP z głównego AP czyli aby wszystkie urządzenia były w jednej podsieci.
Przeczytałem sporo gotowych poradników, ale widzę pewne rozbieżności przy wersji 15.01 być może gdzie robię jakiś prosty błąd - byłbym wdzięczny za wskazówki.

Założenia:
Główny AP z dhcp : 192.168.2.1
Router-bridge: 192.168.2.200

Objawy:
Router łączy się jako klient do głównego AP, jednakże po podpięciu komputera po kablu nie przydziela ip z dhcp, pojawia sie apipa.


Moje configi :
/etc/config/network

root@OpenWrt:~# cat /etc/config/network


config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd84:a490:0872::/48'

config interface 'lan'
        option force_link '1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option _orig_ifname 'eth0.1'
        option _orig_bridge 'false'
        option ifname 'eth0'
        option gateway '192.168.2.1'
        option dns '192.168.2.1'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 2 3 4 5'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 1'

config interface 'wwan'
        option proto 'dhcp'

config interface 'stabridge'
        option proto 'relay'
        option network 'lan wwan'


 

/etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/ar934x_wmac'
        option country 'PL'
        option disabled '0'
        option htmode 'HT40'
        option txpower '19'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option htmode 'HT20'
        option disabled '1'
        option country 'PL'

config wifi-iface
        option device 'radio1'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

config wifi-iface
        option network 'wwan'
        option ssid 'Ponse_De_Leone'
        option encryption 'psk'
        option device 'radio0'
        option mode 'sta'
        option bssid 'xxxxxxxxxxx'
        option key 'xxxxxxxxxx'

/etc/config/firewall

root@OpenWrt:~# cat /etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan wwan'

config zone
        option name 'wan'
        option output 'ACCEPT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan wan6'
        option input 'ACCEPT'
        option forward 'ACCEPT'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fe80::/10'
        option src_port '547'
        option dest_ip 'fe80::/10'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

config rule
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'
root@OpenWrt:~# ifconfig
eth0      Link encap:Ethernet  HWaddr E8:DE:27:77:64:14
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::eade:27ff:fe77:6414/64 Scope:Link
          inet6 addr: fd84:a490:872::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1101 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4515 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:121510 (118.6 KiB)  TX bytes:588395 (574.6 KiB)
          Interrupt:4

eth0.2    Link encap:Ethernet  HWaddr E8:DE:27:77:64:14
          inet6 addr: fe80::eade:27ff:fe77:6414/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:433 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:142782 (139.4 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:333 errors:0 dropped:0 overruns:0 frame:0
          TX packets:333 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:25651 (25.0 KiB)  TX bytes:25651 (25.0 KiB)

wlan0     Link encap:Ethernet  HWaddr E8:DE:27:77:64:15
          inet addr:192.168.2.200  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::eade:27ff:fe77:6415/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5674 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3281 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:673901 (658.1 KiB)  TX bytes:986991 (963.8 KiB)

2 (edytowany przez mar_w 2016-01-08 06:33:56)

Odp: WDR4300 + CC 15.01 + relayd odmawia współpracy

Nie napisałeś czy zrobiłeś punkt 4 i 6. TEJ INSTRUKCJI
smile

* WNDR 4300 * || * WT3020-16MB * || * Xiaomi Miwifi Mini * || Netgear R6220 *
* RTL2832 + IT9135 + Siano *

3 (edytowany przez c0m4r 2016-01-08 18:32:55)

Odp: WDR4300 + CC 15.01 + relayd odmawia współpracy

Tak, zrobiłem wszystkie punkty z tutoriala, nawet żeby się upewnić dziś zrobiłem jeszcze je jeszcze raz smile
Niestety zero efektu. Zmieniałem komputery podpinane do routera aby wyeliminować zwis tcp/ip, za każdym razem widać, że komp wysyła ale nic nie odbiera.
Jakieś wskazówki gdzie dalej szukać przyczyn problemu ?

edit: uaktualniłem configi w pierwszym poście po dzisiejszych kolejnych nieudanych próbach

4

Odp: WDR4300 + CC 15.01 + relayd odmawia współpracy

A to po relayd idą teraz multicasty? DHCP magicznie zaczęłó działać?

5

Odp: WDR4300 + CC 15.01 + relayd odmawia współpracy

Nie rozumiem ? To chyba podstawowa funkcjonalność relayd, że po podpięciu po kablu urządzenia do routera mostowego ten za pomocą wifi łączy się z głównym AP i z dhcp dostaje IPka dla tego urządzenia...