Temat: Problem z ping z WAN?

Przesiadłem się na BB i mam niemiłą niespodziankę. Nie mogę dostać się do routera z WAN, nawet nie odpowiada na ping.  Przekierowania portów też widzę, że nie chodzą.

root@OpenWrt:~# cat /etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fe80::/10'
        option src_port '547'
        option dest_ip 'fe80::/10'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

config include 'miniupnpd'
        option type 'script'
        option path '/usr/share/miniupnpd/firewall.include'
        option family 'any'
        option reload '1'
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd28:9a17:7a74::/48'

config interface 'lan'
        option ifname 'eth0.1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '172.23.198.1'

config interface 'wan'
        option ifname 'eth1'
        option _orig_ifname 'eth1'
        option _orig_bridge 'false'
        option proto 'static'
        option ipaddr 'x.x.x.x'
        option netmask '255.255.255.192'
        option gateway 'x.x.x.y'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'
        option blinkrate '2'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5t'

config switch_port
        option device 'switch0'
        option port '1'
        option led '6'

config switch_port
        option device 'switch0'
        option port '2'
        option led '9'

config switch_port
        option device 'switch0'
        option port '5'
        option led '2'

Problem polega na tym, że wndr3800 podłączony jest do GPON, w trybie mostu i nie mam dostępu do jego konfiguracji żeby cokolwiek sprawdzić. Na WAN mam publiczny adres IP.

2

Odp: Problem z ping z WAN?

Na GPON/EPON jezeli w  bridge nic nie sprawdzisz, bo nie ma co. TO tylko przekaźnik z optyki na złącze elektryczne. Na poprzednim sofcie było OK ?

RB760iGS + RB260GS / Ryzen 5 2660 / 16G DDR4 / MiniITX - Inea 1G (https://i.imgur.com/TLbJVDw.png)
RB951-2HnD / Celeron J1900 / 4G DDR3 / MiniITX - Satpol 100M

3

Odp: Problem z ping z WAN?

Kiedy korzystałem z  AA było na pewno OK, natomiast pierwsze BB wgrałem zaraz jak się pojawiło - niestety nie miałem potrzeby dostać się do urządzania z WAN. Aż do dziś w nocy, teraz zrobiłem update od najnowszego BB z luci i dalej to samo hmm

Most na GPON nie powinien mieć nic do rzeczy.

4

Odp: Problem z ping z WAN?

Jak widzisz w firewallu masz jawnie odblokowane pingi na wanie. Podaj adres ip będziemy sprawdzać smile

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

5

Odp: Problem z ping z WAN?

Adres IP poszedł na priv.

6

Odp: Problem z ping z WAN?

Nope. Nie działa. Możesz chwilowo wyłączyć całkowicie firewalla lub zrobić

iptables -I INPUT -p tcp  -j ACCEPT

I zobaczyć czy to wina systemu czy czegoś przed nim.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

7

Odp: Problem z ping z WAN?

Potestuję z domu.

Na razie podpowiedz mi jak wyłączyć server dhcp v6?

8

Odp: Problem z ping z WAN?

odhcpd wyłącz.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

9

Odp: Problem z ping z WAN?

Szymon_Zy napisał/a:

Potestuję z domu.

Na razie podpowiedz mi jak wyłączyć server dhcp v6?

uci -q set dhcp.lan.dhcpv6=disabled && uci -q commit dhcp

WYPRZEDAJO SPRZĘT WIFI!
Modyfikacja U-Boot dla routerów (obrazy)

Naprawię routery, wymienię RAM i FLASH na większy