26

Odp: Światłowód t-mobile konfiguracja gniazda WAN

logread
https://pastebin.com/1irhS7sJ

27

Odp: Światłowód t-mobile konfiguracja gniazda WAN

procd: /etc/rc.d/S20network: Failed to load config file: : Parse error (invalid command) at line 22, byte 0

Zrobiłeś literówkę w okolicy 22 linii lub brakuje znaku ' czy coś takiego

PS. Tam kreskę zostawiłeś...

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

28

Odp: Światłowód t-mobile konfiguracja gniazda WAN

Faktycznie... w konfigu zostawiłem "_" smile lol
Poprawiłem to i po paru restartach zaczęło wszystko działać big_smile
Choć maksymalne prędkości jakie osiągam są w okolicach 100Mbps - nawet przy połączeniu kablowym 1Gbps.
Możliwe że mam jakieś ograniczenie ustawione? czy to już raczej szczyt możliwości tego routera TL-WDR4300 + OpenWRT?

Poniżej podaje poprawny już konfig (może komuś w przyszłości się przyda):

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'xxxxxxxxxxxxxx'

config interface 'lan'
    option type 'bridge'
    option ifname 'eth0.1'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ip6assign '60'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '2 3 4 5 0t'
    option vid '1'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option vid '35'
    option ports '1t 0t'

config interface 'wan'
    option proto 'pppoe'
    option username '48998xxxxxxx'
    option password 'xxxxxxxxxx'
    option ifname 'eth0.35'
    option ipv6 'auto'


WIELKIE PODZIĘKOWANIE dla Cezary

29

Odp: Światłowód t-mobile konfiguracja gniazda WAN

To nie jest limit tego routera. Oczywiście zależy to od tego ile dostawca daje. Włącz flow offloading.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

30

Odp: Światłowód t-mobile konfiguracja gniazda WAN

Obecnie dostawca oferuje 600Mbps i na ich routerze przy połączeniu kablowym byłem w stanie wyciągnąć taką prędkość.
Jak włączyć flow offloading? też po przez wpisanie komend w plikach konfiguracyjnych? bo w interfejsie Gargoyle nic takiego nie widzę sad chyba że trzeba jakiś dodatek zainstalować?

31

Odp: Światłowód t-mobile konfiguracja gniazda WAN

W gargoyle nie ma tego w gui i jak włączysz to możesz mieć problem np. z qos.
Tak się to robi: https://eko.one.pl/?p=openwrt-konfigura … lowoffload ale musisz mieć openwrt 19.07 lub gargoyle 1.13. Starsze wersje tego nie mają.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

32

Odp: Światłowód t-mobile konfiguracja gniazda WAN

Zainstalowałem OpenWRT 19.07 z GUI LuCI, skopiowałem wcześniejszy konfig i za pośrednictwem GUI włączyłem programowy i sprzętowy flow offloading - teraz na kablu maksymalnie wyciągam 500-520Mbps big_smile

33

Odp: Światłowód t-mobile konfiguracja gniazda WAN

Ale o czym piszesz? O podłączeniu pod wspomnianego t-mobile? To tak, potrzebujesz, z tym z pod openwrt masz to "z urzędu" zapewnione.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

34 (edytowany przez Polarus 2020-11-04 13:16:58)

Odp: Światłowód t-mobile konfiguracja gniazda WAN

Pytanie: jak konfigurujemy router z dwoma interfejsami eth0 i eth1 (Netgear WNDR3800)? Identycznie jak wyżej (eth 0.1 ma być lan a 0.35 to wan)? Czy lan ma być 1.35? Teoretycznie WAN to port 4, ale w dokumentacji / na wiki jest napisane: “Port 4” are connected to CPU's eth1 and usually it should not be used in your configuration.
Config jeszcze przed "wsadzeniem" konfiguracji T-Mobile (prawie surowy):


config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option type 'bridge'
    option ifname 'eth0'
    option proto 'static'
    option ipaddr 'xxx.xxx.xxx.xxx'
    option netmask '255.255.255.0'

config device 'lan_eth0_dev'
    option name 'eth0'
    option macaddr 'xx:xx:xx:xx:xx:xx'

config interface 'wan'
    option ifname 'eth1'
    option proto 'dhcp'

config interface switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'
    option blinkrate '2'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0 1 2 3 5'

config switch_port
    option device 'switch0'
    option port '1'
    option led '6'

config switch_port
    option device 'switch0'
    option port '2'
    option led '9'

config switch_port
    option device 'switch0'
    option port '5'
    option led '2'

35

Odp: Światłowód t-mobile konfiguracja gniazda WAN

Ogólnie: Jeżeli wan jest na eth1 i zrobiłeś vlana to oczywiście powstaje eth1.35 i jego własnie masz użyć.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

36

Odp: Światłowód t-mobile konfiguracja gniazda WAN

Witajcie,
za chwilę będę miał instalowany światłowód z Orange. Będę oczywiście korzystał z powyższych konfiguracji, ale zastanawiam się czy nie dałoby się przygotować poradnika opisującego krok-po-kroku jak uruchomić światłowód (orange/tmobile/netia i itp) na własnym routerze z pominięciem "funboxów". Teraz coraz więcej będzie takich postów.
Chętnie przygotowałbym poradnik ale niestety należę do tych którzy sami z nich korzystają sad

37

Odp: Światłowód t-mobile konfiguracja gniazda WAN

Żeby przygotować taki poradnik to ktoś to musi "przeżyć" i zrobić żeby mieć co opisywać. Więc - musisz to zrobić Ty - jesteś właśnie na bieżąco.

Ja światłowodu nie mam, więc nie jestem na tyle kompetentny żeby takie coś opisać.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

38

Odp: Światłowód t-mobile konfiguracja gniazda WAN

Cezary napisał/a:

Żeby przygotować taki poradnik to ktoś to musi "przeżyć" i zrobić żeby mieć co opisywać. Więc - musisz to zrobić Ty - jesteś właśnie na bieżąco.

Ja światłowodu nie mam, więc nie jestem na tyle kompetentny żeby takie coś opisać.


Spróbuje smile

39

Odp: Światłowód t-mobile konfiguracja gniazda WAN

Ok, oto cały mój config z zamazanymi pewnymi danymi wrażliwymi oczywiście zrobiony pod T-Mobile (na bazie Netgear WNDR3800).
Wszystko działa bez zarzutu. Bez kombinacji, bez tworzenia VLANów, najprościej jak się da. Pamiętamy oczywiście, że Orange/T-Mobile korzystają z VLAN ID 35.
Żeby maksymalnie uprościć wszystko co się da skorzystałem z następującej porady:
Note that the device sections are missing and the VLAN ID and parent interface is derived from the ifname option value in dot-notation (źródło: https://openwrt.org/docs/guide-user/net … el_vlans). Oznacza to ni mniej ni więcej, że nie musimy w ogóle tworzyć VLAN - dodajemy tylko kropkę i vlan ID jak pokazałem poniżej.
W wypadku tego modelu WAN działa na ETH1, a LAN na eth0, więc było jeszcze prościej.
Dla ułatwienia powiem, że jedyną modyfikowaną sekcją przeze mnie był... 'wan'.

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'xxx'

config interface 'lan'
    option type 'bridge'
    option ifname 'eth0'
    option proto 'static'
    option ipaddr 'xxx.xxx.xxx.xxx'
    option netmask '255.255.255.0'
    option ip6assign '60'

config device 'lan_eth0_dev'
    option name 'eth0'
    option macaddr 'xx:xx:xx:xx:xx:xx'

config interface 'wan'
    option ifname 'eth1.35'
    option proto 'pppoe'
    option username '48998xxxxxx'
    option password 'xxxxxxxxxx'
    option ipv6 'auto'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'
    option blinkrate '2'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0 1 2 3 5'

config switch_port
    option device 'switch0'
    option port '1'
    option led '6'

config switch_port
    option device 'switch0'
    option port '2'
    option led '9'

config switch_port
    option device 'switch0'
    option port '5'
    option led '2'

40 (edytowany przez hejduk 2020-11-04 14:37:25)

Odp: Światłowód t-mobile konfiguracja gniazda WAN

Poszedłem jednak na łatwiznę,
znalazłem poniższy poradnik dla TYPOWEGO LAIKA smile Wazne że działa.

hejdom - swiatlowod-orange-i-wlasny-router-ont

dodałem do tego flow_offloading.