1

Temat: OpenWRT jako dumb AP a prędkości

Czołem :-)
Jakiś czas temu pytałem tutaj jak skonfigurować sieć, aby można było swobodnie forwardować porty (https://eko.one.pl/forum/viewtopic.php?id=18908).
Zdecydowałem, że wybiorę prostszą, moim zdaniem, opcję:

Cezary napisał/a:

2. Albo na archerze ustaw adres na lan 192.168.1.2 i podłącz do lanem pod horizona, wtedy archer robi za głupi AP i przekierowanie robisz tylko na horizonie. Na archerze musisz wtedy wyłączyć serwer dhcp.

Wszystko działa sprawnie oprócz jednej rzeczy - występuje różnica prędkości na modemie od UPC a archerze.
Prędkość na Horizonie:
http://i.imgur.com/tHRP2YR.png
Prędkość na Archerze:
http://i.imgur.com/xy6ceT4.png
W praktyce nie odczuwam różnicy, ale z czystej ciekawości chciałbym się dowiedzieć czy też zaobserwowaliście takie "problemy". Dodam, że oba urządzenia są spięte przewodowo a testy przeprowadzałem w podobnej odległości od routerów na tym samym urządzeniu.

2

Odp: OpenWRT jako dumb AP a prędkości

Ustawiłeś na archerze ht40/vht80 i noscan 1?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

3

Odp: OpenWRT jako dumb AP a prędkości

Ustawienia anteny 5Ghz:

 "radio0": {
                "up": true,
                "pending": false,
                "autostart": true,
                "disabled": false,
                "retry_setup_failed": false,
                "config": {
                        "channel": "36",
                        "hwmode": "11a",
                        "path": "pci0000:00/0000:00:00.0",
                        "htmode": "VHT80",
                        "country": "PL"
                },
                "interfaces": [
                        {
                                "section": "default_radio0",
                                "ifname": "wlan0",
                                "config": {
                                        "mode": "ap",
                                        "key": "secret",
                                        "encryption": "psk2",
                                        "ssid": "5_GHz",
                                        "network": [
                                                "lan"
                                        ],
                                        "mode": "ap"
                                }
                        }
                ]
        },

Niestety nie za bardzo wiem gdzie sprawdzić parametr noscan - w /etc/config/wireless nie widzę niczego takiego.
Na podstawie info z neta wykonałem:

uci set wireless.radio0.noscan=1

ale nadal nic nie widzę w wireless - gdzieś indziej się to odkłada?

4

Odp: OpenWRT jako dumb AP a prędkości

uci commit zapomniałeś zrobić. Tyle że dotyczy to radia 2.4GHz. Zamiast szukać w necie zacznij od eko.one.pl: https://eko.one.pl/?p=openwrt-konfiguracja

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

5

Odp: OpenWRT jako dumb AP a prędkości

Oczywiście masz rację - zapomniałem zapisać zmian. Wprowadziłem również zmiany sugerowane na eko.one.pl:

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option country 'PL'
        option noscan '1'
        option disabled '0'
        option htmode 'HT40'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option key 'secret'
        option encryption 'psk2'
        option ssid '5_GHz'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/ahb/18100000.wmac'
        option htmode 'HT20'
        option country 'PL'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option key 'secret'
        option encryption 'psk2'
        option ssid '2.4_GHz'

Dla pewności (jeśli miałoby to w czymkolwiek pomóc) zrestartowałem router, ale bez zmian - prędkości po wifi są nadal dużo słabsze niż bezpośrednio z horizona.
W celu wykluczenia wadliwego przewodu horizon-archer przetestowałem prędkości po kablu (komputer podłączony przewodowo do archera) i tutaj już nie ma żadnych problemów - leci z pełną prędkością.

6

Odp: OpenWRT jako dumb AP a prędkości

No i źle zrobiłeś. Dla 5GHz masz ustawić VHT80, dla 2.4 - HT40. Zrobiłeś dokładnie odwrotnie niż trzeba. I noscan 1 ustaw dla 2.4G a nie 5.

Przeczytaj najpierw dokładnie to co tam jest napisane.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

7

Odp: OpenWRT jako dumb AP a prędkości

No tak to jest jak się ustawia coś o czym się nie ma pojęcia wink
W każdym razie poniższa konfiguracja nie zmieniła zbyt wiele - transfery nadal takie same. Zaś coś źle ustawione czy problem nie leży po stronie konfiguracji a sprzętu? roll

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option country 'PL'
        option disabled '0'
        option htmode 'VHT80'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option key 'secret'
        option encryption 'psk2'
        option ssid '5_GHz'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/ahb/18100000.wmac'
        option country 'PL'
        option htmode 'HT40'
        option noscan '1'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option key 'secret'
        option encryption 'psk2'
        option ssid '2.4_GHz'

8

Odp: OpenWRT jako dumb AP a prędkości

Cześć - przepraszam za wznawianie starego tematu, ale dopiero teraz miałem czas "pobawić" się z routerem.
Zacząłem żonglować oprogramowaniem i ustawieniami. Wgrałem:
1. gargoyle-1.12.0.2-ar71xx-generic-archer-c5-v1-squashfs-factory

config wifi-device 'radio0'
    option type 'mac80211'
    option channel '36'
    option hwmode '11a'
    option path 'pci0000:01/0000:01:00.0'
    option htmode 'VHT80'

config wifi-device 'radio1'
    option type 'mac80211'
    option channel '11'
    option hwmode '11g'
    option path 'platform/qca955x_wmac'
    option htmode 'HT20'
    option noscan '1'

config wifi-iface 'ap_g'
    option device 'radio1'
    option mode 'ap'
    option network 'lan'
    option disassoc_low_ack '0'
    option ssid 'Gargoyle'
    option encryption 'psk2'
    option key 'password'

config wifi-iface 'ap_a'
    option device 'radio0'
    option mode 'ap'
    option network 'lan'
    option disassoc_low_ack '0'
    option ssid 'Gargoyle5GHz'
    option encryption 'psk2'
    option key 'password'

2. luci-19.07-snapshot-r11201-f5afa593e7-ath79-generic-tplink_archer-c5-v1-squashfs-factory

config wifi-device 'radio0'
    option type 'mac80211'
    option channel '36'
    option hwmode '11a'
    option path 'pci0000:00/0000:00:00.0'
    option htmode 'VHT80'
    option country 'PL'

config wifi-iface 'default_radio0'
    option device 'radio0'
    option network 'lan'
    option mode 'ap'
    option encryption 'none'
    option ssid 'OpenWrt5Ghz'

config wifi-device 'radio1'
    option type 'mac80211'
    option channel '11'
    option hwmode '11g'
    option path 'platform/ahb/18100000.wmac'
    option htmode 'HT20'
    option country 'PL'
    option noscan '1'

config wifi-iface 'default_radio1'
    option device 'radio1'
    option network 'lan'
    option mode 'ap'
    option ssid 'OpenWrt'
    option encryption 'none'

3. TP-Link 3.14.1 Build 140912 Rel.58489n - ustawienia domyślne
4. DD-WRT v3.0-r44340 - ustawienia w załączeniu

Wszystkie testy przeprowadziłem w tej samej odległości od routera (~40 cm) na tym samym laptopie (Lenovo T460s z Win10).
Prędkość internetu bezpośrednio z modemu: WiFi 480Mbps, LAN 473 Mbps.
Prędkości z archera:
1. WiFi: 98Mbps, LAN: 160Mbps
2. WiFi: 128Mbps, LAN: 293 Mbps
3. WiFi: 466Mbps, LAN: 470Mbps
4. WiFi: 298Mbps, LAN: -

W ostatnim przypadku zapomniałem zrobić testu po kablu :-(

Nie mam już pomysłów co może być nie tak – starałem się przełączać po kanałach, wprowadzać ustawienia, które są na eko.one.pl, ale bez skutków. W sieci natknąłem się na dyskusje o podobnych problemach np. tutaj: https://forum.openwrt.org/t/archer-c7-v … aster/2260
Zastanawiam się już nawet nad zmianą routera, tylko czy to coś pomoże?

http://i.imgur.com/O9Hnx7St.png

9

Odp: OpenWRT jako dumb AP a prędkości

Jeżeli zrobiłeś faktycznie AP to na lanie nic cie nie ogranicza, masz tyle ile switch pozwala a tobie wychodzi jakeś 160Mbps. Jesteś pewien jakości kabla?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

10 (edytowany przez vekh 2020-09-17 10:18:29)

Odp: OpenWRT jako dumb AP a prędkości

Wszystkie testy były robione na tych samych przewodach. Też myślałem o tym, że to może być wina przewodu, ale bezpośrednio LANem z modemu od UPC transfery idą pełną prędkością łącza. To samo jest w przypadku Connectbox->Archer ze stockowym FW->PC. Problemy ze spadkiem transferów są tylko wtedy, kiedy archer działa na OpenWRT albo DD-WRT.
Mała uwaga - nie jestem pewien czy jest ważna - przesiadłem się z horizona na connectboxa, który obecnie działa w trybie modemu, więc archer jest jedynym urządzeniem, które rozprowadza u mnie sieć.

11

Odp: OpenWRT jako dumb AP a prędkości

I jak podłączysz kabel do switcha to tam go nic nie ogranicza, ma lecieć tyle samo jak bez switcha. O ile nie podłączyłeś kabla np. do portu wan.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

12 (edytowany przez vekh 2020-09-17 10:56:05)

Odp: OpenWRT jako dumb AP a prędkości

Urządzenia końcowe mam wpięte do portów LAN na archerze, ale połączenie ConnectBox-Archer jest po WANie. Ze względu na to, że mogę przepinać connectboxa z trybu routera w tryb modemu koncepcja się nieco zmieniła. DHCP na CB jest całkowicie wyłączone, kiedy urządzenie jest w trybie modemu (CB służy tylko i wyłącznie jako modem) - wszystko odbywa się po stronie archera, więc CB-Archer musi być po porcie WANowym. A przynajmniej tak mi się wydaje...
Tak czy inaczej - przedstawione wartości z testów były robione na tych samych przewodach i tych samych gniazdach (zmieniałem jedynie soft na archerze) a jednak oprogramowanie nieoficjalne znacznie odbiega od tego co można uzyskać na stockowym FW sad

13

Odp: OpenWRT jako dumb AP a prędkości

Czyli nie zrobiłeś AP tylko zrobiłeś normalny router. A to oznacza że jak chcesz coś szybciej to zainstaluj openwrt 19.07 lub gargoyle 1.13 i musisz włączyć flow offloading.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

14

Odp: OpenWRT jako dumb AP a prędkości

Programowy flow offloading
Sprzętowy flow offloading
włączone - szybkość wzrosła do połowy przepustowości łącza i wynosi ~250Mbps

15

Odp: OpenWRT jako dumb AP a prędkości

To i tak za mało, tyle to osiąga zwykły staruszek 1043 bez wspomagania ( https://eko.one.pl/forum/viewtopic.php? … 59#p192459 ) Powinno być kilka razy więcej. Jaki system zainstalowałeś?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

16

Odp: OpenWRT jako dumb AP a prędkości

Aktualnie mam świeżo zainstalowane 19.07:

Nazwa hosta: OpenWrt
Model: TP-Link Archer C5 v1
Architektura: Qualcomm Atheros QCA9558 ver 1 rev 0
Wersja firmware: OpenWrt 19.07-SNAPSHOT r11201-f5afa593e7 / LuCI openwrt-19.07 branch git-20.247.75781-0d0ab01
Wersja kernela: 4.14.195

17 (edytowany przez vekh 2020-09-19 06:42:52)

Odp: OpenWRT jako dumb AP a prędkości

Kombinowałem dalej - wgrałem softa stąd: https://github.com/gwlim/openwrt-sfe-flowoffload-ath79 - niestety bez skutku. Prędkość ~220Mbps
Spróbuję jeszcze tego rozwiązania
https://kcore.org/2017/04/03/upgrading- … r-c7-v2-0/
Mam jednak nieodoparte wrażenie, że ten router po prostu nie da rady działać na owrt z wydajnością której bym oczekiwał. W sieci jest sporo postów opisujacych podobne problemy dla C5/C7.
Nie mam oporów żeby kupić nowe urządzenie, ale pojawiają się dwa pytania: jakie i czy to coś faktycznie zmieni.

18

Odp: OpenWRT jako dumb AP a prędkości

"Upgrade" na c7 nic ci nie da - dla openwrt c5 i c7 to ten sam soft jest, nie ma tam żadnej magii.

Obok jest post forumowicza który ma taki sam problem z C7. Ale to naprawdę aż nieprawdopodobne że macie taki mały transfer nawet bez wspomagania.

Niech się jakiś użytkownik C5 lub C7 pochwali ile wyciąga przy testach iperfa.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

19 (edytowany przez vekh 2020-09-19 10:39:40)

Odp: OpenWRT jako dumb AP a prędkości

Jeśli ktoś ma ochotę to prosiłbym o wrzucenie wyników. U mnie wygląda to tak:
Po WiFi 5Ghz:

PS D:\iperf-3.1.3-win64> .\iperf3.exe -c 192.168.1.1
Connecting to host 192.168.1.1, port 5201
[  4] local 192.168.1.196 port 50393 connected to 192.168.1.1 port 5201
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-1.00   sec  29.6 MBytes   248 Mbits/sec
[  4]   1.00-2.01   sec  29.1 MBytes   243 Mbits/sec
[  4]   2.01-3.00   sec  25.1 MBytes   212 Mbits/sec
[  4]   3.00-4.00   sec  29.0 MBytes   244 Mbits/sec
[  4]   4.00-5.01   sec  29.4 MBytes   245 Mbits/sec
[  4]   5.01-6.01   sec  29.2 MBytes   245 Mbits/sec
[  4]   6.01-7.00   sec  28.6 MBytes   241 Mbits/sec
[  4]   7.00-8.00   sec  20.5 MBytes   171 Mbits/sec
[  4]   8.00-9.01   sec  29.4 MBytes   246 Mbits/sec
[  4]   9.01-10.00  sec  29.5 MBytes   249 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-10.00  sec   280 MBytes   234 Mbits/sec                  sender
[  4]   0.00-10.00  sec   280 MBytes   234 Mbits/sec                  receiver

Verbose z serwera:

iperf 3.7
Linux OpenWrt 4.14.195 #0 Sun Sep 6 16:19:39 2020 mips
-----------------------------------------------------------
Server listening on 5201
-----------------------------------------------------------
get_parameters:
{
        "tcp":  true,
        "omit": 0,
        "time": 10,
        "parallel":     1,
        "len":  131072,
        "client_version":       "3.1.3"
}
SNDBUF is 16384, expecting 0
RCVBUF is 87380, expecting 0
Time: Sat, 19 Sep 2020 09:32:20 UTC
Accepted connection from 192.168.1.196, port 50388
      Cookie: DESKTOP-4MPGBD1.1600507939.751534.04
      TCP MSS: 0 (default)
Congestion algorithm is cubic
[  5] local 192.168.1.1 port 5201 connected to 192.168.1.196 port 50389
Starting Test: protocol: TCP, 1 streams, 131072 byte blocks, omitting 0 seconds, 10 second test, tos 0
tcpi_snd_cwnd 10 tcpi_snd_mss 1460 tcpi_rtt 3458
interval_len 1.000641 bytes_transferred 19660800
interval forces keep
[ ID] Interval           Transfer     Bitrate
[  5]   0.00-1.00   sec  18.8 MBytes   157 Mbits/sec
tcpi_snd_cwnd 10 tcpi_snd_mss 1460 tcpi_rtt 3458
interval_len 0.999908 bytes_transferred 28966912
interval forces keep
[  5]   1.00-2.00   sec  27.6 MBytes   232 Mbits/sec
tcpi_snd_cwnd 10 tcpi_snd_mss 1460 tcpi_rtt 3458
interval_len 1.000050 bytes_transferred 21364736
interval forces keep
[  5]   2.00-3.00   sec  20.4 MBytes   171 Mbits/sec
tcpi_snd_cwnd 10 tcpi_snd_mss 1460 tcpi_rtt 3458
interval_len 1.003808 bytes_transferred 30015488
interval forces keep
[  5]   3.00-4.00   sec  28.6 MBytes   239 Mbits/sec
tcpi_snd_cwnd 10 tcpi_snd_mss 1460 tcpi_rtt 3458
interval_len 0.997453 bytes_transferred 30539776
interval forces keep
[  5]   4.00-5.00   sec  29.1 MBytes   245 Mbits/sec
tcpi_snd_cwnd 10 tcpi_snd_mss 1460 tcpi_rtt 3458
interval_len 1.000407 bytes_transferred 30408704
interval forces keep
[  5]   5.00-6.00   sec  29.0 MBytes   243 Mbits/sec
tcpi_snd_cwnd 10 tcpi_snd_mss 1460 tcpi_rtt 3458
interval_len 0.999960 bytes_transferred 21626880
interval forces keep
[  5]   6.00-7.00   sec  20.6 MBytes   173 Mbits/sec
tcpi_snd_cwnd 10 tcpi_snd_mss 1460 tcpi_rtt 3458
interval_len 0.998145 bytes_transferred 29648552
interval forces keep
[  5]   7.00-8.00   sec  28.3 MBytes   238 Mbits/sec
tcpi_snd_cwnd 10 tcpi_snd_mss 1460 tcpi_rtt 3458
interval_len 1.001714 bytes_transferred 30382424
interval forces keep
[  5]   8.00-9.00   sec  29.0 MBytes   243 Mbits/sec
tcpi_snd_cwnd 10 tcpi_snd_mss 1460 tcpi_rtt 3458
interval_len 1.001860 bytes_transferred 30670848
interval forces keep
[  5]   9.00-10.00  sec  29.2 MBytes   245 Mbits/sec
tcpi_snd_cwnd 10 tcpi_snd_mss 1460 tcpi_rtt 3458
interval_len 0.044953 bytes_transferred 1179648
interval forces keep
[  5]  10.00-10.05  sec  1.12 MBytes   210 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
Test Complete. Summary Results:
[ ID] Interval           Transfer     Bitrate
[  5] (sender statistics not available)
[  5]   0.00-10.05  sec   262 MBytes   219 Mbits/sec                  receiver
rcv_tcp_congestion cubic
get_results
{
        "cpu_util_total":       29.639228,
        "cpu_util_user":        2.776208,
        "cpu_util_system":      26.863021,
        "sender_has_retransmits":       0,
        "streams":      [{
                        "id":   1,
                        "bytes":        274464768,
                        "retransmits":  -1,
                        "jitter":       0,
                        "errors":       0,
                        "packets":      0
                }]
}
send_results
{
        "cpu_util_total":       3.54417430961511,
        "cpu_util_user":        0.046497546453226637,
        "cpu_util_system":      3.4976767631618833,
        "sender_has_retransmits":       -1,
        "congestion_used":      "cubic",
        "streams":      [{
                        "id":   1,
                        "bytes":        274464768,
                        "retransmits":  -1,
                        "jitter":       0,
                        "errors":       0,
                        "packets":      0,
                        "start_time":   0,
                        "end_time":     10.048899
                }]
}

Po przewodzie:

PS D:\iperf-3.1.3-win64> .\iperf3.exe -c 192.168.1.1
Connecting to host 192.168.1.1, port 5201
[  4] local 192.168.1.214 port 58676 connected to 192.168.1.1 port 5201
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-1.01   sec  28.5 MBytes   237 Mbits/sec
[  4]   1.01-2.00   sec  31.2 MBytes   264 Mbits/sec
[  4]   2.00-3.00   sec  28.9 MBytes   242 Mbits/sec
[  4]   3.00-4.00   sec  30.0 MBytes   252 Mbits/sec
[  4]   4.00-5.00   sec  31.5 MBytes   264 Mbits/sec
[  4]   5.00-6.00   sec  31.9 MBytes   268 Mbits/sec
[  4]   6.00-7.00   sec  29.8 MBytes   249 Mbits/sec
[  4]   7.00-8.01   sec  30.1 MBytes   252 Mbits/sec
[  4]   8.01-9.01   sec  29.1 MBytes   244 Mbits/sec
[  4]   9.01-10.00  sec  29.5 MBytes   248 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-10.00  sec   300 MBytes   252 Mbits/sec                  sender
[  4]   0.00-10.00  sec   300 MBytes   252 Mbits/sec                  receiver

I verbose:

iperf 3.7
Linux OpenWrt 4.14.195 #0 Sun Sep 6 16:19:39 2020 mips
-----------------------------------------------------------
Server listening on 5201
-----------------------------------------------------------
get_parameters:
{
        "tcp":  true,
        "omit": 0,
        "time": 10,
        "parallel":     1,
        "len":  131072,
        "client_version":       "3.1.3"
}
SNDBUF is 16384, expecting 0
RCVBUF is 87380, expecting 0
Time: Sat, 19 Sep 2020 09:33:05 UTC
Accepted connection from 192.168.1.196, port 50392
      Cookie: DESKTOP-4MPGBD1.1600507984.171499.73
      TCP MSS: 0 (default)
Congestion algorithm is cubic
[  5] local 192.168.1.1 port 5201 connected to 192.168.1.196 port 50393
Starting Test: protocol: TCP, 1 streams, 131072 byte blocks, omitting 0 seconds, 10 second test, tos 0
tcpi_snd_cwnd 10 tcpi_snd_mss 1460 tcpi_rtt 1935
interval_len 1.000372 bytes_transferred 29884416
interval forces keep
[ ID] Interval           Transfer     Bitrate
[  5]   0.00-1.00   sec  28.5 MBytes   239 Mbits/sec
tcpi_snd_cwnd 10 tcpi_snd_mss 1460 tcpi_rtt 1935
interval_len 1.003491 bytes_transferred 30277632
interval forces keep
[  5]   1.00-2.00   sec  28.9 MBytes   241 Mbits/sec
tcpi_snd_cwnd 10 tcpi_snd_mss 1460 tcpi_rtt 1935
interval_len 0.996502 bytes_transferred 26476544
interval forces keep
[  5]   2.00-3.00   sec  25.2 MBytes   213 Mbits/sec
tcpi_snd_cwnd 10 tcpi_snd_mss 1460 tcpi_rtt 1935
interval_len 0.999999 bytes_transferred 30293692
interval forces keep
[  5]   3.00-4.00   sec  28.9 MBytes   242 Mbits/sec
tcpi_snd_cwnd 10 tcpi_snd_mss 1460 tcpi_rtt 1935
interval_len 1.000558 bytes_transferred 30932992
interval forces keep
[  5]   4.00-5.00   sec  29.5 MBytes   247 Mbits/sec
tcpi_snd_cwnd 10 tcpi_snd_mss 1460 tcpi_rtt 1935
interval_len 1.003582 bytes_transferred 30654788
interval forces keep
[  5]   5.00-6.00   sec  29.2 MBytes   244 Mbits/sec
tcpi_snd_cwnd 10 tcpi_snd_mss 1460 tcpi_rtt 1935
interval_len 1.001175 bytes_transferred 30408704
interval forces keep
[  5]   6.00-7.01   sec  29.0 MBytes   243 Mbits/sec
tcpi_snd_cwnd 10 tcpi_snd_mss 1460 tcpi_rtt 1935
interval_len 0.994694 bytes_transferred 21131792
interval forces keep
[  5]   7.01-8.00   sec  20.2 MBytes   170 Mbits/sec
tcpi_snd_cwnd 10 tcpi_snd_mss 1460 tcpi_rtt 1935
interval_len 1.000993 bytes_transferred 30641648
interval forces keep
[  5]   8.00-9.00   sec  29.2 MBytes   245 Mbits/sec
tcpi_snd_cwnd 10 tcpi_snd_mss 1460 tcpi_rtt 1935
interval_len 0.999348 bytes_transferred 31072824
interval forces keep
[  5]   9.00-10.00  sec  29.6 MBytes   249 Mbits/sec
tcpi_snd_cwnd 10 tcpi_snd_mss 1460 tcpi_rtt 1935
interval_len 0.038688 bytes_transferred 1301960
interval forces keep
[  5]  10.00-10.04  sec  1.24 MBytes   269 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
Test Complete. Summary Results:
[ ID] Interval           Transfer     Bitrate
[  5] (sender statistics not available)
[  5]   0.00-10.04  sec   280 MBytes   234 Mbits/sec                  receiver
rcv_tcp_congestion cubic
get_results
{
        "cpu_util_total":       29.985455,
        "cpu_util_user":        4.946462,
        "cpu_util_system":      25.038993,
        "sender_has_retransmits":       0,
        "streams":      [{
                        "id":   1,
                        "bytes":        293076992,
                        "retransmits":  -1,
                        "jitter":       0,
                        "errors":       0,
                        "packets":      0
                }]
}
send_results
{
        "cpu_util_total":       12.954088310981735,
        "cpu_util_user":        0.19626383632612557,
        "cpu_util_system":      12.757826732560149,
        "sender_has_retransmits":       -1,
        "congestion_used":      "cubic",
        "streams":      [{
                        "id":   1,
                        "bytes":        293076992,
                        "retransmits":  -1,
                        "jitter":       0,
                        "errors":       0,
                        "packets":      0,
                        "start_time":   0,
                        "end_time":     10.039402
                }]
}

20

Odp: OpenWRT jako dumb AP a prędkości

Po wifi to ty nie testuj. Wifi zależy od zbyt wielu czynników i każdy ma inny wynik, to że ma 200Mbps znaczy tylko tyle że masz 200Mbps teraz i za chwilę może być inaczej. Nic to nie znaczy kompletnie dla innej osoby.

Po kablu. I na dodatek - nie testuj iperfem wydajności router -> komputer tylko komputer -> router -> komputer, czyli jego możliwość  natowania pakietów. Bo teraz testujesz tylko tyle że ma słaby procek i żaden flow offload itp nic nie da (bo to jest od przepływu pakietów, a nie od przyśpieszenia routera).

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

21

Odp: OpenWRT jako dumb AP a prędkości

OK. Poniżej test PC->router->PC po lanie (przewodowo):

PS D:\iperf-3.1.3-win64> .\iperf3.exe -c 192.168.1.129
Connecting to host 192.168.1.129, port 5201
[  4] local 192.168.1.214 port 59548 connected to 192.168.1.129 port 5201
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-1.00   sec   100 MBytes   838 Mbits/sec
[  4]   1.00-2.00   sec  99.2 MBytes   832 Mbits/sec
[  4]   2.00-3.00   sec   108 MBytes   903 Mbits/sec
[  4]   3.00-4.00   sec   106 MBytes   889 Mbits/sec
[  4]   4.00-5.00   sec   105 MBytes   879 Mbits/sec
[  4]   5.00-6.00   sec   107 MBytes   900 Mbits/sec
[  4]   6.00-7.00   sec   106 MBytes   885 Mbits/sec
[  4]   7.00-8.00   sec   108 MBytes   906 Mbits/sec
[  4]   8.00-9.00   sec   104 MBytes   875 Mbits/sec
[  4]   9.00-10.00  sec  85.0 MBytes   713 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-10.00  sec  1.00 GBytes   862 Mbits/sec                  sender
[  4]   0.00-10.00  sec  1.00 GBytes   862 Mbits/sec                  receiver

Tylko nie jestem pewien jak to interpretować w odniesieniu do problemu z prędkościami neta sad

22

Odp: OpenWRT jako dumb AP a prędkości

Jednego PC-ta wepnij do WAN, a drugiego do LAN. Tylko tak sprawdzisz natowanie. Po LAN kompy prawie zamykają 1Gb (sprawdziłeś tylko switch), więc teraz pora sprawdzić możliwość routera w kwestii translacji adresów.

23

Odp: OpenWRT jako dumb AP a prędkości

Setup zrobiłem wg. tego poradnika: https://openwrt.org/docs/guide-user/per … chmark.nat
Wyniki:

PS D:\iperf-3.1.3-win64> .\iperf3.exe -c 10.1.1.2
Connecting to host 10.1.1.2, port 5201
[  4] local 192.168.1.214 port 52249 connected to 10.1.1.2 port 5201
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-1.00   sec  45.2 MBytes   379 Mbits/sec
[  4]   1.00-2.00   sec  34.8 MBytes   292 Mbits/sec
[  4]   2.00-3.00   sec  40.1 MBytes   336 Mbits/sec
[  4]   3.00-4.00   sec  47.0 MBytes   395 Mbits/sec
[  4]   4.00-5.00   sec  47.8 MBytes   400 Mbits/sec
[  4]   5.00-6.00   sec  47.8 MBytes   401 Mbits/sec
[  4]   6.00-7.00   sec  34.9 MBytes   293 Mbits/sec
[  4]   7.00-8.00   sec  40.1 MBytes   337 Mbits/sec
[  4]   8.00-9.00   sec  47.6 MBytes   399 Mbits/sec
[  4]   9.00-10.00  sec  48.4 MBytes   406 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-10.00  sec   434 MBytes   364 Mbits/sec                  sender
[  4]   0.00-10.00  sec   434 MBytes   364 Mbits/sec                  receiver

24

Odp: OpenWRT jako dumb AP a prędkości

Z czy bez włączonego flow offloadingu?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

25

Odp: OpenWRT jako dumb AP a prędkości

Bez - zapomniałem włączyć po resecie routera.
Tutaj z włączonym offloadingiem:

PS D:\iperf-3.1.3-win64> .\iperf3.exe -c 10.1.1.2
Connecting to host 10.1.1.2, port 5201
[  4] local 192.168.1.214 port 62905 connected to 10.1.1.2 port 5201
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-1.00   sec   103 MBytes   862 Mbits/sec
[  4]   1.00-2.00   sec   109 MBytes   912 Mbits/sec
[  4]   2.00-3.00   sec   111 MBytes   929 Mbits/sec
[  4]   3.00-4.00   sec   109 MBytes   914 Mbits/sec
[  4]   4.00-5.00   sec   109 MBytes   917 Mbits/sec
[  4]   5.00-6.00   sec   107 MBytes   902 Mbits/sec
[  4]   6.00-7.00   sec   104 MBytes   876 Mbits/sec
[  4]   7.00-8.00   sec   102 MBytes   857 Mbits/sec
[  4]   8.00-9.00   sec   105 MBytes   883 Mbits/sec
[  4]   9.00-10.00  sec   111 MBytes   930 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-10.00  sec  1.05 GBytes   898 Mbits/sec                  sender
[  4]   0.00-10.00  sec  1.05 GBytes   898 Mbits/sec                  receiver