201 (edytowany przez MickO 2020-08-06 20:21:26)

Odp: Gargoyle 1.13.x

root@GargoyleMO1:~# uci show wireguard_gargoyle
wireguard_gargoyle.server=server
wireguard_gargoyle.server.enabled='0'
wireguard_gargoyle.server.ip='10.64.0.1'
wireguard_gargoyle.server.submask='255.255.255.0'
wireguard_gargoyle.server.port='51820'
wireguard_gargoyle.server.c2c='false'
wireguard_gargoyle.server.lan_access='true'
wireguard_gargoyle.server.all_client_traffic='true'
wireguard_gargoyle.client=client
wireguard_gargoyle.client.enabled='0'
wireguard_gargoyle.client.ip='10.64.0.2'
wireguard_gargoyle.client.allow_nonwg_traffic='true'
root@GargoyleMO1:~# ifconfig wg0
ifconfig: wg0: error fetching interface information: Device not found
root@GargoyleMO1:~# ifstatus wg0
Interface wg0 not found

Status page does not show Wireguard as an option.

202

Odp: Gargoyle 1.13.x

Disabled. Problem is somewhere else.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

203

Odp: Gargoyle 1.13.x

Hmmm.  I enabled it in the config and restarted just to see what happened. Still the same error message.
Any suggestions before I install Gargoyle pre7 on my WRT1900?  A lot of work setting up the config by hand if I do.
Wireguard on my WRT1200ac with Gargoyle pre7,  installed, enabled and configured OK
I didn't use Wireguard as the WRT1200 is not being used as my Gateway Router.
Thanks

204

Odp: Gargoyle 1.13.x

Copy configs/scripts etc, install pre7 and restore configs?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

205

Odp: Gargoyle 1.13.x

Surely Keeping config by any means is not recommended from pre5 to pre7?

206

Odp: Gargoyle 1.13.x

i'll backup pre5 and try a restore. If that doesn't work, I'll restart from basic pre7 and hand perm. :-(

207

Odp: Gargoyle 1.13.x

OK. Past midnight again. WRT1900 upgraded to pre7 retaining the config. :-)
I can now get to Wireguard. yet to configure and test.
I have a suspicion Adblock is not working...

Fri Aug  7 01:53:05 2020 daemon.info dnsmasq-dhcp[6838]: read /etc/ethers - 12 addresses
Fri Aug  7 01:53:05 2020 daemon.err uhttpd[5601]: cat: can't open '/adblock/block.hosts': No such file or directory
Fri Aug  7 01:54:04 2020 daemon.err uhttpd[5601]: cat: can't open '/adblock/block.hosts': No such file or directory
Fri Aug  7 01:54:21 2020 user.notice ADBLOCK: Modifying black/white lists from GUI
Fri Aug  7 01:54:21 2020 daemon.err uhttpd[5601]: uci: Entry not found
Fri Aug  7 01:54:21 2020 user.notice ADBLOCK: Removing old hosts file
Fri Aug  7 01:54:21 2020 user.notice ADBLOCK: Retrieving ad lists from remote source
Fri Aug  7 01:54:23 2020 user.notice ADBLOCK: Successfully retrieved ad list
Fri Aug  7 01:54:23 2020 user.notice ADBLOCK: Adding entries from black.list
Fri Aug  7 01:54:24 2020 user.notice ADBLOCK: Removing entries from white.list
Fri Aug  7 01:54:24 2020 daemon.err uhttpd[5601]: /usr/lib/adblock/runadblock.sh: line 131: can't create /adblock/block.hosts: nonexistent directory
Fri Aug  7 01:54:24 2020 user.notice ADBLOCK: Reloading hosts list
Fri Aug  7 01:54:24 2020 daemon.info dnsmasq[6838]: read /etc/hosts - 15 addresses
Fri Aug  7 01:54:24 2020 daemon.info dnsmasq[6838]: read /tmp/hosts/odhcpd - 3 addresses
Fri Aug  7 01:54:24 2020 daemon.info dnsmasq[6838]: read /tmp/hosts/dhcp.cfg01411c - 2 addresses
Fri Aug  7 01:54:24 2020 daemon.err dnsmasq[6838]: failed to load names from /adblock/block.hosts: No such file or directory

See you later, thanks.

208

Odp: Gargoyle 1.13.x

Enable/Add/remove something in adblock gui, if you want. /adblock/block.hosts is created after the lists are downloaded.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

209

Odp: Gargoyle 1.13.x

I did something like that on pre5. I searched the Black list and something was found. But on pre7 that didn't work. I'll try again.
By the way, Wireguard is working fine. Very useful to have. ????

210

Odp: Gargoyle 1.13.x

For 3 month nothing changed in adblock plugin.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

211

Odp: Gargoyle 1.13.x

Maybe it was me. If I recall there were some examples in the Black and White Lists before pre7.
I added the examples into the lists and ran the update. Now I have Displaying 0/20827. Before I had 0/0.
All is well now System Log looks fine.

212

Odp: Gargoyle 1.13.x

What do I put for IPv6 field when enabling Individual Port Opening?
e.g.
Description: Server
Protocol: TCP
IPv6:    ??
Port: 2020

If I don't need IPv6, it doesn't like it empty.

213

Odp: Gargoyle 1.13.x

IPv6 address. Don't fill this section if you don't need ipv6.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

214

Odp: Gargoyle 1.13.x

I would expect that, but if I attempt to add my WG port Gargoyle complains...
192.168.x.x says
There is an error in IPv6
Could not add port open rule.

Another thing I have just noticed and it's not the first time it has happened with various versions of Gargoyle, half of my Port Forwards have gone missing. Also my Static IP's have gone completely. Something has corrupted.

215

Odp: Gargoyle 1.13.x

192.168.x.x says
There is an error in IPv6

192.168.x.x is NOT ipv6 address...

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

216

Odp: Gargoyle 1.13.x

Może coś przegapiłem , ale wgrałem dla testów do wr842 v1 ( a w zasadzie to zmodowany wr3420 v1) pre7 , i wogóle nie można tam wifi włączyć..
Najpierw mnie zdziwiło wogóle brak wifi po uruchomieniu ( bo standardowo Gargoyly ma wifi włączone) , a po zalogowaniu kablem włączyć też się nie da.

217

Odp: Gargoyle 1.13.x

I zaraz będzie że w tym zmodyfikowanym mr3420 właśnie uszkodziłeś art lub wgrałeś obraz z ath79 i dlatego wifi nie wstaje? Zgadłem? Co wygrałem?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

218

Odp: Gargoyle 1.13.x

Dobra , już wiem smile
zapomniałem o tym nieszczęsnym flashu 16MB... Nie uszkodziłem , tylko jest na koncu 16MB , a ath79 odczytuje z 8MB.
poza tym kompilacja ath79 to jedyna na wr842 , w ar71xx nie ma dla wr842 wink

219

Odp: Gargoyle 1.13.x

Wygrałem! Czyżby iphone?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

220

Odp: Gargoyle 1.13.x

Niech będzie i iphone . nie takie rzeczy objecywałem wink

221

Odp: Gargoyle 1.13.x

Cezary napisał/a:

192.168.x.x says
There is an error in IPv6

192.168.x.x is NOT ipv6 address...

I understand that, but that is what the error message is saying.
I am just entering a port to open and ignoring IPv6 field.
Why does it need IPv6 and not IPv4 just to open a port WAN to LAN.
Let me put is another way, How do I open a port WAN to LAN.
Talking about Individual Port Opening, NOT Individual Port Forwarding to a specific LAN IP
I assume Individual Port Opening is open for all internal LAN IP's and not specific to any LAN IP?

222

Odp: Gargoyle 1.13.x

wan -> lan? You need FORWARDING rule for ipv4, not "open port". Use "Individual Port Forwarding", not "Individual Port Opening".

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

223

Odp: Gargoyle 1.13.x

Witam
Czy na najnowszym Garagyle wgranym do WNDR4300 i podłączonym do niego modemie HiLink działa 3ginfo ? czy muszę coś oprócz 3ginfo instalować ?

224

Odp: Gargoyle 1.13.x

Pełen pakiet wget. Zawsze była taka potrzeba i jest taka informacja na stronie z opisem 3ginfo.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

225

Odp: Gargoyle 1.13.x

Ale podczas próby instalacji wget dostaję takie info
opkg install wget
WARNING: Package wget is already installed, ignoring
         Use --force-reinstall to force reinstallation

No packages to install.