101 (edytowany przez pawelmm 2020-04-29 16:47:16)

Odp: Gargoyle 1.13.x

dziś próbowałem zrobić update Gargoyle z 1.10 do 1.13 pre4 (na WD n750) --> pierwsze podniesienie routera przeszło ok, router odpalił (zmiana hasła i restart), natomiast po restarcie przechodzi w tryb recovery i nic nie można zrobić, zrobiłem powrót do wersji 1.10
druga próba --> Gargoyle 1.10 --> oryginalny firmware WD --> Gargoyle 1.13 pre4, niestety tak jak za pierwszym razem, router odpala w trybie recovery, po wpisaniu ip routera mam stronę do wgrania  firmware,
powrót do wersji 1.10, gdzie wszystko działa ok

102

Odp: Gargoyle 1.13.x

Podłącz kabel szergowy i sprawdź co się dzieje.
Tak samo  - sprawdź działanie openwrt 19.07, bo to na nim jest 1.13 oparte.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

103

Odp: Gargoyle 1.13.x

niestety kabla szeregowego nie mam :-(
a luci 19.07 sprawdzę

104

Odp: Gargoyle 1.13.x

Luci 19.07 działa bez problemu na WD n750

105

Odp: Gargoyle 1.13.x

Gargoyle też ci działa do pierwszego resetu. Więc potrzeby jest ktoś z kablem żeby zobaczył co się dzieje.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

106

Odp: Gargoyle 1.13.x

Właśnie zaktualizowałem R6220 do wersji 1.13.0.0pre4 i po skonfigurowaniu i restarcie mam problem, nie mogę dostać się do gui.
Próbowałem na komputerze i telefonie, na różnych przeglądarkach, bez skutku.
Co może być przyczyną?

107

Odp: Gargoyle 1.13.x

Zaloguj się przez ssh i zrestartuj uhttpd. Ktoś już mi zgłaszał ale u mnie działa więc nie jestem w stanie zobaczyć dlaczego. Może ty sprawdzisz?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

108 (edytowany przez FUTURISTA 2020-04-30 21:08:49)

Odp: Gargoyle 1.13.x

Dzięki, pomogło.
Jednak po restarcie routera znów musiałem resetować uhttpd.
W wersji pre1 nie miałem z tym problemu.
Co może być powodem?
W jaki sposób mógłbym to sprawdzić?

109

Odp: Gargoyle 1.13.x

Nie startuje uhttpd wywołany przez procd. To jest w logach i to wiadomo, natomiast nie wiadomo dlaczego - i właśnie do tego ktoś musi  dojść żeby było wiadomo co poprawić.
Zobacz czy coś da np. późniejsze startowanie uhttpd.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

110

Odp: Gargoyle 1.13.x

W jaki sposób mogę opóźnić start uhttpd?

111

Odp: Gargoyle 1.13.x

/etc/init.d/uhttpd disable
w /etc/init.d/uhttpd zmień START=50 na np. START=90
/etc/init.d/uhttpd enable
reboot

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

112

Odp: Gargoyle 1.13.x

Ok, ale zanim przejdę do eksperymentów chciałbym się podzielić jeszcze jednym spostrzeżeniem.
Na nowo wgrałem soft i już przy pierwszym uruchomieniu uhttpd nie wystartował, trzeba było restartować.
Potem, po skonfigurowaniu routera, dodatkowo dostęp do niego ustawiłem tylko przez http (wyłączyłem dostęp przez https) i od tamtej pory zrobiłem już 3 rebooty i gui jest. Może to mieć jakiś związek?

113

Odp: Gargoyle 1.13.x

Nie wiem. Sprawdź na czysto kilka razy czy faktycznie to jest przyczyną.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

114

Odp: Gargoyle 1.13.x

"Na czysto", tzn. po wgraniu na świeżo softu?

115

Odp: Gargoyle 1.13.x

Po zrobieniu firstboota. Nie masz potrzeby za każdym razem wgrywania od nowa.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

116

Odp: Gargoyle 1.13.x

Czyli wystarczy przywrócić domyślną konfigurację w gui?

117

Odp: Gargoyle 1.13.x

No tak...

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

118 (edytowany przez FUTURISTA 2020-04-30 22:58:24)

Odp: Gargoyle 1.13.x

Niestety, na razie nie znajduję żadnej reguły, zależności, prawidłowości, która mogłaby wiązać się z brakiem startu uhttpd.
Dzieje się to jakby zupełnie przypadkowo, kilka razy się uruchomi, potem kilka razy nie, albo na przemian, raz się uruchamia, a następnym razem już nie. Przy wydłużonym czasie startu (na 90 s.) uhttpd też potrafiło się nie uruchomić. Http & https też chyba nie ma z tym nic wspólnego.

119

Odp: Gargoyle 1.13.x

Dodaj sobie to /etc/rc.local restart uhttpd i zrestartuj kilka razy i zobacz co będzie.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

120

Odp: Gargoyle 1.13.x

Jeszcze będę testował. Wydaje mi się jednak, że po wyłączeniu https jest dobrze. Zrobiłem już trochę rebootów i nie miałem potrzeby restartować uhttpd. Zobaczymy.

121

Odp: Gargoyle 1.13.x

Zainstalowałem 1.13.x pre4 na staruszku TP-Link 1043nd V1 i póki co odpukać wszystko hula. Mało flaszu zostaje po instalacji bo tylko około 230 kB, ale na szczęście motyw Xeye udało mi sie zainstalować z konsoli ręcznie, powyłączałem autostart wszystkich zbędnych serwisów - szkoda RAM: nfsd, rpcbind, p910nd, samba, vsftpd, (btw nie ma już zakładki usługi w GUI, a była w poprzednich wersjach). Włączyłem software flow_offloading (w gui też tego nie ma niestety) I teraz dziadek dziarsko hula na testowym gargolcu. Modem USB LTE działa, WAN 500mbps działa. Aż dziw ze ten weteran tyle jeszcze daje radę. Oby jak najdłużej. Dzięki Cezary - dobra robota.

122

Odp: Gargoyle 1.13.x

Zła wiadomość jest taka, że jak wejdzie łatka od ipv6 to gargoyle nie zmieści się nawet do 8MB. Będę musiał znów przyciąć o jakieś programy, ale teraz to pewne będzie poważnie cięcie i wyleci adblock/openvpn/qos i pewnie coś jeszcze.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

123

Odp: Gargoyle 1.13.x

Cezary napisał/a:

Zła wiadomość jest taka, że jak wejdzie łatka od ipv6 to gargoyle nie zmieści się nawet do 8MB. Będę musiał znów przyciąć o jakieś programy, ale teraz to pewne będzie poważnie cięcie i wyleci adblock/openvpn/qos i pewnie coś jeszcze.

A po co utrzymywać wsparcie dla takich leciwych dziadków? Ileż to kosztuje współczesny, niedrogi router? Chwała Ci, że nie olewasz użytkowników, ale może warto w którymś momencie postawić "kreskę", do której udzielasz wsparcia? Na staruszków niech będzie openwrt bez gui, ewentualnie z luci, ale jeśli masz łamać sobie głowę, co tu jeszcze powycinać by coś na tym działało, to może warto się zastanowić i to zwyczajnie odpuścić?

Linksys WRT3200ACM (Gargoyle)
PC Engines APU.4C4 Platforma 4x i211AT LAN, 4GB RAM, AMD GX-412TC CPU (Gargoyle)
Tp-link 1043NDv2 (Gargoyle)

124

Odp: Gargoyle 1.13.x

I dokładnie tak robię. 4M już dawno nie są kompilowane, jak się okaże że nie ma co wycinać już z obrazów to 8M też spotka taki los.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.