1 (edytowany przez chauwa 2011-04-08 19:21:43)

Temat: TL-MR3420+modem3g+exroot na karcie

Witam.

Mam problem z ogarnieciem exroota...

TL-MR3420 zainstalowałam najnowszą gargoyle, podłaczony jet modem E173 z karta 1GB formantowaną na exfat z poziomu windowsa. Próbuje już trzeci dzień z tym się uporać, przeczytałam wszelkie poradniki i kibel w każdym znaczeniu tego słowa

Potrzebne mi to do doinstalowania graficznego wyswietlania poziomu sieci itd. niestety w tym routerze nie ma na nic miejsca bleee wink

http://eko.one.pl/?p=openwrt-externalro … odemiegusb nie działa niestety albo coś robię nie tak...

root@Gargoyle:~$ umount /dev/sda1
umount: can't umount /dev/sda1: No such file or directory
root@Gargoyle:~$ mke2fs -m 0 /dev/sda1 

na tym staje karta jet wykrywana jako SD id3 a w poradniku jako MMC


root@Gargoyle:~$ dmesg
Linux version 2.6.32.27 (cezary@eko.one.pl) (gcc version 4.3.3 (GCC) ) #9 Thu Ap
r 7 18:57:51 CEST 2011
prom: fw_arg0=00000008, fw_arg1=a1f87fb0, fw_arg2=a1f88470, fw_arg3=00000004
MyLoader: sysp=f0f0f0f0, boardp=f0f0f0f0, parts=f0f0f0f0
bootconsole [early0] enabled
CPU revision is: 00019374 (MIPS 24Kc)
Atheros AR7241 rev 1, CPU:400.000 MHz, AHB:200.000 MHz, DDR:400.000 MHz
Determined physical RAM map:
 memory: 02000000 @ 00000000 (usable)
Initrd not found or empty - disabling initrd
Zone PFN ranges:
  Normal   0x00000000 -> 0x00002000
Movable zone start PFN for each node
early_node_map[1] active PFN ranges
    0: 0x00000000 -> 0x00002000
On node 0 totalpages: 8192
free_area_init_node: node 0, pgdat 802a39a0, node_mem_map 81000000
  Normal zone: 64 pages used for memmap
  Normal zone: 0 pages reserved
  Normal zone: 8128 pages, LIFO batch:0
Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 8128
Kernel command line: rootfstype=squashfs,yaffs,jffs2 noinitrd console=ttyS0,1152
00 board=TL-MR3420
PID hash table entries: 128 (order: -3, 512 bytes)
Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
Writing ErrCtl register=00000000
Readback ErrCtl register=00000000
Memory: 29516k/32768k available (1956k kernel code, 3252k reserved, 364k data, 1
48k init, 0k highmem)
SLUB: Genslabs=7, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
Hierarchical RCU implementation.
NR_IRQS:56
Calibrating delay loop... 266.24 BogoMIPS (lpj=1331200)
Mount-cache hash table entries: 512
NET: Registered protocol family 16
MIPS: machine is TP-LINK TL-MR3420
registering PCI controller with io_map_base unset
bio: create slab <bio-0> at 0
pci 0000:00:00.0: fixup device configuration
pci 0000:00:00.0: reg 10 64bit mmio: [0x000000-0x00ffff]
pci 0000:00:00.0: supports D1
pci 0000:00:00.0: PME# supported from D0 D1 D3hot
pci 0000:00:00.0: PME# disabled
PCI: mapping irq 48 to pin1@0000:00:00.0
Switching to clocksource MIPS
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 1024 (order: 1, 8192 bytes)
TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
TCP: Hash tables configured (established 1024 bind 1024)
TCP reno registered
NET: Registered protocol family 1
squashfs: version 4.0 (2009/01/31) Phillip Lougher
Registering mini_fo version $Id$
JFFS2 version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006
 Red Hat, Inc.
msgmni has been set to 57
io scheduler noop registered
io scheduler deadline registered (default)
Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11) is a 16550A
console [ttyS0] enabled, bootconsole disabled
Atheros AR71xx SPI Controller driver version 0.2.4
m25p80 spi0.0: s25sl032a (4096 Kbytes)
spi0.0: searching for MyLoader partition table at offset 0x10000
spi0.0: searching for MyLoader partition table at offset 0x20000
spi0.0: searching for MyLoader partition table at offset 0x30000
spi0.0: searching for MyLoader partition table at offset 0x40000
spi0.0: no MyLoader partition table found
Searching for RedBoot partition table in spi0.0 at offset 0x3e0000
Searching for RedBoot partition table in spi0.0 at offset 0x3f0000
No RedBoot partition table detected in spi0.0
spi0.0: no WRT160NL signature found
Creating 5 MTD partitions on "spi0.0":
0x000000000000-0x000000020000 : "u-boot"
0x000000020000-0x000000140000 : "kernel"
0x000000140000-0x0000003f0000 : "rootfs"
mtd: partition "rootfs" set to be root filesystem
mtd: partition "rootfs_data" created automatically, ofs=3A0000, len=50000
0x0000003a0000-0x0000003f0000 : "rootfs_data"
0x0000003f0000-0x000000400000 : "art"
0x000000020000-0x0000003f0000 : "firmware"
ag71xx_mdio: probed
eth0: Atheros AG71xx at 0xba000000, irq 5
eth0: Found an AR7240 built-in switch
eth1: Atheros AG71xx at 0xb9000000, irq 4
eth1: using fixed link parameters
Atheros AR71xx hardware watchdog driver version 0.1.0
ar71xx-wdt: timeout=15 secs (max=21)
TCP westwood registered
NET: Registered protocol family 17
Bridge firewalling registered
802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
All bugs added by David S. Miller <davem@redhat.com>
VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
Freeing unused kernel memory: 148k freed
Please be patient, while OpenWrt loads ...
input: gpio-buttons as /devices/platform/gpio-buttons/input/input0
Button Hotplug driver version 0.3.1
eth0: link up (1000Mbps/Full duplex)
Registered led device: tl-mr3x20:green:system
Registered led device: tl-mr3x20:green:qss
Registered led device: tl-mr3x20:green:3g
SCSI subsystem initialized
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
ar71xx-ehci ar71xx-ehci: Atheros AR91xx built-in EHCI controller
ar71xx-ehci ar71xx-ehci: new USB bus registered, assigned bus number 1
ar71xx-ehci ar71xx-ehci: irq 3, io mem 0x1b000000
ar71xx-ehci ar71xx-ehci: USB 2.0 started, EHCI 1.00
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 1 port detected
Initializing USB Mass Storage driver...
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
usb 1-1: new high speed USB device using ar71xx-ehci and address 2
usb 1-1: configuration #1 chosen from 1 choice
scsi0 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
scsi1 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
scsi 0:0:0:0: CD-ROM            HUAWEI   Mass Storage     2.31 PQ: 0 ANSI: 2
usb-storage: device scan complete
scsi 1:0:0:0: Direct-Access     HUAWEI   SD Storage       2.31 PQ: 0 ANSI: 2
usb-storage: device scan complete
sd 1:0:0:0: [sda] Attached SCSI removable disk
mini_fo: using base directory: /
mini_fo: using storage directory: /overlay
eth0: link down
eth0: link up (1000Mbps/Full duplex)
device eth0 entered promiscuous mode
br-lan: port 1(eth0) entering forwarding state
deflate: Unknown symbol zlib_deflateEnd
deflate: Unknown symbol zlib_deflate
deflate: Unknown symbol zlib_deflateReset
deflate: Unknown symbol zlib_deflate_workspacesize
deflate: Unknown symbol zlib_deflateInit2
Compat-wireless backport release: compat-wireless-2011-01-31-26-gf7606f5
Backport based on wireless-testing.git master-2011-03-24
cfg80211: Calling CRDA to update world regulatory domain
cfg80211: World regulatory domain updated:
cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
cfg80211:     (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
cfg80211:     (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
PCI: Setting latency timer of device 0000:00:00.0 to 64
ath: EEPROM regdomain: 0x0
ath: EEPROM indicates default country code should be used
ath: doing EEPROM country->regdmn map search
ath: country maps to regdmn code: 0x3a
ath: Country alpha2 being used: US
ath: Regpair used: 0x3a
ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
Registered led device: ath9k-phy0
ieee80211 phy0: Atheros AR9287 Rev:2 mem=0xb0000000, irq=48
cfg80211: Calling CRDA for country: US
cfg80211: Regulatory domain changed to country: US
cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
cfg80211:     (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
cfg80211:     (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
cfg80211:     (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
PPP generic driver version 2.4.2
ip_tables: (C) 2000-2006 Netfilter Core Team
NET: Registered protocol family 24
nf_conntrack version 0.5.0 (463 buckets, 1852 max)
CONFIG_NF_CT_ACCT is deprecated and will be removed soon. Please use
nf_conntrack.acct=1 kernel parameter, acct=1 nf_conntrack module option or
sysctl net.netfilter.nf_conntrack_acct=1 to enable it.
xt_time: kernel timezone is -0000
IMQ driver loaded successfully.
        Hooking IMQ before NAT on PREROUTING.
        Hooking IMQ after NAT on POSTROUTING.
usbcore: registered new interface driver usbserial
USB Serial support registered for generic
usbcore: registered new interface driver usbserial_generic
usbserial: USB Serial Driver core
USB Serial support registered for GSM modem (1-port)
usbcore: registered new interface driver option
option: v0.7.2:USB Driver for GSM modems
device wlan0 entered promiscuous mode
br-lan: port 2(wlan0) entering forwarding state
device wlan0 left promiscuous mode
br-lan: port 2(wlan0) entering disabled state
device wlan0 entered promiscuous mode
br-lan: port 2(wlan0) entering forwarding state
usb 1-1: usbfs: process 1315 (usb_modeswitch) did not claim interface 0 before u
se
usb 1-1: USB disconnect, address 2
usb 1-1: new high speed USB device using ar71xx-ehci and address 3
usb 1-1: configuration #1 chosen from 1 choice
option 1-1:1.0: GSM modem (1-port) converter detected
usb 1-1: GSM modem (1-port) converter now attached to ttyUSB0
option 1-1:1.1: GSM modem (1-port) converter detected
usb 1-1: GSM modem (1-port) converter now attached to ttyUSB1
option 1-1:1.2: GSM modem (1-port) converter detected
usb 1-1: GSM modem (1-port) converter now attached to ttyUSB2
option 1-1:1.3: GSM modem (1-port) converter detected
usb 1-1: GSM modem (1-port) converter now attached to ttyUSB3
scsi6 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 3
usb-storage: waiting for device to settle before scanning
scsi 6:0:0:0: Direct-Access     HUAWEI   SD Storage       2.31 PQ: 0 ANSI: 2
sd 6:0:0:0: [sda] Attached SCSI removable disk
usb-storage: device scan complete
ipt_bandwidth: timezone shift detected, adjusting
ar71xx-wdt: enabling watchdog timer
IMQ driver unloaded successfully.
imq: Unknown parameter `hook_chains'
root@Gargoyle:~$ 

nie wiem jakie jeszcze logi mogę wkleić...


Proszę o pomoc wink

2

Odp: TL-MR3420+modem3g+exroot na karcie

No i teraz napisz jakim sposobem mam Ci pomóc. Napisałeś: nie działa. Nie podałeś co zrobiłeś, jakie masz logi, co ustawiłeś, jakie masz wyniki, nic kompletnie.

I jak chcesz uzyskać pomoc?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

3 (edytowany przez chauwa 2011-04-08 19:46:57)

Odp: TL-MR3420+modem3g+exroot na karcie

Ślepa jestem albo ułomna wink


Jan  1 01:00:45 Gargoyle user.info kernel: br-lan: port 2(wlan0) entering disabled state
Jan  1 01:00:45 Gargoyle user.info kernel: device wlan0 entered promiscuous mode
Jan  1 01:00:45 Gargoyle user.info kernel: br-lan: port 2(wlan0) entering forwarding state
Apr  8 18:11:46 Gargoyle user.info sysinit: Error 1 looking up hostname 0.pl.pool.ntp.org
Apr  8 18:11:46 Gargoyle user.info sysinit: Error 1 looking up hostname 1.pl.pool.ntp.org
Apr  8 18:11:46 Gargoyle user.info sysinit: Error 1 looking up hostname 2.pl.pool.ntp.org
Apr  8 18:11:46 Gargoyle user.info sysinit: Loading defaults
Apr  8 18:11:47 Gargoyle user.info sysinit: Loading synflood protection
Apr  8 18:11:47 Gargoyle user.info sysinit: Adding custom chains
Apr  8 18:11:47 Gargoyle user.info sysinit: Loading zones
Apr  8 18:11:48 Gargoyle user.info sysinit: Loading forwardings
Apr  8 18:11:48 Gargoyle user.info sysinit: Loading redirects
Apr  8 18:11:48 Gargoyle user.info sysinit: Loading rules
Apr  8 18:11:48 Gargoyle user.info sysinit: Loading includes
Apr  8 18:11:49 Gargoyle user.info sysinit: Optimizing conntrack
Apr  8 18:11:49 Gargoyle user.info sysinit: Loading interfaces
Apr  8 18:11:49 Gargoyle user.info firewall: adding lan (br-lan) to zone lan
Apr  8 18:11:50 Gargoyle cron.err crond[1235]: crond (busybox 1.15.3) started, log level 5
Apr  8 18:11:50 Gargoyle authpriv.info dropbear[1245]: Running in background
Apr  8 18:11:51 Gargoyle daemon.crit httpd_gargoyle[1266]: socket :: - Address family not supported by protocol
Apr  8 18:11:51 Gargoyle daemon.err httpd_gargoyle[1266]: unknown sockaddr family on listen socket - 0
Apr  8 18:11:51 Gargoyle daemon.warn httpd_gargoyle[1272]: started as root without requesting chroot(), warning only
Apr  8 18:11:51 Gargoyle daemon.notice httpd_gargoyle[1272]: httpd_gargoyle/1.0 14mar2008 starting on Gargoyle, port 80
Apr  8 18:11:51 Gargoyle authpriv.info dropbear[1277]: Child connection from 192.168.1.100:54424
Apr  8 18:11:51 Gargoyle user.notice dnsmasq: DNS rebinding protection is active, will discard upstream RFC1918 responses!
Apr  8 18:11:51 Gargoyle user.notice dnsmasq: Allowing 127.0.0.0/8 responses
Apr  8 18:11:52 Gargoyle authpriv.notice dropbear[1277]: password auth succeeded for 'root' from 192.168.1.100:54424
Apr  8 18:11:55 Gargoyle daemon.info dnsmasq[1297]: started, version 2.55 cachesize 150
Apr  8 18:11:55 Gargoyle daemon.info dnsmasq[1297]: compile time options: IPv6 GNU-getopt no-DBus no-I18N DHCP TFTP
Apr  8 18:11:55 Gargoyle daemon.info dnsmasq-dhcp[1297]: DHCP, IP range 192.168.1.100 -- 192.168.1.250, lease time 12h
Apr  8 18:11:55 Gargoyle daemon.info dnsmasq[1297]: using local addresses only for domain lan
Apr  8 18:11:55 Gargoyle daemon.info dnsmasq[1297]: reading /tmp/resolv.conf.auto
Apr  8 18:11:55 Gargoyle daemon.warn dnsmasq[1297]: ignoring nameserver 192.168.1.1 - local interface
Apr  8 18:11:55 Gargoyle daemon.info dnsmasq[1297]: using local addresses only for domain lan
Apr  8 18:11:55 Gargoyle daemon.info dnsmasq[1297]: read /etc/hosts - 2 addresses
Apr  8 18:11:55 Gargoyle daemon.info dnsmasq-dhcp[1297]: read /etc/ethers - 0 addresses
Apr  8 18:11:55 Gargoyle user.info sysinit: ERROR: No valid dynamic DNS service configurations defined
Apr  8 18:11:55 Gargoyle user.info sysinit: (Did you specify correct configuration file path?)
Apr  8 18:11:55 Gargoyle user.warn kernel: usb 1-1: usbfs: process 1315 (usb_modeswitch) did not claim interface 0 before use
Apr  8 18:11:55 Gargoyle user.info sysinit: Warning: TargetProductList overrides TargetProduct!
Apr  8 18:11:55 Gargoyle user.info sysinit: Looking for target devices ...
Apr  8 18:11:55 Gargoyle user.info sysinit:  No devices in target mode or class found
Apr  8 18:11:55 Gargoyle user.info sysinit: Looking for default devices ...
Apr  8 18:11:55 Gargoyle user.info sysinit:  Found devices in default mode or class (1)
Apr  8 18:11:55 Gargoyle user.info sysinit: Accessing device 002 on bus 001 ...
Apr  8 18:11:55 Gargoyle user.info sysinit: Using endpoints 0x01 (out) and 0x81 (in)
Apr  8 18:11:55 Gargoyle user.info sysinit: Using endpoints 0x01 (out) and 0x81 (in)
Apr  8 18:11:55 Gargoyle user.info sysinit: Inquiring device details; driver will be detached ...
Apr  8 18:11:55 Gargoyle user.info sysinit: Looking for active driver ...
Apr  8 18:11:55 Gargoyle user.info sysinit:  OK, driver found ("usb-storage")
Apr  8 18:11:55 Gargoyle user.info sysinit: Trying to send message 1 to endpoint 0x01 ...
Apr  8 18:11:55 Gargoyle user.info kernel: usb 1-1: USB disconnect, address 2
Apr  8 18:12:00 Gargoyle user.info kernel: usb 1-1: new high speed USB device using ar71xx-ehci and address 3
Apr  8 18:12:00 Gargoyle user.info kernel: usb 1-1: configuration #1 chosen from 1 choice
Apr  8 18:12:00 Gargoyle user.info kernel: option 1-1:1.0: GSM modem (1-port) converter detected
Apr  8 18:12:00 Gargoyle user.info kernel: usb 1-1: GSM modem (1-port) converter now attached to ttyUSB0
Apr  8 18:12:00 Gargoyle user.info kernel: option 1-1:1.1: GSM modem (1-port) converter detected
Apr  8 18:12:00 Gargoyle user.info kernel: usb 1-1: GSM modem (1-port) converter now attached to ttyUSB1
Apr  8 18:12:00 Gargoyle user.info kernel: option 1-1:1.2: GSM modem (1-port) converter detected
Apr  8 18:12:00 Gargoyle user.info kernel: usb 1-1: GSM modem (1-port) converter now attached to ttyUSB2
Apr  8 18:12:00 Gargoyle user.info kernel: option 1-1:1.3: GSM modem (1-port) converter detected
Apr  8 18:12:00 Gargoyle user.info kernel: usb 1-1: GSM modem (1-port) converter now attached to ttyUSB3
Apr  8 18:12:00 Gargoyle user.info kernel: scsi6 : SCSI emulation for USB Mass Storage devices
Apr  8 18:12:00 Gargoyle user.debug kernel: usb-storage: device found at 3
Apr  8 18:12:00 Gargoyle user.debug kernel: usb-storage: waiting for device to settle before scanning
Apr  8 18:12:00 Gargoyle user.notice usb-modeswitch: 1-1:1.0: Manufacturer=HUAWEI_Technology Product=HUAWEI_Mobile Serial=?
Apr  8 18:12:00 Gargoyle user.notice 3g-hotplug: Starting interface wan for device ttyUSB0
Apr  8 18:12:00 Gargoyle user.notice usb-modeswitch: 1-1:1.1: Manufacturer=HUAWEI_Technology Product=HUAWEI_Mobile Serial=?
Apr  8 18:12:01 Gargoyle user.notice usb-modeswitch: 1-1:1.2: Manufacturer=HUAWEI_Technology Product=HUAWEI_Mobile Serial=?
Apr  8 18:12:01 Gargoyle user.notice usb-modeswitch: 1-1:1.3: Manufacturer=HUAWEI_Technology Product=HUAWEI_Mobile Serial=?
Apr  8 18:12:01 Gargoyle user.notice usb-modeswitch: 1-1:1.4: Manufacturer=HUAWEI_Technology Product=HUAWEI_Mobile Serial=?
Apr  8 18:12:04 Gargoyle daemon.notice pppd[1502]: pppd 2.4.4 started by root, uid 0
Apr  8 18:12:05 Gargoyle local2.info chat[1507]: abort on (BUSY)
Apr  8 18:12:05 Gargoyle local2.info chat[1507]: abort on (NO CARRIER)
Apr  8 18:12:05 Gargoyle user.notice kernel: scsi 6:0:0:0: Direct-Access     HUAWEI   SD Storage       2.31 PQ: 0 ANSI: 2
Apr  8 18:12:05 Gargoyle local2.info chat[1507]: abort on (ERROR)
Apr  8 18:12:05 Gargoyle local2.info chat[1507]: report (CONNECT)
Apr  8 18:12:05 Gargoyle local2.info chat[1507]: timeout set to 10 seconds
Apr  8 18:12:05 Gargoyle local2.info chat[1507]: send (AT&F^M)
Apr  8 18:12:05 Gargoyle user.debug kernel: usb-storage: device scan complete
Apr  8 18:12:05 Gargoyle user.notice kernel: sd 6:0:0:0: [sda] Attached SCSI removable disk
Apr  8 18:12:05 Gargoyle local2.info chat[1507]: expect (OK)
Apr  8 18:12:05 Gargoyle local2.info chat[1507]: AT&F^M^M
Apr  8 18:12:05 Gargoyle local2.info chat[1507]: OK
Apr  8 18:12:05 Gargoyle local2.info chat[1507]:  -- got it
Apr  8 18:12:05 Gargoyle local2.info chat[1507]: send (ATE1^M)
Apr  8 18:12:05 Gargoyle local2.info chat[1507]: expect (OK)
Apr  8 18:12:05 Gargoyle local2.info chat[1507]: ^M
Apr  8 18:12:05 Gargoyle local2.info chat[1507]: ATE1^M^M
Apr  8 18:12:05 Gargoyle local2.info chat[1507]: OK
Apr  8 18:12:05 Gargoyle local2.info chat[1507]:  -- got it
Apr  8 18:12:05 Gargoyle local2.info chat[1507]: send (AT+CGDCONT=1,"IP","internet"^M)
Apr  8 18:12:05 Gargoyle local2.info chat[1507]: timeout set to 30 seconds
Apr  8 18:12:05 Gargoyle local2.info chat[1507]: expect (OK)
Apr  8 18:12:05 Gargoyle local2.info chat[1507]: ^M
Apr  8 18:12:05 Gargoyle local2.info chat[1507]: AT+CGDCONT=1,"IP","internet"^M^M
Apr  8 18:12:05 Gargoyle local2.info chat[1507]: OK
Apr  8 18:12:05 Gargoyle local2.info chat[1507]:  -- got it
Apr  8 18:12:05 Gargoyle local2.info chat[1507]: send (ATD*99***1#^M)
Apr  8 18:12:06 Gargoyle local2.info chat[1507]: expect (CONNECT)
Apr  8 18:12:06 Gargoyle local2.info chat[1507]: ^M
Apr  8 18:12:06 Gargoyle local2.info chat[1507]: ATD*99***1#^M^M
Apr  8 18:12:06 Gargoyle local2.info chat[1507]: CONNECT
Apr  8 18:12:06 Gargoyle local2.info chat[1507]:  -- got it
Apr  8 18:12:06 Gargoyle local2.info chat[1507]: send ( ^M)
Apr  8 18:12:06 Gargoyle daemon.info pppd[1502]: Serial connection established.
Apr  8 18:12:06 Gargoyle daemon.info pppd[1502]: Using interface 3g-wan
Apr  8 18:12:06 Gargoyle daemon.notice pppd[1502]: Connect: 3g-wan <--> /dev/ttyUSB0
Apr  8 18:12:09 Gargoyle daemon.warn pppd[1502]: Could not determine remote IP address: defaulting to 10.64.64.64
Apr  8 18:12:09 Gargoyle daemon.notice pppd[1502]: local  IP address 46.112.122.37
Apr  8 18:12:09 Gargoyle daemon.notice pppd[1502]: remote IP address 10.64.64.64
Apr  8 18:12:09 Gargoyle daemon.notice pppd[1502]: primary   DNS address 89.108.195.20
Apr  8 18:12:09 Gargoyle daemon.notice pppd[1502]: secondary DNS address 217.17.34.10
Apr  8 18:12:10 Gargoyle user.notice ifup: Enabling Router Solicitations on wan (3g-wan)
Apr  8 18:12:10 Gargoyle user.info firewall: adding wan (3g-wan) to zone wan
Apr  8 18:12:12 Gargoyle cron.err crond[1773]: crond (busybox 1.15.3) started, log level 5
Apr  8 18:12:14 Gargoyle user.warn kernel: ipt_bandwidth: timezone shift detected, adjusting
Apr  8 18:12:15 Gargoyle cron.err crond[2402]: crond (busybox 1.15.3) started, log level 5
Apr  8 18:12:16 Gargoyle user.info sysinit:  OK, message successfully sent
Apr  8 18:12:16 Gargoyle user.info sysinit: Resetting response endpoint 0x81
Apr  8 18:12:16 Gargoyle user.info sysinit:  Error resetting endpoint: -71
Apr  8 18:12:16 Gargoyle user.info sysinit: Resetting message endpoint 0x01
Apr  8 18:12:16 Gargoyle user.info sysinit:  Error resetting endpoint: -19
Apr  8 18:12:16 Gargoyle user.info sysinit:  Device is gone, skipping any further commands
Apr  8 18:12:16 Gargoyle user.info sysinit: Checking for mode switch (max. 20 times, once per second) ...
Apr  8 18:12:16 Gargoyle user.info sysinit:  Original device is gone already, not checking
Apr  8 18:12:16 Gargoyle user.info sysinit:  Searching for target devices ...
Apr  8 18:12:16 Gargoyle user.info sysinit:  Searching for target devices ...
Apr  8 18:12:16 Gargoyle user.info sysinit:  Searching for target devices ...
Apr  8 18:12:16 Gargoyle user.info sysinit: setting up led USB
Apr  8 18:12:16 Gargoyle user.info sysinit: usbdev
Apr  8 18:12:16 Gargoyle user.debug kernel: ar71xx-wdt: enabling watchdog timer
Apr  8 18:12:20 Gargoyle user.info kernel: IMQ driver unloaded successfully.
Apr  8 18:12:20 Gargoyle user.err kernel: imq: Unknown parameter `hook_chains'
Apr  8 18:12:22 Gargoyle local5.info qosmon[2754]: starting socketfd = 6, statusfd = 5
Apr  8 18:12:24 Gargoyle daemon.info dnsmasq[1297]: reading /tmp/resolv.conf.auto
Apr  8 18:12:24 Gargoyle daemon.info dnsmasq[1297]: using nameserver 217.17.34.10#53
Apr  8 18:12:24 Gargoyle daemon.info dnsmasq[1297]: using nameserver 89.108.195.20#53
Apr  8 18:12:24 Gargoyle daemon.warn dnsmasq[1297]: ignoring nameserver 192.168.1.1 - local interface
Apr  8 18:12:24 Gargoyle daemon.info dnsmasq[1297]: using local addresses only for domain lan
Apr  8 18:12:52 Gargoyle authpriv.info dropbear[2928]: Child connection from 192.168.1.100:54430
Apr  8 18:13:05 Gargoyle authpriv.notice dropbear[2928]: password auth succeeded for 'root' from 192.168.1.100:54430
root@Gargoyle:~$

Co zrobiłam hmm zainstalowałam Gargoyle, staram sie zrobic tego exroota i staje w punkcie z pierwszego postu pierwszego zaznaczenia code, nic sie dalej nie da zrobic tzn. zadne polecenia nie sa wykonywane bo wyskakuja bledy , wyjmowałam karte, kilka krotnie formatowałam na rozne formaty i za kazdym razem wgrywalam od nowa Gargoyle i przystepowałam do exroota z pomoca poradnika

4

Odp: TL-MR3420+modem3g+exroot na karcie

masz w ogóle partycję na tej karcie?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

5 (edytowany przez chauwa 2011-04-08 22:40:00)

Odp: TL-MR3420+modem3g+exroot na karcie

Format programem Minitool partition wizard pod windowsem karta wyglada tak 
http://img251.imageshack.us/i/ext22.jpg/
przy tym kroku się zacina

# umount /dev/sda1

  teraz zazwyczaj wypluwa  invalid argument, do następnych kroków nie da się przejść

6

Odp: TL-MR3420+modem3g+exroot na karcie

Coś dziwnie to wygląda. Zainstaluj sobie fdisk z pamięci (opkg instal -d ram fdisk), uruchom go (/tmp/sbin/fdisk /dev/sda), zdejmij partycję, załóż jedną podstawową. Tak samo zainstaluj e2fsprogs, zrób format na ext2.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

7 (edytowany przez chauwa 2011-04-09 05:57:47)

Odp: TL-MR3420+modem3g+exroot na karcie

Powiem szczerze, ze to moje pierwsze kroki z linuksem   sposób zwraca błąd  po intalacji e2fsprogs.



Sytuacja jest bardziej skomplikowana router stoi spory kawałek od komputera i jedyny internet jest z modemu 3G wpietego w niego wink wiec trochę to utrudnia wszystko sprawę a  w domu zasięgu nie mam by podłączyć modem bezpośrednio do komputera i próbować działac tylko z nim:}

hmm, jak sie nie uda jedynym wyjściem jakie mi przychodzi do głowy będzie aktywny hub usb, tylko czy będzie działać?

8

Odp: TL-MR3420+modem3g+exroot na karcie

W większości przypadków działa.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

9 (edytowany przez chauwa 2011-04-09 15:38:46)

Odp: TL-MR3420+modem3g+exroot na karcie

Póbuje to formatować, jak możesz napisz mi jaka komendę mam wpisać, zawsze zwraca not found, a zainstalowało się na pewno.

Wpisywalam   /tmp/sbin/mkfs.ex2 /dev/sda1     i podobne (co znalazlam w internecie w poradnikach) i lipa fdisk po instalacji działa.

Command (m for help): p

Disk /dev/sda: 966 MB, 966787072 bytes
30 heads, 62 sectors/track, 1015 cylinders
Units = cylinders of 1860 * 512 = 952320 bytes
Disk identifier: 0xd537f0ea

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1        1015      943919   83  Linux

10

Odp: TL-MR3420+modem3g+exroot na karcie

No i co masz po wpisaniu /tmp/usr/sbin/mke2fs /dev/sda1?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

11

Odp: TL-MR3420+modem3g+exroot na karcie

root@Gargoyle:~$ /tmp/sbin/mkfs.ex2 /dev/sda
-ash: /tmp/sbin/mkfs.ex2: not found
root@Gargoyle:~$ /tmp/sbin/mkfs.ex2 /dev/sda1
-ash: /tmp/sbin/mkfs.ex2: not found
root@Gargoyle:~$

12

Odp: TL-MR3420+modem3g+exroot na karcie

/tmp//usr/sbin/mke2fs /dev/sda1

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

13

Odp: TL-MR3420+modem3g+exroot na karcie

root@Gargoyle:~$ /tmp//usr/sbin/mke2fs /dev/sda1
/tmp//usr/sbin/mke2fs: can't load library 'libext2fs.so.2'
root@Gargoyle:~$

14

Odp: TL-MR3420+modem3g+exroot na karcie

ln -s /mnt/sda1/lib/* /lib
ln -s /mnt/sda1/usr/lib/* /lib

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

15

Odp: TL-MR3420+modem3g+exroot na karcie

W drugim przypadku  wypluwa  file exists

jak próbuje format can't load library 'libext2fs.so.2'

nie wiem czy coś za te * trzeba wstawić? Wcisnęłam tam libext2fs.so.2 i tez wypluwa file exists

16

Odp: TL-MR3420+modem3g+exroot na karcie

Linków poprawnie nie zrobiłaś nadal. zamiast * podstaw konkretną nazwę biblioteki (pliku)

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

17 (edytowany przez chauwa 2011-04-09 23:02:03)

Odp: TL-MR3420+modem3g+exroot na karcie

Nie czaje tych komend wink zwłaszcza co tam wpisywać za nazwy plików, co nie wpisze i tak nie idzie. Zrobiłam kolejny raz pod Windowsem format ale znowu coś nie teges...

Po formacie karty i wykonaniu procedury z poradnika router przestał odpowiadać na modem 3G, WAN sie zmroził na amen i bylo IP ostatniego połączenia, no to heja wgrałam od nowa gorgonzole i widok jest teraz taki jak niżej., aż się boje tykać hehe bo jest postęp i może nareszcie zaskoczyć a nie chce zepsuć

root@Gargoyle:~$ mount
rootfs on / type rootfs (rw)
/dev/root on /rom type squashfs (ro,relatime)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,relatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,relatime)
tmpfs on /dev type tmpfs (rw,relatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,relatime,mode=600)
root on /tmp/root type tmpfs (rw,relatime,mode=755)
mini_fo:/tmp/root on /tmp/root type mini_fo (rw,relatime)
none on /proc/bus/usb type usbfs (rw,relatime)
/dev/sda1 on /tmp/root/mnt/sda1 type ext2 (rw,relatime,errors=continue)
/dev/mtdblock3 on /overlay type jffs2 (rw,relatime)
mini_fo:/overlay on / type mini_fo (rw,relatime)
root@Gargoyle:~$ df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root                 2.4M      2.4M         0 100% /rom
tmpfs                    14.5M    148.0K     14.3M   1% /tmp
tmpfs                   512.0K      4.0K    508.0K   1% /dev
root                      2.4M      2.4M         0 100% /tmp/root
mini_fo:/tmp/root         2.4M      2.4M         0 100% /tmp/root
/dev/sda1               888.2M      2.0K    842.3M   0% /tmp/root/mnt/sda1
/dev/mtdblock3          320.0K    240.0K     80.0K  75% /overlay
mini_fo:/overlay          2.4M      2.4M         0 100% /
root@Gargoyle:~$

(/dev/sda1 on /tmp/root/mnt/sda1 type ext2 (rw,relatime,errors=continue)) hmmmm i tak w kolo, procedura z poradnika i nie ma internetu ani exroota, trzeba wgrywac od nowa

18

Odp: TL-MR3420+modem3g+exroot na karcie

NIe masz extroota. Po następnym resecie będzie normalnie /mnt/sda1 zamontowany. A skoro tak jest, to możesz ustawić is_rootfs na 1 i powinien extroota sobie zrobić.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

19 (edytowany przez chauwa 2011-04-10 17:43:42)

Odp: TL-MR3420+modem3g+exroot na karcie

Po wielu bojach UDAŁO SIE
Dzieki za pomoc Cezary

root@Gargoyle:~$ df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root                 2.4M      2.4M         0 100% /rom
tmpfs                    14.5M     88.0K     14.4M   1% /tmp
tmpfs                   512.0K      4.0K    508.0K   1% /dev
/dev/sda1               835.1M     67.0K    791.9M   0% /overlay
mini_fo:/overlay          2.4M      2.4M         0 100% /
root@Gargoyle:~$

Dla potomnych napisze wink E173 może być użyty do exroota pod warunkiem użycia aktywnego huba inaczej trzeba kombinowac.


Juz miałam zrezygnował i znalazłam starego pendriva 2GB, wpielam w router i pach śmigał za każdym razem, wiec przyszła myśl by poeksperymentować z modemem w komputerze i żadne komendy at nie pomogły, nawet gdy był aktywny jako sam dysk wymienny, wiec skleciłam dodatkowe zasilanie do modemu by był cały czas włączony, zasilacz 5V 1,2A 2diody zenera kawalek przewodu 15minut roboty i hula wink po wpieciu do routera trzeba strzelic REBOOT i bedzie startował za kazdym razem do puki ma zasilanie. Reboot modemu można wykonać wysyłając komendę AT wiec problemu nie ma wink

20

Odp: TL-MR3420+modem3g+exroot na karcie

No to super. Szacunek smile

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

21 (edytowany przez chauwa 2011-04-10 17:54:29)

Odp: TL-MR3420+modem3g+exroot na karcie

Nie będę zakładać nowego wątku, http://eko.one.pl/?p=openwrt-3ginfo#instalacja  nie można tego zainstalowac http://eko.one.pl/openwrt/3ginfo_1-21_all.ipk , brak kompatybilnosci? Reszta bez problemu, Najbardziej mi na tym zależało


Blad jaki jest

root@Gargoyle:~$ opkg install http://eko.one.pl/openwrt/3ginfo_1-21_all.ipk
Downloading http://eko.one.pl/openwrt/3ginfo_1-21_all.ipk.
Installing 3ginfo (1-21) to root...
Collected errors:
 * opkg_install_pkg: Package 3ginfo md5sum mismatch. Either the opkg or the package index are corrupt. Try 'opkg update'.
 * opkg_install_cmd: Cannot install package 3ginfo.

opkg update nic nie zmienia

22

Odp: TL-MR3420+modem3g+exroot na karcie

Zrób po prostu opkg install 3ginfo. Jest u mnie standardowo w repo.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

23

Odp: TL-MR3420+modem3g+exroot na karcie

Po zrobieniu exroota po kazdym reboot trzeba wejść w panel gorgonzoli i kliknąć w ustawieniach zapisz, inaczej nie jest aktywne   polaczenie 3g  jak i  wi-fi nie działa tylko LAN, w projekcie 3ginfo nie działa przycisk rozłącz za to połącz owszem, wszelkie dane włacznie z QOS sa wyswietlane, wiecej problemow nie ma transmision,sftp,ftp i kilka innych działa bez zarzutu.

24

Odp: TL-MR3420+modem3g+exroot na karcie

To coś nie działa Ci. Wifi jeżeli zostało ustawione musi działać od razu po starcie.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

25 (edytowany przez chauwa 2011-04-11 15:48:07)

Odp: TL-MR3420+modem3g+exroot na karcie

Nie działa wifi jak i 3G sie nie łaczy, na razie nie chce tego wzystkiego od nowa instalowac bo mam zamiar kupic karte 16GB wiec prowizorycznie moze szło by gdzieś dopisać linie z opznionym wykonaniem opcji konfiguracja/zapisz.

Po wejsciu w konfiguracje wszystko jest ustawione i zapisane jak trzeba, tylko nie startuje, wchodzę wciskam zapisz i smiga...