Temat: LAMP - problem z instalacją - błąd przy starcie APACHE

Witam, otóż staram się zainstalować i uruchomić LAMP zgodnie z manualem: http://eko.one.pl/?p=openwrt-lamp  , lecz przy próbie uruchomienia Apache dostaję informację:

httpd: apr_sockaddr_info_get() failed for OpenWrt-LLMP
httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
(125)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

i w tym momencie nie wiem co robić. Dodam że mój router to 1043ND z najnowszym Gargoylem z EXROOTem oraz wpiętym pendrive 4GB. Przed moim routerem stoi modemo-router Cisco EPC 3925 od UPC. WAN w TP-LINKU jest statyczny : 192.168.1.10 .

Proszę o pomoc co dalej robić.


Pozdrawiam.

2

Odp: LAMP - problem z instalacją - błąd przy starcie APACHE

1. masz gargoyle uruchomione na porcie 80 i apache nie uruchomi się na nim ponownie. Zmień port albo tu albo tu.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

3

Odp: LAMP - problem z instalacją - błąd przy starcie APACHE

Po zmainie listeningu na 81:

httpd: apr_sockaddr_info_get() failed for OpenWrt-LLMP
httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName

4

Odp: LAMP - problem z instalacją - błąd przy starcie APACHE

A to już nie jest błąd tylko warning że nazwy hosta nie masz.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

5

Odp: LAMP - problem z instalacją - błąd przy starcie APACHE

Czy to znaczy że muszę mieć domenę? Chciałbym na razie aby wszystko chodziło po adresie IP. Jakieś wskazówki co zrobić?

6

Odp: LAMP - problem z instalacją - błąd przy starcie APACHE

Nie nie musisz. Albo ustaw w /etc/hosts nazwę dla 192.168.1.1 albo zignoruj to.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

7

Odp: LAMP - problem z instalacją - błąd przy starcie APACHE

W jaki sposób zignorować? Nie rusza dalej przez ten błąd. Spróbuję zatem dodać nazwę.

8

Odp: LAMP - problem z instalacją - błąd przy starcie APACHE

Wydaje się że wszystko działa. Jak teraz bawić się z tym dalej? Jak wrzucić stronę, jak skonfigurować to żeby strona była widoczna w sieci biorąc pod uwagę to co napisałem o routerach i adresacji?

9

Odp: LAMP - problem z instalacją - błąd przy starcie APACHE

Pytanie dziwne skoro zabrałeś się za konfigurację tego. Poradnik opisuje to - stronę masz wrzucić w katalog domowy określony w konfiguracji serwera www. W internecie nie będzie ona widoczna, dopóki nie będziesz miał:
- publicznego adresu, lub
- przekierowania jakiegoś portu (najlepiej 80) na port 80 routera (czy taki jak ustawiłeś w konfigu)
- odblokowanego firewalla na wan dla tego portu

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

10

Odp: LAMP - problem z instalacją - błąd przy starcie APACHE

Port przekierowany już dawno. Odblokowanie firewall? Na TP-Linku nie ma nic o blokadzie lub ja nie widzę. Na Cisco, który dostarcza neta jest tylko opcja Block Anonymous Internet Requests i opcja jest zaznaczona.

Gdzie wrzucić stronę też wiem - ale nie wiem jak. Folder www1 jest na pendrive, który jest EXTROOTem dla TP-Linka i tu nie wiem jak wrzucać pliki a o tym poradnik nie mówi...

11

Odp: LAMP - problem z instalacją - błąd przy starcie APACHE

Faq nie czytałeś smile. Najprościej przez winscp, jeżeli masz uruchomione to samba/ftp itd.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

12 (edytowany przez snap171 2013-06-17 11:03:24)

Odp: LAMP - problem z instalacją - błąd przy starcie APACHE

No tak ale jak pendrive robi cały za EXTROOT to ciężko ustawić FTP.

Musiałbym go albo przystosować żeby dało się na nim też pliki zapisywać. Chyba że podłącze drugie pendrive-a i przekopiuję www1 i zmienię konfigurację httpd.conf .

13

Odp: LAMP - problem z instalacją - błąd przy starcie APACHE

Winscp tak po prostu...

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

14

Odp: LAMP - problem z instalacją - błąd przy starcie APACHE

Podałem adres routera w WinSCP ale jaki login i hasło (anonimowo nie idze, na login i pass do routera też nie):

Nie można nawiązać połączenia, ponieważ komputer docelowy aktywnie go odmawia.
Połączenie nie powiodło się.

15

Odp: LAMP - problem z instalacją - błąd przy starcie APACHE

root i hasło takie jak go gui.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

16 (edytowany przez snap171 2013-06-17 20:43:36)

Odp: LAMP - problem z instalacją - błąd przy starcie APACHE

Błąd dokładnie taki jak powyżej.

Weszło przez protokół SCP.

Po wpisaniu w przeglądarkę adresu http://192.168.2.1/www1/index.html przenosi na główną stronę zarządzania gargoylem.

17

Odp: LAMP - problem z instalacją - błąd przy starcie APACHE

Czyli gargoyle nasłuchuje na porcie 80. Apache na jakim porcie ustawiłeś?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

18

Odp: LAMP - problem z instalacją - błąd przy starcie APACHE

Jeżeli chodzi o nasłuchiwanie do 81 .

19

Odp: LAMP - problem z instalacją - błąd przy starcie APACHE

http://192.168.2.1:81/www1/index.html
W takim razie..

RB760iGS + RB260GS / Ryzen 5 2660 / 16G DDR4 / MiniITX - Inea 1G (https://i.imgur.com/TLbJVDw.png)
RB951-2HnD / Celeron J1900 / 4G DDR3 / MiniITX - Satpol 100M

20

Odp: LAMP - problem z instalacją - błąd przy starcie APACHE

Błąd strony. Może jednak coś nie działa? Czym sprawdzić czy wszystko jest ok i działa?

21

Odp: LAMP - problem z instalacją - błąd przy starcie APACHE

W logach apache/php.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

22

Odp: LAMP - problem z instalacją - błąd przy starcie APACHE

Nie moge doszukać się żadnych logów - przynajmniej nie w pamięci.

23

Odp: LAMP - problem z instalacją - błąd przy starcie APACHE

A włączyłeś je w konfigach php i apache w ogóle?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

24

Odp: LAMP - problem z instalacją - błąd przy starcie APACHE

Mam podobny problem.
Postępowałem zgodnie z toturialem i wywala mi

httpd: Could not reliably determine the server's fully qualified domain name, using 192.168.1.1 for ServerName

w /etc/hosts mam to:

127.0.0.1 localhost
192.168.1.1 openwrt

A po wpisaniu w przeglądarkę adresu routera ciągle ładuje ale nic nie wyświetla:/

Co może być przyczyną???

25

Odp: LAMP - problem z instalacją - błąd przy starcie APACHE

Na razie nikt tego nie wie, wróżkami nie jesteśmy. W logi patrz.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.