426

Odp: Netgear R6220 instalacje OpenWrt

Dokładnie tyle. Zobacz https://en.wikipedia.org/wiki/List_of_W … j/n/ac/ax)

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

427

Odp: Netgear R6220 instalacje OpenWrt

To co jest nie tak ze po świeżej instalacji gargoyle 1.12 jest u mnie tak biednie ?

428

Odp: Netgear R6220 instalacje OpenWrt

W jakim sensie biednie? W sumie jest 6 pasm 80MHz i 2 pasma 160MHz. I tyle, więcej nie ma ma tej szerokości. Chcesz więcej kanałów to zmień sobie na ht20.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

429

Odp: Netgear R6220 instalacje OpenWrt

Może chodziło o to ,że nie ma tego ostatniego szóstego na 149 kanale....

430

Odp: Netgear R6220 instalacje OpenWrt

@roratoga: pokaż mi wynik polecenia

iw list

dokładnie z tego routera o którym pisałeś w poprzednich postach. Muszę małą teorię sprawdzić.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

431

Odp: Netgear R6220 instalacje OpenWrt

iw list
Wiphy phy1
    max # scan SSIDs: 4
    max scan IEs length: 2247 bytes
    max # sched scan SSIDs: 0
    max # match sets: 0
    max # scan plans: 1
    max scan plan interval: -1
    max scan plan iterations: 0
    Retry short limit: 7
    Retry long limit: 4
    Coverage class: 0 (up to 0m)
    Available Antennas: TX 0x3 RX 0x3
    Configured Antennas: TX 0x3 RX 0x3
    Supported interface modes:
         * IBSS
         * managed
         * AP
         * AP/VLAN
         * monitor
         * mesh point
    Band 2:
        Capabilities: 0x1ff
            RX LDPC
            HT20/HT40
            SM Power Save disabled
            RX Greenfield
            RX HT20 SGI
            RX HT40 SGI
            TX STBC
            RX STBC 1-stream
            Max AMSDU length: 3839 bytes
            No DSSS/CCK HT40
        Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
        Minimum RX AMPDU time spacing: 4 usec (0x05)
        HT TX/RX MCS rate indexes supported: 0-15
        VHT Capabilities (0x018001b0):
            Max MPDU length: 3895
            Supported Channel Width: neither 160 nor 80+80
            RX LDPC
            short GI (80 MHz)
            TX STBC
        VHT RX MCS set:
            1 streams: MCS 0-9
            2 streams: MCS 0-9
            3 streams: not supported
            4 streams: not supported
            5 streams: not supported
            6 streams: not supported
            7 streams: not supported
            8 streams: not supported
        VHT RX highest supported: 0 Mbps
        VHT TX MCS set:
            1 streams: MCS 0-9
            2 streams: MCS 0-9
            3 streams: not supported
            4 streams: not supported
            5 streams: not supported
            6 streams: not supported
            7 streams: not supported
            8 streams: not supported
        VHT TX highest supported: 0 Mbps
        Frequencies:
            * 5180 MHz [36] (20.0 dBm)
            * 5200 MHz [40] (20.0 dBm)
            * 5220 MHz [44] (20.0 dBm)
            * 5240 MHz [48] (20.0 dBm)
            * 5260 MHz [52] (20.0 dBm) (radar detection)
            * 5280 MHz [56] (20.0 dBm) (radar detection)
            * 5300 MHz [60] (20.0 dBm) (radar detection)
            * 5320 MHz [64] (20.0 dBm) (radar detection)
            * 5500 MHz [100] (27.0 dBm) (radar detection)
            * 5520 MHz [104] (27.0 dBm) (radar detection)
            * 5540 MHz [108] (27.0 dBm) (radar detection)
            * 5560 MHz [112] (27.0 dBm) (radar detection)
            * 5580 MHz [116] (27.0 dBm) (radar detection)
            * 5600 MHz [120] (27.0 dBm) (radar detection)
            * 5620 MHz [124] (27.0 dBm) (radar detection)
            * 5640 MHz [128] (27.0 dBm) (radar detection)
            * 5660 MHz [132] (27.0 dBm) (radar detection)
            * 5680 MHz [136] (27.0 dBm) (radar detection)
            * 5700 MHz [140] (27.0 dBm) (radar detection)
            * 5745 MHz [149] (disabled)
            * 5765 MHz [153] (disabled)
            * 5785 MHz [157] (disabled)
            * 5805 MHz [161] (disabled)
            * 5825 MHz [165] (disabled)
    valid interface combinations:
         * #{ IBSS } <= 1, #{ managed, AP, mesh point } <= 8,
           total <= 8, #channels <= 1, STA/AP BI must match, radar detect widths: { 20 MHz (no HT), 20 MHz, 40 MHz, 80 MHz }

    HT Capability overrides:
         * MCS: ff ff ff ff ff ff ff ff ff ff
         * maximum A-MSDU length
         * supported channel width
         * short GI for 40 MHz
         * max A-MPDU length exponent
         * min MPDU start spacing
    Device supports VHT-IBSS.
Wiphy phy0
    max # scan SSIDs: 4
    max scan IEs length: 2257 bytes
    max # sched scan SSIDs: 0
    max # match sets: 0
    max # scan plans: 1
    max scan plan interval: -1
    max scan plan iterations: 0
    Retry short limit: 7
    Retry long limit: 4
    Coverage class: 0 (up to 0m)
    Available Antennas: TX 0x3 RX 0x3
    Supported interface modes:
         * IBSS
         * managed
         * AP
         * AP/VLAN
         * monitor
         * mesh point
    Band 1:
        Capabilities: 0x1fe
            HT20/HT40
            SM Power Save disabled
            RX Greenfield
            RX HT20 SGI
            RX HT40 SGI
            TX STBC
            RX STBC 1-stream
            Max AMSDU length: 3839 bytes
            No DSSS/CCK HT40
        Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
        Minimum RX AMPDU time spacing: 4 usec (0x05)
        HT TX/RX MCS rate indexes supported: 0-15
        Frequencies:
            * 2412 MHz [1] (20.0 dBm)
            * 2417 MHz [2] (20.0 dBm)
            * 2422 MHz [3] (20.0 dBm)
            * 2427 MHz [4] (20.0 dBm)
            * 2432 MHz [5] (20.0 dBm)
            * 2437 MHz [6] (20.0 dBm)
            * 2442 MHz [7] (20.0 dBm)
            * 2447 MHz [8] (20.0 dBm)
            * 2452 MHz [9] (20.0 dBm)
            * 2457 MHz [10] (20.0 dBm)
            * 2462 MHz [11] (20.0 dBm)
            * 2467 MHz [12] (20.0 dBm)
            * 2472 MHz [13] (20.0 dBm)
            * 2484 MHz [14] (disabled)
    valid interface combinations:
         * #{ IBSS } <= 1, #{ managed, AP, mesh point } <= 4,
           total <= 4, #channels <= 1, STA/AP BI must match
    HT Capability overrides:
         * MCS: ff ff ff ff ff ff ff ff ff ff
         * maximum A-MSDU length
         * supported channel width
         * short GI for 40 MHz
         * max A-MPDU length exponent
         * min MPDU start spacing

432

Odp: Netgear R6220 instalacje OpenWrt

Dzięki. Już to zgłosiłem ale zostałem pogoniony za to (i bardzo dobrze dobrze!). Czy ktoś zauważył że Netgear R6220 nie ma... kanału 144? Za chiny nie mogę włączyć VHT80 obejmujący właśnie ten zakres kanałów.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

433 (edytowany przez Dyziek 2020-05-06 15:53:02)

Odp: Netgear R6220 instalacje OpenWrt

Channel 144: This channel was added as part of FCC changes in 2014. So this channel will be problematic for older devices that don't recognize this channel. Worst of all is that some brand new devices in 2020 also mess up and don't support channel 144, so it is best to avoid selecting 144 as a 'primary' channel in most routers -- because if you do, a small subset of clients will not be able to connect to your router. Devices that don't recognize 20 MHz channel 144, also by definition don't recognize 40 MHz channel 142 and 80 MHz channel 138.

https://www.duckware.com/tech/wifi-in-the-us.html
Podają, że dużo Netgear’ów ma z tym problem

434 (edytowany przez gonzales 2020-05-15 23:47:38)

Odp: Netgear R6220 instalacje OpenWrt

Przepraszam z góry za lamerskie pytanie, ale już tak się zakręciłem (oczywiście z braku wiedzy), iż nie wiem co dalej robić.
Konfiguruje WAN jako połączenie PPPoE - działa, zmieniam interface na klient DHCP wpinając za innym routerem działa, zmieniam interface na połączenie LTE,  QMI - internetu brak.

Przecież sterowniki od modemu ZTE821 są w systemie. Sprawdzałem wcześniej modem wykrywa dostępne sieci. A połączenia brak, pewnie gdzieś na odcinku WAN - LAN jest namieszane, zmostkowane lub nie albo nie wiem co. Jednak inne interfejsy działają.

Coś się zmienia jak się przestawiamy na połączenie GSM?

network

config interface 'lan'
    option type 'bridge'
    option proto 'static'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option ipaddr '192.168.9.1'
    option ifname 'eth0.1'

config device 'lan_dev'
    option name 'eth0.1'
    option macaddr 'xx:xx:xx:xx:xx:78'

config device 'wan_dev'
    option name 'eth0.2'
    option macaddr 'xx:xx:xx:xx:xx:79'

config interface 'wan6'
    option ifname 'eth0.2'
    option proto 'dhcpv6'
    option reqaddress 'try'
    option reqprefix 'auto'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0 1 2 3 6t'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '4 6t'

config interface 'wg0'

config wireguard_wg0
    
config interface 'wan'
    option modes 'lte'
    option ifname 'eth0.2'
    option proto 'qmi'
    option pdptype 'ipv4v6'
    option apn 'internet'
    option auth 'none'
    option device '/dev/cdc-wdm0'

firewall

config defaults
    option syn_flood '1'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'ACCEPT'

config zone
    option name 'lan'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'ACCEPT'
    option network 'lan'

config zone
    option name 'wan'
    option input 'REJECT'
    option output 'ACCEPT'
    option forward 'REJECT'
    option masq '1'
    option mtu_fix '1'
    option network 'wan wan6'

config rule
    option name 'Allow-DHCP-Renew'
    option src 'wan'
    option proto 'udp'
    option dest_port '68'
    option target 'ACCEPT'
    option family 'ipv4'

config rule
    option name 'Allow-Ping'
    option src 'wan'
    option proto 'icmp'
    option icmp_type 'echo-request'
    option family 'ipv4'
    option target 'ACCEPT'

config rule
    option name 'Allow-IGMP'
    option src 'wan'
    option proto 'igmp'
    option family 'ipv4'
    option target 'ACCEPT'

config rule
    option name 'Allow-DHCPv6'
    option src 'wan'
    option proto 'udp'
    option src_ip 'fc00::/6'
    option dest_ip 'fc00::/6'
    option dest_port '546'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-MLD'
    option src 'wan'
    option proto 'icmp'
    option src_ip 'fe80::/10'
    list icmp_type '130/0'
    list icmp_type '131/0'
    list icmp_type '132/0'
    list icmp_type '143/0'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-ICMPv6-Input'
    option src 'wan'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    list icmp_type 'router-solicitation'
    list icmp_type 'neighbour-solicitation'
    list icmp_type 'router-advertisement'
    list icmp_type 'neighbour-advertisement'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-ICMPv6-Forward'
    option src 'wan'
    option dest '*'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-IPSec-ESP'
    option src 'wan'
    option dest 'lan'
    option proto 'esp'
    option target 'ACCEPT'

config rule
    option name 'Allow-ISAKMP'
    option src 'wan'
    option dest 'lan'
    option dest_port '500'
    option proto 'udp'
    option target 'ACCEPT'

config include
    option path '/etc/firewall.user'

config rule
    option src 'wan'
    option target 'ACCEPT'
    option proto 'udp'
    option dest_port '55055'
    option name 'wireguard'

config zone
    option name 'wg'
    option input 'ACCEPT'
    option forward 'ACCEPT'
    option output 'ACCEPT'
    option masq '1'
    option network 'wg0'

config forwarding
    option src 'wg'
    option dest 'wan'

config forwarding
    option src 'wan'
    option dest 'wg'

config forwarding
    option src 'wg'
    option dest 'lan'

config forwarding
    option src 'lan'
    option dest 'wg'

435

Odp: Netgear R6220 instalacje OpenWrt

To wywal

    option modes 'lte'
    option ifname 'eth0.2'
    option pdptype 'ipv4v6'
    option auth 'none'


W szczególności ten ifname może przeszkadzać.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

436 (edytowany przez gonzales 2020-05-17 01:12:19)

Odp: Netgear R6220 instalacje OpenWrt

@Cezary dzięki. Po korekcie zgodnie z Twoimi wskazówkami był już prawie sukces.
Czyli internet pozornie był na kompie ale nie otwierało żadnych stron.
VPN wireguard dało się pingować.
Wtedy mi się skojarzyło, że już to przerabiałem, tylko wtedy router będący klientem wireguard był wpięty za routerem z wbudowanym modem LTE (LAN-WAN) a teraz router będący klientem wireguard łączył się sam przy wykorzystaniu modemu LTE na usb.
W tym temacie o tym pisałem.
https://eko.one.pl/forum/viewtopic.php? … 53#p228053
Trzeba było dopisać DNS-y w konfigu, żeby działał internet ale nie z każdym testowanym DNS to skutkowało łączeniem z stronami www.
Nadal nie wiem dlaczego na jednym łączu trzeba wpisaywać DNS a na innym nie ale to w tym momencie nieistotne.

437

Odp: Netgear R6220 instalacje OpenWrt

Cześć,

Krótko się cieszyłem światłowodem po tym jak już były 2 downtime u ISP. Muszę zrobić backup/failover.

"Fabrycznie" 6220 ma 1 WAN.
Czy w wrt na r6220 jest możliwość użycia mwan3 tak aby jeden z portów ETH robił za WAN2?

Najbliżej jest  https://eko.one.pl/?p=openwrt-mwan3 tylko tam użyto (innego HW) i LEDE 17.01 a ja mam gargoyle 1.12.
Czy ten obraz wystarczy?

Zatem zanim rozgrzebię sobie sieć chciałbym się upewnić co do opcji.

Dzięki za wsparcie.
Pozdrawiam
A.

438

Odp: Netgear R6220 instalacje OpenWrt

Tak możesz. Jak wydzielić port masz tutaj: https://eko.one.pl/?p=openwrt-mwan3

Ale gargoyle do tego to zły pomysł, ono nie zna pojęcia drugiego wanu, więc jak się przełączy na drugi wan to gargoyle w gui nie będzie pokazywało połączenia.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

439

Odp: Netgear R6220 instalacje OpenWrt

Cezary napisał/a:

[...]
Ale gargoyle do tego to zły pomysł, ono nie zna pojęcia drugiego wanu, więc jak się przełączy na drugi wan to gargoyle w gui nie będzie pokazywało połączenia.

Cezary, dzięki za wskazówkę.
Zatem Luci.
Teraz, z gargoyle 1.12 -> factory -> luci 19.07. Czy tak?

Pozdrawiam
A.

440

Odp: Netgear R6220 instalacje OpenWrt

Nie, od razu luci sysupgrade, tylko bez zachowania konfiguracji.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

441

Odp: Netgear R6220 instalacje OpenWrt

Cześć wszystkim

Mam mam pytanie odnośnie diody LED informującej o podłączeniu urządzenia do portu USB na R6220. Po zainstalowaniu Gargoyle 1.13 od Cezarego dioda aktywuje się po podłączeniu choćby dysku, natomiast postanowiłem jednak wrócić do wersji stabilnej i zrobiłem downgrade do 1.12 i tam już ta dioda się nie świeci, po mimo tego dysk podłączony pod USB pracuje normalnie i wszystko działa...chciałem zapytać czy faktycznie nie ma wsparcia dla tej diody w wersji 1.12, czy coś skopałem przy aktualizacji do niższej wersji ??


Dzięki z góry za odpowiedź, bo nie mogę spać w nocy big_smile

442

Odp: Netgear R6220 instalacje OpenWrt

Wieczorem mogę ci powiedzieć czy w 1.12 jest coś innego z  obsługą tej diody, bo już nie pamiętam.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

443

Odp: Netgear R6220 instalacje OpenWrt

Cezary napisał/a:

Wieczorem mogę ci powiedzieć czy 1.12 jest coś innego obsługą tej diody, bo już nie pamietam.

Super Cezary, jak jesteś w stanie to sprawdzić to będę wdzięczny smile. Dzięki!

444

Odp: Netgear R6220 instalacje OpenWrt

Tak, w 19.07 jest po prostu inaczej zrobiona obsługa led od usb.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

445

Odp: Netgear R6220 instalacje OpenWrt

Cezary napisał/a:

Tak, w 19.07 jest po prostu inaczej zrobiona obsługa led od usb.

I wszystko jasne Czarku. Dzięki za odzew!

446 (edytowany przez marcin19883 2020-09-24 17:53:28)

Odp: Netgear R6220 instalacje OpenWrt

Kupiłem ten router, niedługo będzie u mnie. Rozumiem, że pierwszy raz instaluje squashfs-factory.img a póżniej kontynuacja z squashfs-sysupgrade.bin. Nie robię nic z paczkami kernel i rootfs w przypadku OpenWrt 19.07?

447

Odp: Netgear R6220 instalacje OpenWrt

Nie. Instalujesz tylko factory i nie ma sensu poprawiać sysupgrade, nigdy się tak  nie robiło. factory to sysupgrade + odpowiedni nagłówek żeby oryginalny soft to łykał.

Nic już nie kombinujesz z kernel i rootfs.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

448 (edytowany przez marcin19883 2020-09-24 18:42:02)

Odp: Netgear R6220 instalacje OpenWrt

Cezary napisał/a:

Nic już nie kombinujesz z kernel i rootfs.

Już rozumiem. Na openwrt 18.06 instalowało się kernel. Wersja 19.07 jest już normalna.

449

Odp: Netgear R6220 instalacje OpenWrt

Dokładnie.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

450

Odp: Netgear R6220 instalacje OpenWrt

Cześć,
mam problem z moim R6220 działającym na OpenWrt 19.07 z luci.
Przez około pół roku wszystko działało OK, jednak od jakichś dwóch tygodni, po pewnym czasie od włączenia routera, przestają wczytywać się strony. Restartuję router, co jednak nie zawsze pomaga. Najczęściej muszę go restartować znowu, gdyż dioda Power na routerze albo się w ogóle nie świeci (a świecą się pozostałe, tj. WAN, Ethernet czy Wi-Fi), albo miga. Zaktualizowałem oprogramowanie do najnowszego dostępnego na tej stronie jednak problem nie ustąpił.
Po tym jak strony przestały się wczytywać, wszedłem w panel administracyjny i skopiowałem log systemowy i kernela, więc jeśli będzie taka potrzeba to mogę je wrzucić.
Wykluczam problem z ISP, gdyż na starym routerze wszystko działa.

Czy ktoś miał podobny problem?