76

Odp: Jak wgrać OpenWrt oraz DD-WRT do Easybox 802 i 803A?

Zależy do czego, bo w 18.06 i 19.07 popsuta jest obsługa USB. Jeśli nie zamierzasz z nich korzystać to wgraj nowszą wersję.

Fast Path od 18.06 jest zbędne, gdyż jest tam wsparcie dla flow offloading. Ale patcha Fast Path  dla 18.06 widziałam więc teoretycznie  można zaaplikować i skompilować.

77

Odp: Jak wgrać OpenWrt oraz DD-WRT do Easybox 802 i 803A?

Zuzia napisał/a:

Zależy do czego, bo w 18.06 i 19.07 popsuta jest obsługa USB. Jeśli nie zamierzasz z nich korzystać to wgraj nowszą wersję.
.

a czy jest 19.07 do easybox 802?

78

Odp: Jak wgrać OpenWrt oraz DD-WRT do Easybox 802 i 803A?

19.07 jeszcze oficjalnie nie ma, jest snapshot.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

79 (edytowany przez Zuzia 2019-07-30 19:31:53)

Odp: Jak wgrać OpenWrt oraz DD-WRT do Easybox 802 i 803A?

Sprawdziłam na szybko na 803A ostatni snapshot, a tu już kernel 4.19 i wszystkie USB działają, modem LTE też. Czyżby po prawie dekadzie Easyboxy doczekały się konkretnego wsparcia? smile Skompiluję i dam znać.

Edycja:
PS. Odradzam własną kompilację 19.07, bo na domyślnej konfiguracji obraz wykłada router tak, że trzeba przywracać przez bootloader.  Ale pobrany stąd działa prawidłowo: https://downloads.openwrt.org/releases/ … ntiq/xway/
Tyle, że system i pakiety mają większą objętość więc przy skromnym flash 8MB wchodzi mniej niż na LEDE.

80

Odp: Jak wgrać OpenWrt oraz DD-WRT do Easybox 802 i 803A?

     _________
    /        /\      _    ___ ___  ___
   /  LE    /  \    | |  | __|   \| __|
  /    DE  /    \   | |__| _|| |) | _|
 /________/  LE  \  |____|___|___/|___|                      lede-project.org
 \        \   DE /
  \    LE  \    /  -----------------------------------------------------------
   \  DE    \  /    Reboot (17.01-SNAPSHOT, r0+4031-14fb5b4f15)
    \________\/    -----------------------------------------------------------

 | Machine: Arcor 803                                                        |
 | Uptime: 0d, 00:04:27                                                      |
 | Load: 0.12 0.43 0.23                                                      |
 | Flash: total: 1.2MB, free: 972KB, used: 20%                               |
 | Memory: total: 58.4MB, free: 39.8MB, used: 31%                            |
 | WAN: 192.168.0.8, proto: dhcp                                             |
 | LAN: 192.168.1.1, leases: 0                                               |
 | radio0: mode: sta, ssid: UPC Wi-Free, channel: auto, conn: 0              |
 -----------------------------------------------------------------------------
Linux version 4.4.184 (zuzia@zuzia) (gcc version 5.4.0 (LEDE GCC 5.4.0 r0+4031-14fb5b4f15) ) #0 Fri Jun 21 12:24:11 2019

Wersja dla Easybox 803A z Fast Path: http://chomikuj.pl/ZuzannaCK/ROUTERY/EA … _fastpath)

81

Odp: Jak wgrać OpenWrt oraz DD-WRT do Easybox 802 i 803A?

no i chyba uwalilem na dobre, dobrze ze to moj zapasowy router "do testowania", easybox 802:
1. probowalem wgrac ten najnowszy snapshot od uzytkownika Zuzia, LEDE Reboot 17.01-SNAPSHOT r0+4031-14fb5b4f15 dla EASYBOX 802, przez GUI bez zapamietania ustawien ale cos chyba poszlo nie tak bo
2. router nie wstaje, co kilka sek migaja wszystkie diody
3. nie daje sie wprowadzic w failsafe, ani przyciskiem wifi na bocznej sciance ani pinem reset, caly czas co jakis czas migaja wszystkie diody.

czy to juz czas oddac na elektrosmieci?

82

Odp: Jak wgrać OpenWrt oraz DD-WRT do Easybox 802 i 803A?

Konwerter szeregowy i przez bootloader.  O ile masz.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

83

Odp: Jak wgrać OpenWrt oraz DD-WRT do Easybox 802 i 803A?

Cezary napisał/a:

Konwerter szeregowy i przez bootloader.  O ile masz.

niestety nie posiadam. czyli jak rozumiem, jesli nei moge go zmusic do wejscia w failsafe to jest trup?

84

Odp: Jak wgrać OpenWrt oraz DD-WRT do Easybox 802 i 803A?

Jak nie działa openwrt to nie działa też failsafe. Więc zostaje kabelek i bootloader.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

85 (edytowany przez Zuzia 2019-07-31 23:29:07)

Odp: Jak wgrać OpenWrt oraz DD-WRT do Easybox 802 i 803A?

@wankus
Kup sobie za kilka złotych konwerter CP2102 USB i wgraj przez niego wg. instrukcji:
http://chomikuj.pl/ZuzannaCK/ROUTERY/EA … er-OpenWRT


Edycja:
Próbowałam wywołać podobny efekt i udało się dopiero przy upgrade z Chaos Calmer do LEDE przez Luci:

[   55.064629] Call Trace:
[   55.067019] [<801da150>] GetPureRepPrice+0x34/0x118
[   55.071751] [<801dc3b8>] LzmaEnc_MemEncode+0x1c94/0x2d6c
[   55.076903] [<80141414>] jffs2_lzma_compress+0x78/0xbc
[   55.081892] [<8012d368>] jffs2_selected_compress+0xdc/0x180
[   55.087291] [<8012d490>] jffs2_compress+0x84/0x2ec
[   55.091947] [<80134aec>] jffs2_write_inode_range+0xd8/0x318
[   55.097344] [<8012f318>] jffs2_write_end+0x16c/0x330
[   55.102177] [<80084a74>] generic_perform_write+0x1fc/0x2e4
[   55.107486] [<80086788>] __generic_file_write_iter+0x17c/0x244
[   55.113145] [<80086a1c>] generic_file_write_iter+0x1cc/0x29c
[   55.118633] [<800c45a4>] __vfs_write+0xe8/0x110
[   55.123025] [<800c461c>] __kernel_write+0x50/0xf0
[   55.127596] [<80111aa0>] dump_emit+0x94/0x104
[   55.131813] [<801102cc>] elf_core_dump+0xf3c/0x1168
[   55.136544] [<80112840>] do_coredump+0x9d0/0xdf0
[   55.141022] [<80036e90>] get_signal+0x618/0x6d4
[   55.145414] [<8001570c>] do_signal+0x18/0x20c
[   55.149637] [<800165e8>] do_notify_resume+0x2c/0x98
[   55.154368] [<800025ac>] work_notifysig+0x10/0x18
[   55.158913] 
[   55.160344] 
Code: 00821021  00063040  00863021 <94420000> 94c30000  384207ff  3405c328  00021102  00031902 
[   55.170222] ---[ end trace f3d09f04ba2a8f7d ]---
[   55.180119] Fatal exception: panic in 5 seconds
[   60.186737] Kernel panic - not syncing: Fatal exception
[   60.193379] Rebooting in 1 seconds..

Restarty w kółko, ale Failsafe jest dostępny.

Można wejść w ten tryb przez szybkie naciskanie przycisku WiFi  przez ok. 15 sek. Jeśli przycisk jest uszkodzony to nie zadziała. W Failsafe da się wejść również za pomocą przycisku Restart znajdującego się przy wtyczce zasilania.

W każdym bądź razie wykonanie firstboot -y przywraca router do życia.

86

Odp: Jak wgrać OpenWrt oraz DD-WRT do Easybox 802 i 803A?

witam
rozpocząłem również póki co nierówną walkę z moim EASY802 udało się wgrać UBOOT niestety nie potwierdziłem Y po jego wgraniu (nie wiedziałem kiedy to zrobić) i teraz nie mogę wgrać reszty oprogramowania
aktualnie po odpaleniu w konsoli mam taki odczyt

ROM VER: 1.0.3
CFG 01
Read�
ROM VER: 1.0.3
CFG 01
Read EEPROMX
X


U-Boot 2010.03 (May 11 2012 - 02:54:15)

Board: ARV4518PW
SoC: Danube/Twinpass/Vinax-VE V1.3, DDR Speed 166 MHz, CPU Speed 333 MHz
DRAM:  64 MB
Flash:  8 MB
*** Warning - bad CRC, using default environment

Net:   
searching for rtl8306 switch ... found
lq_cpe_eth
Hit any key to stop autoboot:  0
Wrong Image Format for bootm command
ERROR: can't get kernel image!
ARV4518 =>

co mam zrobić żeby wgrać resztę
jeżeli można jakąś konkretną podpowiedz bo jestem laikiem w linuksie specjalnie na potrzebę przeprogramowania zainstalowałem sobie MINTa na jednym z komputerów

87 (edytowany przez Zuzia 2019-08-03 00:32:39)

Odp: Jak wgrać OpenWrt oraz DD-WRT do Easybox 802 i 803A?

Instrukcja dla wgrywających LEDE/OpenWRT do Easybox 802 po raz pierwszy

-> http://chomikuj.pl/ZuzannaCK/ROUTERY/EA … er-OpenWRT



@zbyniu1972
W oknie z bootloadrem (tam, gdzie zgłasza się ARV4518 => ) wpisujesz:

loady 0x80500000

i wciskasz Enter.



Otwórz sobie drugie okno konsoli a w nim kolejno wykonaj:

wget https://downloads.openwrt.org/releases/17.01.7/targets/lantiq/xway/lede-17.01.7-lantiq-xway-ARV752DPW-squashfs-sysupgrade.bin

sx -vv lede-17.01.7-lantiq-xway-ARV752DPW-squashfs-sysupgrade.bin < /dev/ttyUSB0 > /dev/ttyUSB0

Można od razu wgrać obraz ode mnie, wtedy odpada późniejsza aktualizacja. Kopiowanie trwa kilka minut po czym pojawia się komunikat "Transfer complete".



Wtedy trzeba przejść do okna konsoli z bootloaderem i wykonać:

era ${kernel_addr} +${filesize};cp.b ${ram_addr} ${kernel_addr} ${filesize}

Odczekać, aż pojawi się komunikat tego rodzaju:

Erased 73 sectors
Copy to Flash... 9....8....7....6....5....4....3....2....1....done

Wypiąc na chwilę wtyk od zasilania, po ponownym uruchomieniu routera wystartuje LEDE.

88

Odp: Jak wgrać OpenWrt oraz DD-WRT do Easybox 802 i 803A?

dzięki @ZUZIA jesteś wielka ,poszło bez problemu

89 (edytowany przez Zuzia 2019-08-09 18:56:21)

Odp: Jak wgrać OpenWrt oraz DD-WRT do Easybox 802 i 803A?

Flow Offloading w 18.06 lub 19.07 daje to samo co Fast Path więc jeśli komuś nie zależy szczególnie na USB może wgrywać obrazy z oficjalnego repozytorium.

90

Odp: Jak wgrać OpenWrt oraz DD-WRT do Easybox 802 i 803A?

Dzięki za pomoc w przerobieniu tego modemu (803A), udało mi się w końcu wgrać 18.06 i działa jak na razie stabilnie.
Mam tylko pytanie odnośnie ADSLa, chciałem nim zastąpić sypiącego się powoli liveboxa Orange'a z tego co kojarzę to w Polsce mam AnnexA, czy wystarczy w ustawieniach DSL wybrać AnnexA, czy trzeba dogrywać jeszcze jakieś inne pakiety?
Próbował, ktoś może odpalać neostradę na nim?

Dorzucę od siebie tylko, że jeżeli ktoś nie ma pod ręką distro Linuxa to do przesyłania Ymodemem można użyć też programu ZOC (emteca).
pozdrawiam

91

Odp: Jak wgrać OpenWrt oraz DD-WRT do Easybox 802 i 803A?

Chyba jeszcze trzeba wgrać firmware od  Annex A. Nie wiem, czy działa, nigdy nie testowałam nic na łączach xDSL.

92 (edytowany przez Zuzia 2020-02-04 17:19:23)

Odp: Jak wgrać OpenWrt oraz DD-WRT do Easybox 802 i 803A?

OpenWrt 18.07 dla Easybox 802/803A z Fast Path (kernel 4.9.211)

- wydajność LAN-WAN około 90 Mb/s
- prawidłowa obsługa wszystkich trzech portów USB
- domyślnie port LAN4/TV służy jako WAN dla kablówki
- WiFi domyślnie jest aktywne
- repozytorium pakietów jest dostępne online, czyli korzysta się tak jak w przypadku każdego innego OpenWrt, opkg update/install
Główne funkcjonalności podane w opisie: nośniki danych (menadżer dysków w Luci), modemy 3G/LTE, UPC Wi-Free/Eduroam itd.), Wireguard, N2N, DDNS itd.

Po zrobieniu Extroot można zmienić funkcjonalność na na xDSL, VoIP itd. (wystarczy dowolny pendrive).

 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 18.07, r0+7977-1b5c116233
-----------------------------------------------------
 | Machine: Arcor 803                                |
 | Uptime: 0d, 01:48:49                              |
 | Load: 3.44 2.24 1.20                              |
 | Flash: total: 704KB, free: 452KB, used: 36%       |
 | Memory: total: 58.0MB, free: 38.8MB, used: 33%    |
 | WAN: 192.168.0.8, proto: dhcp                     |
 | LAN: 192.168.1.1, leases: 1                       |
 -----------------------------------------------------
Linux version 4.9.211 (Astoria@EasyBOX) (gcc version 7.3.0 (OpenWrt GCC 7.3.0 r0+7977-1b5c116233) )

Wersja dla Easybox 802 z wpad-mini: http://chomikuj.pl/ZuzannaCK/ROUTERY/EA … _fastpath)
Wersja dla Easybox 802 z wpad: http://chomikuj.pl/ZuzannaCK/ROUTERY/EA … h_Wi-Free)
Wersja dla Easybox 803A z wpad: http://chomikuj.pl/ZuzannaCK/ROUTERY/EA … h_Wi-Free)

93

Odp: Jak wgrać OpenWrt oraz DD-WRT do Easybox 802 i 803A?

Jak jest z wifi w tym obrazie dla 803A? Bo u mnie często się zawieszało i nawet polecenie "wifi" już go nie podnosiło (połączenie jest ale nie przechodzi nic). Używam w trybie AP, obraz z openwrt.org

94

Odp: Jak wgrać OpenWrt oraz DD-WRT do Easybox 802 i 803A?

WiFi u mnie działa dobrze w obydwu 802/803A, jako test wybrałam sieć UPC Wi-Free, bo router je nadający jest co najmniej za jedną ścianą.
Przyciks WPS aktywuje/dezaktywuje WiFi, domyślna konfiguracja:

config wifi-device 'radio0'
    option type 'mac80211'
    option hwmode '11g'
    option path 'pci0000:00/0000:00:0e.0'
    option legacy_rates '0'
    option country 'PL'
    option wps_pushbutton '0'
    option channel 'auto'
    option htmode 'HT20'
    option disabled '1'

config wifi-iface 'default_radio0'
    option device 'radio0'
    option network 'lan'
    option mode 'ap'
    option ssid 'EasyBOX'
    option encryption 'psk2+aes'
    option key 'WiFipassword'

config wifi-iface
    option network 'upcwifree'
    option ssid 'UPC Wi-Free #SprawdzUPCMobile!'
    option device 'radio0'
    option mode 'sta'
    option identity 'login'
    option password 'password'
    option encryption 'wpa2+tkip+ccmp'
    option eap_type 'peap'
    option auth 'EAP-MSCHAPV2'
    option ca_cert '/etc/ssl/certs/LGI_Root_CA.cer'
    option domain_suffix_match 'wifi-auth.upc.biz'
    option wps_pushbutton '0'
    option disabled '1'

W przypadku nieużywania  UPC Wi-Free zalecam usunąć ostatnią sekcję. HT20 można zmienić na HT40.

Jak będzie działać WiFi u innych tego nie wiem, bo to zależy od wielu czynników. Wybrałam kernel 4.9, ponieważ jest najstabilniejszy na Lantiq i co najważniejsze porty USB funkcjonują poprawnie.

95

Odp: Jak wgrać OpenWrt oraz DD-WRT do Easybox 802 i 803A?

Przy okazji będę testować, problem na pewno sterownika bo po restarcie od razu działało do następnego zawieszenia. Zakłóceń od innych sieci nie ma, bo innych sieci nie ma smile To na działce, najwyżej w okresie wakacji (w sumie głównie wtedy jest potrzebne wifi) była jedna z bardzo słabym sygnałem.

96

Odp: Jak wgrać OpenWrt oraz DD-WRT do Easybox 802 i 803A?

Jak skonfigurować 802openwrt żeby można go używać jako punkt dostępowy PPPoE ? do którego portu włożyć wtyczkę ? który to port WAN?

97

Odp: Jak wgrać OpenWrt oraz DD-WRT do Easybox 802 i 803A?

Jeżeli korzystasz z domyślnych softów od openwrt to tam nie ma wanu. Musisz sobie sam podzielić switch i wydzielić wan na jednym z nich.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

98

Odp: Jak wgrać OpenWrt oraz DD-WRT do Easybox 802 i 803A?

dzięki za odpowiedz korzystam z najnowszego softu z tej strony mógłbyś podpowiedzieć jak to zrobić w miarę możliwości bardzo łopatologicznie smile

99

Odp: Jak wgrać OpenWrt oraz DD-WRT do Easybox 802 i 803A?

Nie posiadam już 802, więc nie napiszę ci konkretnie jak ma konfig wyglądać

Na forum masz za to taką informację: https://eko.one.pl/forum/viewtopic.php?id=15687
A jak coś niejasnego to przeczytaj to: https://eko.one.pl/?p=openwrt-vlan

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

100 (edytowany przez Zuzia 2020-03-02 14:41:26)

Odp: Jak wgrać OpenWrt oraz DD-WRT do Easybox 802 i 803A?

zbyniu1972 napisał/a:

który to port WAN?

Przykładowa konfiguracja dla Easybox 802, gdzie WAN to port oznaczony z tyłu routera jako LAN4/TV:

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fdc1:50ce:9791::/48'

config interface 'lan'
    option force_link '1'
    option type 'bridge'
    option proto 'static'
    option netmask '255.255.255.0'
    option ifname 'eth0.1'
    option ipaddr '192.168.1.1'
    option ip6assign '60'
    option dns '1.1.1.1'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '1 2 3 5t'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '4 5t'

config interface 'wan'
    option proto 'dhcp'
    option ifname 'eth0.2'
    option delegate '0'
    option type 'bridge'
    option metric '20'

config interface 'wan6'
    option ifname '@wan'
    option proto 'dhcpv6'