Temat: Problem z zestawieniem połączenia TP-Link TL-MR3220 v2 i Huawei E3372

Cześć. Zainstalowałem wczoraj na TP-Link TL-MR3220 v2 software LEDE Reboot 17.01.5 r3919-38e704be71 / LuCI lede-17.01 branch (git-18.180.55366-b78664c). Bez problemu działa jeśli do WAN podłączę kabel z modemu od operatora kablowego. Nie mogę natomiast zestawić połączenia z siecią mobilną. Do USB TP-Linka podłączam modem Huawei E3372. Modem automatycznie się łączy i jest zapalona dioda że połączenie został zestawione (dla pewności też podłączyłem bezpośrednio modem do USB komputera aby wykluczyć jakiekolwiek problemy z modemem/kartą SIM i działa w porządku).
W interfejsach stworzyłem sobie nowy interfejs sieciowy wybierając jako protokół UMTS/GPRS/EV-DO. Jako modem device podałem /dev/ttyATH0 dlatego, że przeglądając kernel logi znalazłem
[    0.000000] Kernel command line:  board=TL-MR3220-v2  console=ttyATH0,115200 rootfstype=squashfs,jffs2 noinitrd
[    0.731366] ar933x-uart: ttyATH0 at MMIO 0x18020000 (irq = 11, base_baud = 1562500) is a AR933X UART
[    0.739221] console [ttyATH0] enabled

Próbowałem też losowo z innymi ścieżkami dla modem device. Pozostałe to /dev/ttyS0 aż do /dev/ttyS15.

Modem 192.168.8.1
Router 192.168.1.1

Co robię źle i co zrobić żeby sieć działała?

2

Odp: Problem z zestawieniem połączenia TP-Link TL-MR3220 v2 i Huawei E3372

Zły protokół wybrałeś. Masz hilinka, więc ustaw dhcp i jako interfejs wybierz eth1 lub eth2, w zależności ile tam tego masz.

Nie UMTS/GPRS/EV-DO, bo nie masz modemu udostępniającego porty szeregowe. Czytaj https://eko.one.pl/?p=openwrt-3g#obsuga … ejnphilink

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

3

Odp: Problem z zestawieniem połączenia TP-Link TL-MR3220 v2 i Huawei E3372

Dobrze rozumiem. Doinstalowałem do routera kmod-usb-net-cdc-ether i zrobiłem tak że Protocol do DHCP client a Physical Settings Ethernet Adapter: "eth1" (nie mam więcej ethernet adapterów tylko to, tzn mam Ethernet Switch: "eth0" ale to zakładam że może służyć w inny sposób). W zasadzie tak samo jak w tym 1,5 minutowym filmiku https://www.youtube.com/watch?v=Qxrou7qQWc4
Rebootowałem, wyłączałem router, zrobiłem factory reset i na nowo konfigurację, usunąłem WAN i dodałem jeszcze raz.
Niestety nic z tego.
Jeszcze taka ciekawostka, że zauważyłem że modem rozłącza się po jakichś ~5 minutach (zupełnie nic nie robiłem przez ten czas) - być może jest jakiś problem z USB?
Czy coś mogę jeszcze zrobić?

4 (edytowany przez Cezary 2019-11-16 15:19:23)

Odp: Problem z zestawieniem połączenia TP-Link TL-MR3220 v2 i Huawei E3372

3220-v2 ma eth0.1 jako lan i eth1 jako wan. Więc modem musi mieć eth2. Coś jednak nie zainstalowałeś.

Pokaż wyniki poleceń:

cat /sys/kernel/debug/usb/devices
ifconfig -a
ifstatus wan
route -n
uci show network

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

5

Odp: Problem z zestawieniem połączenia TP-Link TL-MR3220 v2 i Huawei E3372

Załączam wyniki poleceń:

 
root@LEDE:~# cat /sys/kernel/debug/usb/devices

T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480  MxCh= 1
B:  Alloc=  0/800 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0002 Rev= 4.04
S:  Manufacturer=Linux 4.4.140 ehci_hcd
S:  Product=EHCI Host Controller
S:  SerialNumber=ehci-platform
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  0mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   4 Ivl=256ms

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=480  MxCh= 0
D:  Ver= 2.10 Cls=00(>ifc ) Sub=00 Prot=ff MxPS=64 #Cfgs=  1
P:  Vendor=12d1 ProdID=1f01 Rev= 1.02
S:  Manufacturer=HUAWEI_MOBILE
S:  Product=HUAWEI_MOBILE
S:  SerialNumber=0123456789ABCDEF
C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr=  2mA
I:* If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=(none)
E:  Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=125us
root@LEDE:~# ifconfig -a
br-lan    Link encap:Ethernet  HWaddr 60:E3:27:3B:3E:99
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fdf2:b537:23b6::1/60 Scope:Global
          inet6 addr: fe80::62e3:27ff:fe3b:3e99/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1356 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1074 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:117793 (115.0 KiB)  TX bytes:178005 (173.8 KiB)

eth0      Link encap:Ethernet  HWaddr 60:E3:27:3B:3E:99
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:5

eth1      Link encap:Ethernet  HWaddr 60:E3:27:3B:3E:9B
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:4

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:176 errors:0 dropped:0 overruns:0 frame:0
          TX packets:176 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1
          RX bytes:11552 (11.2 KiB)  TX bytes:11552 (11.2 KiB)

wlan0     Link encap:Ethernet  HWaddr 60:E3:27:3B:3E:9A
          inet6 addr: fe80::62e3:27ff:fe3b:3e9a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1355 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1401 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:136757 (133.5 KiB)  TX bytes:236768 (231.2 KiB)

root@LEDE:~# ifstatus wan
{
        "up": false,
        "pending": false,
        "available": true,
        "autostart": true,
        "dynamic": false,
        "proto": "dhcp",
        "device": "eth1",
        "data": {

        }
}
root@LEDE:~# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 br-lan
root@LEDE:~# uci show network
network.loopback=interface
network.loopback.ifname='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.globals.ula_prefix='fdf2:b537:23b6::/48'
network.lan=interface
network.lan.type='bridge'
network.lan.ifname='eth0'
network.lan.proto='static'
network.lan.ipaddr='192.168.1.1'
network.lan.netmask='255.255.255.0'
network.lan.ip6assign='60'
network.wan6=interface
network.wan6.ifname='eth1'
network.wan6.proto='dhcpv6'
network.@switch[0]=switch
network.@switch[0].name='switch0'
network.@switch[0].reset='1'
network.@switch[0].enable_vlan='1'
network.@switch_vlan[0]=switch_vlan
network.@switch_vlan[0].device='switch0'
network.@switch_vlan[0].vlan='1'
network.@switch_vlan[0].ports='1 2 3 4 0'
network.wan=interface
network.wan.proto='dhcp'
network.wan.ifname='eth1'
root@LEDE:~#

Tutaj jeszcze m.in. potwierdzenie, że mam zainstalowany kmod-usb-net-cdc-ether:

root@LEDE:~# opkg install kmod-usb-net-cdc-ether
Package kmod-usb-net-cdc-ether (4.4.140-1) installed in root is up to date.
root@LEDE:~# uci del network.wan
uci: Entry not found
root@LEDE:~# uci del network.mobile_internet
root@LEDE:~# uci set network.wan=interface
root@LEDE:~# uci set network.wan.proto=dhcp
root@LEDE:~# uci set network.wan.ifname=eth1
root@LEDE:~# uci commit network
root@LEDE:~# reboot

(do tej pory klikałem wszystko z interfejsu całą konfigurację)

6

Odp: Problem z zestawieniem połączenia TP-Link TL-MR3220 v2 i Huawei E3372

Nie przeczytałeś tego linku który podałem. Zainstaluj jeszcze usb-modeswitch, bo modem Ci się nie przełączył w odpowiedni tryb. I wtedy przestaw wan na eth2 który się pojawi.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

7

Odp: Problem z zestawieniem połączenia TP-Link TL-MR3220 v2 i Huawei E3372

Super, działa! Właśnie dodaję ten post z tej konfiguracji na OpenWRT.
Zrobiłem na czysto wszystko jeszcze raz i w zasadzie wystarczy kilka poleceń aby można było korzystać.
Wrzucam tutaj jeszcze log wraz z poleceniami, być może ktoś też nie doczyta instrukcji a mu to pomoże:

root@LEDE:~# opkg update
Downloading http://downloads.lede-project.org/releases/17.01.5/targets/ar71xx/generic/packages/Packages.gz
Updated list of available packages in /var/opkg-lists/reboot_core
Downloading http://downloads.lede-project.org/releases/17.01.5/targets/ar71xx/generic/packages/Packages.sig
Signature check passed.
Downloading http://downloads.lede-project.org/releases/17.01.5/packages/mips_24kc/base/Packages.gz
Updated list of available packages in /var/opkg-lists/reboot_base
Downloading http://downloads.lede-project.org/releases/17.01.5/packages/mips_24kc/base/Packages.sig
Signature check passed.
Downloading http://downloads.lede-project.org/releases/17.01.5/packages/mips_24kc/luci/Packages.gz
Updated list of available packages in /var/opkg-lists/reboot_luci
Downloading http://downloads.lede-project.org/releases/17.01.5/packages/mips_24kc/luci/Packages.sig
Signature check passed.
Downloading http://downloads.lede-project.org/releases/17.01.5/packages/mips_24kc/packages/Packages.gz
Updated list of available packages in /var/opkg-lists/reboot_packages
Downloading http://downloads.lede-project.org/releases/17.01.5/packages/mips_24kc/packages/Packages.sig
Signature check passed.
Downloading http://downloads.lede-project.org/releases/17.01.5/packages/mips_24kc/routing/Packages.gz
Updated list of available packages in /var/opkg-lists/reboot_routing
Downloading http://downloads.lede-project.org/releases/17.01.5/packages/mips_24kc/routing/Packages.sig
Signature check passed.
Downloading http://downloads.lede-project.org/releases/17.01.5/packages/mips_24kc/telephony/Packages.gz
Updated list of available packages in /var/opkg-lists/reboot_telephony
Downloading http://downloads.lede-project.org/releases/17.01.5/packages/mips_24kc/telephony/Packages.sig
Signature check passed.
root@LEDE:~# opkg install kmod-usb-net-cdc-ether usb-modeswitch
Installing kmod-usb-net-cdc-ether (4.4.140-1) to root...
Downloading http://downloads.lede-project.org/releases/17.01.5/targets/ar71xx/generic/packages/kmod-usb-net-cdc-ether_4.4.140-1_mips_24kc.ipk
Installing kmod-mii (4.4.140-1) to root...
Downloading http://downloads.lede-project.org/releases/17.01.5/targets/ar71xx/generic/packages/kmod-mii_4.4.140-1_mips_24kc.ipk
Installing kmod-usb-net (4.4.140-1) to root...
Downloading http://downloads.lede-project.org/releases/17.01.5/targets/ar71xx/generic/packages/kmod-usb-net_4.4.140-1_mips_24kc.ipk
Installing usb-modeswitch (2017-05-24-453da8e5-1) to root...
Downloading http://downloads.lede-project.org/releases/17.01.5/packages/mips_24kc/base/usb-modeswitch_2017-05-24-453da8e5-1_mips_24kc.ipk
Installing librt (1.1.16-1) to root...
Downloading http://downloads.lede-project.org/releases/17.01.5/targets/ar71xx/generic/packages/librt_1.1.16-1_mips_24kc.ipk
Installing libusb-1.0 (1.0.21-1) to root...
Downloading http://downloads.lede-project.org/releases/17.01.5/packages/mips_24kc/base/libusb-1.0_1.0.21-1_mips_24kc.ipk
Configuring kmod-mii.
Configuring librt.
Configuring libusb-1.0.
Configuring usb-modeswitch.
Configuring kmod-usb-net.
Configuring kmod-usb-net-cdc-ether.
root@LEDE:~# uci del network.wan
root@LEDE:~# uci set network.wan=interface
root@LEDE:~# uci set network.wan.proto=dhcp
root@LEDE:~# uci set network.wan.ifname=eth2
root@LEDE:~# uci commit network
root@LEDE:~# reboot

Kolejny na warsztat wezmę Edimax, powinno pójść szybciej. smile
Dziękuję!