1

Temat: OPKG w trybie AccessPoint bez routingu - nie działa

Witam
Korzystając z instrukcji
http://eko.one.pl/?p=openwrt-trybypracy
uruchomiłem router NEXX z adresem 192.168.1.10 w trybie AccessPoint bez routingu. Główny router ma 192.168.1.1
Co ma źle ustawione że nie działa mi OPKG ? Błąd "Check your network settings and connectivity."
Ustawienia /etc/config/network
wyglądają tak:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd1a:60d1:aadf::/48'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.10'
        option ifname 'eth0 eth0.1 eth0.2'
        option gateway '192.168.1.1'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr '20:28:18:a0:ea:d2'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 6t'

2

Odp: OPKG w trybie AccessPoint bez routingu - nie działa

option dns 8.8.8.8 w sekcji lan zrób. Nie masz dnsów.

A ten ifname jest bez sensu. option ifname 'eth0.1 eth0.2' po prostu.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

3

Odp: OPKG w trybie AccessPoint bez routingu - nie działa

No i działa
Dzięki