51

Odp: Który system do pyLoad...?

Jeszcze raz wszystkie pakiety zainstalowałem i dalej ten błąd:

root@Gargoyle:/media/pyload# opkg list_installed | grep curl                                                                   
                                                                                                                               
libcurl - 7.40.0-3                                                                                                             
python-curl - 7.19.0-1                                                                                                         
root@Gargoyle:/media/pyload#                                                                                                   
root@Gargoyle:/media/pyload# opkg list_installed | grep python                                                                 
python - 2.7.9-6                                                                                                               
python-base - 2.7.9-6                                                                                                          
python-codecs - 2.7.9-6                                                                                                        
python-compiler - 2.7.9-6                                                                                                      
python-crypto - 2.6-1                                                                                                          
python-ctypes - 2.7.9-6                                                                                                        
python-curl - 7.19.0-1                                                                                                         
python-db - 2.7.9-6                                                                                                            
python-decimal - 2.7.9-6                                                                                                       
python-distutils - 2.7.9-6                                                                                                     
python-django - 1.3.1-1                                                                                                        
python-email - 2.7.9-6                                                                                                         
python-expat - 2.7.3-2                                                                                                         
python-gdbm - 2.7.9-6                                                                                                          
python-imaging-library - 1.1.7-2                                                                                               
python-light - 2.7.9-6                                                                                                         
python-logging - 2.7.9-6                                                                                                       
python-mini - 2.7.3-2                                                                                                          
python-multiprocessing - 2.7.9-6                                                                                               
python-ncurses - 2.7.9-6                                                                                                       
python-openssl - 2.7.9-6                                                                                                       
python-pydoc - 2.7.9-6                                                                                                         
python-sqlite3 - 2.7.9-6                                                                                                       
python-unittest - 2.7.9-6                                                                                                      
python-xml - 2.7.9-6                                                                                                           
root@Gargoyle:/media/pyload# opkg list_installed | grep openssl                                                                
libopenssl - 1.0.2j-1                                                                                                          
libustream-openssl - 2015-07-09-c2d73c22618e8ee444e8d346695eca908ecb72d3                                                       
openssl-util - 1.0.2j-1                                                                                                        
openvpn-openssl - 2.3.6-1                                                                                                      
pyopenssl - 0.10-1                                                                                                             
python-openssl - 2.7.9-6  

52 (edytowany przez mavcin 2017-02-19 00:27:09)

Odp: Który system do pyLoad...?

Pomieszałeś pakiety pythona z BB i CC. Wywal to co masz i zrób wg instrukcji @valdi74

Tak to powinno wyglądać

root@OpenWrt:/media/pyload# opkg list_installed | grep curl
libcurl - 7.38.0-1
python-curl - 7.19.0-1
root@OpenWrt:/media/pyload# opkg list_installed | grep python
python - 2.7.3-2
python-crypto - 2.6-1
python-curl - 7.19.0-1
python-imaging-library - 1.1.7-2
python-mini - 2.7.3-2
python-openssl - 2.7.3-2
python-sqlite3 - 2.7.3-2
root@OpenWrt:/media/pyload# opkg list_installed | grep openssl
libopenssl - 1.0.2f-1
pyopenssl - 0.10-1
python-openssl - 2.7.3-2
root@OpenWrt:/media/pyload# python ./pyLoadCore.py
This is your first start, running configuration assistent now.
Choose your Language / Wähle deine Sprache ([en], de, fr, it, es, nl, sv, ru, pl, cs, sr, pt_BR):
WNDR3800 17.01.4 / WNDR3700v2 17.01.4 / 2x TL-WR741ND v4 15.05.1

53

Odp: Który system do pyLoad...?

Mavcin a w jakiej kolejność to instalowałeś ? Ja odinstalowałem wszystkie pakiety python i próbowałem jeszcze raz. Oto rezultat:

root@Gargoyle:/media# opkg list_installed | grep curl                                                                                   
libcurl - 7.38.0-1                                                                                                                      
python-curl - 7.19.0-1                                                                                                                  
root@Gargoyle:/media# opkg list_installed | grep python                                                                                 
python - 2.7.3-2                                                                                                                        
python-crypto - 2.6-1                                                                                                                   
python-curl - 7.19.0-1                                                                                                                  
python-expat - 2.7.3-2                                                                                                                  
root@Gargoyle:/media# opkg list_installed | grep openssl                                                                                
libopenssl - 1.0.2g-1                                                                                                                   
libustream-openssl - 2015-07-09-c2d73c22618e8ee444e8d346695eca908ecb72d3                                                                
openvpn-openssl - 2.3.6-1                                                                                                               
root@Gargoyle:/media# opkg install python-sqlite3_2.7.3-2_ramips_24kec.ipk                                                              
Segmentation fault                                                                                                                      
root@Gargoyle:/media# ls                                                                                                                
done                                             python-expat_2.7.3-2_ramips_24kec.ipk                                                  
libopenssl_1.0.2f-1_ramips_24kec.ipk             python-imaging-library_1.1.7-2_ramips_24kec.ipk                                        
openssl-util_1.0.2f-1_ramips_24kec.ipk           python-mini_2.7.3-2_ramips_24kec.ipk                                                   
pyopenssl_0.10-1_ramips_24kec.ipk                python-openssl_2.7.3-2_ramips_24kec.ipk                                                
python-crypto_2.6-1_ramips_24kec.ipk             python-sqlite3_2.7.3-2_ramips_24kec.ipk                                                
python-curl_7.19.0-1_ramips_24kec.ipk            python_2.7.3-2_ramips_24kec.ipk                                                        
root@Gargoyle:/media# opkg install python-mini_2.7.3-2_ramips_24kec.ipk                                                                 
Preparing to install the following packages, which will require 1362106 bytes:                                                          
        python-mini                                                                                                                     
                                                                                                                                        
Preparing to install package python-mini...                                                                                             
ERROR: file '/usr/lib/python2.7/token.py'                                                                                               
       from package python-mini already exists.                                                                                         
                                                                                                                                        
An error occurred during Installation, removing partially installed packages.                                                           
Removing package python-mini...                                                                                                         
Finished removing python-mini.                                                                                                          
                                                                                                                                        
Finished removing partially installed packages.                                                                                         
                                                                                                                                        
root@Gargoyle:/media#      

54 (edytowany przez mar_w 2017-02-19 03:11:40)

Odp: Który system do pyLoad...?

@djmysia
Nie słuchasz rad ludzi, którzy przetestowali to z sukcesem.
@mavcin napisał Ci, żebyś stosował instrukcję od @valdi74 post #43

valdi74 napisał/a:

...
Punktem wyjścia jest zainstalowane CC (bez LUCI) od Cezarego....

A ty masz wypasione Gargoyle z pakietami, które różnią się z tym co podaje instrukcja.
Przykład: zainstalowany libopenssl-1.0.2g natomiast w katalogu /media ściągnięty z BB libopenssl-1.0.2f
Nie da się mieć dwóch wersji libopenssl itd itd
Być może niektóre pakiety nie mają znaczenia w jakiej są wersji, ale i tak nie zmienia to faktu, że nie czytasz instrukcji.
Obawiam się, że jak koniecznie chcesz mieć Gargoyle 1.9.X.Y to sposób będziesz musiał znaleźć sam.
Ale jednocześnie życzę Ci, że znajdzie się ktoś, kto orał temat z Gargulcem CC i wyłoży "danie na talerz" smile

* WR1043v1 16MB@64MB * || * WT3020-16MB * || * Xiaomi Miwifi Mini *
* E3276 HiLink + RTL2832 + IT9135 + Siano + EC103 *

55 (edytowany przez djmysia 2017-02-19 12:32:13)

Odp: Który system do pyLoad...?

Działa w 100 % na Gargoyle  1.9.2.1


Pobieramy pakiety :

wget https://downloads.openwrt.org/barrier_breaker/14.07/ramips/mt7620a/packages/oldpackages/python-mini_2.7.3-2_ramips_24kec.ipk
wget https://downloads.openwrt.org/barrier_breaker/14.07/ramips/mt7620a/packages/oldpackages/python_2.7.3-2_ramips_24kec.ipk
wget https://downloads.openwrt.org/barrier_breaker/14.07/ramips/mt7620a/packages/oldpackages/python-crypto_2.6-1_ramips_24kec.ipk
wget https://downloads.openwrt.org/barrier_breaker/14.07/ramips/mt7620a/packages/oldpackages/python-openssl_2.7.3-2_ramips_24kec.ipk
wget https://downloads.openwrt.org/barrier_breaker/14.07/ramips/mt7620a/packages/oldpackages/python-sqlite3_2.7.3-2_ramips_24kec.ipk
wget https://downloads.openwrt.org/barrier_breaker/14.07/ramips/mt7620a/packages/oldpackages/python-imaging-library_1.1.7-2_ramips_24kec.ipk
wget https://downloads.openwrt.org/barrier_breaker/14.07/ramips/mt7620a/packages/oldpackages/pyopenssl_0.10-1_ramips_24kec.ipk
wget https://downloads.openwrt.org/barrier_breaker/14.07/ramips/mt7620a/packages/oldpackages/python-curl_7.19.0-1_ramips_24kec.ipk
wget https://downloads.openwrt.org/barrier_breaker/14.07/ramips/mt7620a/packages/oldpackages/libfreetype_2.4.8-1_ramips_24kec.ipk
wget https://downloads.openwrt.org/barrier_breaker/14.07/ramips/mt7620a/packages/base/libcurl_7.38.0-1_ramips_24kec.ipk 
wget https://downloads.openwrt.org/barrier_breaker/14.07/ramips/mt7620a/packages/base/libpolarssl_1.3.9-2_ramips_24kec.ipk
wget https://downloads.openwrt.org/barrier_breaker/14.07/ramips/mt7620a/packages/base/libopenssl_1.0.2f-1_ramips_24kec.ipk
wget https://downloads.openwrt.org/barrier_breaker/14.07/ramips/mt7620a/packages/base/zlib_1.2.8-1_ramips_24kec.ipk 
wget https://downloads.openwrt.org/barrier_breaker/14.07/ramips/mt7620a/packages/base/libgmp_6.0.0-1_ramips_24kec.ipk
wget https://downloads.openwrt.org/barrier_breaker/14.07/ramips/mt7620a/packages/packages/libffi_3.0.13-1_ramips_24kec.ipk 
wget https://downloads.openwrt.org/barrier_breaker/14.07/ramips/mt7620a/packages/packages/libsqlite3_3080704-1_ramips_24kec.ipk
wget https://downloads.openwrt.org/barrier_breaker/14.07/ramips/mt7620a/packages/packages/libbz2_1.0.6-1_ramips_24kec.ipk
wget https://downloads.openwrt.org/barrier_breaker/14.07/ramips/mt7620a/packages/packages/libjpeg_6b-1_ramips_24kec.ipk

a następnie instalujemy:

opkg install  -w libpolarssl_1.3.9-2_ramips_24kec.ipk libcurl_7.38.0-1_ramips_24kec.ipk zlib_1.2.8-1_ramips_24kec.ipk libffi_3.0.13-1_ramips_24kec.ipk libgmp_6.0.0-1_ramips_24kec.ipk libsqlite3_3080704-1_ramips_24kec.ipk libbz2_1.0.6-1_ramips_24kec.ipk libfreetype_2.4.8-1_ramips_24kec.ipk libjpeg_6b-1_ramips_24kec.ipk libopenssl_1.0.2f-1_ramips_24kec.ipk python-mini_2.7.3-2_ramips_24kec.ipk python_2.7.3-2_ramips_24kec.ipk python-curl_7.19.0-1_ramips_24kec.ipk
opkg install  -w python-crypto_2.6-1_ramips_24kec.ipk python-imaging-library_1.1.7-2_ramips_24kec.ipk python-openssl_2.7.3-2_ramips_24kec.ipk pyopenssl_0.10-1_ramips_24kec.ipk  

następnie restart routera:

reboot

następnie instalacja: (Uwaga bez restartu nie zainstalujecie python-sqlite3)

opkg install  -w python-sqlite3_2.7.3-2_ramips_24kec.ipk

następnie:

 mkdir -p /media
 cd /media
wget https://github.com/pyload/pyload/archive/stable.zip
unzip stable.zip
rm stable.zip
cd pyload-stable
mkdir -p done

Uruchamianie

python ./pyLoadCore.py 

Konfiguracja według poradnika Cezarego.

56

Odp: Który system do pyLoad...?

Czy na LEDE (router wrt1900acs) da się zainstalować pyLoad?

57

Odp: Który system do pyLoad...?

python-imaging chyba nie ma w repo.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

58

Odp: Który system do pyLoad...?

Nie jest niezbedny. PyLoad działa bez niego.

59

Odp: Który system do pyLoad...?

Wiec tak, powinno się dać.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

60

Odp: Który system do pyLoad...?

skwara napisał/a:

Czy na LEDE (router wrt1900acs) da się zainstalować pyLoad?

Testowałem na x86 i Xiaomi Mi R3G. Na obu pyLoad działa. Tu jest howto. Pakiet python-imaging można zastąpić nowyszym pillow.

Qui vit sans folie, n'est pas si sage qu'on croit

61

Odp: Który system do pyLoad...?

Trochę nie w temacie, czy masz obraz LEDE pod wrt1900acs?

62

Odp: Który system do pyLoad...?

Kto, ja?  Tak: https://dl.eko.one.pl/luci/lede/17.01-S … u/generic/

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

63

Odp: Który system do pyLoad...?

Tak ty. Dziękuję bardzo. Szukałem pod ar71xx.