1

Temat: OpenVPN iphone

Witam , mam problem z podłaczeniem klienta do serwera openvpn.
Wersja Gargoyle:1.5.9.3 (r35400)
Skonfigurowany openvpn i działa w połaczeniu z innym routerem tez na Gargoyle:1.5.9.3
router A jest serwerem i inny router Gargoyle:1.5.9.3 łączy się z nim bez problemu.

Dodaje w zakładce openvpn 2 klienta pobieram konfiguracje i wczytuje ją do klienta openvpn na telefonie iphone i to już nie działa.

Router pokazuje :
[iphonemarek]: 'PUSH_REPLY,route-gateway 10.8.0.1,redirect-gateway def1,ping 25,ping-restart 180,route 192.168.0.0 255.255.255.0 10.8.0.1,ifconfig 10.8.0.3 255
Success


A klient iphone pokazuje cos takiego :




2013-02-16 20:46:43 ----- OpenVPN Start -----
2013-02-16 20:46:43 LZO-ASYM init swap=0 asym=0
2013-02-16 20:46:43 EVENT: RESOLVE
2013-02-16 20:46:43 EVENT: WAIT
2013-02-16 20:46:43 Connecting to xxx.xxx.xx.xx:1194 (xxx.xxx.xx.xx) via UDPv4
2013-02-16 20:46:43 EVENT: CONNECTING
2013-02-16 20:46:43 Tunnel Options:V4,dev-type tun,link-mtu 1542,tun-mtu 1500,proto UDPv4,comp-lzo,keydir 1,cipher BF-CBC,auth SHA1,keysize 128,tls-auth,key-method 2,tls-client
2013-02-16 20:46:43 Peer Info:
IV_VER=1.0
IV_PLAT=ios
IV_NCP=1
IV_LZO=1

2013-02-16 20:46:44 VERIFY OK: depth=0
error rendering cert
2013-02-16 20:46:44 VERIFY OK: depth=1
error rendering cert
2013-02-16 20:46:44 SSL Handshake: TLSv1.0/SSL-EDH-RSA-AES-256-SHA
2013-02-16 20:46:44 Session is ACTIVE
2013-02-16 20:46:45 EVENT: GET_CONFIG
2013-02-16 20:46:45 Sending PUSH_REQUEST to server...
2013-02-16 20:46:45 OPTIONS:
0 [route-gateway] [10.8.0.1]
1 [redirect-gateway] [def1]
2 [ping] [25]
3 [ping-restart] [180]
4 [route] [192.168.0.0] [255.255.255.0] [10.8.0.1]
5 [ifconfig] [10.8.0.3] [255.255.255.0]

2013-02-16 20:46:45 LZO-ASYM init swap=0 asym=0
2013-02-16 20:46:45 EVENT: ASSIGN_IP
2013-02-16 20:46:45 TUN Error: tun_builder_error: ifconfig addresses are not in the same /30 subnet (topology net30)
2013-02-16 20:46:45 EVENT: TUN_SETUP_FAILED tun_builder_error: ifconfig addresses are not in the same /30 subnet (topology net30) [ERR]
2013-02-16 20:46:45 EVENT: DISCONNECTED
2013-02-16 20:46:45 Raw stats on disconnect:
BYTES_IN : 5284
BYTES_OUT : 4001
PACKETS_IN : 41
PACKETS_OUT : 41
TUN_SETUP_FAILED : 1
2013-02-16 20:46:45 Performance stats on disconnect:
CPU usage (microseconds): 216554
Network bytes per CPU second: 42876
Tunnel bytes per CPU second: 0
2013-02-16 20:46:45 ----- OpenVPN Stop -----
2013-02-16 20:46:45 EVENT: DISCONNECT_PENDING


w czym problem ? Jakies sugestie ?

2

Odp: OpenVPN iphone

O ile pamiętam to jest to jakieś ograniczenie sterownika tun co do zakresu adresacji sieci. Nie pamiętam dokładnie o co chodziło, przeszukaj witrynę openvpn, było to gdzieś.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

3

Odp: OpenVPN iphone

nie bardzo jestem z vpn . mam zmienic adresacje ?
którą 10.... czy lokalna serwera vpn czy klienta vpn ?

4

Odp: OpenVPN iphone

Nie pamiętam. Poszukaj czego problem dotyczył.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

5

Odp: OpenVPN iphone

TUN Error: tun_builder_error: ifconfig addresses are not in the same /30 subnet (topology net30) ?

6

Odp: OpenVPN iphone

http://eko.one.pl/forum/viewtopic.php?id=4747
widze ze nie tylko ja , chyba to ten sam problem

7

Odp: OpenVPN iphone

Znalazłem coś takiego :

W SERVER.config, spróbuj dodać linię:
Kod:
push "topology subnet"

Cezary gdzie to dopisać ? w którym pliku ?
Myślisz , że pomoże ?

8

Odp: OpenVPN iphone

dobra działa
trzeba wyedytować plik na serwerze Gargoyle:1.5.9.3
/etc/openvpn/server.conf
i dodac na samym dole linijkę
push "topology subnet"
czyli działa teraz . Proponuje domyślnie dodać tą linijkę do konfiguracji smile
push "route-gateway 10.8.0.1"               
push "redirect-gateway def1"                 
push "topology subnet"

pozdrawiam