Temat: Sieć gościnna na AP-ku bez dostępu do sieci lokalnej

Cześć,

Potrzebuję pomocy w konfiguracji sieci domowej.


Jeden router i kilka urządzeń w trybie AP. Połączone przez LAN. Na wszystkich openwrt.

Chcę by na jednym AP z openwrt na pokładzie były dwie sieci.
Jedna domowa (domyślna) i dodatkowo gościnna.

Wymagania sieci gościnnej na poziomie AP-ka
1. Dostępność sterowana czasowo (on/off o konkretnych godzinach np w CRONie)
2. Dostęp tylko do internetu (bez lokalnej sieci)
3. Może być limit prędkości na stałe np 10Mbit

2

Odp: Sieć gościnna na AP-ku bez dostępu do sieci lokalnej

Śmiało, zrób sobie: https://eko.one.pl/?p=openwrt-guestnetwork

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

3

Odp: Sieć gościnna na AP-ku bez dostępu do sieci lokalnej

Czytałem ten poradnik. Nie rozumiem tylko sekcji wydzielania interfejsu dla sieci gościnnej. Jakim cudem to będzie działać na AP-ku.

Przecież on tylko zamienia ramkę LAN na WiFi.
Firewall wciąż jest aktywny?
DHCP przecież jest wyłączone w trybie AP.


# uci set network.guest=interface
    # uci set network.guest.type=bridge
    # uci set network.guest.proto=static
    # uci set network.guest.ipaddr=172.16.0.1
    # uci set network.guest.netmask=255.240.0.0

    # uci set dhcp.guest=dhcp
    # uci set dhcp.guest.start=100
    # uci set dhcp.guest.limit=150
    # uci set dhcp.guest.leasetime=2h
    # uci set dhcp.guest.interface=guest

    # uci set wireless.guest=wifi-iface
    # uci set wireless.guest.device=radio0
    # uci set wireless.guest.mode=ap
    # uci set wireless.guest.network=guest
    # uci set wireless.guest.ssid=dom_goscinna
    # uci set wireless.guest.encryption=none

    # uci add firewall zone
    # uci set firewall.@zone[-1].name=guest
    # uci add_list firewall.@zone[-1].network=guest
    # uci set firewall.@zone[-1].input=ACCEPT
    # uci set firewall.@zone[-1].output=ACCEPT
    # uci set firewall.@zone[-1].forward=ACCEPT

    # uci add firewall forwarding
    # uci set firewall.@forwarding[-1].src=guest
    # uci set firewall.@forwarding[-1].dest=wan

    # uci commit

4

Odp: Sieć gościnna na AP-ku bez dostępu do sieci lokalnej

Jeżeli masz ap jako głupi ap (bez natu i wanu) to nie zrobisz tego. Możesz co najwyżej zrobić drugą sieć i vlanem dać to w sieć lokalną, ale coś musi z tym vlanem pobawić się dalej: https://eko.one.pl/?p=openwrt-vlan#siew … ednymkablu  czyli jednym słowem musisz mieć router który robi w/w rzecz.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

5

Odp: Sieć gościnna na AP-ku bez dostępu do sieci lokalnej

Drugi AP to zwykły router z wgranym w miarę nowym openwrt z LUCI ale ma:
1. Wyłączony WAN (logicznie)
2. WAN spięty z LAN
3. Wyłączone DHCP

6

Odp: Sieć gościnna na AP-ku bez dostępu do sieci lokalnej

Czyli nadal to zwykły głupi ap.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

7

Odp: Sieć gościnna na AP-ku bez dostępu do sieci lokalnej

ok, poczytam o tych VLANach.
Dzięki

8

Odp: Sieć gościnna na AP-ku bez dostępu do sieci lokalnej

Po lekturze poradników wydawało mi się, że rozumiem.
Niestety po przystąpieniu do konfiguracji natrafiłem na taką niespodziankę.
Chyba nie mam konfiguracji SWITCHa.
Wygląda jakby każdy port LAN był niezależnym interfejsem.
Jak to skonfigurować by router nadawał odpowiedni VLAN dla sieci gościnnej?

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'xxxxxxxx'

config interface 'lan'
        option type 'bridge'
        option ifname 'lan1 lan2 lan3 lan4'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipv6 'off'

config device 'lan_lan1_dev'
        option name 'lan1'
        option macaddr '30:23:03:e8:XX:XX'

config device 'lan_lan2_dev'
        option name 'lan2'
        option macaddr '30:23:03:e8:XX:XX'

config device 'lan_lan3_dev'
        option name 'lan3'
        option macaddr '30:23:03:e8:XX:XX'

config device 'lan_lan4_dev'
        option name 'lan4'
        option macaddr '30:23:03:e8:XX:XX'

config interface 'wan'
        option ifname 'wan'
        option proto 'pppoe'
        option username 'name'
        option password 'pass'
        option keepalive '3 5'
        option ipv6 'off'

config device 'wan_wan_dev'
        option name 'wan'
        option macaddr '30:23:03:e8:XX:XX'

config interface 'wan6'
        option ifname 'wan'
        option proto 'dhcpv6'

9

Odp: Sieć gościnna na AP-ku bez dostępu do sieci lokalnej

Używasz snapshota z DSA, poradniki tego nie obejmują jeszcze.

Spróbuj zrobić interfejs np. lan1.7, może wersja którą masz to obsługuje.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

10 (edytowany przez kacperr 2021-02-19 20:31:08)

Odp: Sieć gościnna na AP-ku bez dostępu do sieci lokalnej

Tak to snapshot. Niestety nie ma wersji stabilnej na Linksys EA7500 v2.
Sprawdzę LAN1.7

11

Odp: Sieć gościnna na AP-ku bez dostępu do sieci lokalnej

Za chwilę będzie. Ale i tak będziesz miał już DSA w standardzie.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.