26

Odp: Klient AP bez routingu / Dumb AP Client

A ustawiłeś sobie  sobie na stałe adres 192.168.2.2 czy 192.168.1.2 na karcie? Chyba nie skoro ci leci z adres dhcp apipa windowsa.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

27 (edytowany przez WoT 2020-05-21 14:22:05)

Odp: Klient AP bez routingu / Dumb AP Client

Tak miałem 192.168.2.2 i pingowałem 192.168.2.1 (lan) oraz 192.168.1.2 i pingowałem 192.168.1.1 (wan -
czyli awaryjny)

A wpad nie musi być pełny żeby działał realay?
Znalazłem wątek gdzie go ekstra instalują: https://blog.cavebeat.org/2012/08/openw … udobridge/

28

Odp: Klient AP bez routingu / Dumb AP Client

Nie, nie musi być. wpad pełny potrzebujesz do mesha, eap itp. Jak masz zwykłe wpa2 to wystarczy (nawet się połączyłeś przecież).

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

29 (edytowany przez WoT 2020-05-21 14:35:29)

Odp: Klient AP bez routingu / Dumb AP Client

Znalazłem ciekawy błąd podczas zabawy firewallem:
Warning: Section @zone[0] (lan) cannot resolve device of network 'bridge'

...
config zone
    option name 'lan'
    option network 'lan bridge wwan'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'ACCEPT'
...

A przecież jest w network

...
config interface 'bridge'
    option proto 'relay'
    option network 'lan wwan'
    option ipaddr '10.0.0.19'
...

To normalne?

30

Odp: Klient AP bez routingu / Dumb AP Client

Ale nie ma interfejsu, dodawany jest dynamicznie przez wifi w momencie uruchomienia wifi.

Tak, to normalne.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

31

Odp: Klient AP bez routingu / Dumb AP Client

WoT napisał/a:

Wally Podaj przykład takiej konfiguracji?
Ja jak wcześniej testowałem na WR1043n w postaci repeatera (czyli z wifi do wifi) to pamiętam że mi nieźle działało. Ale teraz muszę na WR841 zrobić wifi do lan

Wszytko zgodnie z poradnikiem: klient WDS, wyłączony dnsmasq a nawet DHCP na br-lan zamiast stałego IP (jak już działał) i staruszek działa jako repeater a czasem jako karta sieciowa. Jak będę w domu, to podrzucę.

Wally

32 (edytowany przez WoT 2020-05-22 14:33:24)

Odp: Klient AP bez routingu / Dumb AP Client

Wczoraj ta sprawa (która powinna być w miarę prosta) doprowadziła mi do szewskiej pasji, więc skorzystałem z pewnej niezbyt konkretnej acz skutecznej porady "Jak nie działa, wywal wszystko w cholerę, przeformatuj i zacznij od nowa".

Toteż tak zrobiłem. Zarwałem nockę ale udało się!
Ale wcześniej działy się cuda!
- na przykład klient dostawał IP z puli 192.168 (która była przypisana do lanu bez dhcp) a jednak dostawał taką!? (nie rozkminialem, może jakiś W10-owy bubel u klienta)
- innym razem zrobiłem wszystko idealnie, zadziałało ale straciłem dostęp do routera relay.

Nie mogłem tej sprawy tak zostawić więc jeszcze raz od nowa i ostatecznie: operacja się powiodła, chociaż pacjent zmarł



No ale do rzeczy:
- Wykryłem istotny błąd w mojej konfiguracji switcha, dla WR841 powyższa poprawnie działa dla nazw eth0, eth1 a nie eth0.1, eth0.2 - to przyczyniało się do braku komunikacji na lan i było powodem dla którego nie mogłem odzyskać dostępu do routera
- po poprawie komputer kliencki zaczął dostawać IP, a ostatecznie poprawne IP

Więc czemu pacjent zmarł?
Uzyskany efekt  niestety jest daleki od moich oczekiwań:
1) [ok] router relay łączy się z nadrzędnym przez wifi, uzyskuje IP i internet i przekazuje do lan
2) [ok] komputer klient otrzymuje IP z puli routera nadrzędnego
3) [ok] k-klient dostaje połączenie z internetem i pinguje router nadrzędny
4) źle, że k-klient nie może pingoać routera relay ani nie widzi żadnego innego komputera w sieci
5) inne-komputery w sieci podłączone do routera nadrzędnego nie widza k-klienta i nie mogą się z nim kontaktować (a zakładałem ze będą mogły); jest to niedopuszczalne bo nie mogą wymieniać informacji z k-klientem w sieci ani chociażby go obudzić; można sie z nim skontaktować tylko przez internet (np anydeskiem, a potrzebny jest rdp, samba, dlna, wol i inne działające tylko w lan)
6) dodam, że inne-komputery widza router relay ale nie po IP 10.0.0.19 podanym w interface 'bridge' tylko po IP który przyznaje router nadrzędny (w sumie drobiazg, ale może to jakiś trop)

Czego oczekiwałem?
1) przede wszystkim swobodnej komunikacji pomiędzy komputerami w tej samej sieci lan
2) k-klienta z IP z puli głównego serwera i z internetem - to działa.

Czy da się jakoś skomunikować te komputery?

33

Odp: Klient AP bez routingu / Dumb AP Client

ad6 - więc po co ustawiłeś 10.0.0.19? Masz ustawić ten który dostał z routera nadrzędnego...

Zmień router, bo ten co ci sprawia kłopoty. Most właśnie działa prawie przezroczyście, widzi się każdy z każdym tak jak tego byś oczekiwał.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

34 (edytowany przez Wally 2020-05-24 17:20:49)

Odp: Klient AP bez routingu / Dumb AP Client

WoT napisał/a:

Wally Podaj przykład takiej konfiguracji?
Ja jak wcześniej testowałem na WR1043n w postaci repeatera (czyli z wifi do wifi) to pamiętam że mi nieźle działało. Ale teraz muszę na WR841 zrobić wifi do lan

Na lanie zmnieniony IP, najpierw na 192.168.1.2 a jak zadziałało to na DHCP. Konfiguracja wifi z działającego repeatera (po podłączeniu do portow lan urządzenia dostają adresy z głównego routera i są normalnie widoczne w sieci):

WN575A3:~# cat /etc/config/wireless 

config wifi-device 'radio0'
    option type 'mac80211'
    option channel '11'
    option hwmode '11g'
    option path 'platform/10300000.wmac'
    option disabled '1'
    option country 'PL'
    option noscan '1'
    option htmode 'HT40'
    option log_level '4'
    option log_80211 '0'
    option log_8021x '0'
    option log_radius '0'
    option log_wpa '0'
    option log_driver '0'
    option log_iapp '0'
    option log_mlme '0'
 
config wifi-iface '2G'
    option device 'radio0'
    option network 'lan'
    option mode 'ap'
    option ssid 'Highway To Hell'
    option key 'haselko'
    option disabled '0'
    option pmk_r1_push '1'
    option encryption 'psk2+ccmp'
    option wpa_disable_eapol_key_retries '1'
    option ieee80211r '1'
    option ft_over_ds '1'
    option mobility_domain 'f666'
    option ieee80211w '1'
    option ft_psk_generate_local '1'

config wifi-device 'radio1'
    option type 'mac80211'
    option channel '36'
    option hwmode '11a'
    option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
    option htmode 'VHT80'
    option country 'PL'
    option noscan '1'
    option log_level '4'
    option log_80211 '0'
    option log_8021x '0'
    option log_radius '0'
    option log_wpa '0'
    option log_driver '0'
    option log_iapp '0'
    option log_mlme '0'

config wifi-iface '5G'
    option device 'radio1'
    option network 'lan'
    option mode 'ap'
    option pmk_r1_push '1'
    option ssid 'Stairway To Heaven'
    option key 'haselko'
    option disabled '0'
    option encryption 'psk2+ccmp'
    option wpa_disable_eapol_key_retries '1'
    option ieee80211r '1'
    option ft_over_ds '1'
    option mobility_domain 'f777'
    option ieee80211w '1'
    option ft_psk_generate_local '1'

config wifi-iface 'UPLINK'
    option device 'radio1'
    option bssid 'xx:xx:xx:xx:xx:xx'
    option ssid 'Stairway To Heaven'
    option key 'haselko'
    option mode 'sta'
    option wds '1'
    option encryption 'psk2+ccmp'
    option network 'lan'
    option ieee80211w '1'
Wally

35 (edytowany przez WoT 2020-05-24 20:34:36)

Odp: Klient AP bez routingu / Dumb AP Client

Wally napisał/a:

...

Dzięki, ale bardziej by się przydały konfigi network i firewall

Cezary napisał/a:

ad6 - więc po co ustawiłeś 10.0.0.19? Masz ustawić ten który dostał z routera nadrzędnego...
.... Most właśnie działa prawie przezroczyście, widzi się każdy z każdym tak jak tego byś oczekiwał.

Cynk dobry! Ustaliłem na routerze nadrzędnym, żeby się trzymał IP 19 dla routera relay i jest poprawa:
1) [ok]
2) [ok]
3) [ok]
4) [ok] k-klient pinguje inne komputery w sieci! smile
5) nadal źle inne-komputery w sieci podłączone do routera nadrzędnego nie widza k-klienta
6) źle że nie wszystkie komputery widza router relay. Widzi go na pewno router nadrzędny oraz komputery podłączone przez dhcp tego routera. Te co mają sztywne IP nie widzą routera relay

Czyli już blisko sukcesu.
Pytanie: czemu inne komputery nie widza komputera klienta relay?
Logicznie byłoby szukać w firwall, ale tam pozostaje konfiguracja otwarte:

config zone
    option name        lan
    option network        'lan bridge wwan'
    option input        ACCEPT
    option output        ACCEPT
    option forward        ACCEPT

Próbowałem rozbić zony i zrobić ręcznie forward, jak tu:

config forwarding
    option src        wwan
    option dest        lan

Niestety bez sukcesu.

Jeśli pingi z k-klienta innych-kompów wracają, to czemu z tych kompów nie mogę pingować k-klienta?

36 (edytowany przez WoT 2020-05-24 20:24:15)

Odp: Klient AP bez routingu / Dumb AP Client

Btw trace z k-klienta innego-kompa wygląda tak:

Tracing route to inny-komputer [10.0.0.33]
over a maximum of 30 hops:
  1    <1 ms    <1 ms    <1 ms  10.0.0.19
  2     3 ms     2 ms     2 ms  inny-komputer [10.0.0.33]

Trace z innego-kompa do k-klienta (jego ip to 10.0.0.9):

Tracing route to klient-komputer-za-relay [10.0.0.9]
over a maximum of 30 hops:
  1     2 ms     2 ms     9 ms  klient-komputer-za-relay [10.0.0.19]
  2     *        *        *     Request timed out.
  3     *        *        *     Request timed out.

Wpadło mi jeszcze do głowy czy pula IP ma znaczenie? Może realy działa tylko dla 192.168? Albo dla jakichś totalnie innych określonych (znalazłem gdzieś przykład z IP na 178.0.0.0)

37 (edytowany przez Wally 2020-05-24 20:50:20)

Odp: Klient AP bez routingu / Dumb AP Client

WoT napisał/a:
Wally napisał/a:

...

Dzięki, ale bardziej by się przydały konfigi network i firewall

Firewall nietykany (chyba nawet wyłączony), w network  br-lan zmieniony tylko IP (ta sama podsieć),  gateway i dns ustawiony na .1.1 (docelowo dałem DHCP) i wyłączony dnsmasq, to wszystko.
WDS to najprostsza konfiguracja połączenia po wifi - zobacz tu - raptem kilka poleceń, więcej czasu zajmuje wyklikanie z GUI.

Wally

38

Odp: Klient AP bez routingu / Dumb AP Client

Adresacja nie ma znaczenia. Ja mam np 10.0.0.0/8  i działa...

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

39

Odp: Klient AP bez routingu / Dumb AP Client

Działa! relay jest transparentny!
Wpadłem na trop gdy zeskanowałem porty k-klienta na innym kompie. Niektóre z nich były otwarte lecz nie te na których mi zależało. Na jednym z forów znalazłem wątek na temat zmiany charakterystyki firewalla w Windowsie po zmianie sieci. I tak się najprawdopodobniej stało. Winda z k-klienta uzbroiła firewalla, gdy przełączyłem komputer pod router relay.

Zatem kończąc temat
Powyższa konfiguracja jest poprawna, z poprawką na v-lany i na firewalla windy w której trzeba zrobić dziury (w moim przypadku wystarczyło w sambie i rdp) lub wyłączyć w ogóle (niezalecane).

Dzięki za pomoc