1 (edytowany przez WoT 2020-04-23 01:51:49)

Temat: Klient AP bez routingu / Dumb AP Client

Cześć

Niby prosta sprawa, a robię i robię i zrobić nie mogę

Mam sieć z routerem głównym dhcp i AP. Jednego serwera nie da się podłączyć fizycznie kablem do routera głównego, ale jet w zasięgu wifi. Wziąłem więc router openwrt który robi za Klienta AP a do jego switcha podłączyłem serwer, coś na wzór https://eko.one.pl/?p=openwrt-trybypracy#klientap jednkaże

Tyle, że w odróżnieniu do tej instrukcji serwer musi zostać w tej samej podsieci i otrzymywać IP z routera głównego.

wireless

[...]
config wifi-iface
    option ssid 'wifi_glownego_routera'
    option encryption 'psk2'
    option device 'radio0'
    option mode 'sta'
    option key 'hasło'
    option network 'lan'

network

config interface 'loopback'
[...]
config interface 'lan'
    option ifname 'eth0'
    option proto 'dhcp'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '1 2 3 4 0'

W efekcie:
- Router z Klientem AP łączy się bezprzewodowo z serwerem,
- dostaje IP
ale
- serwer nie łączy się do internetu
- nie można go też pingować, ani routera k-AP

Dla testów wpiąłem się sztywnym kablem od głównego do routera k-AP - wtedy wszystko gra, k-AP i serwer dostają IP, mają internet

Co robię źle?

2 (edytowany przez WoT 2020-04-23 10:22:16)

Odp: Klient AP bez routingu / Dumb AP Client

Dodam, ze router WR841N
I niestety opcja z relaydem odpada bo nic nie zmieści https://openwrt.org/docs/guide-user/net … figuration

3

Odp: Klient AP bez routingu / Dumb AP Client

WDS jest rozwiązaniem Twoich problemów. Ew. zbudowanie własnego obrazu z dołączonym pakietem relayd a usuniętymi innymi, które nie są potrzebne.

Mam i używam: Linksysy 1900ACS, LB-Link BL-W1200, Netgear R6220, Unielec U7621-06, TP-Linki 1043 V1, V2.
Mam: D-Linki DWR-921, DWR-118, DWR-116, TP-Link WDR-4900 v1, Checkpoint L-50.

4

Odp: Klient AP bez routingu / Dumb AP Client

Jak ci sie nie zmieści relayd? Zainstaluj soft bez luci, to się zmieści relayd.

Właśnie most bezprzewodowy. wds będzie działać jak po drugiej stronie też masz openwrt z atherosem.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

5

Odp: Klient AP bez routingu / Dumb AP Client

Czyli łatwo i przyjemnie nie będzie?

wr841n jest w wersji v11 gdzie moge znaleźć repo z obrazami bez luci?

6

Odp: Klient AP bez routingu / Dumb AP Client

Chociaż by u mnie na eko.one.pl...

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

7 (edytowany przez WoT 2020-05-20 21:09:43)

Odp: Klient AP bez routingu / Dumb AP Client

Cześć
Sory za dłuższa przerwę...

Dopiero miałem chwilę, żeby wrócić do tematu.
Toteż zrobiłem upgrade. Dzięki za obraz Cezary, oszczędza naprawdę sporo miejsca!
Potem zrobiłem zgodnie z: https://eko.one.pl/?p=openwrt-sta#mostbezprzewodowy

Moje configi:

wireless

config wifi-device 'radio0'
    option type 'mac80211'
    option hwmode '11g'
    option path 'platform/qca953x_wmac'
    option htmode 'HT20'
    option disabled '0'
    option country 'PL'
    option channel '11'
    
config wifi-iface
    option device 'radio0'
    option network 'wwan'
    option mode 'sta'
    option ssid 'dom'
    option encryption 'psk2'
    option key 'najlepiej_w_domku'

dhcp

...
config dhcp 'lan'
    option interface 'lan'
    option ignore '1'
...

firewall

...
config zone
    option name 'lan'
    option network 'lan bridge wwan'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'ACCEPT'
...

network

config interface 'loopback'
...
config interface 'lan'
    option ifname 'eth0.1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.2.1'
    option netmask '255.255.255.0'

config interface 'wan' #to awaryjnie bo już 5 razy restartowałem router
    option ifname 'eth0.2'
    option proto 'dhcp'    

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '1 2 3 4 0'

config interface 'wwan'
    option proto 'dhcp'

config interface 'bridge'
    option proto 'relay'
    list network 'lan'
    list network 'wwan'
    option ipaddr '10.0.0.19'

Przypomnę cel:
Router tl-wr841n ma się połączyć do sieci domowej orzymać IP i przekazać IP z tej samej puli komputerowi podłączonemu do portu lan wraz z internetem.

Po tej konfiguracji:
1. [ok] Router łączy się bezprzewodowo do sieci domowej
2. [ok] Nie mam pewności czy dostaje IP czy to dlatego że ma wpisane, ale można go odnaleźć poprawnie po 10.0.0.19
3. Router nie przekazuje ip do komputera podłączonego do lan
4. Komputer nie ma internetu

Próby modyfikacji konfiguracji wykorzystując mieędzy innymi: https://eko.one.pl/forum/viewtopic.php? … 20#p76920, i tego https://openwrt.org/docs/guide-user/net … figuration również nie poskutkowały, a nawet powodowały brak dostępu do routera i potrzebę restartu sad

Co robię źle?

8

Odp: Klient AP bez routingu / Dumb AP Client

2. To sprawdź. Na interfejsie ma mieć adres z dhcp, zresztą w logu też to będzie.

Oczywiście zainstalowałeś relayd, prawda? Konfiguracja i dobra i sprawdzona (zresztą identyczna jest na wiki którą zacytowałeś). Problemów szukaj więc np, w jakiś zabezpieczeniach na mac adres czy innych tego typu rzeczach.
Sprawdź też czy będziesz miał internet jak klientowi na stałę ustawisz adres i gatewaya (z sieci 10.0.0.x oczywiście).

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

9 (edytowany przez WoT 2020-05-20 21:59:02)

Odp: Klient AP bez routingu / Dumb AP Client

Dzięi za odzew

relayd - oczywiście smile z http://dl.eko.one.pl/lede/17.01-SNAPSHO … s_24kc.ipk

Ad 2)
jeśli dobrze czytam loga, to router relayd dostaje poprawnie IP z zew routera

Wed May 20 20:38:16 2020 daemon.notice netifd: wwan (1040): udhcpc: lease of 10.0.0.19 obtained, lease time 21600
Wed May 20 20:38:16 2020 daemon.notice netifd: Interface 'wwan' is now up
Wed May 20 20:38:16 2020 daemon.info dnsmasq[1019]: reading /tmp/resolv.conf.auto
Wed May 20 20:38:16 2020 daemon.info dnsmasq[1019]: using local addresses only for domain lan
Wed May 20 20:38:16 2020 daemon.info dnsmasq[1019]: using nameserver 10.0.0.1#53

5) Jak się bawię kablem od komputera do lan relayd'a, jakiś tam ślad aktywności w logu jest ale niewielki

Wed May 20 21:43:57 2020 daemon.notice netifd: Interface 'lan' has link connectivity

i tyle

6) Nie mam zabezpieczeń mac (albo nie jestem świadom, ale wszystko mam po standardowych konfigach)

7) Ustawiłem na stałe IP w komputerze kliencie na 10.0.0.20,  bramą na router główny 10.0.0.1 - co ciekawe żadnej reakcji. Komputer (Win10) wykazuje jako sieć niezidentyfikowaną. Nie można pingowac routera relayd ani głównego sad

8) i jeszcze ciekawostka # logread | grep relay nic nie wyrzuca w logach

10

Odp: Klient AP bez routingu / Dumb AP Client

Z tego routera który robi za most możesz pingować 10.0.0.1 i w ogóle internet?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

11

Odp: Klient AP bez routingu / Dumb AP Client

Zgadza się. Ma internet i widzi inne komputery w sieci, oprócz tego klienckiego który ma podłącozny pod lan.

12

Odp: Klient AP bez routingu / Dumb AP Client

Jaki pakiet z lede ty zainstalowałeś? Jakiego ty w ogóle systemu używasz?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

13 (edytowany przez WoT 2020-05-20 23:27:54)

Odp: Klient AP bez routingu / Dumb AP Client

9) Też rozważam ten trop.
Wgrałem znaleziony u ciebie sysupgrad: lede-17.01-snapshot-r3948-5886a5060a-ar71xx-generic-tl-wr841-v11-squashfs-sysupgrade.bin
Relayd też ściągnął z dl.eko.one.pl

10) Czy może to być też kwestia sprzętowa? jakas niekompatybilność w TL-WR841N
W zeszłym roku stawiałem relayda na WR1043v2 z 18.06 i pamiętam że działał świetnie, (chociaż to nie była taka sama konfiguracja).

14

Odp: Klient AP bez routingu / Dumb AP Client

Lede jest stare i nie rozwijane, a same pakiety już kilka razy zaktualizowali. Jak już to ostatnią wersję systemu sprawdź, nikt nie będzie się bawił w rozgryzanie problemu  które być może już dawno nie ma.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

15

Odp: Klient AP bez routingu / Dumb AP Client

Początkowo chciałem nawet najnowszy 19.07. Niestety nie masz sysubgradu dla WR841 w
https://dl.eko.one.pl/openwrt-19.07/tar … x/generic/
Na głównej openwrt znalazłem tylko nieużyteczną wersję tiny dla 18.06
https://downloads.openwrt.org/releases/ … 71xx/tiny/
a sam obrazu nie umiem przygotować sad

16

Odp: Klient AP bez routingu / Dumb AP Client

On jest w tiny a nie generic. On ma tylko 4M

https://dl.eko.one.pl/openwrt-19.07/targets/ath79/tiny/

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

17

Odp: Klient AP bez routingu / Dumb AP Client

WDS powinien działać. Wcześniej miałem mosty ale dużo prościej jest zrobić WDS. Nawet działa między Qualcomem, Atherosami i Mediatekiem, nie tylko pomiędzy Atherosami.

Wally

18

Odp: Klient AP bez routingu / Dumb AP Client

Dla pewności proponuję sprawdzić klienta, którym nie możesz się połączyć. Może win10 coś blokuje? Na szybko można pobrać jakiegoś linuxa na pendrive'a.

To nic nie znaczy, ale sam korzystam na kliencie relayd ze starego lede (17.01 snapshot), a na routerze nadrzędnym z gargoyle 1.11.0.4 i oba systemy mają ten sam pakiet relayd (to samo oznaczenie, jakie wgrałeś), a przecież pomiędzy buildami jest różnica prawie 2 lata.

19

Odp: Klient AP bez routingu / Dumb AP Client

Dzięki za odp.
maslako Sprawdziłem, na innym kliencie. Podłączyłem sobie pomiędzy jeszcze jeden stary router openwrt i wciąż to samo - klient nie dostaje IP (na sztywnym IP tez nic).
Różnica między klientami taka, że staruch-wrt coś tam wymienia z relaydem a w Win10 na sztywno nie ma żadnego ruchu.

Ale dobrze wiedzieć, że mogę się trzymać 17.01

Wally Podaj przykład takiej konfiguracji?
Ja jak wcześniej testowałem na WR1043n w postaci repeatera (czyli z wifi do wifi) to pamiętam że mi nieźle działało. Ale teraz muszę na WR841 zrobić wifi do lan

Cezary Na razie wykluczyliśmy wadę 17.01 ale tak na przyszłość to rozumiem ze Tiny są pełnowartościowe i tylko nazwane tak z uwagi na 4MB? Pamiętam ze kiedyś wgrałem taki na WR740 i miałem wrażenie, ze ma dużo uboższe funkcje (przynajmniej te dostępne przez WWW)

20

Odp: Klient AP bez routingu / Dumb AP Client

Żadne z moich obrazów dla tiny nie mają luci, więc nie ma żadnych funkcji które są dostępne przez www...
Ile masz miejsca tyle możesz zainstalować.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

21

Odp: Klient AP bez routingu / Dumb AP Client

Tak dla sprostowania: Osobiście korzystam z innego sprzętu (WDR3600 i MiR3g) niż Ty. Informuję tylko, że stary pakiet relayd funkcjonuje.
Relayd ma jeszcze zależności pakietowe (libc i inne), może tutaj coś szwankuje?

22 (edytowany przez WoT 2020-05-21 12:16:22)

Odp: Klient AP bez routingu / Dumb AP Client

Ma zalezności: libc, libubox
libc był aktualny, a libubox własnie zakutualizowałem, niestety bez zmian. Ale trop dobry.

Zacząłem znowu myśleć ze mam gdzieś błąd w konfiguracji, bo dziwi mnie ten brak komunikacji na lanie.

...
config interface 'lan'
    option ifname 'eth0.1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.2.1'
    option netmask '255.255.255.0'
...

k1)To jest na pewno poprawnie, że jest option type 'bridge'?
k2) W tym wątku https://eko.one.pl/forum/viewtopic.php? … 20#p76920, adres z puli lan jest w tej samej klasie adresowe, na pewno on mi nie blokuje komunikacji? (Co prawda próbowałem już tej opcji i w efekcie straciłem kontakt z routerem, ale może to kolejny trop)

23

Odp: Klient AP bez routingu / Dumb AP Client

1. Tak, tak jest domyślnie i może zostać.
2. Patrzysz na post przed 7 lat (!). To co zrobiłeś jest dobre (ma być inny adres na lanie).

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

24

Odp: Klient AP bez routingu / Dumb AP Client

Ad k2) Ten adres z innej puli to takie rozwiązanie awaryjne. Router relayd ma wyłączony serwer dhcp, więc jak nie dostanie IP z routera nadrzędnego, wtedy można się z nim połączyć na tym pomocniczym adresie. Podłączasz kompa z ręcznie wpisanym 192.168.2.2 i będąc w tej samej klasie adresowej dasz radę się zalogować.
Ad k1) Tak. Ja mam dodatkowo w option ifname ' oprócz 'eth0.1' dodatkowo 'eth0.2' (pisałeś o wanie) oraz dodatkowo 'eth0' (kiedyś miałem problem z sambą na moście, a ten wpis pomógł).

25 (edytowany przez WoT 2020-05-21 13:15:39)

Odp: Klient AP bez routingu / Dumb AP Client

Ad k2) To już wiem, że coś tu jest nie tak - bo gdy popsuję konfigurację to nie mogę się podłączyć awaryjnie
(10.0.0.19 albo w ogóle)

...i zostawiłem sobie dhcp na eth0.2
Dla pewności gdyby dhcp coś mieszał wyłączyłem i wan też ustawiłem statycznie

...
config interface 'lan'
    option ifname 'eth0.1'
    #option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.2.1'
    option netmask '255.255.255.0'

config interface 'wan'
    option ifname 'eth0.2'
    #option proto 'dhcp'    
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
...

I tez (awaryjnie) nie moge sie wanem dostać do routera sad

Przeczytałem na innym forum, żeby podsłuchać transmisję. Zainstalowałem Wiresharka, ale w tym już jestem zielony. Widzę tylko że większość idzie od 169.254.209.26 (zapewne jakiś wydumany ip karty sieciowej) do 255.255... Poza tym 0.0.0.0 do 255.255.. robi DHCP discover ale bez odpowiedzi

edit: i widzę jak ping idzie bez odpowiedzi