151

Odp: Gargoyle 1.13.x

Dodałem nowe obrazy w których znajduje się wsparcie dla IPv6, plugin wiregiard i cron. Choć widzę że z jakiegoś powodu obrazy dla  MT7621 nie mają wireguard, skompiluję to ponownie wieczorem a tymczasem jak się nie chce komuś czekać to może zainstalować to z pluginów.

IPv6 wymaga jeszcze sprawdzenia, lista rzeczy do zrobienia jest tutaj: https://github.com/ericpaulbishop/gargoyle/issues/883
Jeżeli ktoś znajdzie jakiś problem z w/w pluginami to niech to zgłasza tutaj: https://github.com/ericpaulbishop/gargoyle/issues

Plugin wireguard jest nowy, plugin cron już kiedyś był nieoficjalnie, został teraz po prostu przepisany na nowe gui i pojawił się standardowo w źródłach gargoyle.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

152 (edytowany przez sebastan 2020-07-13 08:02:02)

Odp: Gargoyle 1.13.x

Po zalogowaniu widzę tylko niebieskie tło. mir3g.

PS. Normalnie działa wszystko, tylko GUI nie wstaje, restartowałem, sprawdziłem na kilku przeglądarkach

153

Odp: Gargoyle 1.13.x

Jakie niebieskie tło? W sensie uruchomił się i treści nie pokazał czy masz niebieskie tło w przeglądarce?

Zrób podgląd źródła strony, wstaw na pastebin i daj tu linka.
Wyświetl też konsolę js i zobacz czy czegoś nie wyświetlił.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

154

Odp: Gargoyle 1.13.x

Mogę wpisać hasło, po jego zatwierdzeniu nie ma żadnej treści, jest tylko niebieskie tło, takie typowe gargoylowe.

[url]https://pastebin.pl/view/801f245d[/url]

155

Odp: Gargoyle 1.13.x

Uruchom tryb prywatny w przeglądarce i spróbuj się zalogować.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

156

Odp: Gargoyle 1.13.x

Taki sam efekt, strona logowania wygląda, jak zwykle, potem już tylko niebieskie tło.

Dokładnie takie :

https://megadrive.pl/#/view/file/xwwkalrxlzyjrcoxzhzg/Gargoyle tło.jpg

157

Odp: Gargoyle 1.13.x

Tak, to tło z gargoyle. Inna przeglądarka też tak wyświetla?

Treść jest, powinno się wyświetlać...

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

158

Odp: Gargoyle 1.13.x

Sprawdzałem Chrome, Edge i Firefoxa, ten ostatni instalowany na świeżo pierwszy raz na tym komputerze. Zrobiłem na tej niebieskiej stronie "zaznacz wszystko" i kopiuj-wklej do notatnika, wyszło tak:
    Gargoyle
    Gargoyle Logo
    Nazwa: Gargoyle
    Status
        Ogólny
        Zużycie pasma
        Podział pasma
        Monitor sieci
        Połączone urządzenia
        Lista połączeń
        Status OpenVPN
    Konfiguracja
    Firewall
    System
    Wylogowanie

Jednak żadnej interakcji z tym nie zauważam. Oczywiście przed aktualizacją było ok, bo robiłem ją poprzez gui.

159

Odp: Gargoyle 1.13.x

Mała propozycja - odłącz go od internetu, zrób firstboot z konsoli, pozwól mu się uruchomić i zobacz co będzie.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

160

Odp: Gargoyle 1.13.x

Zrobiłem testowo aktualizację bez zachowania konfiguracji i początkowo było OK, domyślne hasło, jego zmiana, kolejny ekran ustawienie IP, ustawienie wifi, zapisanie, potem ponowne logowanie i w tym momencie już niebieski ekran. z firstbootem spróbuję potem, ale poczekam do wieczora, pisałeś o nowych obrazach dla 7621

161

Odp: Gargoyle 1.13.x

Cezary,

Niestety, nic się nie zmienia, masz może wersję pre5 pod ręką?

Również i przeglądarki w telefonie nie pokazują nic.

162

Odp: Gargoyle 1.13.x

Nie mam.

Ale skoro na początku działa to problem jest jakiś inny. Zaloguj się przez ssh i zobacz w logread czy dmesg czy coś się nie wywaliło.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

163

Odp: Gargoyle 1.13.x

https://pastebin.com/TZhiqP6z

164

Odp: Gargoyle 1.13.x

Masz na samym początku:

Mon Jul 13 21:08:22 2020 kern.info kernel: [   60.225967] do_page_fault(): sending SIGSEGV to gargoyle_header for invalid read access from 00000000
Mon Jul 13 21:08:22 2020 kern.info kernel: [   60.235193] epc = 77f87014 in libc.so[77f13000+98000]
Mon Jul 13 21:08:22 2020 kern.info kernel: [   60.240254] ra  = 004026c5 in gargoyle_header_footer[400000+6000]
Mon Jul 13 21:08:22 2020 daemon.err uhttpd[4757]: Segmentation fault

Wywalił się program który generuje nagłówek strony. Jesteś pewien że ten twój router ma sprawną pamięć ram?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

165

Odp: Gargoyle 1.13.x

Jestem pewien, że nie miałem żadnych sygnałów dot. pamięci ram do momentu aktualizacji.

166

Odp: Gargoyle 1.13.x

Więc problem może być z samym wprowadzeniem ipv6. Zastosuj obraz z https://www.gargoyle-router.com/phpbb/v … mp;t=12467 i zobacz czy będzie tak samo się zachowywał. Jeżeli tak - zgłoś buga.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

167

Odp: Gargoyle 1.13.x

Tak samo się zachowuje, jak w Twoich obrazach.

168

Odp: Gargoyle 1.13.x

Zgłoś buga.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

169

Odp: Gargoyle 1.13.x

Na WD my net n750 działa :-), brak problemów z wcześniejszych wersji 13. Diody (poza power) nie działają , pewnie jest 'wd' zamiast 'mynet-n750'  :-) . Testuję na ipv4.

170

Odp: Gargoyle 1.13.x

Myslałem że to poprzednio przestawiłem. Sprawdź co jest w /tmp/sysinfo i co jest w /etc/config/system

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

171

Odp: Gargoyle 1.13.x

w /tmp/sysinfo w board_name jest 'wd,mynet-n750' a w '/etc/config/system' jest:
config system
    option ttylogin '0'
    option log_size '64'
    option urandom_seed '0'
    option hostname 'Gargoyle'
    option cronloglevel '9'
    option timezone 'CET-1CEST,M3.5.0/2,M10.5.0/3'
    option zonename 'Europe/Warsaw'
    option stat '1'

config timeserver 'ntp'
    option enabled '1'
    option enable_server '1'
    list server '0.pool.ntp.org'
    list server '1.pool.ntp.org'
    list server '2.pool.ntp.org'
    list server '3.pool.ntp.org'

config button 'reboot_button'
    option action 'released'
    option handler 'logger reboot ; /usr/lib/gargoyle/reboot.sh ;'
    option min '3'
    option button 'reset'
    option max '10'

config button 'reset_button'
    option button 'reset'
    option action 'released'
    option handler 'logger restore defaults ; /sbin/firstboot -y; reboot ;'
    option max '90'
    option min '11'

config button 'wps_button'
    option button 'wps'
    option action 'released'
    option handler 'logger reboot ; /sbin/wifionoff ;'
    option min '0'
    option max '2'

config button 'rfkill_button'
    option button 'rfkill'
    option action 'released'
    option handler 'logger reboot ; /sbin/wifionoff ;'
    option min '0'
    option max '2'

config button 'btn2_button'
    option button 'BTN_2'
    option action 'released'
    option handler 'logger reboot ; /sbin/wifionoff ;'
    option min '0'
    option max '2'

config button 'power_button'
    option button 'power'
    option action 'released'
    option handler 'exec /sbin/poweroff'
    option min '0'
    option max '90'

172

Odp: Gargoyle 1.13.x

tutaj dopisałem:
config led 'led_wan'
    option name 'WAN'
    option sysfs 'mynet-n750:blue:internet'
    option trigger 'netdev'
    option dev 'eth0.2'
    option mode 'link tx rx'

config led 'led_wlan'
    option name 'WLAN'
    option sysfs 'mynet-n750:blue:wireless'
    option trigger 'phy0tpt'

i diody świecą, ale jednostajnie bez migotania :-)

173

Odp: Gargoyle 1.13.x

A nie, jednak nie dodałem smile

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

174

Odp: Gargoyle 1.13.x

Przed chwilą zaktualizowałem i na Check Point 600  tak samo niebieski ekran.

175

Odp: Gargoyle 1.13.x

Też zgłoś problem.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.