351

Odp: Gargoyle 1.13.x

Trochę nie miałem czasu ale już wracam ;p
Chodziło mi o to że do wyboru są dwa kanały; 36 i 100, wybierając 100 jest opis:

"Wybrany kanał oznaczony jest jako DFS (dynamiczny wybór częstotliwości). Przed transmisją Gargoyle musi najpierw przeskanować przez 60 sekund sygnały z instalacji radarowych zajmujących tę częstotliwość. Jeśli zostaną wykryte, Gargoyle może przestawić na inny kanał niż wybrałeś (...)"

i mi chodzi o to że to w ogóle nie działa co również potwierdza dodatek "Analizator widma" który nie wykrywa żadnej sieci. Dla tego modelu nie działa wyszukiwanie dla 5GHz i tym samym nie potrafi dobrać sobie najlepszej częstotliwości.

Co do "Sam wybierasz sobie kanał." to też nie do końca, znalazłem na szybko że dla europy są to kanały 36-64 i 100-140 natomiast ustawiając kanał wyższy niż 124 ten już się nie uruchamia... dlaczego? Całe szczęście rutery UPC nie ogarniają i wszystkie chodzą na 100 więc mój na 124 działa w miarę tak że się nie nachodzą.

Teraz wracając do pasma; zauważyłem że po restarcie znika historia dla minut, kwadransów i godzin, dla dni już zlicza zużyte dane wcześniej w ciągu dnia także... no niech będzie ;P Ale wynikł inny problem -,- wczoraj pobrałem z 300GB...? Natomiast Gargoyle dla wczorajszego dnia na całym paśmie zliczył łącznie 34.476 MB. Dla dzisiejszego zliczył 7.814 MB gdzie obejrzane mam łącznie jakieś 40min YT w 1080/2160p także powinno być "nieco" więcej.
Wgram jeszcze raz sysupgrade bez zachowania ustawień, ponownie wszystko ręcznie ustawie i cóż, będę obserwował.

352 (edytowany przez Cezary 2021-02-07 09:51:07)

Odp: Gargoyle 1.13.x

Może nie czekałeś? Jak masz pecha to on nie uruchomi się natychmiast na kanale z DFS, czasami i 5minut mu to zajmuje zanim to zrobi. Tak działa właśnie DFS...

I jak ustawiłeś  kanał z DFS lub nie włączyłeś wifi 5GHz to skanowanie też może nie działać, tak to działa.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

353

Odp: Gargoyle 1.13.x

Nie no, ja czekałem co najmniej pół doby jak nie dłużej bo chyba to wieczorem zostawiłem, minęła noc, dzień w pracy itd. Po prostu on coś "nie umie" w 5GHz...
Jestem też po tym sysupgrade, wszystko ustawiłem, wyklikałem, włączyłem flow offload żeby był w stanie okiełznać pełne prędkości (po co w ogóle to jest domyślnie wyłączone?), wszystko śmigało więc postanowiłem zrobić taki ostateczny restart rutera i... znowu zużycie pasma się wysypało, tzn sytuacja jak na obrazku poniżej
https://i.ibb.co/Ybv7yvM/Przechwytywanie.jpg
Był to test na speedtest.net; 300Mb/s downloadu i 20Mb/s uploadu a na wykresie jakieś dwa piki po kilkanaście MB/s (bo robiłem dwa testy) a na uploadzie w ogóle nic praktycznie nie ma. Wykresy wysokiej rozdzielczości oczywiście włączone, po wyłączeniu w zasadzie bez zmian.

No imo ewidentny bug w gargoyle, napisz ewentualnie czy jakoś mogę pomóc w diagnozie i mam nadzieję że się uda to naprawić albo może komuś zreprodukować też u siebie bo może to nie tylko na R6350 tak się dzieje.

354

Odp: Gargoyle 1.13.x

Ok, wyłącz flow offload. Flow offload gryzie się qos i może być tu też problem i dlatego jest domyślnie wyłączony.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

355

Odp: Gargoyle 1.13.x

Faktycznie flow offload był problemem... da się to kiedyś jakoś naprawić? Bez tej opcji transfer mi skacze w okolicach 210-240Mb/s i tak patrzę że z czasem powoli zwalnia bo po jakiś 2-3 minutach jest to już średnio ok 200Mb/s.

356

Odp: Gargoyle 1.13.x

Raczej nie bez przepisana koncepcji jednego lub drugiego.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

357

Odp: Gargoyle 1.13.x

Flow offload is incompatible with most iptables rules. That's how it performs so well.

Monitor/filter/restrict/manage packets
OR
Have full line speed.

Choose only one. smile

358

Odp: Gargoyle 1.13.x

Witam
Na R6220 zainstalowałem Gargoyle  gargoyle-1.13.0.0pre9-ar71xx-generic-tl-wr1043nd-v1-squashfs-sysupgrade połączenie poprzez E3131 na Areo2.
Uruchomiłem ręcznie klienta OPENVPN bo nie chciało poprawnie uruchomić  konfiguracji poprzez GUI (WWW)
Jak się podniesie interfejs klienta OPENVPN to automatycznie odcina mi  dostęp od routera w sieci wewnętrznej jedyny dostęp to tylko i wyłącznie
poprzez drugi router ze świata.
Czy problemem może być zablokowanie ruchu na firewall-u, nic jeszcze nie konfigurowałem?


Konfiguracja
config openvpn 'custom_config'
        option script_security '2'
        option up '/etc/openvpn.up'
        option down '/etc/openvpn.down'
        option config '/etc/openvpn/rod.conf'
        option enabled '1'

config openvpn 'rod'
        option enabled '1'
        option client '1'
        option dev 'tun'
        option proto 'udp'
        list remote 'piratee.no-ip.pl 1194'
        option resolv_retry 'infinite'
        option nobind '1'
        option persist_key '1'
        option persist_tun '1'
        option ca '/etc/openvpn/ca.crt'
        option cert '/etc/openvpn/rod.crt'
        option key '/etc/openvpn/rod.key'
        option compress 'lzo'
        option tls-auth ta.key 1
        option verb '3'
        option topology subnet

oraz
serwer OPENVPN
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         host-89-228-24- 0.0.0.0         UG    0      0        0 eth0.2
10.8.0.0        *               255.255.255.0   U     0      0        0 tun0
89.228.24.0     *               255.255.248.0   U     0      0        0 eth0.2
172.20.1.0      *               255.255.255.0   U     0      0        0 br-lan
192.168.1.0     10.8.0.4        255.255.255.0   UG    0      0        0 tun0
192.168.1.0     10.8.0.2        255.255.255.0   UG    0      0        0 tun0


client OpenVPN
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         10.8.0.1        128.0.0.0       UG    0      0        0 tun0
default         10.64.64.64     0.0.0.0         UG    0      0        0 3g-wan
10.8.0.0        *               255.255.255.0   U     0      0        0 tun0
10.64.64.64     *               255.255.255.255 UH    0      0        0 3g-wan
89.228.24.164   10.64.64.64     255.255.255.255 UGH   0      0        0 3g-wan
128.0.0.0       10.8.0.1        128.0.0.0       UG    0      0        0 tun0
172.20.1.0      10.8.0.1        255.255.255.0   UG    0      0        0 tun0
192.168.1.0     10.8.0.1        255.255.255.0   UG    0      0        0 tun0
192.168.1.0     *               255.255.255.0   U     0      0        0 br-lan

Pozdrawiam

TP-LINK 1043ND-v1 mod RAM 64MB - OpenWrt 19.07-SNAPSHOT
TP-LINK Archer C7 v5 - 1.12.0.2 (27ec1e48)
Netgear R6220 Gargoyle PL 1.13.0.0pre9

359

Odp: Gargoyle 1.13.x

Konfiguracja robiona z gui działa. Co ci nie chciało działać?

A dostęp ci odcina bo masz konfigurację openvpn która dostarcza trasę do sieci 192.168.1.1 przez vpn. Albo źle skonfigurowałeś openvpn i tej trasy tam nie powinno być, albo dobrze, ale nie zmieniłeś adresu ip na lanie, bo nie może być taki sam jak vpn dostarcza.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

360 (edytowany przez piratee 2021-03-05 13:15:21)

Odp: Gargoyle 1.13.x

Konfigurację mam pobraną (zrobioną na 1.12.0.2 (27ec1e48) przez GUI są wygenerowane certyfikaty)
Wykonując przez GUI import na 1.13 wykrzacza mi się konfiguracja.
Adresów nie wprowadzałem ręcznie.
Adres serwera OPENVPN 10.8.0.1 (klasa wewnętrzna 172.20.1.245) zaś klient ma klasę 192.168.1.1

Może być powodem błędnego dziania istniejąca przykładowa konfiguracja która przyszła z plikiem factory??

TP-LINK 1043ND-v1 mod RAM 64MB - OpenWrt 19.07-SNAPSHOT
TP-LINK Archer C7 v5 - 1.12.0.2 (27ec1e48)
Netgear R6220 Gargoyle PL 1.13.0.0pre9

361

Odp: Gargoyle 1.13.x

I serwer też ma na lanie 192.168.1.1. Tak nie może być.

Z plikiem factory nie przychodzi żadna konfiguracja. Wszystko jest wyłączone.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

362 (edytowany przez piratee 2021-03-05 13:25:55)

Odp: Gargoyle 1.13.x

na serwerze OpenVPN zdefiniowałem adres podsieci 192.168.1.0 aby się widziały nawzajem generując klucz.
W starszej wersji Gargoyle działało to prawidłowo, w pliku nie definiuję żadnych IP.
serwer na którym jest serwer OpenVPN jest adres 172.20.1.245
Serwer z OPENVPN SERWER (172.20.1.245) ---> klasa TUN 10.8.0.1 ---> Klient z OPENVPN (192.168.1.1)

Po imporcie w katalogu /etc/openvpn tworzy takie nazwy plików
grouter_client_cxcbtnjchjrx*.*

TP-LINK 1043ND-v1 mod RAM 64MB - OpenWrt 19.07-SNAPSHOT
TP-LINK Archer C7 v5 - 1.12.0.2 (27ec1e48)
Netgear R6220 Gargoyle PL 1.13.0.0pre9

363

Odp: Gargoyle 1.13.x

Czy jak napisze po raz trzeci że nie może tak być to coś da?
Cały ruch do 192.168.1.1 idzie ci do vpn zamiast na lan. Możesz pisać i tupać że działało, ale nie działa bo zdefiniowałeś taką samą podsieć za klientem jak ma serwer na lanie. To jest powód że ci "automatycznie odcina dostęp do routera w sieci wewnętrznej".

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

364

Odp: Gargoyle 1.13.x

Ja nie tupię napisałem jakie mam adresy IP.

Wyzeruję konfigurację i wykonam konfigurację ponownie, zobaczymy co będzie po imporcie.

TP-LINK 1043ND-v1 mod RAM 64MB - OpenWrt 19.07-SNAPSHOT
TP-LINK Archer C7 v5 - 1.12.0.2 (27ec1e48)
Netgear R6220 Gargoyle PL 1.13.0.0pre9

365 (edytowany przez piratee 2021-03-05 13:53:19)

Odp: Gargoyle 1.13.x

Wykonałem wszystko jeszcze raz, ale chciałbym dołączyć zrzuty - jak mogę to uczynić

TP-LINK 1043ND-v1 mod RAM 64MB - OpenWrt 19.07-SNAPSHOT
TP-LINK Archer C7 v5 - 1.12.0.2 (27ec1e48)
Netgear R6220 Gargoyle PL 1.13.0.0pre9

366

Odp: Gargoyle 1.13.x

Daj to na dowolny serwer z obrazami i tu podaj linka.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

367 (edytowany przez piratee 2021-03-05 14:00:27)

Odp: Gargoyle 1.13.x

Dodałem pliki konfiguracyjne ręcznie wg zrzutu.
https://ibb.co/JrHkHrq

Po zatwierdzeniu dostaję komunikat
https://ibb.co/bm4DgW5

"Błąd. Parametry zostały zapisane ale nie udało się nawiązać połączenia"

w katalogu /etc/config brak utworzenia pliku openvpn
zaś w katalogu są tworzone wszystkie pliki
grouter_client_daitlkmgtbwn.conf
grouter_client_daitlkmgtbwn.crt
grouter_client_daitlkmgtbwn.key
grouter_client_daitlkmgtbwn_ca.crt
grouter_client_daitlkmgtbwn_ta.key

tym samym klient Openvpn nie startuje

TP-LINK 1043ND-v1 mod RAM 64MB - OpenWrt 19.07-SNAPSHOT
TP-LINK Archer C7 v5 - 1.12.0.2 (27ec1e48)
Netgear R6220 Gargoyle PL 1.13.0.0pre9

368

Odp: Gargoyle 1.13.x

Tylko tyle że nie nawiązał połącznia z serwerem. Dlaczego to już patrz w logi, bo gui Ci tego nie pokaże. Ten conf jest plikiem który podałeś.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

369

Odp: Gargoyle 1.13.x

przeglądając logread nie ma nawet linijki wpisu aby system chciał uruchomić openvpn-a
zrobię fristboot i zacznę od początku

TP-LINK 1043ND-v1 mod RAM 64MB - OpenWrt 19.07-SNAPSHOT
TP-LINK Archer C7 v5 - 1.12.0.2 (27ec1e48)
Netgear R6220 Gargoyle PL 1.13.0.0pre9

370

Odp: Gargoyle 1.13.x

Nie rób tego. Pokaż za to logi.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

371 (edytowany przez piratee 2021-03-05 14:27:02)

Odp: Gargoyle 1.13.x

Wyzerowałem i zrobię od początku.
po wykonaniu firstboot w /etc/config zostały stworzone pliki

"openvpn" z zawartością

config openvpn 'custom_config'
        option enabled '0'
        option config '/etc/openvpn/my-vpn.conf'
        option script_security '2'
        option up '/etc/openvpn.up'
        option down '/etc/openvpn.down'

config openvpn 'sample_server'
        option enabled '0'
        option port '1194'
        option proto 'udp'
        option dev 'tun'
        option ca '/etc/openvpn/ca.crt'
        option cert '/etc/openvpn/server.crt'
        option key '/etc/openvpn/server.key'
        option dh '/etc/openvpn/dh1024.pem'
        option server '10.8.0.0 255.255.255.0'
        option ifconfig_pool_persist '/tmp/ipp.txt'
        option keepalive '10 120'
        option compress 'lzo'
        option persist_key '1'
        option persist_tun '1'
        option user 'nobody'
        option status '/tmp/openvpn-status.log'
        option verb '3'

config openvpn 'sample_client'
        option enabled '0'
        option client '1'
        option dev 'tun'
        option proto 'udp'
        list remote 'my_server_1 1194'
        option resolv_retry 'infinite'
        option nobind '1'
        option persist_key '1'
        option persist_tun '1'
        option user 'nobody'
        option ca '/etc/openvpn/ca.crt'
        option cert '/etc/openvpn/client.crt'
        option key '/etc/openvpn/client.key'
        option compress 'lzo'
        option verb '3'


oraz

"openvpn_gargoyle" z zawartością

config 'server' 'server'
        option  'enabled'                       'false'
        option  'internal_ip'                   '10.8.0.1'
        option  'internal_mask'                 '255.255.255.0'
        option  'port'                          '1194'
        option  'proto'                         'udp'
        option  'cipher'                        'AES-256-CBC'
        option  'client_to_client'              'false'
        option  'duplicate_cn'                  'false'
        option  'redirect_gateway'              'true'
        option  'subnet_access'                 'false'


## client info, appears in server configuration
#config 'allowed_client' 'client_1'
#       option  'id'            'client_1'
#       option  'name'          'My First Client'
#       option  'remote'        'myhost.chickenkiller.com'
#       option  'ip'            '10.8.0.2'
#       option  'subnet_ip'     '192.168.3.0'
#       option  'subnet_mask'   '255.255.255.0'
#

config 'client' 'client'
        option  'enabled'       'false'
        #option 'id'            'grouter_client_123456543210'

i teraz jak do tego podejść - usunąć - zmieniać i czy jak wstawię samego klienta to konfiguracja pojawi się na UI ??

TP-LINK 1043ND-v1 mod RAM 64MB - OpenWrt 19.07-SNAPSHOT
TP-LINK Archer C7 v5 - 1.12.0.2 (27ec1e48)
Netgear R6220 Gargoyle PL 1.13.0.0pre9

372

Odp: Gargoyle 1.13.x

Zrób to przez gui tak jak robiłeś jeżeli chcesz to widzieć w gui.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

373

Odp: Gargoyle 1.13.x

ok w GUI stworzyło konfigurację ale odcieło mnie od strony wewnętrznej routera

Sun Jan 24 18:01:32 2021 daemon.notice openvpn(custom_config)[14632]: OPTIONS IMPORT: timers and/or timeouts modified
Sun Jan 24 18:01:32 2021 daemon.notice openvpn(custom_config)[14632]: OPTIONS IMPORT: --ifconfig/up options modified
Sun Jan 24 18:01:32 2021 daemon.notice openvpn(custom_config)[14632]: OPTIONS IMPORT: route options modified
Sun Jan 24 18:01:32 2021 daemon.notice openvpn(custom_config)[14632]: OPTIONS IMPORT: route-related options modified
Sun Jan 24 18:01:32 2021 daemon.notice openvpn(custom_config)[14632]: OPTIONS IMPORT: peer-id set
Sun Jan 24 18:01:32 2021 daemon.notice openvpn(custom_config)[14632]: OPTIONS IMPORT: adjusting link_mtu to 1627
Sun Jan 24 18:01:32 2021 daemon.notice openvpn(custom_config)[14632]: OPTIONS IMPORT: data channel crypto options modified
Sun Jan 24 18:01:32 2021 daemon.notice openvpn(custom_config)[14632]: Outgoing Data Channel: Cipher 'AES-256-GCM' initialized with 256 bit key
Sun Jan 24 18:01:32 2021 daemon.notice openvpn(custom_config)[14632]: Incoming Data Channel: Cipher 'AES-256-GCM' initialized with 256 bit key
Sun Jan 24 18:01:32 2021 daemon.notice openvpn(custom_config)[14632]: TUN/TAP device tun0 opened
Sun Jan 24 18:01:32 2021 daemon.notice openvpn(custom_config)[14632]: TUN/TAP TX queue length set to 100
Sun Jan 24 18:01:32 2021 daemon.notice openvpn(custom_config)[14632]: do_ifconfig, tt->did_ifconfig_ipv6_setup=0
Sun Jan 24 18:01:32 2021 daemon.notice openvpn(custom_config)[14632]: /sbin/ifconfig tun0 10.8.0.4 netmask 255.255.255.0 mtu 1500 broadcast 10.8.0.255
Sun Jan 24 18:01:32 2021 daemon.notice openvpn(custom_config)[14632]: /etc/openvpn.up tun0 1500 1555 10.8.0.4 255.255.255.0 init
Sun Jan 24 18:01:32 2021 user.notice root: openvpn up script called
Sun Jan 24 18:01:33 2021 daemon.notice openvpn(custom_config)[14632]: /sbin/route add -net 89.228.24.164 netmask 255.255.255.255 gw 10.64.64.64
Sun Jan 24 18:01:33 2021 daemon.notice openvpn(custom_config)[14632]: /sbin/route add -net 0.0.0.0 netmask 128.0.0.0 gw 10.8.0.1
Sun Jan 24 18:01:33 2021 daemon.notice openvpn(custom_config)[14632]: /sbin/route add -net 128.0.0.0 netmask 128.0.0.0 gw 10.8.0.1
Sun Jan 24 18:01:33 2021 daemon.notice openvpn(custom_config)[14632]: /sbin/route add -net 192.168.1.0 netmask 255.255.255.0 gw 10.8.0.1
Sun Jan 24 18:01:33 2021 daemon.notice openvpn(custom_config)[14632]: /sbin/route add -net 172.20.1.0 netmask 255.255.255.0 gw 10.8.0.1
Sun Jan 24 18:01:33 2021 daemon.warn openvpn(custom_config)[14632]: WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
Sun Jan 24 18:01:33 2021 daemon.notice openvpn(custom_config)[14632]: Initialization Sequence Completed


Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         10.8.0.1        128.0.0.0       UG    0      0        0 tun0
default         10.64.64.64     0.0.0.0         UG    0      0        0 3g-wan
10.8.0.0        *               255.255.255.0   U     0      0        0 tun0
10.64.64.64     *               255.255.255.255 UH    0      0        0 3g-wan
89.228.24.164   10.64.64.64     255.255.255.255 UGH   0      0        0 3g-wan
128.0.0.0       10.8.0.1        128.0.0.0       UG    0      0        0 tun0
172.20.1.0      10.8.0.1        255.255.255.0   UG    0      0        0 tun0
192.168.1.0     10.8.0.1        255.255.255.0   UG    0      0        0 tun0
192.168.1.0     *               255.255.255.0   U     0      0        0 br-lan

TP-LINK 1043ND-v1 mod RAM 64MB - OpenWrt 19.07-SNAPSHOT
TP-LINK Archer C7 v5 - 1.12.0.2 (27ec1e48)
Netgear R6220 Gargoyle PL 1.13.0.0pre9

374

Odp: Gargoyle 1.13.x

Po raz czwarty - bo masz taką samą adresację na lan jak udostępnia serwer w routingu.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

375

Odp: Gargoyle 1.13.x

to się samo tworzy po uruchomieniu tunelu:
to jest zrzut z serwera z openvpn

br-lan    Link encap:Ethernet  HWaddr D8:07:B6:B6:81:D2
          inet addr:172.20.1.245  Bcast:172.20.1.255  Mask:255.255.255.0
          inet6 addr: fd2f:f89b:a423::1/60 Scope:Global
          inet6 addr: fe80::da07:b6ff:feb6:81d2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:46743054 errors:0 dropped:973 overruns:0 frame:0
          TX packets:152829615 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:8675841918 (8.0 GiB)  TX bytes:170975760184 (159.2 GiB)

eth0      Link encap:Ethernet  HWaddr D8:07:B6:B6:81:D2
          inet6 addr: fe80::da07:b6ff:feb6:81d2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:374100648 errors:0 dropped:0 overruns:9002 frame:0
          TX packets:78817875 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1370584907 (1.2 GiB)  TX bytes:1005088469 (958.5 MiB)
          Interrupt:4

eth0.1    Link encap:Ethernet  HWaddr D8:07:B6:B6:81:D2
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:11449442 errors:0 dropped:5 overruns:0 frame:0
          TX packets:32105491 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2726999631 (2.5 GiB)  TX bytes:38396669491 (35.7 GiB)

eth0.2    Link encap:Ethernet  HWaddr D8:07:B6:B6:81:D3
          inet addr:89.228.24.164  Bcast:89.228.31.255  Mask:255.255.248.0
          inet6 addr: fe80::da07:b6ff:feb6:81d3/64 Scope:Link
          inet6 addr: fe80::da07:b6ff:feb6:81d3/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:362651199 errors:0 dropped:0 overruns:0 frame:0
          TX packets:46713068 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:176593366359 (164.4 GiB)  TX bytes:9537851908 (8.8 GiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:8316 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8316 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1
          RX bytes:741273 (723.8 KiB)  TX bytes:741273 (723.8 KiB)

tun0      Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00                                                                                        -00
          inet addr:10.8.0.1  P-t-P:10.8.0.1  Mask:255.255.255.0
          inet6 addr: fe80::2d88:5109:1af:4cde/64 Scope:Link
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:53939 errors:0 dropped:0 overruns:0 frame:0
          TX packets:67311 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:5632993 (5.3 MiB)  TX bytes:42762111 (40.7 MiB)

wlan0     Link encap:Ethernet  HWaddr D8:07:B6:B6:81:D1
          inet6 addr: fe80::da07:b6ff:feb6:81d1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:10333574 errors:0 dropped:0 overruns:0 frame:0
          TX packets:40435625 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2848159394 (2.6 GiB)  TX bytes:42014347366 (39.1 GiB)

wlan1     Link encap:Ethernet  HWaddr D8:07:B6:B6:81:D2
          inet6 addr: fe80::da07:b6ff:feb6:81d2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:30230723 errors:0 dropped:0 overruns:0 frame:0
          TX packets:97158830 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:5112611959 (4.7 GiB)  TX bytes:100394361384 (93.4 GiB)

TP-LINK 1043ND-v1 mod RAM 64MB - OpenWrt 19.07-SNAPSHOT
TP-LINK Archer C7 v5 - 1.12.0.2 (27ec1e48)
Netgear R6220 Gargoyle PL 1.13.0.0pre9