1 (edytowany przez miguelos 2019-11-28 21:22:37)

Temat: 18.06 -> 19.07 wifi

Hej

3 dni po upgradzie jak w temacie, router archer c5 v1
Nagle po prostu wieczorem przestaje dzialac wifi, patrze w logi nic nie widac
W luci w wireless widze 3 radio zamiast 2 jak wczesniej
radio0 - Generic 802.11bg
radio1 - Generic 802.11bgn
radio2 - Qualcomm Atheros QCA9880 802.11nac

daje restart, wstaje tylko radio1

Thu Nov 28 19:01:27 2019 daemon.info hostapd: wlan1: STA 80:01:84:f8:9f:df IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Thu Nov 28 19:05:45 2019 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED b8:27:eb:fa:20:80
Thu Nov 28 19:05:45 2019 daemon.info hostapd: wlan1: STA b8:27:eb:fa:20:80 IEEE 802.11: disassociated due to inactivity
Thu Nov 28 19:05:45 2019 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED 38:a4:ed:1b:3d:f6
Thu Nov 28 19:05:45 2019 daemon.info hostapd: wlan1: STA 38:a4:ed:1b:3d:f6 IEEE 802.11: disassociated due to inactivity
Thu Nov 28 19:05:46 2019 daemon.info hostapd: wlan1: STA b8:27:eb:fa:20:80 IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Thu Nov 28 19:05:46 2019 daemon.info hostapd: wlan1: STA 38:a4:ed:1b:3d:f6 IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)

Thu Nov 28 20:42:16 2019 daemon.notice hostapd: wlan1: interface state ENABLED->DISABLED
Thu Nov 28 20:42:16 2019 daemon.notice hostapd: wlan1: AP-DISABLED
Thu Nov 28 20:42:16 2019 daemon.notice hostapd: wlan1: CTRL-EVENT-TERMINATING
Thu Nov 28 20:42:16 2019 daemon.notice hostapd: nl80211: deinit ifname=wlan1 disabled_11b_rates=0
Thu Nov 28 20:42:16 2019 kern.info kernel: [123390.901600] device wlan1 left promiscuous mode
Thu Nov 28 20:42:16 2019 kern.info kernel: [123390.906334] br-lan: port 2(wlan1) entered disabled state
Thu Nov 28 20:42:16 2019 daemon.notice netifd: Network device 'wlan1' link is down
Thu Nov 28 20:42:17 2019 daemon.err hostapd: Configuration file: /var/run/hostapd-phy1.conf
Thu Nov 28 20:42:17 2019 kern.info kernel: [123391.988091] IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready
Thu Nov 28 20:42:18 2019 kern.info kernel: [123392.047095] br-lan: port 2(wlan1) entered blocking state
Thu Nov 28 20:42:18 2019 kern.info kernel: [123392.052762] br-lan: port 2(wlan1) entered disabled state
Thu Nov 28 20:42:18 2019 kern.info kernel: [123392.058547] device wlan1 entered promiscuous mode
Thu Nov 28 20:42:18 2019 daemon.notice hostapd: wlan1: interface state UNINITIALIZED->COUNTRY_UPDATE
Thu Nov 28 20:42:18 2019 daemon.err hostapd: Using interface wlan1 with hwaddr c4:e9:84:43:92:76 and ssid "Miguel008"
Thu Nov 28 20:42:18 2019 kern.info kernel: [123392.571185] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
Thu Nov 28 20:42:18 2019 kern.info kernel: [123392.577907] br-lan: port 2(wlan1) entered blocking state
Thu Nov 28 20:42:18 2019 kern.info kernel: [123392.583399] br-lan: port 2(wlan1) entered forwarding state
Thu Nov 28 20:42:18 2019 daemon.notice hostapd: wlan1: interface state COUNTRY_UPDATE->ENABLED
Thu Nov 28 20:42:18 2019 daemon.notice hostapd: wlan1: AP-ENABLED
Thu Nov 28 20:42:18 2019 daemon.notice netifd: Network device 'wlan1' link is up
Thu Nov 28 20:42:21 2019 daemon.info hostapd: wlan1: STA b8:27:eb:fa:20:80 IEEE 802.11: authenticated
Thu Nov 28 20:42:21 2019 daemon.info hostapd: wlan1: STA b8:27:eb:fa:20:80 IEEE 802.11: associated (aid 1)
Thu Nov 28 20:42:21 2019 daemon.notice hostapd: wlan1: AP-STA-CONNECTED b8:27:eb:fa:20:80
Thu Nov 28 20:42:21 2019 daemon.info hostapd: wlan1: STA b8:27:eb:fa:20:80 WPA: pairwise key handshake completed (RSN)
Thu Nov 28 20:42:26 2019 daemon.notice netifd: radio0 (13713): Could not find PHY for device 'radio0'
Thu Nov 28 20:42:27 2019 daemon.notice netifd: radio0 (13722): WARNING: Variable 'data' does not exist or is not an array/object

config

config wifi-device 'radio0'
    option type 'mac80211'
    option hwmode '11a'
    option path 'pci0000:01/0000:01:00.0'
    option htmode 'VHT80'
    option noscan '1'
    option disabled '0'
    option country 'US'
    option channel '36'

config wifi-iface 'default_radio0'
    option device 'radio0'
    option network 'lan'
    option mode 'ap'
    option ssid 'Miguel008'
    option encryption 'psk2+ccmp'
    option key 'xxx'
    option wpa_group_rekey '144000'
    option wps_pushbutton '0'

config wifi-device 'radio1'
    option type 'mac80211'
    option hwmode '11g'
    option channel '1'
    option noscan '1'
    option htmode 'HT40'
    option disabled '0'
    option country 'US'
    option path 'platform/ahb/ahb:apb/18100000.wmac'

config wifi-iface 'default_radio1'
    option device 'radio1'
    option network 'lan'
    option mode 'ap'
    option ssid 'Miguel008'
    option encryption 'psk2+ccmp'
    option key 'xxx'
    option wpa_group_rekey '14400'
    option wps_pushbutton '0'

config wifi-device 'radio2'
    option type 'mac80211'
    option channel '36'
    option hwmode '11a'
    option path 'pci0000:00/0000:00:00.0'
    option htmode 'VHT80'
    option disabled '1'
    option country 'PL'

config wifi-iface 'default_radio2'
    option device 'radio2'
    option network 'lan'
    option mode 'ap'
    option ssid 'OpenWrt'
    option encryption 'none'

skad w ogole radio2 ? robilem upgrade z zachowaniem konfiguracji
restart radio0 - 2 linijki w logach
restart radio2 - zero w logach

2

Odp: 18.06 -> 19.07 wifi

Usuń konfig wifi, zrób wifi config niech zrobi go ponownie i tyle. 19.07 lekko pozmieniało się dla niektórych urządzeń i może w twoim radio jest inaczej wykrywane. Nie wiem, C5 nie używałem na 19.07.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

3 (edytowany przez miguelos 2019-12-01 11:39:39)

Odp: 18.06 -> 19.07 wifi

zrobilem jak poleciles, teoretycznie sie polepszylo, tzn mam tylko wlan0 i wlan1
mimo wszystko widze, ze nieregularnie pada wlan1 (2.4GHz) - problematyczne o tyle, ze nie wszystkie urzadzenia chodza u mnie po  5GHz..

W logach zero bledow, bo prostu siec nie dziala
musze dac restart z Luci albo wifi z shella...

(mam w cronie wylaczanie wifi na noc, wiec wstaje o 5:30) :

Sun Dec  1 05:30:05 2019 daemon.notice hostapd: wlan1: interface state UNINITIALIZED->COUNTRY_UPDATE
Sun Dec  1 05:30:05 2019 daemon.err hostapd: Using interface wlan1 with hwaddr c4:e9:84:43:92:76 and ssid "Miguel008"
Sun Dec  1 05:30:05 2019 kern.info kernel: [327858.883129] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
Sun Dec  1 05:30:05 2019 kern.info kernel: [327858.889859] br-lan: port 3(wlan1) entered blocking state
Sun Dec  1 05:30:05 2019 kern.info kernel: [327858.895398] br-lan: port 3(wlan1) entered forwarding state
Sun Dec  1 05:30:05 2019 daemon.notice hostapd: wlan1: interface state COUNTRY_UPDATE->ENABLED
Sun Dec  1 05:30:05 2019 daemon.notice hostapd: wlan1: AP-ENABLED
Sun Dec  1 05:30:05 2019 daemon.notice netifd: Network device 'wlan1' link is up
Sun Dec  1 05:30:10 2019 daemon.info hostapd: wlan1: STA b8:27:eb:fa:20:80 IEEE 802.11: authenticated
Sun Dec  1 05:30:10 2019 daemon.info hostapd: wlan1: STA b8:27:eb:fa:20:80 IEEE 802.11: associated (aid 1)
Sun Dec  1 05:30:10 2019 daemon.notice hostapd: wlan1: AP-STA-CONNECTED b8:27:eb:fa:20:80
Sun Dec  1 05:30:10 2019 daemon.info hostapd: wlan1: STA b8:27:eb:fa:20:80 WPA: pairwise key handshake completed (RSN)
Sun Dec  1 05:38:41 2019 daemon.notice hostapd: wlan1: AP-STA-POLL-OK b8:27:eb:fa:20:80
Sun Dec  1 05:48:37 2019 daemon.notice hostapd: wlan1: AP-STA-POLL-OK b8:27:eb:fa:20:80
Sun Dec  1 05:59:42 2019 daemon.notice hostapd: wlan1: AP-STA-POLL-OK b8:27:eb:fa:20:80
Sun Dec  1 06:12:56 2019 daemon.notice hostapd: wlan1: AP-STA-POLL-OK b8:27:eb:fa:20:80
Sun Dec  1 06:18:14 2019 daemon.notice hostapd: wlan1: AP-STA-POLL-OK b8:27:eb:fa:20:80
Sun Dec  1 06:23:31 2019 daemon.notice hostapd: wlan1: AP-STA-POLL-OK b8:27:eb:fa:20:80
Sun Dec  1 06:37:01 2019 daemon.notice hostapd: wlan1: AP-STA-POLL-OK b8:27:eb:fa:20:80
Sun Dec  1 06:49:54 2019 daemon.notice hostapd: wlan1: AP-STA-POLL-OK b8:27:eb:fa:20:80
Sun Dec  1 06:55:06 2019 daemon.notice hostapd: wlan1: AP-STA-POLL-OK b8:27:eb:fa:20:80
Sun Dec  1 07:00:20 2019 daemon.notice hostapd: wlan1: AP-STA-POLL-OK b8:27:eb:fa:20:80
Sun Dec  1 07:07:59 2019 daemon.notice hostapd: wlan1: AP-STA-POLL-OK b8:27:eb:fa:20:80
Sun Dec  1 07:13:10 2019 daemon.notice hostapd: wlan1: AP-STA-POLL-OK b8:27:eb:fa:20:80
Sun Dec  1 07:21:05 2019 daemon.notice hostapd: wlan1: AP-STA-POLL-OK b8:27:eb:fa:20:80
Sun Dec  1 08:06:57 2019 daemon.info hostapd: wlan1: STA 80:01:84:f8:9f:df IEEE 802.11: authenticated
Sun Dec  1 08:06:57 2019 daemon.info hostapd: wlan1: STA 80:01:84:f8:9f:df IEEE 802.11: associated (aid 2)
Sun Dec  1 08:06:58 2019 daemon.notice hostapd: wlan1: AP-STA-CONNECTED 80:01:84:f8:9f:df
Sun Dec  1 08:06:58 2019 daemon.info hostapd: wlan1: STA 80:01:84:f8:9f:df WPA: pairwise key handshake completed (RSN)
Sun Dec  1 08:06:58 2019 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED 80:01:84:f8:9f:df
Sun Dec  1 08:07:04 2019 daemon.info hostapd: wlan1: STA 80:01:84:f8:9f:df IEEE 802.11: authenticated
Sun Dec  1 08:07:04 2019 daemon.info hostapd: wlan1: STA 80:01:84:f8:9f:df IEEE 802.11: associated (aid 2)
Sun Dec  1 08:07:04 2019 daemon.notice hostapd: wlan1: AP-STA-CONNECTED 80:01:84:f8:9f:df
Sun Dec  1 08:07:04 2019 daemon.info hostapd: wlan1: STA 80:01:84:f8:9f:df WPA: pairwise key handshake completed (RSN)
Sun Dec  1 08:39:44 2019 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED 80:01:84:f8:9f:df
Sun Dec  1 08:39:44 2019 daemon.info hostapd: wlan1: STA 80:01:84:f8:9f:df IEEE 802.11: authenticated
Sun Dec  1 08:39:44 2019 daemon.info hostapd: wlan1: STA 80:01:84:f8:9f:df IEEE 802.11: associated (aid 2)
Sun Dec  1 08:39:44 2019 daemon.notice hostapd: wlan1: AP-STA-CONNECTED 80:01:84:f8:9f:df
Sun Dec  1 08:39:44 2019 daemon.info hostapd: wlan1: STA 80:01:84:f8:9f:df WPA: pairwise key handshake completed (RSN)
Sun Dec  1 08:40:52 2019 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED 80:01:84:f8:9f:df
Sun Dec  1 08:40:52 2019 daemon.info hostapd: wlan1: STA 80:01:84:f8:9f:df IEEE 802.11: authenticated
Sun Dec  1 08:40:52 2019 daemon.info hostapd: wlan1: STA 80:01:84:f8:9f:df IEEE 802.11: associated (aid 2)
Sun Dec  1 08:40:52 2019 daemon.notice hostapd: wlan1: AP-STA-CONNECTED 80:01:84:f8:9f:df
Sun Dec  1 08:40:52 2019 daemon.info hostapd: wlan1: STA 80:01:84:f8:9f:df WPA: pairwise key handshake completed (RSN)
Sun Dec  1 08:41:48 2019 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED 80:01:84:f8:9f:df
Sun Dec  1 08:41:48 2019 daemon.info hostapd: wlan1: STA 80:01:84:f8:9f:df IEEE 802.11: authenticated
Sun Dec  1 08:41:48 2019 daemon.info hostapd: wlan1: STA 80:01:84:f8:9f:df IEEE 802.11: associated (aid 2)
Sun Dec  1 08:41:48 2019 daemon.notice hostapd: wlan1: AP-STA-CONNECTED 80:01:84:f8:9f:df
Sun Dec  1 08:41:48 2019 daemon.info hostapd: wlan1: STA 80:01:84:f8:9f:df WPA: pairwise key handshake completed (RSN)
Sun Dec  1 08:49:45 2019 daemon.info hostapd: wlan1: STA 9c:2e:a1:e7:93:21 IEEE 802.11: authenticated
Sun Dec  1 08:49:45 2019 daemon.info hostapd: wlan1: STA 9c:2e:a1:e7:93:21 IEEE 802.11: associated (aid 3)
Sun Dec  1 08:49:45 2019 daemon.notice hostapd: wlan1: AP-STA-CONNECTED 9c:2e:a1:e7:93:21
Sun Dec  1 08:49:45 2019 daemon.info hostapd: wlan1: STA 9c:2e:a1:e7:93:21 WPA: pairwise key handshake completed (RSN)
Sun Dec  1 08:51:49 2019 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED 9c:2e:a1:e7:93:21
Sun Dec  1 08:52:23 2019 daemon.info hostapd: wlan1: STA 50:dc:e7:db:14:ed IEEE 802.11: authenticated
Sun Dec  1 08:52:23 2019 daemon.info hostapd: wlan1: STA 50:dc:e7:db:14:ed IEEE 802.11: associated (aid 3)
Sun Dec  1 08:52:23 2019 daemon.notice hostapd: wlan1: AP-STA-CONNECTED 50:dc:e7:db:14:ed
Sun Dec  1 08:52:23 2019 daemon.info hostapd: wlan1: STA 50:dc:e7:db:14:ed WPA: pairwise key handshake completed (RSN)
Sun Dec  1 08:54:06 2019 daemon.info hostapd: wlan1: STA 00:f4:8d:fd:98:b9 IEEE 802.11: authenticated
Sun Dec  1 08:54:06 2019 daemon.info hostapd: wlan1: STA 00:f4:8d:fd:98:b9 IEEE 802.11: associated (aid 4)
Sun Dec  1 08:54:06 2019 daemon.notice hostapd: wlan1: AP-STA-CONNECTED 00:f4:8d:fd:98:b9
Sun Dec  1 08:54:06 2019 daemon.info hostapd: wlan1: STA 00:f4:8d:fd:98:b9 WPA: pairwise key handshake completed (RSN)
Sun Dec  1 08:54:49 2019 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED 50:dc:e7:db:14:ed
Sun Dec  1 08:54:49 2019 daemon.info hostapd: wlan1: STA 50:dc:e7:db:14:ed IEEE 802.11: disassociated
Sun Dec  1 09:07:55 2019 daemon.info hostapd: wlan1: STA 00:f4:8d:fd:98:b9 IEEE 802.11: disconnected due to excessive missing ACKs
Sun Dec  1 09:07:55 2019 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED 00:f4:8d:fd:98:b9
Sun Dec  1 09:08:25 2019 daemon.info hostapd: wlan1: STA b8:27:eb:fa:20:80 IEEE 802.11: disconnected due to excessive missing ACKs
Sun Dec  1 09:08:25 2019 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED b8:27:eb:fa:20:80
Sun Dec  1 09:08:25 2019 daemon.info hostapd: wlan1: STA 00:f4:8d:fd:98:b9 IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Sun Dec  1 09:08:55 2019 daemon.info hostapd: wlan1: STA b8:27:eb:fa:20:80 IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Sun Dec  1 09:13:06 2019 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED 80:01:84:f8:9f:df
Sun Dec  1 09:13:06 2019 daemon.info hostapd: wlan1: STA 80:01:84:f8:9f:df IEEE 802.11: disassociated due to inactivity
Sun Dec  1 09:13:07 2019 daemon.info hostapd: wlan1: STA 80:01:84:f8:9f:df IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
root@rtr303:~# cat /etc/config/wireless

config wifi-device 'radio0'
    option type 'mac80211'
    option channel '36'
    option hwmode '11a'
    option path 'pci0000:00/0000:00:00.0'
    option htmode 'VHT80'
    option disabled '0'
    option country 'US'
    option noscan '1'
    option legacy_rates '0'

config wifi-iface 'default_radio0'
    option device 'radio0'
    option network 'lan'
    option mode 'ap'
    option ssid 'Miguel008'
    option encryption 'psk2+ccmp'
    option key 'xxxxxxxxx'

config wifi-device 'radio1'
    option type 'mac80211'
    option channel '11'
    option hwmode '11g'
    option path 'platform/ahb/ahb:apb/18100000.wmac'
    option disabled '0'
    option country 'US'
    option noscan '1'
    option txpower '24'
    option htmode 'HT40'
    option legacy_rates '0'

config wifi-iface 'default_radio1'
    option device 'radio1'
    option network 'lan'
    option mode 'ap'
    option ssid 'Miguel008'
    option encryption 'psk2+ccmp'
    option key 'xxxxxxxx'

jedyne co ostatnio zmienialem to option legacy_rates '0' ale po restarcie klienci 2.4 GHz lacza sie z tym ustawieniem
I prawdopodobnie z option legacy_rates '1' bylo podobnie

czy sa jakies dodatkowe logi / poziom logowania ktory moge zapuscic by to zanalizowac ?

4

Odp: 18.06 -> 19.07 wifi

Zgłoś na bugs.openwrt.org. Co jak co ale ath9k/ath10k są dobrze "obcykane" przez deweloperów i niezbyt często zdarza się jakiś tajemniczy błąd z nimi związany.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

5

Odp: 18.06 -> 19.07 wifi

to jednak kwestia legacy_rates
na oryginalnym legacy_rates '1' problem sie nie pojawil

6

Odp: 18.06 -> 19.07 wifi

Zmiana legacy_rates na 0 nie ma sensu, bo jedynie stracisz połączenie z prędkością b (11Mb/s) więc jakiegoś bardzo starego urządzenie nie podłączysz a jednocześnie nic nie zyskasz na tym.

7

Odp: 18.06 -> 19.07 wifi

9tysiecy napisał/a:

Zmiana legacy_rates na 0 nie ma sensu, bo jedynie stracisz połączenie z prędkością b (11Mb/s) więc jakiegoś bardzo starego urządzenie nie podłączysz a jednocześnie nic nie zyskasz na tym.

http://divdyn.com/disable-lower-legacy-data-rates/