1 (edytowany przez chauwa 2018-03-07 12:47:29)

Temat: 5372 nie działa z mifi

ten mr3420 mifi z starym modemem 3372 działa. Nie działa tylko z 5372 .
Cokolwiek wgram innego i smiga.


zaraz podłącze dwr 116 i wgram mifi tylko nie widzę obrazu.

2 (edytowany przez chauwa 2018-03-07 13:02:46)

Odp: 5372 nie działa z mifi

na dwr 116 z obrazem mifi nie działa smile logread też nie bo jest smietnik jak w starym temacie o dwr116 jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00214010: 0x678a instead
i tak cały log

3

Odp: 5372 nie działa z mifi

To samo - pokaż logi oraz cat /sys/kernel/debug/usb/devices

Akurat dwr-116 jest złym przykładem routera, bo oficjalnych obrazów dla tego linka nie ma więc nie ma z czym porównać. Używaj tego tplinka.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

4 (edytowany przez chauwa 2018-03-07 13:05:25)

Odp: 5372 nie działa z mifi

T:  Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=12   MxCh= 1
B:  Alloc=  0/900 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 1.10 Cls=09(hub  ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0001 Rev= 4.04
S:  Manufacturer=Linux 4.4.116 ohci_hcd
S:  Product=Generic Platform OHCI controller
S:  SerialNumber=101c1000.ohci
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  0mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   2 Ivl=255ms

T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480  MxCh= 1
B:  Alloc=  0/800 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0002 Rev= 4.04
S:  Manufacturer=Linux 4.4.116 ehci_hcd
S:  Product=EHCI Host Controller
S:  SerialNumber=101c0000.ehci
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  0mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   4 Ivl=256ms

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  3 Spd=480  MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=12d1 ProdID=1506 Rev= 1.02
S:  Manufacturer=HUAWEI Technology
S:  Product=HUAWEI Mobile
C:* #Ifs= 4 Cfg#= 1 Atr=80 MxPwr=500mA
I:* If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=02 Prot=12 Driver=option
E:  Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=4ms
I:  If#= 1 Alt= 0 #EPs= 1 Cls=ff(vend.) Sub=02 Prot=16 Driver=huawei_cdc_ncm
E:  Ad=82(I) Atr=03(Int.) MxPS=  64 Ivl=2ms
I:* If#= 1 Alt= 1 #EPs= 3 Cls=ff(vend.) Sub=02 Prot=16 Driver=huawei_cdc_ncm
E:  Ad=82(I) Atr=03(Int.) MxPS=  64 Ivl=2ms
E:  Ad=83(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=4ms
I:* If#= 2 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=(none)
E:  Ad=03(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=84(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:* If#= 3 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=(none)
E:  Ad=04(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=85(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms

natomiast  log to smietnik od początku do końca
Tue Feb 20 10:53:44 2018 kern.notice kernel: [  193.468711] jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00214020: 0x4974 instead

5

Odp: 5372 nie działa z mifi

cat /sys/kernel/debug/usb/devices

Źle wgrałaś obraz, pisał o tym @krolik. Wgraj oryginał przez recovery i z jego poziomu dopiero factory.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

6

Odp: 5372 nie działa z mifi

To wieczorem wgram od nowa ale wieczorem albo jutro rano, ja muszę z domu wyjść.

Wielkie dzieki.

7 (edytowany przez chauwa 2018-03-07 13:30:40)

Odp: 5372 nie działa z mifi

Tak na szybko, router dwr116  z mifi pokazuje siłę sygnału sieci LTE i na tym się impreza kończy.
Brak dostępu do panelu modemu hlink i internetu

ifconfig
https://pastebin.com/MdmDVbCs

8

Odp: 5372 nie działa z mifi

Wg tego co pokazałaś to on jest zwykłym ncm i tak powinnaś nawiązać połączenie.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

9 (edytowany przez chauwa 2018-03-07 13:40:40)

Odp: 5372 nie działa z mifi

To sam widzisz, że obrazy mifi mają złą konfigurację, ten modem ma vid  jak stare modemy które działaja jak zwykły modem .
Po podłączeniu 12d1:14fe   <<<<  np ma taki staroswiecki modem 352
w trybie modemu 12d1:1506  hlink



Nie połączysz sie w zaden inny sposób jak przez panel modemu hlink w tym modelu.
5372 to HLINK i działa normalnie na innych obrazach tylko nie mifi.

10

Odp: 5372 nie działa z mifi

Sterowniki się same ładują na podstawie tego co kernel widzi. Weź obraz lede 17.01 (nie mój, ten z openwrt.org), zainstaluj mr3420 i zobaczysz co będzie.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

11

Odp: 5372 nie działa z mifi

działa idealnie każdy obraz tylko nie mifi, powtarzac mam jak mantrę?
Przecież wziełam obraz do dwr 116 Twojego autorstwa tylko zwykły zmieniłam interfejs na wwan0 i wszystko działa, to samo masz na mr 3420  zwykły obraz zmiana interfejsu i tyle, mi fi nawet nie wie że mu coś wetknięto

12 (edytowany przez Cezary 2018-03-07 13:55:33)

Odp: 5372 nie działa z mifi

Mifi rozpoznaje typ połączenia na podstawie sterowników które obsługują modem. Jeżeli załadowały sie option/huawei_cdc_ncm to uważa że jest to ncm właśnie.

Masz dwr-116 z działającym modemem, tak? Zrestartuj go i pokaż mi jeszcze raz wyniki:
uci show network
ifconfig
logread

Po restarcie bo chcę zobaczyć proces wykrywania interfejsów i nie chcę żeby było za dużo śmieci w logach.

EDIT: na forum jest kilka wątków o 5372. np ten: http://eko.one.pl/forum/viewtopic.php?id=9228
ncm, po podłączeniu dostał na wanie 192.168.8.101, ponoć działał. Są też inne wątki w których ludzie piszą o ustawieniu dhcp na wwan0 i tyle.  Ustaw ten ncm, niech się podłączy i zobaczysz.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

13 (edytowany przez chauwa 2018-03-09 16:11:57)

Odp: 5372 nie działa z mifi

To teraz bez znaczenia na zwykłym Twoim obrazie router sie zacina ten który mam od królika działa ale nie ma gui, od wczoraj dwa razy. Jedyna opcja wyłączyć i włączyć.

więc logów nie ma bo zwis konski ostry


Chcesz to daj adres na pm to Ci go wysle, mi sie bawić z złomem nie chce wink   nie mam na to czasu a komus się może przyda.


Po zabawie oddasz komuś charytatywnie z gratis wysyłką tak jak ja Tobie wyslę.

Ma tylko urwaną jedna antene wi-fi,   oddam w takim stanie jak dostałam, przeleżał ponad rok w rupieciach.

14

Odp: 5372 nie działa z mifi

Chcę. Z chęcią zobaczę o co z nim chodzi.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

15

Odp: 5372 nie działa z mifi

Jak chcesz dorzuce banana m3, też leżała w szufladzie  pózniej na paprapecie woda ją zalał z doniczki ale nie była podłączana. po wyschnięciu nie startuje.


To trudny przypadek bo nie startowała wczesniej bo był problem z kartą i obrazem

16

Odp: 5372 nie działa z mifi

Dorzuć, pobawię się.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

17 (edytowany przez chauwa 2018-03-09 16:21:05)

Odp: 5372 nie działa z mifi

banana może być sprawna, to nie raspberry pi gdzie wgrasz obraz na karte i startuje, to coś dla Ciebie wink

używana była 2 dni big_smile zakupiona 2 lata temu