151

Odp: Weekend z Xiaomi Mi Router 3G

Ja mam tą małą śmieszną antenę i mam ją dlatego że nie mogłem za bardzo sobie dużej zapodać, ta jest mała robi swoje z 70-80% mam 100% sygnału i zamontowałem ją na zewnątrz na wieszaku/uchwycie do głośników. Miałem gdzieś swoje zdjęcia ale musiałbym poszukać.. tak to zapodaję link do filmiku na YT

https://www.youtube.com/watch?v=a--gS9uFf88

.

Linksys WRT1200AC & WRT002ANT-EU + HUAWEI e3276s-150 + 128GB SanDisk :: OpenWrt 18.06
NEXX WT3020F (16M) | Xiaomi 3G + HUAWEI e3373h :: Padavan / OpenWrt 18.06

152

Odp: Weekend z Xiaomi Mi Router 3G

mar_w napisał/a:

@george2002
Mając 135Mbps na e3372 uważam że kupno anteny to zbędny wydatek.
Lepiej pożycz sobie modem z agregacja pasm i jak wyjdzie 200 Mbps to kup ten lepszy modem, zamiast patelni za oknem.

Hmm dzięki za info a jakiś konkretny model modemu ? bo szukałem ale coś powyżej 150Mbit/50Mbit DOWN/UP nie mogę znaleźć, oczywiście na USB tylko wchodzi w rachubę;)

153

Odp: Weekend z Xiaomi Mi Router 3G

IceG napisał/a:

Ja mam tą małą śmieszną antenę i mam ją dlatego że nie mogłem za bardzo sobie dużej zapodać, ta jest mała robi swoje z 70-80% mam 100% sygnału i zamontowałem ją na zewnątrz na wieszaku/uchwycie do głośników. Miałem gdzieś swoje zdjęcia ale musiałbym poszukać.. tak to zapodaję link do filmiku na YT

https://www.youtube.com/watch?v=a--gS9uFf88

.

Hmm czyli jak rozumiem jest jakaś szansa że nie będzie gorzej tylko lepiej smile ? prędkość już pal licho bo jest lepsza niż niektóre kablówki w standardzie a do tego za 5zł miesięcznie w redbull mobile mnie wychodzi ten internet ale pingi chciałbym lepsze osiągać bo nie ukrywam że grywam co nieco a wiadomo jak lag to ... lag big_smile no i tylko pytanie czy antena antenie równa, możesz jakiegoś linka gdzie kupiłeś i za ile zapodać wink ?

154 (edytowany przez sty 2017-10-26 19:07:25)

Odp: Weekend z Xiaomi Mi Router 3G

hehe - @george2002 - antena antenie nie jest równa a już zdecydowanie nie w tanich, chińskich konstrukcjach. Nie twierdzę, że chińskie są złe (sam używam kilku do np. wifi...oczywiście po drobnych przeróbkach)  ale trzeba utrafić określony model i egzemplarz aby Ci spasował. Zazwyczaj w środku nigdy nie ma tego co obiecuje sprzedawca (w sensie nie takie parametry, itd.) - u chinoli to często norma (z przeróżnych powodów). Tak na prawdę dobra antena wymaga zaprojektowania jej (i najlepiej wykonania jej osobiście) indywidualnie w danych warunkach lokalnych (dopasowanie do danego terenu, sprzętu - czasem nawet do danego egzemplarza urządzenia z seri, itd.).
Tak ogólnie to dobra i wydajna antena czy do LTE, czy do WIFI, to prawdziwa kwadratura koła.

155

Odp: Weekend z Xiaomi Mi Router 3G

george2002 napisał/a:
mar_w napisał/a:

@george2002
Mając 135Mbps na e3372 uważam że kupno anteny to zbędny wydatek.
Lepiej pożycz sobie modem z agregacja pasm i jak wyjdzie 200 Mbps to kup ten lepszy modem, zamiast patelni za oknem.

Hmm dzięki za info a jakiś konkretny model modemu ? bo szukałem ale coś powyżej 150Mbit/50Mbit DOWN/UP nie mogę znaleźć, oczywiście na USB tylko wchodzi w rachubę;)

Dobra, ostatni post bo rozmywamy temat.
Pożycz Huawei E5786 (tego nie testowałem) lub Netgear 810s (kmod-usb-net-rndis) ale to nie jest pewne, że Ci skoczy DOWN ponad 150Mbps, ponieważ druga częstotliwość to tylko jako pomoc np. przy słabym transferze i może być tak, że ustawione mają na jednego klienta (SIM) max 140Mbps i nawet jak zagregujesz drugie pasmo to nie koniecznie będzie to suma arytmetyczna np (135 + 135 = 270Mbps) Słowo klucz: POŻYCZ bo to trochę droga zabawka, jak na takie (za przeproszeniem) małe g..no.

* WR1043v1 16MB@64MB * || * WT3020-16MB * || * Xiaomi Miwifi Mini *
* E3276 HiLink + RTL2832 + IT9135 + Siano + EC103 *

156

Odp: Weekend z Xiaomi Mi Router 3G

mar_w napisał/a:
george2002 napisał/a:
mar_w napisał/a:

@george2002
Mając 135Mbps na e3372 uważam że kupno anteny to zbędny wydatek.
Lepiej pożycz sobie modem z agregacja pasm i jak wyjdzie 200 Mbps to kup ten lepszy modem, zamiast patelni za oknem.

Hmm dzięki za info a jakiś konkretny model modemu ? bo szukałem ale coś powyżej 150Mbit/50Mbit DOWN/UP nie mogę znaleźć, oczywiście na USB tylko wchodzi w rachubę;)

Dobra, ostatni post bo rozmywamy temat.
Pożycz Huawei E5786 (tego nie testowałem) lub Netgear 810s (kmod-usb-net-rndis) ale to nie jest pewne, że Ci skoczy DOWN ponad 150Mbps, ponieważ druga częstotliwość to tylko jako pomoc np. przy słabym transferze i może być tak, że ustawione mają na jednego klienta (SIM) max 140Mbps i nawet jak zagregujesz drugie pasmo to nie koniecznie będzie to suma arytmetyczna np (135 + 135 = 270Mbps) Słowo klucz: POŻYCZ bo to trochę droga zabawka, jak na takie (za przeproszeniem) małe g..no.

Ani jedno ani drugie to nie modem na USB wink poza tym nie mam skąd pożyczyć big_smile

157

Odp: Weekend z Xiaomi Mi Router 3G

Zachęcony wątkiem zamówiłem sobie też ten router, wczoraj przyszedł. Flashowanie przeszło gładko, ale mam problem z modemem, może pomożecie...

Mój ZTE MF823 (hilink/hostless) rezerwuje dla siebie adres 192.168.0.1. Na starym routerze z Gargoyle modem też miał ten adres ale router  przydzielał klientom adresy 192.168.1.* W przypadku LEDE i tego Xiaomi po połączeniu klienta do routera mam internet, ale wygląda na to, że modem przejmuje funkcje serwera DHCP i przydziela mi adresy z puli 192.168.0.* przez co kompletnie nie mam dostępu do routera (192.168.1.1). W jaki sposób skonfigurować router aby przydzielał on samodzielnie klientom adresy IP a modem wykorzystywał tylko jako kartę sieciową? Definicję wan'a w /etc/config/network skopiowałem z Gargoyle, ale tutaj działa ona z jakiegoś powodu inaczej:

config interface 'wan'
        option auto '1'
        option proto 'dhcp'
        option ifname 'usb0'
        option macaddr '21:33:77:77:19:74'
        option type 'bridge'

Z góry dzięki za pomoc i porady,

158

Odp: Weekend z Xiaomi Mi Router 3G

@tuvok:

Cezary napisał/a:

(...)
Obsługa modemów "hostless"
Dotyczy nowych modemów LTE np. ZTE MF823, niektórych modeli telefonów komórkowych


    # opkg install kmod-usb-net-rndis
    # uci del network.wan
    # uci set network.wan=interface
    # uci set network.wan.proto=dhcp
    # uci set network.wan.ifname=usb0
    # uci commit network
    # reboot

Czyli sekcja wan powinna wyglądać następująco:


    config 'interface' 'wan'
        option 'proto' 'dhcp'
        option 'ifname' 'usb0'

Gdzie usb0 to dodatkowy interfejs utworzony przez sterownik (może być różny w zależności od routera i ilości modemów). APN i pin ustawia się w gui modemu. Może być wymagana zmiana adresu IP LAN routera.
(...)

https://eko.one.pl/?p=openwrt-3g

159

Odp: Weekend z Xiaomi Mi Router 3G

@sty
Robiłem właśnie wg tego poradnika i wszystko działało poza tym, że modem przejmował funkcje serwera DHCP
Finalnie zwalczyłem problem - prawdopodobnie pozostałe wpisy w /etc/config/network były z jakiegoś powodu niepoprawne, np.

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 6t'

zmieniłem to na podobieństwo tego co miałem w Gargoyle czyli wszystkie 'eth0.1' i 'switch0' zastąpiłem 'eth0':

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config switch
        option name 'eth0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'eth0'
        option vlan '1'
        option ports '2 3 6t'

Dodatkowo wyciąłem ostatnią pozycję z definicji interfejsu 'wan', którą wklejałem w poście wyżej czyli

        option type 'bridge'

Teraz wszystko ładnie i szybko hula. Jak za cenę 140zł, którą zapłaciłem to router absolutnie bezkonkurencyjny

160

Odp: Weekend z Xiaomi Mi Router 3G

Właśnie w powody tego bridge to się działo.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

161

Odp: Weekend z Xiaomi Mi Router 3G

@Cezary
OK, dobrze wiedzeić na przyszłość smile
Szczerze mówiąc w interfejscie Luci po doświadczeniach z Gargoyle czuję się nieco zagubiony. Czekam czekam z niecierpliwością kiedy zaczną Gargoyle na LEDE budować, póki co temat jakby umarł:
https://github.com/ericpaulbishop/gargoyle/issues/633

162 (edytowany przez sty 2017-10-28 13:42:24)

Odp: Weekend z Xiaomi Mi Router 3G

@tuvok - po to są właśnie poradniki od Cezarego aby...się odnaleźć. LEDE to nie Gargoyle i vice versa. Wiele opcji się różni chociaż dotyczy tego samego (itd.,itp.).
Wracając do wcześniej zacytowanego przeze mnie fragmentu poradnika Cezarego - wyraźnie tam widać, że nie ma opcji "bridge". Na przyszłość nie kopiuj na pałę tylko wszystko od A do Z na nowo ustawić i czytać ze zrozumieniem (tak jest najlepiej przy pierwszej instalacji bez zachowania ustawień - z Gargoyle na LEDE, czy odwrotnie lub ogólnie z czegokolwiek na cokolwiek o ile się da bez np. portu szeregowego, jtag, uboot, tftp, factory itd.).
Co do słuszności eth0 lub eth0.1 to zależy konkretnie od danego urządzenia - po pierwszej instalacji/aktualizacji bez zachowania ustawień widać to wyraźnie w defaultowym /etc/config/network jak obraz na dane urządzenie w ogóle istnieje chociażby w sekcji master github dla LEDE. Jak to jest amatorska samoróba i ktoś sam portował dany sprzęt to trzymasz się konwencji/logiki nazewnictwa jakiej użył autor - wszystko jest względne.

163

Odp: Weekend z Xiaomi Mi Router 3G

Cezary napisał/a:

A jednak...

Sat Oct  7 17:48:29 2017 kern.info kernel: [72943.862571] Data buffer not 16 bytes aligned: 8e674078

U mnie ten komunikat występuje prawie zawsze jak coś instaluję/usuwam przez opkg. Jeśli dobrze interpretuję źródła, to jest tylko informacja, że bufor z danymi do zapisania nie był wyrównany do 16 bajtów (pewnie jakieś wymaganie NAND'a) i został wyrównany. Reasumując - nie ma się czego obawiać.

Qui vit sans folie, n'est pas si sage qu'on croit

164

Odp: Weekend z Xiaomi Mi Router 3G

sty napisał/a:

(...)
Tak ogólnie to dobra i wydajna antena czy do LTE, czy do WIFI, to prawdziwa kwadratura koła.

Nie mu tutaj żadnej magi. Konstrukcja anteny mikrofalowej wymaga po prostu precyzji przy montażu i zachowania parametrów użytych materiałów (zwłaszcza panelowe na laminacie mikrofalowym, który jest drogi i kusi by zakombinować). Bez problemu kupisz dobrą antenę o znanych i opisanych parametrach np. w dipolu, ale będzie droższa. Wiem co mówie bo to jakby moja działka i kilka anten zaprojektowałem w swoim czasie. Choć to już daaawno było wink

165

Odp: Weekend z Xiaomi Mi Router 3G

c#Hunter napisał/a:
sty napisał/a:

(...)
Tak ogólnie to dobra i wydajna antena czy do LTE, czy do WIFI, to prawdziwa kwadratura koła.

Nie mu tutaj żadnej magi. Konstrukcja anteny mikrofalowej wymaga po prostu precyzji przy montażu i zachowania parametrów użytych materiałów (zwłaszcza panelowe na laminacie mikrofalowym, który jest drogi i kusi by zakombinować). Bez problemu kupisz dobrą antenę o znanych i opisanych parametrach np. w dipolu, ale będzie droższa. Wiem co mówie bo to jakby moja działka i kilka anten zaprojektowałem w swoim czasie. Choć to już daaawno było wink

Nie twierdzę, że to jest magia, ale chyba sam przyznasz, że do łatwych zadań to nie należy, szczególnie jak w warunkach amatorskich taką antenę po prostu trzeba zrobić żeby nie bulić jak za zboże za te tzw. "profesjonalne" lub dopasować daną antenę rozmiarami do tego co w danych warunkach można zrobić/zainstalować lub dopasować do terenu, itd. - co można oczywiście uzyskać ciężkim znojem w oparciu np. o wieloletni bagaż doświadczeń i umiejętności na tym polu. No i biorąc to wszystko razem do kupy robi się z tego prawdziwa "kwadratura koła". wink

166

Odp: Weekend z Xiaomi Mi Router 3G

Cześć,
czy ktoś z użytkowników korzysta z powodzeniem z freeradius na tym routerze? Wiem, że to wersja rozwojowa LEDE, ale może?
Po dodaniu dodatkowych repozytoriów udało się zainstalować wszystkie pakiety do freeradius2 (wg. poradnika Cezarego, ale ten odnosi się do OpenWrt). Niestety daemon hostapd "gryzie" się z serwerem accounting na porcie 1813 - Connection refused oraz inne błędy. Po wielu kombinacjach smartfon z androidem jakoś połączył się z siecią poprzez logowanie 802.1x, ale w logu nadal siało błędami. Ostatecznie usunąłem wszystko związane z freeradius2 (tylko wpad został) i wróciłem do WPA2-PSK (nie zachowały się żadne logi, więc w tej kwestii niczego nie zaprezentuję).

167

Odp: Weekend z Xiaomi Mi Router 3G

george2002 napisał/a:
pepe2k napisał/a:

Więcej zdjęć:

Dzięki za dobre zdjęcia smile ktoś wie co to w końcu za złącza J10 i J11 bo widzę że gdzieś tam są podpięte bo ścieżki idą smile ?

Na forum lede jest: https://forum.lede-project.org/t/xiaomi … g/5377/189

– J10 and J11 jumpers need to be closed to enable and select the SPI flash as boot source

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

168

Odp: Weekend z Xiaomi Mi Router 3G

Aby wgrać LEDE korzystać z tego poradnika ?

https://forum.lede-project.org/t/xiaomi … er-3g/5377

Czy macie może inny poradnik ?

169

Odp: Weekend z Xiaomi Mi Router 3G

Ten jest dobry i działa.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

170

Odp: Weekend z Xiaomi Mi Router 3G

Dzięki działa smile

171

Odp: Weekend z Xiaomi Mi Router 3G

Zbliża się za kilka dni miesiąc od rzekomego wysłania routera z https://www.gearbest.com/ w promowanym na początku tematu linku i...cisza...śledzenie nie działa od początku - ogólnie cienko to widzę, hehe.
big_smile

172 (edytowany przez jacgl 2017-11-06 22:56:38)

Odp: Weekend z Xiaomi Mi Router 3G

Doszedł jakiś tydz. temu. Zamówiony 12/10, też przesyłka nierejestrowana. Dostarcza Poczta Polska, czyli odbiór w okienku przesyłki zwykłej ponadgabarytowej.
Pozdr

173 (edytowany przez george2002 2017-11-06 23:43:13)

Odp: Weekend z Xiaomi Mi Router 3G

sty napisał/a:

Zbliża się za kilka dni miesiąc od rzekomego wysłania routera z https://www.gearbest.com/ w promowanym na początku tematu linku i...cisza...śledzenie nie działa od początku - ogólnie cienko to widzę, hehe.
big_smile

Spokojnie, mój też szedł ok miesiąc ale w końcu doszedł a na oceanach/morzach jeszcze sztormów dużych nie ma także tratwa z routerkiem na pewno płynie big_smile
Profilaktycznie też możesz jak ja zapytać przez gearbest jaki jest status i gdzie się znajduje paczka smile
PS
Zdarza się u Mnie niestety to rozłączanie WiFi tzn np wracam do domu, IPhone 7 niby pisze że połączony a brak neta, muszę rozłączać i polanczac ponownie, to samo na laptopie Żony tez już z dwa razy się tak działo że niby połączenie jest a internetu brak hmmm smile

174

Odp: Weekend z Xiaomi Mi Router 3G

Mam pewien problem ze stabilnością tego routera albo oprogramowania. Bardzo często (kilka razy dziennie) urządzenia są wypinane z sieci, albo raportują dostęp do sieci, ale nie da się spingować routera (ani nic innego). Albo mój sprzęt jest walnięty albo to wina oprogramowania - ktoś zauważył coś podobnego u siebie?
Wcześniej używałem poprzedniej wersji tego routera - Xiaomi Router 3 (bez G) na oryginalnym oprogramowaniu od Xiaomi i wszystko działało bardzo stabilnie. Teraz niestety nie jest tak fajnie a reboot'a dodałem już do cron'a (raz dziennie) ale i to nie rozwiązało problemu. Być może ok. 20 urządzeń podłączonych do sieci to za dużo dla niego?

175

Odp: Weekend z Xiaomi Mi Router 3G

Wróć do oryginału będziesz wiedział czy to sprzęt czy soft.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.