51

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

a podpowiesz jak z to zaaplikować?
coś mi nie idzie sad

52

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

To co jest w katalogach ma się znaleźć w tych samych katalogach w źródłach. Po prostu skopiuj. A łatka:

patch -p1 < tocośmojego.patch

będąc w katalogu ze źródłami

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

53 (edytowany przez r43k3n 2017-09-22 17:43:22)

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

Ja zauważyłem dość znaczący problem z SFE w połączeniu z SQM.
Niestety SQM w tym tandemie działa bardzo ułomnie. Funkcje cake takie jak nat oraz dual-dsthost / dual-srchost w ogóle nie działają. Samo SQM również nie pracuje w 100% poprawnie. U mnie generowało to bardzo duże problemy z odpowiednim dzieleniem łącza. Dodatkowo opóźnienia i bufferbloat znacząco wzrastały.

Dlatego, jeżeli ktoś chce wykorzystać SQM z SFE to mocno odradzam.

54

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

Znalazłem właśnie jakiś router, na którym mogłem się bawić i zamieszczam wyniki:

Testy prędkości na FTP
Oprogramowanie Klienta: FileZilla 3.27.1
Router Tplink TL-WDR3600 ver 1.1:
Plik 4 684 199 670

Bez NAT:
Transfer plików zakończony pomyślnie, przeniesione 4 684 199 670 bajtów w 41 sekund ~ 110 MiB/s

NAT
Gargoyle 1.9.2.3 (r49483) by obsy
Prędkość przesyłania FTP:
Transfer plików zakończony pomyślnie, przeniesione 4 684 199 670 bajtów w 213 sekund ~21MiB/s


LEDE- luci r3514-97ebdf9

Transfer plików zakończony pomyślnie, przeniesione 4 684 199 670 bajtów w 120 sekund ~37 MiB/s


LEDE- luci r3514-97ebdf9 + kmod-fast-classifier kmod-shortcut-fe

Transfer plików zakończony pomyślnie, przeniesione 4 684 199 670 bajtów w 40 sekund ~109,5 MiB/s


Rewelacja!
Dziękuję za paczkę. Za kilka tygodni postaram się zrobić upgrade na moim TP-Link Archer C7 v2.

Pozdrawiam.
:-)

55

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

Mam problem z instalacją pakietów na TP-Link TL-WR1043N/ND v3.
root@LEDE:~# opkg install kmod-fast-classifier kmod-shortcut-fe
Installing kmod-fast-classifier (4.4.87-1) to root...
Downloading http://dl.eko.one.pl/lede/17.01-SNAPSHO … s_24kc.ipk
Package kmod-shortcut-fe (4.4.87-1) installed in root is up to date.
Collected errors:
* pkg_get_installed_files: Failed to open //usr/lib/opkg/info/kmod-ipt-conntrack-extra.list: No such file or directory.
* pkg_get_installed_files: Failed to open //usr/lib/opkg/info/tc.list: No such file or directory.
* pkg_get_installed_files: Failed to open //usr/lib/opkg/info/iptables-mod-ipopt.list: No such file or directory.
* pkg_get_installed_files: Failed to open //usr/lib/opkg/info/luci-app-sqm.list: No such file or directory.
* pkg_get_installed_files: Failed to open //usr/lib/opkg/info/sqm-scripts.list: No such file or directory.
* pkg_get_installed_files: Failed to open //usr/lib/opkg/info/iptables-mod-conntrack-extra.list: No such file or directory.
* pkg_get_installed_files: Failed to open //usr/lib/opkg/info/kmod-ipt-ipopt.list: No such file or directory.
* pkg_get_installed_files: Failed to open //usr/lib/opkg/info/kmod-sched-cake.list: No such file or directory.
* pkg_get_installed_files: Failed to open //usr/lib/opkg/info/kmod-ifb.list: No such file or directory.
* pkg_get_installed_files: Failed to open //usr/lib/opkg/info/kmod-sched-core.list: No such file or directory.
* satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-fast-classifier:
*      kernel (= 4.4.87-1-80ae4c5257a87565b3459e611cc501a2) *
* opkg_install_cmd: Cannot install package kmod-fast-classifier.

56

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

Przeinstaluj pakiety które zgłaszają błędy, bo chyba coś na extroocie Ci poleciało.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

57

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

Nie mam extroota, ale tez nic nie idzie przeinstalować.
Aktualizowałem LEDE z zachowaniem ustawień i pewnie trzeba będzię przywrócić wszystko do domyślnych.

58

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

Więc tak, zrób fistboota i nie przywracaj ustawień.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

59 (edytowany przez solargrim 2017-09-26 06:22:29)

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

Cezary, czy te pakiety dostepne sa dla LEDE Reboot 17.01-SNAPSHOT r3491-889638c?
kmod-fast-classifier
kmod-shortcut-fe

60

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

W pierwszym poście masz od której wersji są dostępne.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

61

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

Zrobiłem firstboota, zainstalowałem kmod-fast-classifier kmod-shortcut-fe i przywróciłem ustawienia i wszystko działa(moduły są faktycznie załadowane).

62

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

Czyli nie sa dostepne. sad

63

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

Na lede z luci, SFE, 1043nd wyszły mi transfery podobne do gołego lede bez SFE ( ok. 230Mb na orange światłowód 300Mb ). Czy to możliwe że luci spowalnia, tak jak gargoyle?
Czy na tp-4300 jest szansa że będzie lepiej?

64

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

Załadowały się w ogóle moduły? Co masz zainstalowane jeszcze na routerze?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

65

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

Tak, lsmod i logread dały takie same wyniki jak te z pierwszego posta. Przed instalacją SFE było ok. 180Mb. Ten tplink ma wan wpięty do lan funboxa jeśli to ma znaczenie.

66

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

obraz kompilowany samodzielnie
wykonałem pomiary  używając 2 laptopy na wzór testu Cezarego
Model    ZyXEL P-2812HNU-F3
Wersja firmware    LEDE Reboot SNAPSHOT r4852-692aa82 / LuCI Master (git-17.260.43176-678c15c)
Wersja jądra    4.9.49
podłaczenie 2 laptopy do lan  192.168.2.100  oraz  192.168.2.120

adam@Z51 ~ $ iperf3 -c 192.168.2.120
Connecting to host 192.168.2.120, port 5201
[  4] local 192.168.2.100 port 43406 connected to 192.168.2.120 port 5201
[ ID] Interval           Transfer     Bandwidth       Retr  Cwnd
[  4]   0.00-1.00   sec   112 MBytes   938 Mbits/sec    0    113 KBytes       
[  4]   1.00-2.00   sec   112 MBytes   938 Mbits/sec    0    140 KBytes       
[  4]   2.00-3.00   sec   112 MBytes   941 Mbits/sec    0    175 KBytes       
[  4]   3.00-4.00   sec   112 MBytes   941 Mbits/sec    0    212 KBytes       
[  4]   4.00-5.00   sec   112 MBytes   941 Mbits/sec    0    212 KBytes       
[  4]   5.00-6.00   sec   112 MBytes   941 Mbits/sec    0    212 KBytes       
[  4]   6.00-7.00   sec   112 MBytes   941 Mbits/sec    0    212 KBytes       
[  4]   7.00-8.00   sec   112 MBytes   941 Mbits/sec    0    212 KBytes       
[  4]   8.00-9.00   sec   112 MBytes   941 Mbits/sec    0    212 KBytes       
[  4]   9.00-10.00  sec   112 MBytes   941 Mbits/sec    0    212 KBytes       
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth       Retr
[  4]   0.00-10.00  sec  1.09 GBytes   940 Mbits/sec    0             sender
[  4]   0.00-10.00  sec  1.09 GBytes   940 Mbits/sec                  receiver

przed załadowaniem modułów   laptop1 do wan 192.168.2.100
                             laptop2 do lan 192.168.1.120

C:\Users\adam\Desktop\iperf-3\iperf-3.1.3-win64>iperf3 -c 192.168.1.120
Connecting to host 192.168.1.120, port 5201
[  4] local 192.168.2.100 port 49701 connected to 192.168.1.120 port 5201
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-1.00   sec  19.5 MBytes   163 Mbits/sec
[  4]   1.00-2.01   sec  19.0 MBytes   159 Mbits/sec
[  4]   2.01-3.00   sec  19.0 MBytes   160 Mbits/sec
[  4]   3.00-4.00   sec  19.4 MBytes   163 Mbits/sec
[  4]   4.00-5.00   sec  19.2 MBytes   162 Mbits/sec
[  4]   5.00-6.00   sec  19.0 MBytes   159 Mbits/sec
[  4]   6.00-7.00   sec  18.9 MBytes   158 Mbits/sec
[  4]   7.00-8.00   sec  18.4 MBytes   154 Mbits/sec
[  4]   8.00-9.00   sec  18.9 MBytes   159 Mbits/sec
[  4]   9.00-10.00  sec  19.0 MBytes   159 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-10.00  sec   190 MBytes   160 Mbits/sec                  sender
[  4]   0.00-10.00  sec   190 MBytes   159 Mbits/sec                  receiver

po załadowaniu modułów  laptop1 do wan 192.168.2.100
                        laptop2 do lan 192.168.1.120

root@LEDE:/tmp#  lsmod | grep short
shortcut_fe            50489  1 fast_classifier
shortcut_fe_ipv6       51513  1 fast_classifier
C:\Users\adam\Desktop\iperf-3\iperf-3.1.3-win64>iperf3 -c 192.168.1.120
Connecting to host 192.168.1.120, port 5201
[  4] local 192.168.2.100 port 49778 connected to 192.168.1.120 port 5201
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-1.00   sec  16.5 MBytes   138 Mbits/sec
[  4]   1.00-2.00   sec  17.6 MBytes   148 Mbits/sec
[  4]   2.00-3.00   sec  19.5 MBytes   164 Mbits/sec
[  4]   3.00-4.00   sec  19.5 MBytes   164 Mbits/sec
[  4]   4.00-5.00   sec  19.6 MBytes   165 Mbits/sec
[  4]   5.00-6.00   sec  17.0 MBytes   142 Mbits/sec
[  4]   6.00-7.00   sec  17.4 MBytes   146 Mbits/sec
[  4]   7.00-8.00   sec  19.6 MBytes   165 Mbits/sec
[  4]   8.00-9.00   sec  19.5 MBytes   164 Mbits/sec
[  4]   9.00-10.00  sec  13.6 MBytes   114 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-10.00  sec   180 MBytes   151 Mbits/sec                  sender
[  4]   0.00-10.00  sec   180 MBytes   151 Mbits/sec                  receiver

oraz pomiar na linuxie 

adam@Z51 ~ $ iperf3 -c 192.168.1.120
Connecting to host 192.168.1.120, port 5201
[  4] local 192.168.2.100 port 36098 connected to 192.168.1.120 port 5201
[ ID] Interval           Transfer     Bandwidth       Retr  Cwnd
[  4]   0.00-1.00   sec  19.3 MBytes   162 Mbits/sec    0    218 KBytes       
[  4]   1.00-2.00   sec  18.9 MBytes   159 Mbits/sec    0    218 KBytes       
[  4]   2.00-3.00   sec  18.9 MBytes   159 Mbits/sec    0    218 KBytes       
[  4]   3.00-4.00   sec  19.0 MBytes   159 Mbits/sec    0    218 KBytes       
[  4]   4.00-5.00   sec  19.0 MBytes   159 Mbits/sec    0    218 KBytes       
[  4]   5.00-6.00   sec  19.0 MBytes   160 Mbits/sec    0    218 KBytes       
[  4]   6.00-7.00   sec  19.1 MBytes   160 Mbits/sec    0    218 KBytes       
[  4]   7.00-8.00   sec  19.1 MBytes   160 Mbits/sec    0    218 KBytes       
[  4]   8.00-9.00   sec  19.1 MBytes   160 Mbits/sec    0    218 KBytes       
[  4]   9.00-10.00  sec  19.0 MBytes   160 Mbits/sec    0    218 KBytes       
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth       Retr
[  4]   0.00-10.00  sec   190 MBytes   160 Mbits/sec    0             sender
[  4]   0.00-10.00  sec   190 MBytes   159 Mbits/sec                  receiver

w przypadku  tego routera  nie  widać  wzrostu  ani  spadku
test przeprowadzałem  kilkanascie razy  i zawsze  wyniki były  zblizone  - zawsze sprawdzałem czy moduły są załadowane

67 (edytowany przez spamsool 2017-10-01 19:18:54)

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

ad2014 napisał/a:

obraz kompilowany samodzielnie
wykonałem pomiary  używając 2 laptopy na wzór testu Cezarego
Model    ZyXEL P-2812HNU-F3

w przypadku  tego routera  nie  widać  wzrostu  ani  spadku
test przeprowadzałem  kilkanascie razy  i zawsze  wyniki były  zblizone  - zawsze sprawdzałem czy moduły są załadowane

A pokaż, co pokazuje polecenie:

cat /sys/fast_classifier/debug_info

Sprawdź głównie 1 linijkę coś w stylu:

size=84 offload=0 offload_no_match=0 offloaded=9056 done=9052 offl_dbg_msg_fail=9056 done_dbg_msg_fail=9052

Zapisz wartości, nastepnie zrób test i zobacz czy wartości offloaded, offl_dbg_msg_fail oraz done_dbg_msg_fail wzrosły po wykonaniu testu? Bo jeśli wzrosły, to znaczy że moduły działają. Nie przejmuj się słowem fail, w tym konkretnym przypadku to właśnie oznacza że fastpath działa poprawnie.

68

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

tak na szybko   

root@LEDE:~#  lsmod | grep short
shortcut_fe            50489  1 fast_classifier
shortcut_fe_ipv6       51513  1 fast_classifier
root@LEDE:~# dmesg                    # fragment  
[   15.300657] fast-classifier: starting up
[   15.303561] fast-classifier: registered
root@LEDE:~# logread | grep fast
Tue Sep 26 23:20:48 2017 kern.notice kernel: [    0.499546] random: fast init done
Tue Sep 26 23:20:49 2017 kern.alert kernel: [   15.300657] fast-classifier: starting up
Tue Sep 26 23:20:49 2017 kern.alert kernel: [   15.303561] fast-classifier: registered

ale  tu mam same zera

root@LEDE:~# cat /sys/fast_classifier/debug_info
size=0 offload=0 offload_no_match=0 offloaded=0 done=0 offl_dbg_msg_fail=0 done_dbg_msg_fail=0

później  sprawdze czy  wartosci  się zmienią  po wykonaniu testu

69

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

ad2014 napisał/a:

ale  tu mam same zera

root@LEDE:~# cat /sys/fast_classifier/debug_info
size=0 offload=0 offload_no_match=0 offloaded=0 done=0 offl_dbg_msg_fail=0 done_dbg_msg_fail=0

później  sprawdze czy  wartosci  się zmienią  po wykonaniu testu

Jak nie masz czasu na iperf3, to możesz nawet na szybko wykonać test szybkości łącza na speedtest.net i sprawdzić czy wzrośnie, u mnie wtedy wartości z debug_info wzrastają.

70

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

po speedtest 

root@LEDE:~# cat /sys/fast_classifier/debug_info
size=15 offload=0 offload_no_match=0 offloaded=15 done=9 offl_dbg_msg_fail=15 done_dbg_msg_fail=9

2 test 
size=232 offload=0 offload_no_match=0 offloaded=32 done=14 offl_dbg_msg_fail=32 done_dbg_msg_fail=14

3test 
size=295 offload=0 offload_no_match=0 offloaded=43 done=22 offl_dbg_msg_fail=43 done_dbg_msg_fail=22

71

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

w wersji  rozwojowej Lede   ( SNAPSHOT r5218-f90f94d )  zauważyłem  że  pojawił się  trzeci  pakiet do fastpatch  - skompilowaem to  jak M

adam@Z51 ~/lede/bin/targets/lantiq/xrx200/packages $ ls | grep shortcut
kmod-shortcut-fe_4.9.58-1_mips_24kc.ipk
kmod-shortcut-fe-cm_4.9.58-1_mips_24kc.ipk
adam@Z51 ~/lede/bin/targets/lantiq/xrx200/packages $ ls | grep fast
kmod-fast-classifier_4.9.58-1_mips_24kc.ipk

pytanie  czym  jest ten trzeci   kmod-shortcut-fe-cm

72

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

On zawsze był, u mnie też jest. Przeczytaj wątek na forum lede, tam wyjaśniają dlaczego są trzy.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

73

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

Czy da sie bez dodatkowych modyfikacji dograc i załadować 2 moduly fast path z buildu Cezarego do oficialnego buildu Lede? Chcialbym dograć je do Cisco Meraki mr12 i mr18 a Cezary nie udostępnia u siebie obrazów na te 2 modele Cisco Meraki

74

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

spamsool napisał/a:

Czy da sie bez dodatkowych modyfikacji dograc i załadować 2 moduly fast path z buildu Cezarego do oficialnego buildu Lede? Chcialbym dograć je do Cisco Meraki mr12 i mr18 a Cezary nie udostępnia u siebie obrazów na te 2 modele Cisco Meraki

Nie.

Modyfikacja U-Boot dla routerów (gotowe obrazy)
Free Your Router, Again!

Podejmę się naprawy każdego routera, wymienię RAM i FLASH (32-128 MB już dostępne!) na większy

75

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

@spamsool: Jak nie udostępniam? W ogóle nie patrzyłeś.
MR18 jest tu: http://dl.eko.one.pl/lede/17.01-SNAPSHO … 71xx/nand/
MR12 jest tu: http://dl.eko.one.pl/lede/17.01-SNAPSHO … x/generic/

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.