1

(4 odpowiedzi, napisanych Oprogramowanie)

Cezary napisał/a:

To nie jest WDS tylko zwykły klient, więc będzie działało z każdym AP do którego możesz się połączyć.  Nic wspólnego z WDS to nie ma i nie ustawiaj nic specjalnie w mikrotiku, zrób go zwykłym AP.

okej, czyli zapominam o tej całej kombinatoryce, a jak ruszy, to poleci update.

dzięki jeszcze raz za ten poradnik, pozdrawiam!

2

(4 odpowiedzi, napisanych Oprogramowanie)

Cezary napisał/a:

Chcesz po polsku?  https://eko.one.pl/?p=openwrt-sta#mostbezprzewodowy

no i coś czułem, że to tutaj powinienem zadać pytanie, z ciekawości - jest duże prawdopodobieństwo, że to zadziała? (nawet specjalnie trzymam mikrotika na starym routeros, bo na nim lepiej ten wds działał (na ówczesnej, stabilnej wersji, soft tplinka nawet nie chciał zaskoczyć na chwilę jako `wds` do sieci wiifi mikrona bez hasłą))

w takim razie, pora na backup i zobaczymy, co uda mi się wykombinować

3

(4 odpowiedzi, napisanych Oprogramowanie)

Witam,

próbowałem zestawić RB962UiGS-5HacT2HnT z WR740N (na openwrt oraz oryginalnym sofcie), wedle 2 'schematu' (obecnie działa to jak w punkcie pierwszym).

Na stockowym sofcie tplinka były ogromnie problemy z wds - sieć z hasłem w ogóle nie pozwalała się podłączyć jako klient, natomiast sieć bez hasła bez problemu łączyła się z softem tplinka (a właściwie to na odwrót), ale jedynie na kilka sekund i połączenie zostało przerywane (i tak w kółko). Poświęciłem sporo czasu, i dowiedziałem się, że mikrotiki mają problemy same w sobie z wds a tp link nie jest kompatybilny, jeśli chodzi o charakterystyki połączenia (sposób szyfrowania bla bla, chodź przetestowałem to na x możliwych sposób).

I tutaj jest moje pytanie, bo nigdy nie ustawiałem openwrt w trybie emm 'ripitera'?
Jedyne co, to znalazłem taki poradnik, ale jedyne co zrobiłem dłuższy czas temu, to na czystym openwrt zainstalowałem ten pakiet i połączyłem się z wifi, ale jakoś tego internetu nie podawało dalej (a z racji, ograniczonego czasu, wróciłem do wersji pierwszej z obrazka).

Czy ktoś z was ma pomysł na zestawienie tego? Może istnieje inny pakiet albo poradnik? https://openwrt.org/docs/guide-user/net … figuration

Pozdrawiam!
schemat-test

4

(9 odpowiedzi, napisanych Notebooki)

Okej, będę kombinował - odnośnie tego mikrotika na vmce dałem mu 4 rdzenie, noo w sumie wedle wytycznych tego gościa - https://forum.mikrotik.com/viewtopic.php?t=150063 - i to dalej nie jest to, kurde, będę musiał kombinować, dzięki big_smile

5

(9 odpowiedzi, napisanych Notebooki)

Okej, a jeśli mam bez ustawionego routingu i odziwo pakiety się nie gubią to mogę tak zostawić, czy jednak lepiej wklepać?
Aktualnie mam odznaczone przy vpnie korzystanie z bramy domyślnej, żebym miał ten swój 'niepubliczny adres' od dostawcy za natem, a przez vpna lecą do mnie wszystkie zapytania, które przekierowuje portami lokalnie. Jeśli chodzi o vlany, to da się np. ustawić, aby podpinając się pod dany port w routerze, dostawało się tylko ten adres z vpna? (może inaczej, żeby ten vpn był tylko załączony dla danego portu, i w zasadzie cały ruch może być wydzielony, właśnie na dany port)

Okej, sprawdzę tą wydajność VM'ki - czyli jeśli rozchodzi się tu o wydajność, więcej na tym mikrotiku (750 GL) nie da rady wycisnąć?

Pozdrawiam!

6

(9 odpowiedzi, napisanych Notebooki)

dziwne, że nie chciało działać w bridge - wcześniej miałem WAN unmanagment i do tego robiłem kolejne interfejsy - w każdym razie mam wana (ustawionego z unmanagment na ppoe), 2 interfejs do zte oraz vpna.

aby nie tworzyć nowego wątku, zadam to pytanie tutaj - jak działa tworzenie trasy?
jeśli wybiorę np interfejs vpn i ustawie tam, że jeśli zapytanie będzie lecieć na sieć 188.88.88.0/24, to openwrt ma to pokierować do danej bramy np. 172.xx.xxx.xx (której szuka na danym interfejsie?)

i ostatnie pytanie - zrobiłem serwer vpn pptp / l2tp na mikrotiku, ale prędkość oscylowała w okolicach 1MB/s (kiedy mikrotik był na VM'ce) a fizycznie ok. 25Mb/s - wiesz może gdzie szukać przyczyny?

Pozdrawiam!

7

(9 odpowiedzi, napisanych Notebooki)

Firewall:
(z tego co widzę, to są tam dopisane 2 poprzednie interfejsy, które usunąłem z samego pliku interfaces, czyli syf niestety pozostał hmm)


config defaults
    option input 'ACCEPT'
    option output 'ACCEPT'
    option drop_invalid '1'
    option syn_flood '1'
    option forward 'REJECT'

config zone
    option name 'lan'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'ACCEPT'
    option network 'lan'

config zone
    option name 'wan'
    option output 'ACCEPT'
    option mtu_fix '1'
    option input 'ACCEPT'
    option masq '1'
    option forward 'REJECT'
    option network 'ZTE_LAN INTERSAT_NAT kurka VPN'

config forwarding
    option src 'lan'
    option dest 'wan'

config rule
    option name 'Allow-DHCP-Renew'
    option src 'wan'
    option proto 'udp'
    option dest_port '68'
    option target 'ACCEPT'
    option family 'ipv4'

config rule
    option name 'Allow-Ping'
    option src 'wan'
    option proto 'icmp'
    option icmp_type 'echo-request'
    option family 'ipv4'
    option target 'REJECT'

config rule
    option name 'Allow-IGMP'
    option src 'wan'
    option proto 'igmp'
    option family 'ipv4'
    option target 'ACCEPT'

config rule
    option name 'Allow-DHCPv6'
    option src 'wan'
    option proto 'udp'
    option src_ip 'fc00::/6'
    option dest_ip 'fc00::/6'
    option dest_port '546'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-MLD'
    option src 'wan'
    option proto 'icmp'
    option src_ip 'fe80::/10'
    list icmp_type '130/0'
    list icmp_type '131/0'
    list icmp_type '132/0'
    list icmp_type '143/0'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-ICMPv6-Input'
    option src 'wan'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    list icmp_type 'router-solicitation'
    list icmp_type 'neighbour-solicitation'
    list icmp_type 'router-advertisement'
    list icmp_type 'neighbour-advertisement'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-ICMPv6-Forward'
    option src 'wan'
    option dest '*'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-IPSec-ESP'
    option src 'wan'
    option dest 'lan'
    option proto 'esp'
    option target 'ACCEPT'

config rule
    option name 'Allow-ISAKMP'
    option src 'wan'
    option dest 'lan'
    option dest_port '500'
    option proto 'udp'
    option target 'ACCEPT'

config include
    option path '/etc/firewall.user'

config include 'miniupnpd'
    option type 'script'
    option path '/usr/share/miniupnpd/firewall.include'
    option family 'any'
    option reload '1'

8

(9 odpowiedzi, napisanych Notebooki)

Cezary napisał/a:

Tu masz: https://openwrt.org/docs/guide-user/net … hrough.nat

I trochę namieszałeś - zrobiłeś eth0 w bridgu jak ten interfejs w ogóle nie powinien być używany, bo switch jest na nim i używa vlana...


Trochę mnie wcięło, więc:

Poprawiłem te mostki i zrobiłem konfiguracje wedle poradnika, z sekcji 'WAN by PPPoE...'

Wynik jest następujący:

Jeśli ppoe jest wyłączone, mogę dostać się do konwentera
Jeśli włączę ppoe, nie mogę dostać się do konwentera, ale odpowiada mi 192.168.0.2 (adres statyczny, nadany routerowi w sieci konwentera)
Jeśli zrestartuje interfejs, który leci do konwentera, to cały ruch z sieci chce lecieć do 192.168.0.1, ale 192.168.0.2 odpowiada, że host jest nie osiągalny, a sam konwenter (192.168.0.1) nie wchodzi (muszę wyłączyć ppoe)

Aktualny config:
config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fdec:c29d:ab07::/48'

config interface 'lan'
    option type 'bridge'
    option ifname 'eth0.1'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ip6assign '60'

config interface 'wan'
    option ifname 'eth1'
    option proto 'none'
    option auto '1'
    option force_link '1'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option vid '1'
    option ports '0t 1 2 3 4'

config interface 'INTERSAT_NAT'
    option type 'bridge'
    option proto 'pppoe'
    option ifname 'eth1'
    option username 'login'
    option password 'haslo'
    option stp '0'
    option igmp_snooping '0'
    option force_link '1'
    option ipv6 'auto'

config interface 'kurka'
    option proto 'static'
    option ifname 'eth1'
    option delegate '0'
    option force_link '0'
    option ipaddr '192.168.0.2'
    option netmask '255.255.255.0'
    option gateway '192.168.0.1'
    option broadcast '192.168.0.255'

#tutaj próbowałem coś z trasą, ale niestety niezbyt działa hmm

config route
    option gateway '192.168.1.1'
    option target '192.168.1.1'
    option interface 'lan'

config route
    option target '192.168.0.1'
    option gateway '192.168.0.1'
    option interface 'lan'

9

(9 odpowiedzi, napisanych Notebooki)

Witam,

na początku tego roku pisałem podobny post, ale wtedy niestety nic z tego nie wyszło, natomiast ostatnio wróciłem do tematu i moje pytanie wygląda następująco - jak dostać się do konwentera ZTE?

Moja sieć wygląda następująco:

test

A tak wygląda plik network:

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fdec:c29d:ab07::/48'

config interface 'lan'
    option type 'bridge'
    option ifname 'eth0.1'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ip6assign '60'

config interface 'wan'
    option ifname 'eth1'
    option proto 'none'
    option auto '1'
    option force_link '1'

#config interface 'wan6'
    #option ifname 'eth1'
    #option proto 'dhcpv6'
    #option auto '0'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option vid '1'
    option ports '0t 1 2 3 4'

config interface 'ZTE_LAN'
    option type 'bridge'
    option proto 'static'
    option ifname 'eth0 eth1'
   
    option ipaddr '192.168.0.2'
    option netmask '255.255.255.0'
    option gateway '192.168.0.1'
    #option broadcast '192.168.0.255'
    #option dns '192.168.0.1'

    option stp '0'
    option igmp_snooping '0'
    option auto '1'
    option force_link '0'

config interface 'INTERSAT_NAT'
    option type 'bridge'
    option proto 'pppoe'
    option ifname 'eth0 eth1'
    option username 'xx'
    option password 'xx'
   
    #option ipv6 'auto'
    option stp '0'
    option igmp_snooping '0'
    option auto '1'
    option force_link '1'

Pomijam sam fakt, że w luci nie mogłem ustawić bridge na protokole poe, poradziłem sobie jak widać configiem. Teoretycznie wszystko powinno działać - internet jest, natomiast mam trudności dostania się do konwentera POE ZTE F601. Dodam, że jeśli wyłączę na chwilę połączenie POE i zrestartuje 2 bridge (ZTE) dostaje następujący komunikat - "Network device is not present".

Niestety, tutaj kończy się moje pomysły, a raczej wątpię, że pomoże tu zmiana ustawień typu:
    option stp '0'
    option igmp_snooping '0'
    option auto '1'
    option force_link '0'

Dodam, że oby dwa bridge, oraz sam port WAN są dodane 'do tej wspólnej strefy firewalla'.

10

(19 odpowiedzi, napisanych Oprogramowanie)

Dokładnie, najpewniej jest dolutować się do portu szeregowego, i np. cp2102 się pod niego podłączyć, a następnie wedle poradników. Sam tak kilka razy podnosiłem swojego tplinka - po ddwrt, i przez głupotę. Koniec końców, za bardzo przekombinowałem i musiałem skorzystać z programatora - ale router dalej śmiga big_smile Jeśli chodzi o zmodyfikowanego uboota, przeczytaj uważnie instrukcję i przede wszystkim skopiuj sobie 'plik' ze 'sterownikiem' do wifi (u mnie było to ostatnie 64kB na kostce)

11

(1 odpowiedzi, napisanych Oprogramowanie)

Witam serdecznie,

obecnie moja sieć wygląda tak:

---światłowód----- ZTE F601 -----rj45------ tplink wr740n----rj45-----komputer

Połączenie routera do zte jest (tak mi się wydaje) jest zrobiony bridge (na routerze loguję się za pomocą ppoe) i nie mam dostępu do konwertera. IP na WAN'ie jest z tego drugiego zakresu adresów niepublicznych, 172.31.1.57

Jeśli podepnę się do niego na 'krótko' ------światłowód-----zte---rj45---komputer, to mogę się dostać na jego panel.

No i teraz moje pytanie, jak to ze sobą zgrać:

WR740N - OpenWRT, sieć to 192.168.1.1/24
Na ZTE ustawiłem LAN na 192.168.2.1/24

Gdy dodaje 2 interfejs WAN (WAN2) na TPLINK'U, zaznaczam, że ma być zrobiony bridge na dotychczasowym wan'ie (WAN, wpisuje statyczny adres IP (192.168.2.1 - brama, 192.168.2.2 - router).

Gdy wbijam 192.168.2.2 pokazuje mi się stronka OpenWRT, więc jest ok, ale jak wbijam 192.168.2.1, mam komunikat, że połączenie zostało odrzucone oraz nie mogę puścić pinga.

Podpowiecie coś? Pozdrawiam!

12

(3 odpowiedzi, napisanych Oprogramowanie)

Właśnie taki pomysł chodził mi od dawna po głownie, ale postanowiłem podmienić kostkę na większą, ale jak szybko się przekonałem, RAM również powinienem wymienić na większy i tu mam wąskie gardło, a luci na routerze trochę wcina, a takie rozwiązanie nie było by głupie

13

(3 odpowiedzi, napisanych Oprogramowanie)

Witam, przyszła mi na myśl pewne ciekawe rozwiązanie, a mianowicie:

Czy ktoś z was widział lub wpadł na pomysł zrobienia prostej lecz użytecznej aplikacji, lub chociażby strony internetowej, coś a'la Mikrotikowego Winbonda, ale dla OpenWRT?

Z pewnością przydało by się dla osób, które nie chcą instalować webGUI :>

Pozdrawiam

14

(15 odpowiedzi, napisanych Oprogramowanie)

Jeszcze raz, dziękuję za pomoc!

15

(15 odpowiedzi, napisanych Oprogramowanie)

Cezary napisał/a:

Wystarczy jak zakomentujesz tylko src/gz openwrt_luci. Pamiętaj że ja nie kompiluję wszystkich pakietów od luci.

No i pięknie, wszystko ruszyło, czyli na przyszłość - raz z repo eko one, a jeśli nie śmiga to z openwrt. No pewnie - tych pakietów jest od groma, przejrzałem dopiero połowę z nich.

Wrzucę jeszcze logi na koniec:

Using username "root".


BusyBox v1.28.4 () built-in shell (ash)

  _______                     ________        __
|       |.-----.-----.-----.|  |  |  |.----.|  |_
|   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
|_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
-----------------------------------------------------------------------------
|                                                                           |
| OpenWrt 18.06-SNAPSHOT, r7812-aced9de9a4                                  |
|                                                                           |
| Build time: 2019-07-06 08:48 CEST                                         |
| Cezary Jackiewicz (obsy), http://eko.one.pl                               |
|                                                                           |
-----------------------------------------------------------------------------
| Machine: TP-Link TL-WR740N/ND v4                                          |
| Uptime: 0d, 00:04:11                                                      |
| Load: 0.14 0.28 0.14                                                      |
| Flash: total: 12.6MB, free: 12.2MB, used: 4%                              |
| Memory: total: 27.2MB, free: 15.4MB, used: 43%                            |
| WAN: 192.168.0.151, proto: dhcp                                           |
| LAN: 192.168.1.1, leases: 1                                               |
-----------------------------------------------------------------------------
=== WARNING! ================================================================
There is no root password defined on this device!
Use the "passwd" command to set up a new password
in order to prevent unauthorized SSH logins.
-----------------------------------------------------------------------------
root@OpenWrt:~# opkg update
Downloading http://dl.eko.one.pl/openwrt-18.06/targ … ackages.gz
Updated list of available packages in /var/opkg-lists/eko1_core
Downloading http://dl.eko.one.pl/openwrt-18.06/targ … ckages.sig
Signature check passed.
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … ackages.gz
Updated list of available packages in /var/opkg-lists/eko1_base
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … ckages.sig
Signature check passed.
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … ackages.gz
Updated list of available packages in /var/opkg-lists/eko1_luci
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … ckages.sig
Signature check passed.
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … ackages.gz
Updated list of available packages in /var/opkg-lists/eko1_packages
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … ckages.sig
Signature check passed.
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … ackages.gz
Updated list of available packages in /var/opkg-lists/eko1_routing
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … ckages.sig
Signature check passed.
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … ackages.gz
Updated list of available packages in /var/opkg-lists/eko1_telephony
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … ckages.sig
Signature check passed.
Downloading http://dl.eko.one.pl/openwrt-18.06/targ … ackages.gz
Updated list of available packages in /var/opkg-lists/eko1_kmods
Downloading http://dl.eko.one.pl/openwrt-18.06/targ … ckages.sig
Signature check passed.
root@OpenWrt:~# opkg install luci
Installing luci (git-19.186.54187-cbc000b-1) to root...
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … -1_all.ipk
Installing uhttpd (2018-11-28-cdfc902a-3) to root...
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … s_24kc.ipk
Installing liblua (5.1.5-1) to root...
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … s_24kc.ipk
Installing lua (5.1.5-1) to root...
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … s_24kc.ipk
Installing luci-lib-nixio (git-19.186.54187-cbc000b-1) to root...
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … s_24kc.ipk
Installing luci-lib-ip (git-19.186.54187-cbc000b-1) to root...
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … s_24kc.ipk
Installing rpcd (2018-11-28-3aa81d0d-2) to root...
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … s_24kc.ipk
Installing libubus-lua (2018-10-06-221ce7e7-1) to root...
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … s_24kc.ipk
Installing luci-lib-jsonc (git-19.186.54187-cbc000b-1) to root...
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … s_24kc.ipk
Installing liblucihttp (2019-07-05-a34a17d5-1) to root...
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … s_24kc.ipk
Installing liblucihttp-lua (2019-07-05-a34a17d5-1) to root...
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … s_24kc.ipk
Installing luci-base (git-19.186.54187-cbc000b-1) to root...
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … s_24kc.ipk
Installing luci-mod-admin-full (git-19.186.54187-cbc000b-1) to root...
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … s_24kc.ipk
Installing luci-theme-bootstrap (git-19.186.54187-cbc000b-1) to root...
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … -1_all.ipk
Installing luci-app-firewall (git-19.186.54187-cbc000b-1) to root...
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … -1_all.ipk
Installing luci-proto-ppp (git-19.186.54187-cbc000b-1) to root...
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … -1_all.ipk
Installing libiwinfo-lua (2018-07-31-65b8333f-1) to root...
Downloading http://dl.eko.one.pl/openwrt-18.06/targ … s_24kc.ipk
Installing luci-proto-ipv6 (git-19.186.54187-cbc000b-1) to root...
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … -1_all.ipk
Installing rpcd-mod-rrdns (20170710) to root...
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … s_24kc.ipk
Configuring rpcd.
Configuring liblua.
Configuring luci-lib-ip.
Configuring libubus-lua.
Configuring libiwinfo-lua.
Configuring luci-theme-bootstrap.
Configuring luci-app-firewall.
Configuring lua.
Configuring luci-proto-ppp.
Configuring luci-lib-nixio.
Configuring luci-lib-jsonc.
Configuring liblucihttp.
Configuring liblucihttp-lua.
Configuring luci-base.
Configuring luci-mod-admin-full.
Configuring luci-proto-ipv6.
Configuring uhttpd.
Configuring rpcd-mod-rrdns.
Configuring luci.
root@OpenWrt:~# opkg install luci-app-ddns
Installing luci-app-ddns (2.4.9-3) to root...
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … -3_all.ipk
Installing ddns-scripts (2.7.8-1) to root...
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … -1_all.ipk
Configuring ddns-scripts.
Configuring luci-app-ddns.
root@OpenWrt:~#  223542  WARN : Service section disabled! - TERMINATE
223545  WARN : Service section disabled! - TERMINATE

16

(15 odpowiedzi, napisanych Oprogramowanie)

Cezary napisał/a:

Przyczyna jest inna - pomieszałeś pakiety z różnych repo. Zainstaluj całkowicie luci z mojego repo albo z repo openwrt.

Odinstaluj luci, w /etc/opkg/distfeeds.conf  zakomentuj albo jedno albo drugie repo z luci i zainstaluj wszystko od nowa.

Domyślnie miałem takie repozytoria:

Rozumiem, że po edycji mają wyglądać następująco?

17

(15 odpowiedzi, napisanych Oprogramowanie)

steel_rat napisał/a:

A po za tym co zwraca tobie polecenie "opkg list"

Bufor w putty chyba się skończył, dlatego ucięło górę: https://pastebin.com/0SNP1NRK
https://pastebin.com/0SNP1NRK

18

(15 odpowiedzi, napisanych Oprogramowanie)

Cały proces, który robię zaraz po wgraniu czystego softa: (w tym: uci show ddns)

Using username "root".


BusyBox v1.28.4 () built-in shell (ash)

  _______                     ________        __
|       |.-----.-----.-----.|  |  |  |.----.|  |_
|   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
|_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
-----------------------------------------------------------------------------
|                                                                           |
| OpenWrt 18.06-SNAPSHOT, r7812-aced9de9a4                                  |
|                                                                           |
| Build time: 2019-07-06 08:48 CEST                                         |
| Cezary Jackiewicz (obsy), http://eko.one.pl                               |
|                                                                           |
-----------------------------------------------------------------------------
| Machine: TP-Link TL-WR740N/ND v4                                          |
| Uptime: 0d, 00:01:47                                                      |
| Load: 1.38 0.60 0.22                                                      |
| Flash: total: 12.6MB, free: 12.2MB, used: 4%                              |
| Memory: total: 27.2MB, free: 15.1MB, used: 44%                            |
| WAN: 192.168.0.151, proto: dhcp                                           |
| LAN: 192.168.1.1, leases: 1                                               |
-----------------------------------------------------------------------------
=== WARNING! ================================================================
There is no root password defined on this device!
Use the "passwd" command to set up a new password
in order to prevent unauthorized SSH logins.
-----------------------------------------------------------------------------
root@OpenWrt:~# opkg install luci
Unknown package 'luci'.
Collected errors:
* opkg_install_cmd: Cannot install package luci.
root@OpenWrt:~# opkg update
Downloading http://downloads.openwrt.org/releases/1 … ackages.gz
Updated list of available packages in /var/opkg-lists/openwrt_base
Downloading http://downloads.openwrt.org/releases/1 … ckages.sig
Signature check passed.
Downloading http://downloads.openwrt.org/releases/1 … ackages.gz
Updated list of available packages in /var/opkg-lists/openwrt_luci
Downloading http://downloads.openwrt.org/releases/1 … ckages.sig
Signature check passed.
Downloading http://downloads.openwrt.org/releases/1 … ackages.gz
Updated list of available packages in /var/opkg-lists/openwrt_packages
Downloading http://downloads.openwrt.org/releases/1 … ckages.sig
Signature check passed.
Downloading http://downloads.openwrt.org/releases/1 … ackages.gz
Updated list of available packages in /var/opkg-lists/openwrt_routing
Downloading http://downloads.openwrt.org/releases/1 … ckages.sig
Signature check passed.
Downloading http://downloads.openwrt.org/releases/1 … ackages.gz
Updated list of available packages in /var/opkg-lists/openwrt_telephony
Downloading http://downloads.openwrt.org/releases/1 … ckages.sig
Signature check passed.
Downloading http://dl.eko.one.pl/openwrt-18.06/targ … ackages.gz
Updated list of available packages in /var/opkg-lists/eko1_core
Downloading http://dl.eko.one.pl/openwrt-18.06/targ … ckages.sig
Signature check passed.
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … ackages.gz
Updated list of available packages in /var/opkg-lists/eko1_base
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … ckages.sig
Signature check passed.
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … ackages.gz
Updated list of available packages in /var/opkg-lists/eko1_luci
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … ckages.sig
Signature check passed.
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … ackages.gz
Updated list of available packages in /var/opkg-lists/eko1_packages
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … ckages.sig
Signature check passed.
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … ackages.gz
Updated list of available packages in /var/opkg-lists/eko1_routing
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … ckages.sig
Signature check passed.
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … ackages.gz
Updated list of available packages in /var/opkg-lists/eko1_telephony
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … ckages.sig
Signature check passed.
Downloading http://dl.eko.one.pl/openwrt-18.06/targ … ackages.gz
Updated list of available packages in /var/opkg-lists/eko1_kmods
Downloading http://dl.eko.one.pl/openwrt-18.06/targ … ckages.sig
Signature check passed.
root@OpenWrt:~# opkg install luci
Installing luci (git-19.190.55614-35357e4-1) to root...
Downloading http://downloads.openwrt.org/releases/1 … -1_all.ipk
Installing uhttpd (2018-11-28-cdfc902a-3) to root...
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … s_24kc.ipk
Installing liblua (5.1.5-1) to root...
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … s_24kc.ipk
Installing lua (5.1.5-1) to root...
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … s_24kc.ipk
Installing luci-lib-nixio (git-19.190.55614-35357e4-1) to root...
Downloading http://downloads.openwrt.org/releases/1 … s_24kc.ipk
Installing luci-lib-ip (git-19.190.55614-35357e4-1) to root...
Downloading http://downloads.openwrt.org/releases/1 … s_24kc.ipk
Installing rpcd (2018-11-28-3aa81d0d-2) to root...
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … s_24kc.ipk
Installing libubus-lua (2018-10-06-221ce7e7-1) to root...
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … s_24kc.ipk
Installing luci-lib-jsonc (git-19.190.55614-35357e4-1) to root...
Downloading http://downloads.openwrt.org/releases/1 … s_24kc.ipk
Installing liblucihttp (2019-07-05-a34a17d5-1) to root...
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … s_24kc.ipk
Installing liblucihttp-lua (2019-07-05-a34a17d5-1) to root...
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … s_24kc.ipk
Installing luci-base (git-19.190.55614-35357e4-1) to root...
Downloading http://downloads.openwrt.org/releases/1 … s_24kc.ipk
Installing luci-mod-admin-full (git-19.190.55614-35357e4-1) to root...
Downloading http://downloads.openwrt.org/releases/1 … s_24kc.ipk
Installing luci-theme-bootstrap (git-19.190.55614-35357e4-1) to root...
Downloading http://downloads.openwrt.org/releases/1 … -1_all.ipk
Installing luci-app-firewall (git-19.190.55614-35357e4-1) to root...
Downloading http://downloads.openwrt.org/releases/1 … -1_all.ipk
Installing luci-proto-ppp (git-19.190.55614-35357e4-1) to root...
Downloading http://downloads.openwrt.org/releases/1 … -1_all.ipk
Installing libiwinfo-lua (2018-07-31-65b8333f-1) to root...
Downloading http://dl.eko.one.pl/openwrt-18.06/targ … s_24kc.ipk
Installing luci-proto-ipv6 (git-19.190.55614-35357e4-1) to root...
Downloading http://downloads.openwrt.org/releases/1 … -1_all.ipk
Installing rpcd-mod-rrdns (20170710) to root...
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … s_24kc.ipk
Configuring rpcd.
Configuring liblua.
Configuring luci-lib-ip.
Configuring libubus-lua.
Configuring libiwinfo-lua.
Configuring luci-theme-bootstrap.
Configuring luci-app-firewall.
Configuring lua.
Configuring luci-proto-ppp.
Configuring luci-lib-nixio.
Configuring luci-lib-jsonc.
Configuring liblucihttp.
Configuring liblucihttp-lua.
Configuring luci-base.
Configuring luci-mod-admin-full.
Configuring luci-proto-ipv6.
Configuring uhttpd.
Configuring rpcd-mod-rrdns.
Configuring luci.
root@OpenWrt:~# opkg install luci-app-ddns
Installing luci-app-ddns (2.4.9-3) to root...
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … -3_all.ipk
Installing ddns-scripts (2.7.8-1) to root...
Downloading http://dl.eko.one.pl/openwrt-18.06/pack … -1_all.ipk
Configuring ddns-scripts.
Configuring luci-app-ddns.
root@OpenWrt:~# uci show ddns
ddns.global=ddns
ddns.global.ddns_dateformat='%F %R'
ddns.global.ddns_loglines='250'
ddns.global.upd_privateip='0'
ddns.myddns_ipv4=service
ddns.myddns_ipv4.lookup_host='yourhost.example.com'
ddns.myddns_ipv4.domain='yourhost.example.com'
ddns.myddns_ipv4.username='your_username'
ddns.myddns_ipv4.password='your_password'
ddns.myddns_ipv4.interface='wan'
ddns.myddns_ipv4.ip_source='network'
ddns.myddns_ipv4.ip_network='wan'
ddns.myddns_ipv4.service_name='dyn.com'
ddns.myddns_ipv6=service
ddns.myddns_ipv6.update_url='http://[USERNAME]:[PASSWORD]@your.provider.net/nic/update?hostname=[DOMAIN]&myip=[IP]'
ddns.myddns_ipv6.lookup_host='yourhost.example.com'
ddns.myddns_ipv6.domain='yourhost.example.com'
ddns.myddns_ipv6.username='your_username'
ddns.myddns_ipv6.password='your_password'
ddns.myddns_ipv6.use_ipv6='1'
ddns.myddns_ipv6.interface='wan6'
ddns.myddns_ipv6.ip_source='network'
ddns.myddns_ipv6.ip_network='wan6'
root@OpenWrt:~# 215851  WARN : Service section disabled! - TERMINATE
215853  WARN : Service section disabled! - TERMINATE

19

(15 odpowiedzi, napisanych Oprogramowanie)

9tysiecy napisał/a:

Możesz doinstalować Luci do obrazów Cezarego przecież

I tak robię, problem w tym, że nie ważne jaki system, mam problem z błędem, który podałem powyżej

20

(15 odpowiedzi, napisanych Oprogramowanie)

Czyli muszę szukać obrazów z preinstalowanym luci, ale takie nie są aktualnie do zdobycia, a jak próbuje doinstalować luci to wywala własnie ten błąd. Żeby nie kombinować to podłączyłem się UART'em do konsoli i z poziomu UBOOT'a ustawiłem adres MAC (i przy okazji PIN), ale chyba widzę, że nie obejdzie się bez wymiany pamięci RAM na większą kostkę, mogłem od razu zamówić.

A co do VPN'a, mój drugi komputer (w sumie taki 'serwer'), łączył by się przez VPN'a tym samym dostając 'publiczne ip' (kiedyś to testowałem (na gargulcu) i z ciekawości wkleiłem ip do przeglądarki i moim oczom ukazała się strona openwrt, i że nie mam dostępu bla bla). Także idąc ślepo tą informacją, chciałbym zrobić takie osobne połączenie na jednym z portów - a ddns przydał by mi się po to, żeby aktualizowało mi ip w subdomenie. Wiem, że dużo kombinatoryki i pewnie dało by radę zrobić to o wiele prościej (wszystko skonfigurować na 'serwerze'), alee taka szalona koncepcja, którą kiedyś może się zajmę jak ogarnę podstawowe rzeczy.

W taki razie idę szukać jakiś obrazów, dziękuję za pomoc!

21

(15 odpowiedzi, napisanych Oprogramowanie)

Czyli według tego obrazka  -> skopiować pierwsze 128KiB z pierwszej kostki i wrzucić je na drugą kostkę, dopiero później wgrywać uboota od pepe2k. Z pierwszej kostki może uda mi się zrobić to za pomocą OpenWRT, zaś na nowej, drugiej kostce będzie wóz, albo przewóz, wszystko zależy od tego czy pomylę się w komendach przy uboocie. Obym dał radę, bo nie mam dostępu do programatora, chyba pora na kupno jakiegoś najtańszego prosto z chin.

Odnośnie tego VPN'a - chciałem sprytnym sposobem zrobić sobie 'publiczne' ip + zależnie od tego jaki byłby to serwer VPN przydało by mi się właśnie paczka ddns, ale tutaj chyba wgram po prostu jakiś stary soft, ewentualnie będę coś jeszcze w tej kwestii kombinował.

Apropos obrazów, myślałem, że te z wyszukiwarki są robione przez twoją osobę, widocznie się pomyliłem, także przepraszam

Dziękuję za odpowiedź!

Witam serdecznie, mam kilka pytań apropo OpenWRT: (model routera to WR740N)

- Po wymianie kości flash na większą (16MiB), oraz zmianie uboota (na wersję od pepe2k) widocznie czegoś nie skopiowałem i za każdym razem adres mac dla wszytkich interfejsów jest generowany losowo - czy można za pomocą openwrt ustawić go gdzieś na sztywno?

- Czy istnieje klient VPN na OpenWRT, który będzie działał jedynie na wskazanym porcie? (zgaduje, że trzeba będzie skonfigurować 2 osobne interfejsy)

- Jakie pakiety macie zainstalowane u siebie? big_smile (aktualnie posiadam sqm, adblocka, wol, ddns)

- Na wydaniu od OpenWRT oraz od Cezarego, pakiet ddns-script oraz luci-app-dns sypie takim błędem (a googlując dużo nie znalazłem):

Failed to execute cbi dispatcher target for entry '/admin/services/ddns'.
The called action terminated with an exception:
/usr/lib/lua/luci/controller/ddns.lua:107: attempt to index field '?' (a nil value)
stack traceback:
    /usr/lib/lua/luci/controller/ddns.lua:107: in function 'service_version'
    /usr/lib/lua/luci/controller/ddns.lua:117: in function 'service_ok'
    /usr/lib/lua/luci/model/cbi/ddns/overview.lua:20: in function 'func'
    /usr/lib/lua/luci/cbi.lua:66: in function 'load'
    /usr/lib/lua/luci/dispatcher.lua:841: in function </usr/lib/lua/luci/dispatcher.lua:835>

Witam, z góry mówię że korzystam z forum po raz drugi, więc jeśli źle umieściłem ten temat to przepraszam i proszę o przeniesienie.
Więc tak jak w temacie, strzelam że winę za niedziałające wifi jest odpowiedzialny plik art. Jeden z grupowiczów SysOps / DevOps Polska, napisał mi instrukcję jak wgrać ten plik, niestety podesłał mi od innego modelu (na próbę) i router rozpakuje sobie kernel, ale resetuje się później. Logi po wgraniu arthacked.bin - https://pastebin.com/HTVwaPmP.
Podobno WR743NDv2 i WR740ND mają taką samą 'antenę' więc być może art od nich by pasował. Jeśli by ktoś miał, to prosił bym o podesłanie na test.