1

(11 odpowiedzi, napisanych Oprogramowanie)

ogólnie coraz mniej sensownego sprzętu można dostać pod openwrt.
W przyszłości zostanie chyba tylko x86 + karty Wlan.

2

(11 odpowiedzi, napisanych Oprogramowanie)

te błędy przerwań, z tego co przeglądałem tematy na githubie,pojawiają się na wszystkich routerach opartych na MT7621.
Próbował ktoś zwolnić 2gi wątek ?

3

(2 odpowiedzi, napisanych Oprogramowanie)

nie chce routera stawiac na proxie, ma być pewny stabilny i lekki.

teraz openwrt zużywa całe 5% cpu przy natowaniu 1Gbps, zjadając 35MB ramu i pobierajac 7W z gniazdka wink

prox w idlu zeżre 10x tyle zasobów.

Już prędzej go postawie na alpine - troche przy tym grzebałem ale nie moge nigdzie zebrać kompletu informacji jak to bezpiecznie skonfigurować jako router wan-lan+firewall+adblock+openvpn+wireguard z pewnością 100% uptime.


główny serwer mam na debianie + kvm, ale tam mam po prostu zmostkowaną karte z virt-mana.

4

(2 odpowiedzi, napisanych Oprogramowanie)

Cześć,

jako że ostatnio przestawiłem się z poprzedniego igela 820c na docelowego mio z i5 4300U.
Jest to najlepiej zabezpieczona przed bakami zasilania lokalizacja - a tych u mnie nie brakuje - więc chiałem tam postawić VM z Home Assistantem + docker na jakieś lokalne pierdoły.

samo qemu działa ok, chociaż nie udało mi się odpalić obrazu z uefi (jest to w ogóle możliwe w openwrt ?).

Testowo połączenie przez -nic user w qemu działa ok.
Problem mam za to z brctl. Jako żę chciałem aby VM była widoczna jako kolejne urządzenie w sieci a nie siedziała za NATem.

obecnie qemu wyglada tak

qemu-system-x86_64 -enable-kvm -cpu host -smp 2 -m 2G \
        -nic user,hostfwd=tcp::2222-:22 \
        -drive file=alpine.qcow2,if=virtio \
        -device virtio-net-pci,mac=89:3F:87:F5:64:FD,netdev=br0 \
        -netdev bridge,br=br-lan,id=br0 \
        -nographic

postawiony alpine, utworzone zostają 2 interfejsy sieciowe eth0 (virtio) i eth1(nic user)

auto eth0
iface eth0 inet dhcp
        hostname localhost

auto eth1
iface eth1 inet dhcp
        hostname localhost

o ile eth1 wstaje i dziala bez problemu,
ifup eth0
ip: ioctl 0x8914 failed: Address not available

sam mostek się tworzy

root@OpenWrt:~# brctl show
bridge name     bridge id               STP enabled     interfaces
br-lan          7fff.0022fa96b233       no              eth0
                                                        tap0

ale ani po dhcp ani po static nie moge sie dobic do sieci z poziomu vm

reszta konfiguracji to w zasadzie default openwrt.

5

(26 odpowiedzi, napisanych Sprzęt)

u mnie dell e5540 - tak samo więcej jak 650-700 nie wyciąga.

6

(180 odpowiedzi, napisanych Sprzęt)

też testowałem 1 karte przez przejściówke, ale bez znaczenia - jak tylko coś jest obecne - nie bootuje. Na wszystkich 3 jeżach jakie posiadam.

poprawka na atherosie mpcie bootuje,
nie bootuje jednak nawet z samą przejściówką bez karty mpcie->m.2
chyba że mam złą przelotke
https://ae01.alicdn.com/kf/HTB1y5D3Vkvo … Y3pXaz.jpg

7

(180 odpowiedzi, napisanych Sprzęt)

btw udało się komuś cokolwiek uruchomić w mpcie w 820c ?
U mnie żadna sztuka nie bootuje gdy coś tam wsadzę, czy to karta wifi czy dysk msata.

8

(8 odpowiedzi, napisanych Oprogramowanie)

tylko HW offload, SW moze zostać. Wątpie by ktoś to naprawił w najbliższym czasie.

9

(172 odpowiedzi, napisanych Oprogramowanie)

openwrt tak ma. Chyba na każdym dostępnym.

10

(8 odpowiedzi, napisanych Oprogramowanie)

masz HW offloading właczony ?  kiedyś jak działało na starych buildach miałem takie same objawy.
Potem naprawili - tzn wyłączyli całkiem - teraz ponoć wróciło.

11

(17 odpowiedzi, napisanych Sprzęt)

Wgraj sobie najnowszego gargulca, włącz offload i tyle. Albo openwrt, z tym że w ostatnich buildach jest jakiś problem z DHCP na tym routerze. 300/100 to pociągnie z palcem w nosie.
A jak chcesz mieć tyle po wifi no to tylko coś w AC

12

(180 odpowiedzi, napisanych Sprzęt)

ambrozy5 napisał/a:

problem jest taki, że jeż kosztuje 35zł a advantech 200 big_smile oba zrobią taką samą robotę big_smile

jasne, ale + karta serwerowa 4 port ~80pln
i już się robi ponad 100. Nie wspominając jakbyś chciał te nowsze kupić.
No i redukcja poboru energii całości do <10W

Tak więc da się zrobić tanio, ale jak już się zacznie robić coraz to nowsze upgrejdy to finalnie wyjdzie drożej niż zintegrowane rozwiązanie wink

13

(180 odpowiedzi, napisanych Sprzęt)

karta dla KUNAPEK wink
czyli jednak ktoś robi, a tam obok pewnie jakiś Asmedia jako dzielnik portu.

Już lepiej kupić jakieś MIO-xxxx od Advantecha, płytki industrial, wielkosci 3.5cal, używki chodzą od czasu do czasu po ~200zł na allegro.
CPU w cały świat od amd przez j1900, e3xxx po i5 serii U.
zwykle mają 2 i2xx na pokładzie.

14

(180 odpowiedzi, napisanych Sprzęt)

te i2xx to wszystko są jednoportówki, nie sądzę by istniała jedna karta z kilkoma takimi układami, bo wymagałoby to jeszcze kolejnego układu dzielącego pcie -> 2xPcie. a wtedy oszczędność prądu się już zatrze wink

a z kart serwerowych to nie wiem czy jeszcze robią 1Gbps, chyba już same 10Gbps +

15

(180 odpowiedzi, napisanych Sprzęt)

ja im dociąłem takie małe radiatorki i przylepiłem klejem sylikonowym.
https://eko.one.pl/forum/viewtopic.php? … 57#p237657
i są tylko ciepłe, więc raczej ok. Z gołym jajcem bym się obawiał je zostawić wink

16

(180 odpowiedzi, napisanych Sprzęt)

cd benchmarków, Linpack xtreme v1.1.3

AIMB 275, celeron 3930   - 21.6822GFlops  ; 30,756s     ;21W
AIMB 275, celeron 3900   - 15.3591GFlops  ; 43,418s     ;23,6W
IGEL 820c,               - 7.9473GFlops   ; 83,911s     ;23,8W
IGEL 720,via             - 2.4073GFlops   ; 277.022s    ;24,2W
Dx0d, amd T48            - 2.1236GFlops   ; 314.028s    ;16W

MIO-5271, i5 4300U    - 61.8715GFlops  ;       ;36W
Shuttle xh61, i5 3470    - 78.6092GFlops  ; 8,483s      ;90W

zaskoczony jestem zwłaszcza VIA 1c1t vs t48 2c2t od AMD, wychodzi jak strasznie kaszaniasty jest to CPU od czerwonych ;p
Kaby lake ofc wymiata.

17

(180 odpowiedzi, napisanych Sprzęt)

ambrozy5 napisał/a:
chemik89 napisał/a:

przeglądałem jakie mam kostki sata w szufladzie i odpaliłem sobie batocera dla testu, w nim kodi z filmem 1080 h264. to 2gie go zabiło, brak sprzętowego dekodowania - nie nadaje sie na htpc wink

tam grafika 2 gen wiec powinno smigac dekodowanie hw, kodi inna sprawa

SandyBridge miało wszystkie Celerony oskalpowane ze sprzętowych dekoderów.

18

(180 odpowiedzi, napisanych Sprzęt)

przeglądałem jakie mam kostki sata w szufladzie i odpaliłem sobie batocera dla testu, w nim kodi z filmem 1080 h264. to 2gie go zabiło, brak sprzętowego dekodowania - nie nadaje sie na htpc wink

19

(180 odpowiedzi, napisanych Sprzęt)

ten 820 troche papu potrafi łyknąć, przy 99% obciążenia 31W ...
aż mi restart zaliczył, zasilacz od routera 12v 2A nie dał rady smile

20

(180 odpowiedzi, napisanych Sprzęt)

ja wytapiam tą ściankę transformatorówką i odcinam co zostanie nożykiem do tapet. 2min roboty.
Niektóre obudowy tych złącz są strasznie kruche i potrafią pękać przy samym cięciu.

21

(180 odpowiedzi, napisanych Sprzęt)

ten 820 ma. 710 nie. za to 710 ma sprzętowy aes i pcie 4x i wlutowane 2 sata. I słaby procek via wink

tam siedzi Intel AX200. Nie wiem czy to się nadaje w ogóle do pracy jako AP.
kup przejściówke pcie-NVME/m.2 i wciśnij tam jakąś laptopową karte.

23

(180 odpowiedzi, napisanych Sprzęt)

no masz np to co wspominalem wcześniej
https://allegro.pl/oferta/fujitsu-2x10- … 7312566301
coś nalepisz i nie bedzie parzyło. Od tego samego sprzedawcy co jeż ;p

a pojedyńczego intela to kupowalem cos takiego, tylko dostalem o polowe mniejsza gabarytowo ;p (jak na 2gim obrazku, jest zimny, ten sam układ co integrowany zwykle na płytach)
https://archiwum.allegro.pl/oferta/kart … 01733.html


4W to sporo, biorąc pod uwage że to CPU pobiera podobnie, a ma z 6x wiekszy radiator wink
To karty serwerowe - producent przewiduje że w obudowie będzie tornado 6*C wink

jakby kogos interesowala wydajnosc dysku jeża

------------------------------------------------------------------------------
CrystalDiskMark 7.0.0 (C) 2007-2019 hiyohiyo
                                  Crystal Dew World: [url]https://crystalmark.info/[/url]
------------------------------------------------------------------------------
* MB/s = 1,000,000 bytes/s [SATA/600 = 600,000,000 bytes/s]
* KB = 1000 bytes, KiB = 1024 bytes

[Read]
Sequential 1MiB (Q=  8, T= 1):    81.591 MB/s [     77.8 IOPS] <101593.76 us>
Sequential 1MiB (Q=  1, T= 1):    80.753 MB/s [     77.0 IOPS] < 12954.19 us>
    Random 4KiB (Q= 32, T=16):    13.640 MB/s [   3330.1 IOPS] <150416.04 us>
    Random 4KiB (Q=  1, T= 1):    11.817 MB/s [   2885.0 IOPS] <   344.06 us>

[Write]
Sequential 1MiB (Q=  8, T= 1):    54.527 MB/s [     52.0 IOPS] <151281.54 us>
Sequential 1MiB (Q=  1, T= 1):    54.735 MB/s [     52.2 IOPS] < 19088.40 us>
    Random 4KiB (Q= 32, T=16):     2.490 MB/s [    607.9 IOPS] <384462.24 us>
    Random 4KiB (Q=  1, T= 1):     2.396 MB/s [    585.0 IOPS] <  1705.56 us>

Profile: Default
   Test: 64 MiB (x5) [Interval: 5 sec] <DefaultAffinity=DISABLED>
   Date: 2020/05/07 23:00:02
     OS: Windows 10 Professional [10.0 Build 18363] (x64)

24

(180 odpowiedzi, napisanych Sprzęt)

jak ktoś nie ma gigabita na WAN to spokojnie może do tego celu użyć wbudowanego realteca + jakaś jedno-portówka.
Jednoportówki maja tą zalete że jest to zwykle jakiś nowszy intel 21x, o tdp <0.5W

25

(180 odpowiedzi, napisanych Sprzęt)

pf dostał juz wsparcie dla wireguarda czy dalej są konserwatywni ?

no i jak dla kogoś nie będzie w sam raz karta 4 lan, tj i tak będzie potrzebował dodatkowego switcha lub zadowoli się 2 portami - to takie są 3-4x tańsze wink

edit: ale przy pozostałych ww. OS nie będzie już zużycia ramu na poziomie 20MB/xGB i systemu na 5MB jak na wrt  big_smile