1 (edytowany przez Cezary 2022-12-01 12:03:39)

Temat: Docker w OpenWrt

Docker... technologia która od kilku lat podbija świat IT, pozwalająca na uruchamianie różnych serwisów w izolowanych środowiskach, która jednocześnie nie jest emulatorem całego komputera. Trudno napisać w jednym zdaniu czym jest docker, jeżeli ktoś jeszcze nie spotkał się tym tematem (co by było dość dziwne), to polecam google oraz masę poradników np. na YouTube.

W OpenWrt możemy uruchomić bez problemu dockera, tylko musimy pamiętać o spełnieniu kilku wymagań:
- musi być to maszyna x86 lub ARM (to są najpopularniejsze architektury na które dostępne są obrazy, o ile korzystamy z publicznych źródeł i nie tworzymy obrazów samodzielenie)
- musi mieć sporo wolnej przestrzeni dyskowej (naprawdę sporo - kontener wraz z zależnościami może zajmować kilka gigabajtów - wynika to ze sposobu tworzenia kontenerów, ale także jakie obrazy już mamy)
- dość sporo pamięci RAM - ponieważ uruchamiamy wiele procesów.

W praktyce więc możemy od razu odrzucić popularne routery ze 64/128MB ramu, potrzebujemy raczej routera zrobionego z PC lub np. Raspberry PI. Jeżeli będziemy korzystać z publicznego repozytorium to musimy też pamiętać że nie są dostępne obrazy na wszystkie możliwe architektury, najczęściej będzie to x86/64 lub ARM/v7 czy ARM/v8.

Co możemy uruchomić w dokerze? W obecnych czasach praktycznie... wszystko. Od bazy danych do serwera www, od serwisu typu aria2c do nextcluda, od własnego programu w pythonie do hadoop'a czy innych programów w javie. Polecam przejrzenie publicznego repozytorium: https://hub.docker.com/ i poszukanie rzeczy którą potrzebujemy.

Ten poradnik będzie bardzo prosty - skupimy się na instalacji dockera, jego zarządzaniu i uruchomimy przykładowe obrazy. Po więcej informacji zapraszam do odwiedzenia google i setek stron poświęconych temu projektowi. Całość opisana na podstawie OpenWrt 22.03.

Instalacja
opkg update
opkg install docker dockerd 

Zarządzać dockerem możemy w linii poleceń (konsoli), jeżeli ktoś używa LuCI to polecam doinstalować odpowiedni pakiet:

opkg install luci-app-dockerman luci-i18n-dockerman-pl

Dzięki czemu można zarządzać dockerem bezpośrednio z luci i nie trzeba instalować aplikacji typu portainer.

Domyślnie docker w openwrt swoje pliki wrzuca do /opt/docker - jest to do zmiany w pliku /etc/config/dockerd lub przez luci. W związku z tym musimy mieć dużo przestrzeni dyskowej (zrobić extroota lub podmontować zewnętrzny dysk). Należy jeszcze trochę podrasować konfigurację:

uci set network.@device[-1].bridge_empty='1'
uci -q del network.docker.auto
uci add firewall forwarding
uci set firewall.@forwarding[-1].src=docker
uci set firewall.@forwarding[-1].dest=lan
uci add firewall forwarding
uci set firewall.@forwarding[-1].dest=docker
uci set firewall.@forwarding[-1].src=lan
uci commit

Restartujemy router i... mamy dockera! Proste...

Zarządzenie

Polecenie docker Twoim przyjacielem

root@OpenWrt:~# docker version
Client:
 Version:           20.10.18
 API version:       1.41
 Go version:        go1.18.4
 Git commit:        b40c2f6
 Built:             Thu Nov 10 07:37:16 2022
 OS/Arch:           linux/amd64
 Context:           default
 Experimental:      true

Server:
 Engine:
  Version:          20.10.18
  API version:      1.41 (minimum version 1.12)
  Go version:       go1.18.4
  Git commit:       e42327a
  Built:            Tue Nov  8 13:15:51 2022
  OS/Arch:          linux/amd64
  Experimental:     false
 containerd:
  Version:          1.6.8
  GitCommit:        
 runc:
  Version:          1.1.4
  GitCommit:        
 docker-init:
  Version:          0.19.0
  GitCommit:        de40ad0

Jak ktoś lubi konsolę to odnajdzie się bez problemu, jak ktoś woli luci, proszę bardzo:

https://i.postimg.cc/CKBjsqNh/Zrzut-ekranu-z-2022-11-11-14-52-01.png

To tylko przegląd, bo osobno można zarządzać obrazami, woluminami, sieciami itd. Można także dodawać i usuwać obrazy. Do podstawowych rzeczy wystarczy tyle ile mamy dostępne w LuCI.

Obrazy, kontenery i cała reszta

Teraz do rzeczy - uruchamiamy gotowe projekty z repozytorium. Powiedzmy że potrzebujemy np. speedtesta. Odpowiedni obraz jest w repozytorium, można poszukać, przeczytać jak go uruchomić, więc to robimy:

root@OpenWrt:~# docker run --restart=unless-stopped --name openspeedtest -d -p 3000:3000 -p 3001:3001 openspeedtest/latest
Unable to find image 'openspeedtest/latest:latest' locally
latest: Pulling from openspeedtest/latest
213ec9aee27d: Pull complete 
c589aa91d168: Pull complete 
c1ad9ebac4a7: Pull complete 
b8bb7f719704: Pull complete 
a22122b8d79a: Pull complete 
91492f978c76: Pull complete 
66804b4484ed: Pull complete 
9d2fd9029ae1: Pull complete 
daa32a7f5b00: Pull complete 
f3ac76760cdd: Pull complete 
ee71529f3c7d: Pull complete 
f4cdfc19565a: Pull complete 
ab0f5dd6a522: Pull complete 
4d522e947bc8: Pull complete 
b7aa60f060b4: Pull complete 
407c9b680f77: Pull complete 
Digest: sha256:2af93b7894443d5759161238b91dabdc08b299543d1d60dbd5b18e07ddbdf897
Status: Downloaded newer image for openspeedtest/latest:latest
6f983b04c63c6e8a951efc5300e9ce4d2501b375c220b3b5c5d2ad5cfbc61d04
[ 1415.302861] docker0: port 2(veth9caeb44) entered blocking state
[ 1415.308124] docker0: port 2(veth9caeb44) entered disabled state
[ 1415.309320] device veth9caeb44 entered promiscuous mode

I tyle. Obrazy pobrane i rozpakowane, kontener został uruchomiony:

root@OpenWrt:~# docker ps
CONTAINER ID   IMAGE                  COMMAND                  CREATED              STATUS          PORTS                                                                     NAMES
6f983b04c63c   openspeedtest/latest   "/docker-entrypoint.…"   About a minute ago   Up 46 seconds   0.0.0.0:3000-3001->3000-3001/tcp, :::3000-3001->3000-3001/tcp, 8080/tcp   openspeedtest

Więc teraz otwieramy przeglądarkę, wpisujemy http://192.168.1.1:3000 i mamy własny serwer speedtesta. Proste, prawda?

Inny przykład z forum - ktoś potrzebował nextclouda - własną chmurę do zarządzenia plikami itd. Normalnie trzeba instalować apache, php, konfigurować, dodawać pliki projektu itd. A tak:

root@OpenWrt:~# ddocker run -d  -p 8888:80  --restart=unless-stopped -v nextcloud:/opt/docker/nextcloud/var/www/html -v apps://opt/docker/nextcloudvar/www/html/custom_apps -v config:/opt/docker/nextcloud/var/www/html/config -v data:/opt/docker/nextcloud/var/www/html/data nextcloud:latest

Przechodzimy na http://192.168.1.1:8888 i okazuje się że nextcloud już jest, działa, wystarczy skonfigurować i tyle.

Oczywiście docker jest sporo bardziej rozbudowany -  sieci, woluminy, zabawa z composerem itd - ale to już zostawiam czytelnikowi. Celem tego poradnika było pokazanie że na OpenWrt też to się da.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

2 (edytowany przez lexmark3200 2022-11-11 20:49:22)

Odp: Docker w OpenWrt

Zaciekawiłeś mnie. A już zgłębiałem temat na zagranicznych forach jak to się uruchamia.
Może się skuszę i z mojego OPNsense przejdę na OpenWRT. Mam t620 plus z 8GB DDR i do tego 64GB dysk.
Procek GX-420.

Do zarządzania dockerem można postawić Portainer.

3

Odp: Docker w OpenWrt

Możesz, ale nie musisz smile

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

4 (edytowany przez lukjod 2022-11-12 12:00:36)

Odp: Docker w OpenWrt

Fakt docker to piekna rzecz, sam sie aktualizuje przy uzyciu np watchtower. U mnie na qnap sciaga filmy seriale przez torrent, dopasowuje napisy, jednym slowem dodaj fil i zapomnij do czasu sciagniecia i dodania do plex. Super rzecz. Dla zainteresowanyxh szukjajcie kontenerow z koncowka arr sonarr, radarr, bazarr, prowlarr, readarr i tp

ASUS ax4200 & Linksys e8450 AP @ openwrt 23.05 & Huawei e5786 jako backup

5

Odp: Docker w OpenWrt

Docker to świetna sprawa.
Używam na Qnapie (większe możliwości) od dłuższego czasu
Do tego portainer do zarządzania dockerami...

ASUS TUF AX6000 <-> QNAP TS-473A <->Pihole<->

6

Odp: Docker w OpenWrt

@Cezary działa na 22.03?
Jakiś czas temu czytałem, że nie jest kompatybilny z nowy firewallem.

APU2 @ OpenWrt 18.06-SNAPSHOT, r7852-7ac6044632

7

Odp: Docker w OpenWrt

Ten tekst właśnie był z 22.03. Działa, objechali to przez instalację iptables-nft i używanie starych regułek.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

8

Odp: Docker w OpenWrt

@Cezary, dziękuję za info.

APU2 @ OpenWrt 18.06-SNAPSHOT, r7852-7ac6044632

9

Odp: Docker w OpenWrt

Super temat. Dziękuję.

TP-Link TL-WDR4300 Mod, CPU 700MHz, Flash 16 MB, Gargoyle 1.5.11.4, extroot + dysk zewnętrzny Samsung (S2), kamerka MS LifeCam HD-5000
TP-Link TL-WR1043ND Mod, RAM 64 MB, chłodzenie pasywne, Gargoyle 1.5.10.14, extroot, kamerka Logitech HD Webcam C270

10 (edytowany przez miguelos 2022-11-19 10:30:37)

Odp: Docker w OpenWrt

A dla tych co nie maja sprzetu
Openwrt <-VPN, np. wireguard-> VMka w cloudzie + docker

Oracle cloud daje darmowe nawet 4VMki na arm (for ever)
https://www.oracle.com/cloud/free/

11

Odp: Docker w OpenWrt

U mnie jakiś problem z dostępem do aplikacji w kontenerach hmm

root@nanopi:~# docker ps
CONTAINER ID   IMAGE                         COMMAND                  CREATED          STATUS         PORTS                                                                     NAMES
6268fea9d44a   openspeedtest/latest:latest   "/docker-entrypoint.…"   20 seconds ago   Up 4 seconds   0.0.0.0:3000-3001->3000-3001/tcp, :::3000-3001->3000-3001/tcp, 8080/tcp   openspeedtest

Kontener jak widać uruchomiony. netstat też pokazuje:

tcp        0      0 0.0.0.0:3000            0.0.0.0:*               LISTEN      14461/docker-proxy
tcp        0      0 0.0.0.0:3001            0.0.0.0:*               LISTEN      14417/docker-proxy

Próba połączenia z routera oczywiście jest pomyślna:

root@nanopi:~# curl --head http://localhost:3000
HTTP/1.1 200 OK
Server: nginx
Date: Sat, 26 Nov 2022 23:15:42 GMT
Content-Type: text/html
Content-Length: 8727
Last-Modified: Sun, 20 Nov 2022 00:58:42 GMT
Connection: keep-alive
Vary: Accept-Encoding
ETag: "63797bc2-2217"
Expires: Sun, 26 Nov 2023 23:15:42 GMT
Cache-Control: max-age=31536000
Cache-Control: public
Vary: Accept-Encoding
Accept-Ranges: bytes

Niestety z LAN już nie mogę się połączyć:

➜  curl http://192.168.0.1:3000
curl: (28) Failed to connect to 192.168.0.1 port 3000 after 130369 ms: Couldn't connect to server

Sieć standardowo:

config interface 'docker'
        option device 'docker0'
        option proto 'none'
        option delegate '0'

config device
        option type 'bridge'
        option name 'docker0'
        option ipv6 '0'
        option bridge_empty '1'

A firewall domyślny:

config zone 'docker'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option name 'docker'
        list network 'docker'

Jakieś pomysły?

12

Odp: Docker w OpenWrt

Mimo w/w zezwól na forwarding docker<>lan?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

13

Odp: Docker w OpenWrt

Próbuje zainstalowć dockera na Fujitsu Futro s720 (soft: openwrt-22.03-snapshot-r19881-353e468f47-x86-64-generic-ext4-combined.img) i dostaję takie coś:

 root@OpenWrt:~# opkg install docker dockerd
Installing docker (20.10.18-1) to root...
Downloading https://downloads.openwrt.org/releases/22.03-SNAPSHOT/packages/x86_64/packages/docker_20.10.18-1_x86_64.ipk
Installing dockerd (20.10.18-1) to root...
Downloading https://downloads.openwrt.org/releases/22.03-SNAPSHOT/packages/x86_64/packages/dockerd_20.10.18-1_x86_64.ipk
Configuring docker.
Collected errors:
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.154-1-b5656daf1040a34ee2f682b2e3cd2524) for kmod-crypto-acompress
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-crypto-acompress found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.154-1-b5656daf1040a34ee2f682b2e3cd2524) for kmod-lib-lzo
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-lib-lzo found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.154-1-b5656daf1040a34ee2f682b2e3cd2524) for kmod-lib-zlib-inflate
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-lib-zlib-inflate found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.154-1-b5656daf1040a34ee2f682b2e3cd2524) for kmod-lib-zlib-deflate
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-lib-zlib-deflate found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.154-1-b5656daf1040a34ee2f682b2e3cd2524) for kmod-lib-raid6
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-lib-raid6 found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.154-1-b5656daf1040a34ee2f682b2e3cd2524) for kmod-lib-xor
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-lib-xor found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.154-1-b5656daf1040a34ee2f682b2e3cd2524) for kmod-lib-zstd
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-lib-zstd found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.154-1-b5656daf1040a34ee2f682b2e3cd2524) for kmod-fs-btrfs
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-fs-btrfs found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.154-1-b5656daf1040a34ee2f682b2e3cd2524) for kmod-nf-ipt
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-nf-ipt found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.154-1-b5656daf1040a34ee2f682b2e3cd2524) for kmod-ipt-core
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-ipt-core found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.154-1-b5656daf1040a34ee2f682b2e3cd2524) for kmod-nft-compat
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-nft-compat found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.154-1-b5656daf1040a34ee2f682b2e3cd2524) for kmod-ipt-extra
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-ipt-extra found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.154-1-b5656daf1040a34ee2f682b2e3cd2524) for kmod-nf-ipt6
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-nf-ipt6 found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.154-1-b5656daf1040a34ee2f682b2e3cd2524) for kmod-ip6tables
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-ip6tables found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.154-1-b5656daf1040a34ee2f682b2e3cd2524) for kmod-nf-nat6
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-nf-nat6 found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.154-1-b5656daf1040a34ee2f682b2e3cd2524) for kmod-ipt-conntrack
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-ipt-conntrack found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.154-1-b5656daf1040a34ee2f682b2e3cd2524) for kmod-ipt-nat
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-ipt-nat found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.154-1-b5656daf1040a34ee2f682b2e3cd2524) for kmod-ipt-nat6
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-ipt-nat6 found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.154-1-b5656daf1040a34ee2f682b2e3cd2524) for kmod-br-netfilter
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-br-netfilter found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.154-1-b5656daf1040a34ee2f682b2e3cd2524) for kmod-ipt-physdev
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-ipt-physdev found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.154-1-b5656daf1040a34ee2f682b2e3cd2524) for kmod-nf-ipvs
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-nf-ipvs found, but incompatible with the architectures configured
 * pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.154-1-b5656daf1040a34ee2f682b2e3cd2524) for kmod-veth
 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-veth found, but incompatible with the architectures configured
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for dockerd:
 *     kernel (= 5.10.154-1-b5656daf1040a34ee2f682b2e3cd2524)
 * opkg_install_cmd: Cannot install package dockerd.
Netgear R6220 - OpenWrt 23.05 by Cezary
Fujitsu Futro S720 - Ubuntu 20.04 (bieda nas, jellyfin)
ZTE 286 - MIFI 23.05 by Cezary
Cudy WR3000 - OpenWrt 23.05 by Cezary

14

Odp: Docker w OpenWrt

Masz złe repozytorium z modułami. Użyłeś swojego obrazu lub obrazu snapshota 22.03 z repo openwrt, więc użyj właściwego repozytorium z modułami - swojego jeżeli sam kompilowałeś lub z openwrt tego: https://downloads.openwrt.org/releases/ … 2e3cd2524/

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

15

Odp: Docker w OpenWrt

Zaktualizowałem dockermana z repo lisaac/luci-app-dockerman i pojawiły się dodatkowe ustawienia. Do listy dozwolonych interfejsów dodałem domowy vlan i od teraz mam dostęp do kontenerów. Wygląda na to, że domyślna konfiguracja firewalla u mnie nie działała tak jak trzeba.

https://i.postimg.cc/vTLVZfHz/Screenshot-2022-11-28-00-57-15.png

16

Odp: Docker w OpenWrt

Domyślnie nie vlanu 10 na br-lan w openwrt. Jak zrobiłeś inaczej sieć to siłą rzeczy sam musisz się zatroszczyć też o inne rzeczy.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

17

Odp: Docker w OpenWrt

Cezary piękny poradnik popełniłeś, teraz wiem co mogę na moich meraki mx64 przetestować bo 2GB ramu tam się marnuje niesamowicie.

Dom : router https://i.imgur.com/IuB6Zwy.png | TP-LINK T1700G-28TQ |Zyxel XGS-1210-12 | Dynalink WRX-36 | wax50 pro | rb hex poe gbit sfp | XPenology | kilka kamer reolink 5MP i jakieś tam jeszcze ustrojstwa połączone światłowodami, skrętką i wifi ,  apc smart ups 750 lcd smile
Podróżne : GL.Inet MT3000  zyxel nsa325 +6TB @ openwrt
http://tinyurl.com/bufferbloattest

18

Odp: Docker w OpenWrt

miguelos napisał/a:

A dla tych co nie maja sprzetu
Openwrt <-VPN, np. wireguard-> VMka w cloudzie + docker

Oracle cloud daje darmowe nawet 4VMki na arm (for ever)
https://www.oracle.com/cloud/free/

Próbuję się zarejestrować, ale za Chiny Ludowe moja fizyczna karta Visa z mbanku nie przechodzi weryfikacji....też tak macie?

Netgear R6220 - OpenWrt 23.05 by Cezary
Fujitsu Futro S720 - Ubuntu 20.04 (bieda nas, jellyfin)
ZTE 286 - MIFI 23.05 by Cezary
Cudy WR3000 - OpenWrt 23.05 by Cezary

19 (edytowany przez oneiro 2023-01-28 20:07:09)

Odp: Docker w OpenWrt

Co do wiecznego i darmowego serwera oraclowego to nie ma reguły, mi i wielu innym usuwają bez podania przyczyny. Co do rejestracji jest phytonowy skrypt, który próbuje aż do skutku

https://www.hintdesk.com/2022/01/15/how … -capacity/

Tak to wygoda, to akurat moje z peppera sprzed miesiąca

BusyBox v1.35.0 (2022-12-01 00:57:01 UTC) built-in shell (ash)

root@OpenWrt:/oracle# ls
config oci_auto.py
oci.log oci_private_key.pem
root@OpenWrt:/oracle# python3 oci_auto.py
[INFO] 2022-12-14 15:48:31,772 - #####################################################
[INFO] 2022-12-14 15:48:31,776 - Script to spawn VM.Standard.A1.Flex instance
[INFO] 2022-12-14 15:48:31,778 - Start spawning instance VM.Standard.A1.Flex - 3 ocpus - 18 GB
[INFO] 2022-12-14 15:48:32,095 - Loading OCI config
[INFO] 2022-12-14 15:48:32,103 - Initialize service client with default config file
[INFO] 2022-12-14 15:48:35,128 - Instance to create: VM.Standard.A1.Flex - 3 ocpus - 18 GB
[INFO] 2022-12-14 15:48:35,193 - Check current instances in account
[INFO] 2022-12-14 15:48:35,195 - Note: Free upto 4xVM.Standard.A1.Flex instance, total of 4 ocpus and 24 GB of memory
[INFO] 2022-12-14 15:48:35,862 - 1 instance(s) found!
[INFO] 2022-12-14 15:48:35,865 - NAZWA_INSTANCJI- VM.Standard.A1.Flex - 1 ocpu(s) - 6.0 GB(s) | State: STOPPED
[INFO] 2022-12-14 15:48:35,867 - Current: 1 active VM.Standard.A1.Flex instance(s) (including RUNNING OR STOPPED)
[INFO] 2022-12-14 15:48:35,931 - Total ocpus: 1 - Total memory: 6 (GB) || Free 3 ocpus - Free memory: 18 (GB)
[INFO] 2022-12-14 15:48:35,994 - Precheck pass! Create new instance VM.Standard.A1.Flex: 3 opus - 18 GB
[INFO] 2022-12-14 15:48:37,384 - Out of host capacity. Retry in 30s
[INFO] 2022-12-14 15:49:09,167 - Out of host capacity. Retry in 30s

PS. Po kilku godzinach zadziałało, dobre

[INFO] 2022-12-14 19:20:34,587 - Out of host capacity. Retry in 30s
[INFO] 2022-12-14 19:21:05,883 - Out of host capacity. Retry in 30s
[INFO] 2022-12-14 19:21:37,364 - Out of host capacity. Retry in 30s
[INFO] 2022-12-14 19:22:08,813 - Out of host capacity. Retry in 30s
[INFO] 2022-12-14 19:22:40,532 - Out of host capacity. Retry in 30s
[INFO] 2022-12-14 19:23:12,586 - Out of host capacity. Retry in 30s
[INFO] 2022-12-14 19:23:47,227 - Success! Edit vnic to get public ip address
root@OpenWrt:~# 

20 (edytowany przez mjab 2023-02-07 21:34:44)

Odp: Docker w OpenWrt

Instaluje sobie docker'a z tego poradnika w OpenWRT 22.03 x32/64 i mam :

Installing dockerd (20.10.22-1) to root...
Downloading https://downloads.openwrt.org/releases/ … x86_64.ipk

Collected errors:
* pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.165-1-9309db0b721b9fb3fe826181264a78c4) for kmod-crypto-crc32c
* pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.165-1-9309db0b721b9fb3fe826181264a78c4) for kmod-lib-zlib-inflate
* pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.165-1-9309db0b721b9fb3fe826181264a78c4) for kmod-lib-zlib-deflate
* pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.165-1-9309db0b721b9fb3fe826181264a78c4) for kmod-nf-reject
* pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.165-1-9309db0b721b9fb3fe826181264a78c4) for kmod-nf-ipt
* pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.165-1-9309db0b721b9fb3fe826181264a78c4) for kmod-nf-log
* pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.165-1-9309db0b721b9fb3fe826181264a78c4) for kmod-ipt-core
* pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.165-1-9309db0b721b9fb3fe826181264a78c4) for kmod-nf-reject6
* pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.165-1-9309db0b721b9fb3fe826181264a78c4) for kmod-nf-log6
* pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.165-1-9309db0b721b9fb3fe826181264a78c4) for kmod-nft-core
* pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.165-1-9309db0b721b9fb3fe826181264a78c4) for kmod-nf-ipt6
* pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.165-1-9309db0b721b9fb3fe826181264a78c4) for kmod-ip6tables
* pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.165-1-9309db0b721b9fb3fe826181264a78c4) for kmod-br-netfilter
* pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.165-1-9309db0b721b9fb3fe826181264a78c4) for kmod-nf-flow
* satisfy_dependencies_for: Cannot satisfy the following dependencies for dockerd:
*     kernel (= 5.10.165-1-9309db0b721b9fb3fe826181264a78c4)
* opkg_install_cmd: Cannot install package dockerd.


I co z tym zrobić?

21

Odp: Docker w OpenWrt

Zainstalować moduły z tego samego źródła skąd masz obraz. Jeżeli to twój obraz to zainstaluj modułu od siebie a nie z repo openwrt.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

22

Odp: Docker w OpenWrt

@Cezary mam od Ciebie obraz smile

23

Odp: Docker w OpenWrt

Nie piszesz całej prawdy. Ja jeszcze nie zbudowałem obrazu z kernelem  5.10.165, on się pojawił dopiero tydzień temu. Albo włączyłeś sobie w opkg repozytoria które powinny zostać wyłączone.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

24

Odp: Docker w OpenWrt

oooo, tak włączyłem repozytoria smile I co wyłączyć je? Czy jak tongue

25

Odp: Docker w OpenWrt

Jak to teraz rozwalić ... ?