1 (edytowany przez Skubi 2021-10-22 08:20:37)

Temat: Mikrotik konfiguracja jako switch?

Hej,
W tym momencie konfiguracja sieci wygląda w ten sposób, że idą kable do salonu tam podpięty jest router WAN po PPPoE (do niego wszystkie urządzenia) i wszystko gra. Okazało się, że w skrzynce na korytarzu mam drugi kabel który idzie do drugiego pokoju gdzie chciałbym podłączyć inny komputer do sieci po kablu. Kupiłem mikrotika hap AC2 i zastanawiam się czy taka konfiguracja jaką narysowalem na schemacie poniżej jest możliwa? https://imgur.com/a/Il4Yd7x
Chciałbym, żeby nadal router Netgeara był głównym i zarządzał całą siecią, natomiast mikrotik robił w tym wypadku bardziej za switcha, czyli podał dalej kabel WAN do Netgeara oraz połączył drugi pokój z nim.
W jaki sposób powinienem skonfigurować mikrotika?

Chciałbym uniknąć jeżeli możliwe konfiguracji w której mikrotik gra 1 skrzypce (cały firewall, vpn itd..), a Netgear jest tylko AP. Z prostej przyczyny. Nie potrafię zarządzać mikrotikiem, ale to był jedyny mały, który mieści się w skrzynce..

2

Odp: Mikrotik konfiguracja jako switch?

W ogóle nie konfigurujesz? Jak podłączysz kabel pod dowolny router który nie ma skonfigurowany vlanów to będzie robił za switcha. Wystarczy że ma zasilanie, najczęściej nawet nie potrzebuje systemu do działania.

Ustaw tylko na nim hasło że nikt się do niego niego nie dostał.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

3

Odp: Mikrotik konfiguracja jako switch?

W sensie, że nie mam doświadczenia w jego konfigurowaniu. Ogólnie po podłączeniu się do niego kablem przydziela IP z jego puli, także nie zadziała to do końca tak jakbym chciał out of box i potrzebuję małej pomocy.

4

Odp: Mikrotik konfiguracja jako switch?

Wyłącz serwer dhcp, ip -> dhcp serwer, masz default, wyłącz go lub usun.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

5 (edytowany przez Skubi 2021-10-22 09:43:53)

Odp: Mikrotik konfiguracja jako switch?

ok czyli wyłączam DHCP i kable łączę jak na diagramie i powinno grać w sensie Netgear przydzieli adresy po DHCP?
Zastanawiam się jeszcze jak ustawić do w tryb repeatera WIFI obecnej sieci z Netgeara..

6

Odp: Mikrotik konfiguracja jako switch?

Nie, jeżeli netgeara podłączysz pod wan to nic nie przydzieli. A podłączyć pod lan nie chesz, bo byś udostępnił swój lan całemu światu. Podłączając tak switcha masz po prostu switch podłączony pod wany, a nie że spina ci to sieci lokalne.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

7

Odp: Mikrotik konfiguracja jako switch?

Nie wiem czegoś nie rozumiem. Obecnie mam WAN > Netgear i wszystko gra. Teraz pomiędzy chcę wsadzić tego mikrotika, ale żeby był jedynie switchem (a zarządzał siecią dalej Netgear i on był wyrzucony na świat) + dopiął do tego drugi pokój z kablem LAN.

8

Odp: Mikrotik konfiguracja jako switch?

Drugi pokój masz dopiąć do lan netgera. Jak wepniesz drugi pokój w mikrotika to będzie wpięty do wanu netgeara a nie do lanu. Logicznie, nie?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

9 (edytowany przez Skubi 2021-10-22 11:11:42)

Odp: Mikrotik konfiguracja jako switch?

Nie jestem w stanie podłączyć drugiego pokoju do lanu netgeara
Teraz idzie WAN prosto do WAN Salon + LAN w skrzynce do pokoju wisi luzem.
Jak ten WAN rozetnę będę miał w skrzynce jak niżej WAN + LAN do salon + LAN do pokój

10 (edytowany przez Cezary 2021-10-22 18:16:53)

Odp: Mikrotik konfiguracja jako switch?

Najgłupszy sposób - zrób sobie vpna w drugiego pokoju do negeara.
Bardziej skompilowany - uczyń mikrotika routerem zamiast netgeara
Jeszcze inny - zrób na netgearze vlany żeby ruch z lanu szedł także vlanem na wan i tym samym do drugiego pokoju.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

11

Odp: Mikrotik konfiguracja jako switch?

W tym momencie pokój z boku jest zupełnie odłączony od sieci i kabel wisi w skrzynce i wychodzi w ścianie. Nie jestem zatem w żaden sposób go magicznie podłączyć. Jedyne miejsce, gdzie 3 kable się spotykają to skrzynka w której aktualnie WAN idzie bezpośrednio i wchodzi do Salonu, gdzie podłączony jest do Netgeara. Mikrotika mógłbym zrobić routerem. Przeciąć w skrzynce kabel który idzie w salon wpiąć mu WAN do WAN, a dalej LANY w lewo salon (netgeara zrobić AP) i prawo pokój tylko to wiąże się z rekonfiguracją całej sieci, a obecnie wszystko mam ustawione na Netgearze hmm przekierowania portów itd... w OpenWRT wiem wszystko, natomiast z mikrotikiem mam pierwszy raz styczność i zupełnie nie wiem jak się za to zabrać x) to jedyny mały router, który wchodzi do skrzynki..

12

Odp: Mikrotik konfiguracja jako switch?

Jakaś podpowiedź jak to spiąć, żeby miało ręce i nogi? sad

13

Odp: Mikrotik konfiguracja jako switch?

A żaden z podanych przeze mnie trzech sposobów Ci nie pasuje?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

14

Odp: Mikrotik konfiguracja jako switch?

praktycznie sam sobie odpowieziałeś na pytanie  . skoro w skrzyce masz 3 kable ( zasilanie wan , lan salon , lan pokój )  to  wypnij netgara z salonu zanies do skrzynki  i  wepnij   i tyle  , nic nie musisz  zmieniać   - chyba ze chcesz dodatkowy AP w salonie  to tam  dopnij  mikrotika   -  pewnie  ktos  kto rozprowadzał te kable  tak to miał  rozplanowane  ze router główny bedzie w skrzynce

15

Odp: Mikrotik konfiguracja jako switch?

Nie może bo się nie zmieści...

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

16 (edytowany przez Skubi 2021-10-23 10:07:58)

Odp: Mikrotik konfiguracja jako switch?

Dokładnie jak wyżej. Nie mogę wypiąć Netgeara i go przenieść do przedpokoju.

"Jeszcze inny - zrób na netgearze vlany żeby ruch z lanu szedł także vlanem na wan i tym samym do drugiego pokoju."
Czy tym sposobem netgear zostanie głównym routerem, a mikrotik tylko wszystko połączy?

W Netgearze w salonie wszystkie porty LAN mam zajęte przez różne urządzenia. Jak miałoby wyglądać połączenie?

Dobrze rozumiem, że mikrotik miałby być wpięty w porty 1 > Salon WAN ; 2 > Pokój ?

Czy ewentualnie mogę skonfigurować mikrotika, żeby był jedynie odbiorcą WAN po PPPoE (robił za router), a dalej zarządzał siecią na zewnątrz Netgear?

17 (edytowany przez ad2014 2021-10-23 11:00:49)

Odp: Mikrotik konfiguracja jako switch?

zapoznaj się z tym https://eko.one.pl/?p=openwrt-vlan
oraz z tym https://eko.one.pl/?p=openwrt-vlan  zwróć uwage że w nowym wydaniu openwrt robi się to troche inaczej z wykorzystaniem DSA - jest tez gdzies watek o tym na openwrt  dobrze to  opisujacy
to jest tu : https://forum.openwrt.org/t/mini-tutori … nfig/96998

18 (edytowany przez Skubi 2021-10-23 13:24:37)

Odp: Mikrotik konfiguracja jako switch?

ad2014 napisał/a:

zapoznaj się z tym https://eko.one.pl/?p=openwrt-vlan
oraz z tym https://eko.one.pl/?p=openwrt-vlan  zwróć uwage że w nowym wydaniu openwrt robi się to troche inaczej z wykorzystaniem DSA - jest tez gdzies watek o tym na openwrt  dobrze to  opisujacy
to jest tu : https://forum.openwrt.org/t/mini-tutori … nfig/96998


Zamieściłeś pierwsze dwa adresy takie same.
Czytam ten tutorial z forum i jaki miałby być u mnie zamysł? Jak podłączyć mikrotika i co w nim ustawić oraz jakie VLANy na netgearze?
W dalszym ciągu zależy mi na tym, żeby to Netgear był wyjściem na świat i całą konfiguracją, a mikrotik jedynie spinał dwa pokoje..

19

Odp: Mikrotik konfiguracja jako switch?

"Jeszcze inny - zrób na netgearze vlany żeby ruch z lanu szedł także vlanem na wan i tym samym do drugiego pokoju."
Zrobienie VLAN, żeby cały LAN szedł VLANEM na WAN jeszcze rozumiem, ale już "tym tamym do drugiego pokoju" nie bardzo..
Czytam i głupi jestem z tego wszystkiego. Trzeba było chyba zainwestować w jakiegoś switcha po prostu...

20

Odp: Mikrotik konfiguracja jako switch?

W linkach o vlanie masz to. Zamiast lanu dajesz tagowany vlan, coś jak w sieci gościnnej na ap.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

21

Odp: Mikrotik konfiguracja jako switch?

W Mikrotiku wyłączam DHCP. Wpinam się kablami w skrzynce jako zwykłe porty pomijając WAN mikrotika i jak następnie
przesstawiam /etc/config/network ?
Poniżej obecna konfiguracja

config interface 'loopback'
    option device 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fd60:df33:ed15::/48'

config device
    option name 'br-lan'
    option type 'bridge'
    list ports 'eth1.1'

config interface 'lan'
    option device 'br-lan'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ip6assign '60'

config interface 'wan'
    option proto 'pppoe'
    option username 'username'
    option password 'password'
    option ipv6 'auto'
    list dns '8.8.8.8'
    list dns '8.8.4.4'
    option peerdns '0'
    option device 'eth0.2'

config interface 'wan6'
    option device 'eth0.2'
    option proto 'dhcpv6'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '1 2 3 4 6t'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '5 0t'

config interface 'vpn'
    option proto 'none'
    option device 'tun0'

22

Odp: Mikrotik konfiguracja jako switch?

Ale to jest konfiguracja czego? Tego netgeara który robi za główny?  Zmień linie

option ports '1 2 3 4 6t'

na

option ports '1 2 3 4 5t 6t'

Wtedy w komputerze w drugim pokoju jeżeli to windows - vlan na 2 w ustawieniach karty sieciowej.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

23

Odp: Mikrotik konfiguracja jako switch?

Tak to wyżej to konfiguracja Netgeara, który ma w dalszym ciągu robić za główny router.

W laptopie mam kartę LAN Killer E3100G i nie mogę się doszukać jak przestawiać w niej VLANy..

24

Odp: Mikrotik konfiguracja jako switch?

Albo jest w we właściwościach sterownika albo do ustawienia w tym dedykowanym sofcie intela do karty sieciowej. Szukaj.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

25 (edytowany przez Skubi 2021-10-27 11:39:49)

Odp: Mikrotik konfiguracja jako switch?

Właśnie wszystkie to oprogramowanie od killera mam wyłączone, bo miałem problemy z połączeniem się do firmowego VPNa jak te serwisy od "killera" działały w tle i dopiero ich zablokowanie pomogło x)
W ustawieniach sterownika nie ma... nic no musze pogrzebać.

@Cezary czy to tutaj:
https://i.imgur.com/fllo7Or.png

?