Temat: Orange światłowód / neostrada i IPv4 + IPv6

Z miesiąc temu kupiłem internet po światłowodzie od orange, przekonując z sukcesem salon, infolinię i technika żeby dali mi ONT + Funbox 2.0 (bo z 3.0 nie da się pdłączyć własnego routera [1]). Funbox wrócił do pudełka, w jego miejsce postawiłem router z openwrt/lede. Czyli: [skrzynka orange]--(światłowód)--[ONT]--(skrętka)--[openwrt/lede].
Parę dni temu znalazłem czas żeby sprawdzić co robi '/ipv6' w loginie z umowy o neostradę (o którym technik powiedział "że tego się nie wpisuje" ;-) ).

W efekcie udało mi się dostać konfigurację w której dostaję adres IPv4 (dynamiczny, jak to w Polsce jest normą) i prefix IPv6 (stały). Nie natknąłem się nigdzie na opis takiej konfiguracji szperając w internecie, więc zdecydowałem się go tu wrzucić – może się komuś przyda (a wierzyć w kompetentną pomoc ze strony wsparcia technicznego dostawcy neostrady są zdolni chyba tylko ludzie obdarzeni bezgranicznym optymizmem).

Podsumowując:

  • internet w światłowodzie jest na vlanie 35

  • na tym vlanie da się nawiązać sesję PPPoE na użytkownika xxx@neostrada.pl i dostać adres IPv4

  • na tym vlanie da się równocześnie nawiązać drugą sesję PPPoE na użytkownika xxx@neostrada.pl/ipv6 i dostać prefix IPv6 (i opcję dhcpv6 konfigurującą DS-lite, którą olewam skoro mam publiczne IPv4)


Fragmenty z konfiguracji (u mnie stoi Archer C2, ale poza numerami portów na switchu konfiguracja powinna działać z wszystkim):

  • switch w sprzęcie ustawiony tak, żeby na porcie 6-tym (do procesora, eth0) szedł ruch tagowany z vlanu 35 i 1 (LAN), a na porcie 0-wym (skrętka od ONT) szedł ruch tagowany z vlanu 35.

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '1 2 3 4 6t'

config switch_vlan
    option device 'switch0'
    option vlan '35'
    option ports '0t 6t'
  • konfiguracja PPPoE dla IPv4 

config interface 'wan'
    option ifname 'eth0.35'
    option proto 'pppoe'
    option username 'xxx@neostrada.pl'
    option password 'xxx'
  • konfiguracja PPPoE dla IPv6 

config interface 'wan6'
    option ifname 'eth0.35'
    option proto 'pppoe'
    option username 'xxx@neostrada.pl/ipv6'
    option password 'xxx'
    option ipv6 'auto'

I w sumie... tyle.

Taka konfiguracja daje na interfejsie sesji PPP dla IPv6 tylko adres link-local (fe80::), ale ustawia na głównym interfejsie sieci lokalnej (u mnie br-lan) adres IPv6 z delegowanego prefiksu i włącza rozgłaszanie prefiksu (razem z RDNSS) po sieci lokalnej. Dla IPv4 dostaję normalne IP na interfejsie sesji PPP.
Poniżej wyniki konfiguracji:

# ip addr
12: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
   (...)
   inet6 2a01:114f:4301:xxxx::1/60 scope global noprefixroute dynamic 
       valid_lft 83500sec preferred_lft 83500sec
   (...)
88: pppoe-wan6: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 qdisc fq_codel state UNKNOWN group (…)
    link/ppp 
    inet6 fe80::f50b:54a0:83c6:803c/10 scope link 
       valid_lft forever preferred_lft forever
89: pppoe-wan: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 qdisc fq_codel state UNKNOWN group (…)
    link/ppp 
    inet 188.47.28.21 peer 83.1.4.252/32 scope global pppoe-wan
       valid_lft forever preferred_lft forever
# ip -6 route
default from 2a01:114f:4301:xxxx::/56 via fe80::f21c:2dff:fe2a:374a dev pppoe-wan6  proto static  metric 512  pref medium
2a01:114f:4301:xxxx::/64 dev br-lan  proto static  metric 1024  pref medium
unreachable 2a01:114f:4301:xxxx::/56 dev lo  proto static  metric 2147483647  error -148 pref medium

Parę jeszcze szczegółów dotyczących tego IPv6:

  1. Delegowany prefix jest /56, nie wiem dlaczego openwrt/lede sobie wybiera z tego akurat adres /60. Za to rozgłasza w sieci lokalnej prefix /64 i trasę do /56.

  2. Po PPPoE konfiguracja IPv6 leci przez stateful autocofiguration (NDP+DHCPv6).

  3. DHCPv6 przesyła opcję "Dual-Stack Lite AFTR Name" do konfiguracji DS-lite (ja dostaję np. node07.cgn.tpnet.pl). Zapewne funboxy mają w ten sposób łączność do IPv4 po sieci IPv6. (DS-lite to tunelowanie ruchu IPv4 – pakiety z prywatnymi IPv4 lecą przez sieć IPv6 do urządzenia u dostawcy usługi które robi NATa, [2]).  Poza DS-lite po DHCPv6 dostaję tylko prefiks i serwer DNS.

  4. Zapewne po dodaniu pakietu ds-lite dodałoby mi tunelowanie IPv4 przez ten DS-Lite AFTR, ale tego nie chcę, więc nie próbowałem.

W końcu mogę powiedzieć że mój ISP daje IPv6. Ale tunel z HE jeszcze na chwilę zostawiam ;-) (choć konfiguracja dwóch WANów do ipv6 z openwrt/lede do przyjemnych zdecydowanie nie należy jeśli się chce ustawić jeden jako główny, drugi jako zapasowy).

2

Odp: Orange światłowód / neostrada i IPv4 + IPv6

Tu coś więcej: https://trzepak.pl/viewtopic.php?f=20&t=51177

3

Odp: Orange światłowód / neostrada i IPv4 + IPv6

Powtórzyłem podobną konfigurację na neostradzie. Dwa interfejsy pppoe, jeden z loginem /ipv6, drugi zwykły. Dostałem tak jak kolega 2 niezależne adresy, w tym publiczny ipv4.
ALE, konfiguracja działała poprawnie tylko przez 5 dni, potem pojawił się parmanentny błąd autoryzacji na obu interfejsach.
Najwyraźniej Orange ma automat, który sprawdza czy nie ma podwójnego logowania na tego samego użytkownika.
Powrót do pojedynczego interfejsu pppoe (obojętnie czy ipv4, czy ipv6) dał znów poprawną autoryzację.
Podobnie jak ze światłowodem PD jest /56.
Nie udało mi się natomiast skonfigurować DS-Lite. Zamiast tunelu powiązanego z interfejsem WAN, powstaje automatycznie nowy interfejs o nazwie w stylu wan6_4_4, i do jego konfiguracji nie ma dostępu.