1

Temat: Raspberry Pi + Logitech media server - problem z instalacją :(

Witam
Od wczoraj jestem posiadaczem Raspberry Pi  i próbuje sobie coś tam na niej skonfigurować ale pojawiają się problemy...

Domoticz odpalił bez większych problemów - znalazłem doby opis w sieci...
Przeglądając różne projekty na Raspberry trafiłem na Logitech Media Server + Squeezbox , który bardzo mi się spodobał ale nie mogę zainstalować tego ustrojstwa - może Coś mi podpowiecie...

Robię to wg tego opisu:
http://cezarowy.blogspot.com/2017/02/ra … party.html

pi@raspberrypi:~ $ sudo dpkg -i logitechmediaserver_all.deb
(Odczytywanie bazy danych ... 139323 pliki i katalogi obecnie zainstalowane.)
Przygotowywanie do rozpakowania pakietu logitechmediaserver_all.deb ...
Rozpakowywanie pakietu logitechmediaserver (7.9.1) nad (7.9.1) ...
dpkg: problemy z zaleĹźnoĹiami uniemoĹźliwiajÄ
 skonfigurowanie pakietu logitechmediaserver:
 logitechmediaserver zaleĹźy od libio-socket-ssl-perl; jednakĹźe:
  Pakiet libio-socket-ssl-perl nie jest zainstalowany.

dpkg: bĹÄ
d przetwarzania pakietu logitechmediaserver (--install):
 problemy z zaleĹźnoĹiami - pozostawianie nieskonfigurowanego
^[[?6c^[[?6cPrzetwarzanie wyzwalaczy pakietu systemd (232-25+deb9u6)...
WystÄ
piĹy bĹÄdy podczas przetwarzania:
 logitechmediaserver
pi@raspberrypi:~ $ 6c6clibio-socket-ssl-perl
-bash: 6c6clibio-socket-ssl-perl: nie znaleziono polecenia
pi@raspberrypi:~ $
pi@raspberrypi:~ $ sudo apt-get install -y libio-socket-ssl-perl
Czytanie list pakietĂłw... Gotowe
Budowanie drzewa zaleĹźnoĹi
Odczyt informacji o stanie... Gotowe
NaleĹźy uruchomiÄ "apt --fix-broken install", aby je naprawiÄ.
NastÄpujÄ
ce pakiety majÄ
 niespeĹnione zaleĹźnoĹi:
^[[?6c libio-socket-ssl-perl : Wymaga: libnet-ssleay-perl (>= 1.59) ale nie zostanie zainstalowany
                         Poleca: libnet-libidn-perl ale nie zostanie zainstalowany lub
                                 libnet-idn-encode-perl ale nie zostanie zainstalowany lub
                                 liburi-perl ale nie zostanie zainstalowany
E: NiespeĹnione zaleĹźnoĹi. ProszÄ sprĂłbowaÄ wykonaÄ "apt --fix-broken install" bez pakietĂłw (lub podaÄ rozwiÄ
zanie).
^[[?6cpi@raspberrypi:~ $ apt --fix-broken install libio-socket-ssl-perl
E: Nie udaĹo siÄ otworzyÄ pliku blokady /var/lib/dpkg/lock - open (13: Brak dostÄpu)
E: Nie udaĹo siÄ zablokowaÄ katalogu administracyjnego (/var/lib/dpkg/), czy uĹźyto uprawnieĹ
              administratora?
pi@raspberrypi:~ $

Co począć z tym błędem?

Pozdrawiam.

Sprzedam: Tp-link WDR3600 16MB, 4xUSB, OC , Tenda AC15 - fabrycznie nowa! , Easybox 904xdsl, Sagemcom Fast 2704.

Netgear R6220 + Huawei 3372 HiLink LTE,   Brother DCP- J125
Nexx WT3020 Gargoyle + webcam Creative Vista! IM

2

Odp: Raspberry Pi + Logitech media server - problem z instalacją :(

Zależności. Znajdź pakiet libio-socket-ssl-perl do rasbiana.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

3 (edytowany przez edass 2019-01-01 18:11:36)

Odp: Raspberry Pi + Logitech media server - problem z instalacją :(

Właśnie nie obczajam tego...

pi@raspberrypi:~ $ sudo dpkg -i logitechmediaserver_all.deb
(Odczytywanie bazy danych ... 139323 pliki i katalogi obecnie zainstalowane.)
Przygotowywanie do rozpakowania pakietu logitechmediaserver_all.deb ...
Rozpakowywanie pakietu logitechmediaserver (7.9.1) nad (7.9.1) ...
dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie pakietu logitechmediaserver:
 logitechmediaserver zależy od libio-socket-ssl-perl; jednakże:
  Pakiet libio-socket-ssl-perl nie jest zainstalowany.

dpkg: błąd przetwarzania pakietu logitechmediaserver (--install):
 problemy z zależnościami - pozostawianie nieskonfigurowanego
Przetwarzanie wyzwalaczy pakietu systemd (232-25+deb9u6)...
Wystąpiły błędy podczas przetwarzania:
 logitechmediaserver
pi@raspberrypi:~ $ sudo apt-get install libio-socket-ssl-perl
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności
Odczyt informacji o stanie... Gotowe
Należy uruchomić "apt --fix-broken install", aby je naprawić.
Następujące pakiety mają niespełnione zależności:
 libio-socket-ssl-perl : Wymaga: libnet-ssleay-perl (>= 1.59) ale nie zostanie zainstalowany
                         Poleca: libnet-libidn-perl ale nie zostanie zainstalowany lub
                                 libnet-idn-encode-perl ale nie zostanie zainstalowany lub
                                 liburi-perl ale nie zostanie zainstalowany
E: Niespełnione zależności. Proszę spróbować wykonać "apt --fix-broken install" bez pakietów (lub podać rozwiązanie).
pi@raspberrypi:~ $ sudo apt-get install -y libnet-ssleay-perl
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności
Odczyt informacji o stanie... Gotowe
Należy uruchomić "apt --fix-broken install", aby je naprawić.
Następujące pakiety mają niespełnione zależności:
 libnet-ssleay-perl : Wymaga: perl-openssl-abi-1.1
 logitechmediaserver : Wymaga: libio-socket-ssl-perl ale nie zostanie zainstalowany
E: Niespełnione zależności. Proszę spróbować wykonać "apt --fix-broken install" bez pakietów (lub podać rozwiązanie).
pi@raspberrypi:~ $ apt --fix-broken install libio-socket-ssl-perl
E: Nie udało się otworzyć pliku blokady /var/lib/dpkg/lock - open (13: Brak dostępu)
E: Nie udało się zablokować katalogu administracyjnego (/var/lib/dpkg/), czy użyto uprawnień administratora?
pi@raspberrypi:~ $

----------Rozwiązane-------------------
Trzeba było wpisać:
sudo apt --fix-broken install

Sprzedam: Tp-link WDR3600 16MB, 4xUSB, OC , Tenda AC15 - fabrycznie nowa! , Easybox 904xdsl, Sagemcom Fast 2704.

Netgear R6220 + Huawei 3372 HiLink LTE,   Brother DCP- J125
Nexx WT3020 Gargoyle + webcam Creative Vista! IM