101

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

Pomyśl trochę proszę. Nie /dev/ttyHSX tylko /dev/ttyHS0, /dev/ttyHS1 czy /dev/ttyHS55, w zależności ile i jakie porty masz. Skąd mam wiedzieć ile tych portów jest u ciebie?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

102

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

Sory, teraz takie odp :

root@OpenWrt:~# gcom -d /dev/ttyHS0 reg
Waiting for Registration.............................................................
Failed to register
root@OpenWrt:~# gcom -d /dev/ttyHS0 info
##### Wireless WAN Modem Configuration #####
Product text:
====

====
Manufacturer:
IMEI and Serial Number:
Manufacturer's Revision: comgt 16:22:57 -> -- Error Report --
comgt 16:22:57 -> ---->                      ^
comgt 16:22:57 -> Error @982, line 56, String is shorter than second argument. (7)

root@OpenWrt:~#

103

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

Inne porty sprawdź. Nie na wszystkich odpowiada.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

104 (edytowany przez grisha 2013-11-15 04:09:05)

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

root@OpenWrt:~# gcom -d /dev/ttyHS1 reg
Waiting for Registration
Registered on Roaming network: "Aero2",2
root@OpenWrt:~# gcom -d /dev/ttyHS1 info
##### Wireless WAN Modem Configuration #####
Product text:
====

Manufacturer: Option N.V.
Model: GI0505
Revision: 3.19.0 (Date: Mar 16 2010, Time: 15:03:03)
OK
====
Manufacturer:           Option N.V.
IMEI and Serial Number: 353625034111325,ZR19ACA3CT
Manufacturer's Revision:
3.19.0 (Date: Mar 16 2010, Time: 15:03:0
Hardware Revision:      1.1
Network Locked:         0
Customisation:

Band settings:          Europe 900/1800MHz (4)
APN:                    1,"IP","darmowy","",0,0
##### END #####
root@OpenWrt:~#

Czyli  rejestruje się w aero ale nie działa. Co mam zrobić żeby ruszył ?

105

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

Cały czas przy każdej próbie uruchomienia jest :

root@OpenWrt:~# hso.sh
(hso): Failed to connect and obtain IP address.
root@OpenWrt:~#

106

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

Uruchom polecenia ręcznie i zobaczysz.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

107

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

W Luci daję connect i nic się nie dzieje.

108

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

W luci nie masz dawać connect bo to nic nie przyniesie. Skrypt powoduje połączenie a nie samo ifup wan

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

109

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

W końcu połączył (zmieniłem go z wan6 na wan) :
root@OpenWrt:~# ifup wan
root@OpenWrt:~# hso.sh
root@OpenWrt:~#
Prawdopodobnie inne modemy w hubie działajęce w tym multiwanie powodują niestabilność i problem w nawiązaniu łącza.
Jak to można zautomatyzować (hso.sh) ?
Będę testował.
Wielkie dzięki za pomoc.

110

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

W cronie? W monitorze połączenia? W skrypcie startowym?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

111

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

Dodałem do etc\rc.local
hso.sh
i rusza po kilku sekundach.

112

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

Cezary napisał/a:

W cronie? W monitorze połączenia? W skrypcie startowym?

Bardzo bym prosił jakiś przykład, bo w multiwanie hso0 nie chce samo wystartować -muszę wysłać przez putty :

| Gargoyle PL 1.5.11.2 (22b6434)                               |
| OpenWrt Attitude Adjustment 12.09.1 (r38621)                 |
| Build time: 2013-11-13 19:38 CET                             |
|                                                              |
| Cezary Jackiewicz (obsy), http://eko.one.pl                  |
|                                                              |
----------------------------------------------------------------
| Machine: TP-Link TL-MR3420 v1                                |
| Uptime: 0d, 00:10:01                                         |
| Load: 0.00 0.04 0.05                                         |
| Flash: total: 384.0K, free: 68.0K, used: 82%                 |
| Memory: total: 29228K, free: 16488K, used: 43%               |
| WAN:                                                         |
| LAN: 192.168.0.1                                             |
| WLAN: mode: ap, ssid: Gargoyle, channel: 4, conn: 1          |
----------------------------------------------------------------
root@Gargoyle:~# hso.sh
root@Gargoyle:~#

113

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

Dodaj go do /etc/rc.local, z jakimś opóźnieniem żeby urządzenie zdążyło się wykryć. Albo wywołaj to w /etc/hotplug.d/ifname.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

114

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

Opóźnnienie w /etc/rc.local np. sleep 5 nic nie daje.
Dodałem ifname w /etc/hotplug.d i rusza po wydaniu polecenia własnego hso.sh, jednak po wyłączeniu z prądu i włączeniu nadal hso nie rusza.
Proszę jeszce o sugestie w tym temacie, bo może coś źle robię.

115

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

Sorry, iface miało być. I właśnie tam hso.sh wołasz w skrypcie.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

116

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

Wpisałem polecenie własne hso.sh do /etc/hotplug.d/iface, jest na liście i hso startuje jak wywołam go tam. Po wyłączeniu z prądu i ponownym włączeniu nie startuje sam z automatu.
To jak to ugryźć żeby zadziałało ?

117

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

A w logach co masz?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

118

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

Doszedłem metodą prób i błędów, że interface hso w Gargoyle musi się nazywać wan (nie wan1 itd.).

| Gargoyle PL 1.5.11.2 (22b6434)                               |
| OpenWrt Attitude Adjustment 12.09.1 (r38621)                 |
| Build time: 2013-11-13 19:38 CET                             |
|                                                              |
| Cezary Jackiewicz (obsy), http://eko.one.pl                  |
|                                                              |
----------------------------------------------------------------
| Machine: TP-Link TL-MR3420 v1                                |
| Uptime: 0d, 00:04:04                                         |
| Load: 0.15 0.18 0.08                                         |
| Flash: total: 384.0K, free: 72.0K, used: 81%                 |
| Memory: total: 29228K, free: 16356K, used: 44%               |
| WAN:                                                         |
| LAN: 192.168.0.1                                             |
| WLAN: mode: ap, ssid: Gargoyle, channel: 11, conn: 1         |
----------------------------------------------------------------
root@Gargoyle:~# gcom -d /dev/ttyHS1 reg
Waiting for Registration
Registered on Roaming network: "Aero2",2
root@Gargoyle:~# gcom -d /dev/ttyHS1 info
##### Wireless WAN Modem Configuration #####
Product text:
====

Manufacturer: Option N.V.
Model: GI0505
Revision: 3.19.0 (Date: Mar 16 2010, Time: 15:03:03)
OK
====
Manufacturer:           Option N.V.
IMEI and Serial Number: 353625034111325,ZR19ACA3CT
Manufacturer's Revision:
3.19.0 (Date: Mar 16 2010, Time: 15:03:0
Hardware Revision:      1.1
Network Locked:         0
Customisation:

Band settings:          Europe 900/1800MHz (4)
APN:                    1,"IP","darmowy","",0,0
##### END #####
root@Gargoyle:~#

Bez mwn3 i bez drugiego modemu w hubie startuje z automatu na takim wpisie w /etc/rc.local
sleep 2
hso.sh

exit 0

Po dodaniu drugiego modemu i włączeniu do prądu nie wystartuje już sam - trza albo poleceniem własnym hso.sh w  /etc/hotplug.d/iface (jest dodane na stałe ale trzeba go kliknąć) albo przez putty.

Może jest jeszcze inny sposób na autostart hso ?

119

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

No jako wan, nie coś innego. Nie ma, dopóki ktoś to nie przepisze tego na normalne połączenie dla netifd.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

120

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

Na mwn3 rusza hso ale tylko jak jest jeden modem (option) w hubie, po załapaniu można wpiąć drugi modem (np. e3131 -tak jak jest ustawiony multiwan) i wtedu działają dwa.
Jak podczas odpalenia są dwa modemy to hso nie startuje sam i trza ręcznie go wywołać.
Czyli teraz nie ma na to jakiejś rady ?

121

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

Teraz nie.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

122

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

Albo odwrotnie :
(w moim przypadku)
ażeby cdc-ether podłączał się z opóźnieniem np 3min po hso
?

123

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

Wywołaj hso, zrób sleep na 3min a później ifup wan2?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

124

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

Tylko że wan2 to cdc-ether i podłącza się błyskawicznie jeszcze nawet przed wifi.

125

Odp: Nowe wersje skryptów HSO, NDIS i QMI dla modemów 3G/LTE

Oj, problemów coś szukasz cały czas. Sprawdź czy jest połączenie przez hso i wtedy odpal to drugie. Albo wręcz zmień ten skrypt hso.sh żeby po nawiązaniu połączenia robił ifup wan2.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.