26

Odp: Oscam pod OpenWRT X86_64, pomocy :)

To już gadaj z developerami  oscama

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

27

Odp: Oscam pod OpenWRT X86_64, pomocy :)

a co masz w pliku oscam.version ?  możesz wkleić

28 (edytowany przez onken 2019-09-09 17:57:20)

Odp: Oscam pod OpenWRT X86_64, pomocy :)

W tunerze wykrywa poprawnie:

2019/09/09 18:15:18 02A4425B r (reader) nc+ [nagra merlin]

ten co nie działa na routerze )
OSCam: 1.20_svn Build: r11539 Compiler: x86_64-openwrt-linux-musl

A w version mam:

Unix starttime: 1568046095
Starttime:      09.09.2019 18:21:35
Version:        oscam-1.20_svn-r11539
Compiler:       x86_64-openwrt-linux-musl
Box type:       generic (generic)
PID:            18481
TempDir:        /tmp/.oscam
GBox tmp_dir:   not defined using: /tmp/.oscam
ConfigDir:      /root/oscam/B_1/

A tutaj działający poprawnie na tunerze:

Unix starttime: 1568031605
Starttime:      09.09.2019 14:20:05
Version:        oscam--r11546
Compiler:       arm_dream-ssl-libusb
Box type:       vuuno4k (generic)
PID:            23826
TempDir:        /tmp/.oscam
GBox tmp_dir:   not defined using: /tmp/.oscam
ConfigDir:      /usb/config/oscam_te

Mozna wogole pobrać skądś toolchaina do tego routera i do simplbuild3 ??

29

Odp: Oscam pod OpenWRT X86_64, pomocy :)

to jest cały oscam.version ja mam inny oscam w tunerze i tam nizej sa podane z jakimi obcjami był kopilowany oscam cos takiego

Web interface support:                   yes
LiveLog support:                         yes
jQuery support intern:                   yes
Touch interface support:                 no
SSL support:                             yes
DVB API support:                         yes
DVB API with AZBOX support:              no
DVB API with MCA support:                no
DVB API with COOLAPI support:            no
DVB API with COOLAPI2 support:           no
DVB API with STAPI support:              no
DVB API with STAPI5 support:             no
DVB API with NEUTRINO support:           no
DVB API read-sdt charsets:               yes
Irdeto guessing:                         yes
Anti-cascading support:                  no
Debug mode:                              yes
Monitor:                                 yes
Loadbalancing support:                   yes
Cache exchange support:                  no
CW Cycle Check support:                  no
LCD support:                             no
LED support:                             no
Clockfix with realtime clock:            no
IPv6 support:                            no
Emulator support:                        yes
Built-in SoftCam.Key:                    yes

camd 3.3x:                               no
camd 3.5 UDP:                            yes
camd 3.5 TCP:                            yes
newcamd:                                 yes
CCcam:                                   yes
CCcam share:                             yes
gbox:                                    yes
radegast:                                no
scam:                                    yes
serial:                                  no
constant CW:                             no
Pandora:                                 no
ghttp:                                   no

Reader support:                          yes

Nagra:                                   yes
Nagra Merlin:                            yes
Irdeto:                                  yes
Conax:                                   yes
Cryptoworks:                             yes
Seca:                                    yes
Viaccess:                                yes
NDS Videoguard:                          yes
DRE Crypt:                               yes
TONGFANG:                                yes
Bulcrypt:                                yes
Griffin:                                 yes
DGCrypt:                                 yes

cardreader_phoenix:                      yes
cardreader_drecas:                       no
cardreader_internal_azbox:               no
cardreader_internal_coolapi:             no
cardreader_internal_coolapi2:            no
cardreader_internal_sci:                 yes
cardreader_sc8in1:                       no
cardreader_mp35:                         no
cardreader_smargo:                       no
cardreader_pcsc:                         no
cardreader_smartreader:                  no
cardreader_db2com:                       no
cardreader_stapi:                        no
cardreader_stapi5:                       no
cardreader_stinger:                      yes

nie wiem moze pod openwrt jest to wyciete   - jest jeszcze pewien skrypt do samodzielnej kopilacji oscama ale nie probowałem zobacz
http://www.satnigmo.com/2264/compile-os … ld-script/

30 (edytowany przez onken 2019-09-09 21:12:05)

Odp: Oscam pod OpenWRT X86_64, pomocy :)

Pod simplebuild nie ma potrzebnego toolchaina sad

Nagra Merlin u mnie też jest.... w oscam version

Ale nie chce się aktywować.

Ciągle wywala to co pisałem.

A do tego nie ma przycisku co by ją aktywował ( jak np mam pod arm w tunerze sat )

@Cezary

Mam dwa patche pod nagre CAK7, mógłbyś proszę je użyć i skompilować oscama najnowszego z nimi pod potrzebna architekturę ( na początek ) smile

Bardzo bym Cię prosił...

31

Odp: Oscam pod OpenWRT X86_64, pomocy :)

To co podałeś nie wejdzie bo jak pisalem oscam to ma w sobie. Chyba że o innych latach piszesz.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

32

Odp: Oscam pod OpenWRT X86_64, pomocy :)

Tak, ja wiem ze ma, ale mam inne patche, pod konkretne polskie karty smile

Tu masz w załączniku, na 99% powinno pomóc, bo kolega kompiluje pod arm samodzielnie i to mu lata.

wiec jak masz środowisko pod moją platformę to i u mnie powinno ruszyć smile

Dwie wersje Ci podsyłam.

https://megawrzuta.pl/download/22ab817d … f5837.html

https://megawrzuta.pl/download/7331e983 … 1ca0e.html

33

Odp: Oscam pod OpenWRT X86_64, pomocy :)

Cezary, uda się smile ?

Druga sprawa, wywalił mi się mwan3 sad po instalacji albo raczej skasowaniu libopenssl a teraz nie chce sie usunac poprawnie i zainstalować ponownie

Jak to recznie skasowac by stary libopenssl zainstalować i dograć tylko pliki z nowego ??

34

Odp: Oscam pod OpenWRT X86_64, pomocy :)

Nie wiem czy się uda, wrócę do domu to zobaczę.

Po prostu zainstaluj, wymuś instalację i tyle. Z tym że mwan3 to tylko skryty niezależne od binarek w systemie.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

35 (edytowany przez onken 2019-09-10 07:41:45)

Odp: Oscam pod OpenWRT X86_64, pomocy :)

Ok, zainstalowałem właśnie stary openssl ale nie działa teraz ani openvpn ( cos sie usuwało po kasowaniu newego openssl i nie strtuje tez mwan3, gdzie szukać przyczyny ?

36

Odp: Oscam pod OpenWRT X86_64, pomocy :)

W logach... uruchom ręcznie i zobacz o co piszczy.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

37 (edytowany przez onken 2019-09-10 08:04:04)

Odp: Oscam pod OpenWRT X86_64, pomocy :)

Zacząłem od openvpn

Usunałem, zainstlaowałem ponownie i ok

Edit, już ok

To czekam na oscama, mama wielką nadzieję że Ci sie uda smile

Pozdrawiam smile

38

Odp: Oscam pod OpenWRT X86_64, pomocy :)

Ja na razie nie zainstalowałeś openvpn bo /etc/init.d/openvpn jest częścią pakietu openvpn. Przeinstaluj jeszcze raz.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

39

Odp: Oscam pod OpenWRT X86_64, pomocy :)

Tak, własnie, zapomniałem o składowej openvpn

To czekam na oscama, mama wielką nadzieję że Ci sie uda smile

Pozdrawiam smile

40

Odp: Oscam pod OpenWRT X86_64, pomocy :)

https://dl.eko.one.pl/test/oscam_11546-1_x86_64.ipk

tylko ta new_patch. Old patch to łątka na same pliki. Niestety powodują one konflikt z łatką cameleon

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

41 (edytowany przez onken 2019-09-10 17:54:23)

Odp: Oscam pod OpenWRT X86_64, pomocy :)

Wykrywa  teraz kartę jako merlin, czyli poprawnie, ale cos nie moze jej zainicjalizować sad

Edit

Problem Phoenix, ale kombinuje z ustaeieniami "delay" i juz karte czyta, więć coraz lepiej smile

42 (edytowany przez onken 2019-09-10 19:59:04)

Odp: Oscam pod OpenWRT X86_64, pomocy :)

Cezary, znajomy jeszcze próbuje robić komiplacje u siebie pod OpenWRT 19

Ale napotkał problem

x86_64-openwrt-linux-musl/bin/ld: cannot find -lcrypto
x86_64-openwrt-linux-musl/bin/ld: cannot find -lssl

Masz pomysł smile ?

43

Odp: Oscam pod OpenWRT X86_64, pomocy :)

Nie znalazł libopenssl w bibliotekach.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

44

Odp: Oscam pod OpenWRT X86_64, pomocy :)

Tak, wiemy, ale to zwykły lib dla debiana czy do openwrt SDK musi byc ?

45

Odp: Oscam pod OpenWRT X86_64, pomocy :)

ważna jest tez predkosć  - sprobuj ustawic na 500 mHz

46

Odp: Oscam pod OpenWRT X86_64, pomocy :)

Wesz że to pytanie bez sensu? Kompilujesz dla openwrt więc dla openwrt ma być, nie linkujesz przecież bliblioteki hosta (choć całkiem przypadkiem to jest ta sama architektura x86)

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

47

Odp: Oscam pod OpenWRT X86_64, pomocy :)

to gdzie tego w takim razie szukać smile bo i ja i on szukamy i nie mozeemy znalezc tego dla SDK, a czy to nie ten sam lib co ja musiałem do siebie już do routera wgrywac ?

48

Odp: Oscam pod OpenWRT X86_64, pomocy :)

libopenssl jest normalnie w paczkach przecież. Uzyj zwykłego finda, jeżeli masz pakiet skompilowany to biblioteki są w  staging_dir/target-x86_64_musl/usr/lib/:

ls staging_dir/target-x86_64_musl/usr/lib/libssl*
staging_dir/target-x86_64_musl/usr/lib/libssl.a  staging_dir/target-x86_64_musl/usr/lib/libssl.so  staging_dir/target-x86_64_musl/usr/lib/libssl.so.1.1
$ ls staging_dir/target-x86_64_musl/usr/lib/libcrypto*
staging_dir/target-x86_64_musl/usr/lib/libcrypto.a  staging_dir/target-x86_64_musl/usr/lib/libcrypto.so  staging_dir/target-x86_64_musl/usr/lib/libcrypto.so.1.1
Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

49

Odp: Oscam pod OpenWRT X86_64, pomocy :)

ok, walczymy smile

Dzięki smile

50

Odp: Oscam pod OpenWRT X86_64, pomocy :)

Cezary napisał/a:

tylko ta new_patch. Old patch to łątka na same pliki. Niestety powodują one konflikt z łatką cameleon

Te 2 nowe patche mają mają już w sobie obsługę cameleon'a, pewnie temu ten konflikt.