1

(519 odpowiedzi, napisanych Oprogramowanie)

Nie, podłączam na szybko u kolegi router w roli repeatera, działa na 19.07 wiec juz zostawie, w domu wgram do swojego routera i zobacze jak będzie

2

(519 odpowiedzi, napisanych Oprogramowanie)

na 19.07 dziala

3

(519 odpowiedzi, napisanych Oprogramowanie)

Wgrałem najnowsze OpenWrt Luci i nie widzi wifi 2.4 ghz , można to jakos naprawic ?

4

(519 odpowiedzi, napisanych Oprogramowanie)

a jak na oryginalnym software zrobic repetear ? niby jest taka zakładka, ale nie ma tutaj skanowania sieci tak jak na openwrt, tylko tak jak na foto

https://zapodaj.net/ba824f9b831ae.png.html

5

(519 odpowiedzi, napisanych Oprogramowanie)

Witam, mam wgrany OpenWrt do Netgeara, czy mozna teraz przywrócic soft do oryginalnego firmware od Netgear  ?

6

(24 odpowiedzi, napisanych Oprogramowanie)

Cezary napisał/a:

speedtest-netperf jest

jak to odpalic?

7

(24 odpowiedzi, napisanych Oprogramowanie)

Czy na aktualnych obrazach mozna zainstalowac speedtest ?

8

(9 odpowiedzi, napisanych Oprogramowanie)

Cezary napisał/a:

Wyłącz, odłącz pendrive, uruchom, router uruchomi sie z tego co ma we flash.

Po ponowym podpięciu pendrive wykryje exroota, czy wszystko od nowa trzeba ustawiać ?

9

(9 odpowiedzi, napisanych Oprogramowanie)

Hej, niechce zakłądac nowego tematu.

Mam na routerze Nexx zrobionego exroota, HUB z pendrivem 15 GB.
Teraz jak bym chciał zrezygnowac z exroota, to po odłączeniu pendrive wykryje mi router ? czy mam przywrocic ustawienia fabryczne, badz wgrac nowy soft przez GUI korzystając jeszcze z exroota ?

10

(514 odpowiedzi, napisanych Oprogramowanie)

zainstalowalem na nexxie z exroot którego mam przy sobie, ale chce na routerze w domu.

11

(514 odpowiedzi, napisanych Oprogramowanie)

Pózniej jak bym chciał usunac przez terminal poleceniem

opkg remove netdata ?

Jestem podlączony do routera przez zerotier i chce aby pozniej mozna było usunąc smile

12

(514 odpowiedzi, napisanych Oprogramowanie)

Cezary napisał/a:

Nie masz wolnego miejsca na instalację. Zrób extroota.

Nie masz netstat w standardzie?

Przepraszam chodzi mi o NetData

https://www.youtube.com/watch?v=bc-5tSqDFeM&t=293s

Mam jeszcze 11 MB wolnego w Netgear r6220, netstat zajmuje cos kolo 1,6 MB

Moge przez terminal ?

13

(514 odpowiedzi, napisanych Oprogramowanie)

Mając zainstalowanego Gargoyle, moge normalnie zainstalowac przez terminal netstat ?

14

(203 odpowiedzi, napisanych Oprogramowanie)

Cezary napisał/a:

Więc musisz skonfigurować serwer tak żeby wysyłał klientom odpowiednie trasy. Bez tego nie ruszysz z tematem.

No własnie, może ktoś przerabiał ten temat i napotkał poradnik który okazał się pomocny ?

15

(203 odpowiedzi, napisanych Oprogramowanie)

Cezary napisał/a:

Więc czemu pisałeś że nie działa jak po prostu tego nie zrobiłeś...

Troszkę sie zamotałem smile nie za bardzo wiem jak to ogarnąc, ponieważ serwer OpenVPN jest na VPSie, a nie na routerze w domu. tym bardziej ze instalowałem go z gotowego skryptu, 5 klikniec i serwer stoi i działa, ale tylko można sie do niego łączyc i do klientów VPNa w tej konfiguracji podstawowej, a ja chce aby router był klientem z możliwoscią przeglądania jego LANu

16

(203 odpowiedzi, napisanych Oprogramowanie)

Cezary napisał/a:

Ale "nie mogę" to trochę za mało żeby coś wyjaśniać. Dodałeś routing na serwerze? Klienci dostają nowe tablice routingu?

No nie dodałem nic, teraz bede miał troche czasu moze sie uda.

17

(203 odpowiedzi, napisanych Oprogramowanie)

Cezary napisał/a:

Podczas robienia klienta w gargoyle automatycznie dodaje się też odpowiednia sekcja w firewallu i forwarding pomiędzy vpn a lan.


Nawet gdy dodaje sie gotowa konfiguracje z pliku.ovpn ? bo skoro tak to nie moge dostac sie do ip 192.168.1.125 bedac podlaczonym do serwera VPN  przez Androida.

18

(203 odpowiedzi, napisanych Oprogramowanie)

Cezary napisał/a:

Czytaj: https://eko.one.pl/?p=openwrt-openvpntu … lanklienta

Zakładając że masz dostęp do serwera. Bo inaczej nie zrobisz żeby on wiedział że słać pakiety które mu klient przysyła.

To sie tyczy tylko OpenWRT ? czy tez majac skonfigurowanego klienta Garogoyle  przez GUI?

19

(203 odpowiedzi, napisanych Oprogramowanie)

Cezary napisał/a:

To zależy czy vpn umożliwia dostęp do routera. Od dostawcy zależy.

Tak łącze sie po IP 10.8.0.4 przez ssh z innego urządzenia podłączonego do serwera VPN.

Co musiał bym jeszcze dodac do konfiguracji z pierwszego posta?

20

(203 odpowiedzi, napisanych Oprogramowanie)

Odkopie troche temat, powracając do pierwszego posta.
Czy jest mozliwość aby na komercyjnym VPNie miec dostęp do sieci LAN za swoim routerem ?

Nie idzie mi to smile Ale musze dojść do tego smile

tą podwójna sekcje wg usunąłem z firewall, a teraz mam usunąc z sekcji network te wpisy ?

config interface 'wg0'
    option proto 'wireguard'
    list addresses '10.6.0.13/24'
    option private_key 'uIG**********'

config wireguard_wg0
    option persistent_keepalive '25'
    option public_key 'HZz*******'
    option description 'VPS'
    option endpoint_port '51855'
    option endpoint_host '37.*******'
    list allowed_ips '0.0.0.0/0'
    option preshared_key 'sBy******'
    option route_allowed_ips '1'

Czyli co mam usunąc/dodać  do firewalla ?

Tak namieszłem że musiałem tryb falsawe odpalić i zrobic, konfig od nowa, nie dodawałem jeszcze sekcji allowedip 192.168.1.0/24 , mam ją dodac w konfigu peera na routerze czy klienta z którego łącze ?

network

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fd4f:272a:695c::/48'

config interface 'lan'
    option type 'bridge'
    option ifname 'eth0.1'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ip6assign '60'

config device 'lan_eth0_1_dev'
    option name 'eth0.1'
    option macaddr 'b4:*********'

config interface 'wan'
    option ifname 'eth0.2'
    option proto 'dhcp'
    list dns '1.1.1.1'
    list dns '8.8.8.8'
    option peerdns '0'

config device 'wan_eth0_2_dev'
    option name 'eth0.2'
    option macaddr 'b4:********'

config interface 'wan6'
    option ifname 'eth0.2'
    option proto 'dhcpv6'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0 1 2 3 6t'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '4 6t'

config interface 'wg0'
    option proto 'wireguard'
    list addresses '10.6.0.13/24'
    option private_key 'uIG**********'

config wireguard_wg0
    option persistent_keepalive '25'
    option public_key 'HZz*******'
    option description 'VPS'
    option endpoint_port '51855'
    option endpoint_host '37.*******'
    list allowed_ips '0.0.0.0/0'
    option preshared_key 'sBy******'
    option route_allowed_ips '1'

firewall

config defaults
    option syn_flood '1'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'REJECT'

config zone
    option name 'lan'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'ACCEPT'
    option network 'lan'

config zone
    option name 'wan'
    option input 'REJECT'
    option output 'ACCEPT'
    option forward 'REJECT'
    option masq '1'
    option mtu_fix '1'
    option network 'wan wan6 wg0'

config forwarding
    option src 'lan'
    option dest 'wan'

config rule
    option name 'Allow-DHCP-Renew'
    option src 'wan'
    option proto 'udp'
    option dest_port '68'
    option target 'ACCEPT'
    option family 'ipv4'

config rule
    option name 'Allow-Ping'
    option src 'wan'
    option proto 'icmp'
    option icmp_type 'echo-request'
    option family 'ipv4'
    option target 'ACCEPT'

config rule
    option name 'Allow-IGMP'
    option src 'wan'
    option proto 'igmp'
    option family 'ipv4'
    option target 'ACCEPT'

config rule
    option name 'Allow-DHCPv6'
    option src 'wan'
    option proto 'udp'
    option src_ip 'fc00::/6'
    option dest_ip 'fc00::/6'
    option dest_port '546'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-MLD'
    option src 'wan'
    option proto 'icmp'
    option src_ip 'fe80::/10'
    list icmp_type '130/0'
    list icmp_type '131/0'
    list icmp_type '132/0'
    list icmp_type '143/0'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-ICMPv6-Input'
    option src 'wan'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    list icmp_type 'router-solicitation'
    list icmp_type 'neighbour-solicitation'
    list icmp_type 'router-advertisement'
    list icmp_type 'neighbour-advertisement'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-ICMPv6-Forward'
    option src 'wan'
    option dest '*'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-IPSec-ESP'
    option src 'wan'
    option dest 'lan'
    option proto 'esp'
    option target 'ACCEPT'

config rule
    option name 'Allow-ISAKMP'
    option src 'wan'
    option dest 'lan'
    option dest_port '500'
    option proto 'udp'
    option target 'ACCEPT'

config include
    option path '/etc/firewall.user'

config zone
    option name 'wg'
    option input 'ACCEPT'
    option forward 'ACCEPT'
    option output 'ACCEPT'
    option masq '1'

config forwarding
    option src 'wg'
    option dest 'wan'

config forwarding
    option src 'wan'
    option dest 'wg'

config forwarding
    option src 'wg'
    option dest 'lan'

config forwarding
    option src 'lan'
    option dest 'wg'

config zone
    option name 'wg'
    option input 'ACCEPT'
    option forward 'ACCEPT'
    option output 'ACCEPT'
    option masq '1'
    option network 'wg0'

config forwarding
    option src 'wg'
    option dest 'wan'

config forwarding
    option src 'wan'
    option dest 'wg'

config forwarding
    option src 'wg'
    option dest 'lan'

config forwarding
    option src 'lan'
    option dest 'wg'

https://drive.google.com/drive/folders/ … sp=sharing  screeny.