1

(2 odpowiedzi, napisanych Oprogramowanie)

ehhh...niestety średnio mi się widzi ta zmiana hmm jeszcze pokombinuje i w ostateczności zmienię smile

2

(2 odpowiedzi, napisanych Oprogramowanie)

Po zaktualizowaniu gragoyle (>1.5.10.12 (r37768), by obsy) mam problem z przesyłaniem plików z dysku podłączonego do routera (tl-wr1043nd) poprzez hub. Wcześniej zapis/odczyt na poziomie ~4/10MB a teraz ~2/5 MB. Sprawdzałem poprzez ftp i samba. Podczas pobierania plików na dysk (transmission/pyload) potrafi odłączyć go, albo zawiesza cały router i dopiero restart pomaga. System plików to ntfs.

3

(6 odpowiedzi, napisanych Oprogramowanie)

i wszystko działa big_smile

4

(6 odpowiedzi, napisanych Oprogramowanie)

wygląda ok

src/gz attitude_adjustment http://downloads.openwrt.org/attitude_adjustment/12.09/ar71xx/generic/packages
dest root /
dest ram /tmp
dest plugin_root /plugin_root
lists_dir ext /var/opkg-lists
option overlay_root /overlay
src/gz eko1 http://ecco.selfip.net/attitude_adjustment/ar71xx/packages
src/gz gargoylepl http://ecco.selfip.net/gargoyle-pl/attitude_adjustment/ar71xx/packages

5

(6 odpowiedzi, napisanych Oprogramowanie)

i tak dosamo mi wypluwa hmm

6

(6 odpowiedzi, napisanych Oprogramowanie)

Nie mogę zainstalować python-sqlite3, który potrzebny mi jest do instalacji pyload:

root@Gargoyle:~# opkg install  python-sqlite3
ERROR: No package named python-sqlite3 found, try updating your package lists

oczywiście polecenie opkg update wykonane przed wszystkim. Inne pakiety instalują się normalnie.

No nic, może ktoś inny będzie mógł sprawdzić.
Mam ten dysk z hubem ponad rok i jestem ciekaw ile jeszcze pożyje i jak wpływ ma na to usypianie.

Dzięki Cezary. Jeszcze dodam, że usypianie działa jedynie poprzez hdidle. Przez hdparm w ogóle nie da się uruchomić usypiania (wywala błąd). Do huba podłączony jest dysk i pendrive,  na którym jest extroot. Po jakimś czasie od włączenia usypiania system plików na extroot'cie krzaczy się. Po restarcie wszystko jest ok.

Edit: Dodaje wpis z dmesg:
sd 1:0:0:0: [sdb] Device not ready
sd 1:0:0:0: [sdb] Result: hostbyte=0x00 driverbyte=0x08
sd 1:0:0:0: [sdb] Sense Key : 0x2 [current]
sd 1:0:0:0: [sdb] ASC=0x3a ASCQ=0x0
sd 1:0:0:0: [sdb] CDB: cdb[0]=0x28: 28 00 00 45 90 ae 00 00 08 00
end_request: I/O error, dev sdb, sector 4559022
sd 1:0:0:0: [sdb] Device not ready
sd 1:0:0:0: [sdb] Result: hostbyte=0x00 driverbyte=0x08
sd 1:0:0:0: [sdb] Sense Key : 0x2 [current]
sd 1:0:0:0: [sdb] ASC=0x3a ASCQ=0x0
sd 1:0:0:0: [sdb] CDB: cdb[0]=0x28: 28 00 00 45 90 c6 00 00 08 00
end_request: I/O error, dev sdb, sector 4559046
sd 1:0:0:0: [sdb] Device not ready
sd 1:0:0:0: [sdb] Result: hostbyte=0x00 driverbyte=0x08
sd 1:0:0:0: [sdb] Sense Key : 0x2 [current]
sd 1:0:0:0: [sdb] ASC=0x3a ASCQ=0x0
sd 1:0:0:0: [sdb] CDB: cdb[0]=0x28: 28 00 00 45 90 ae 00 00 08 00
end_request: I/O error, dev sdb, sector 4559022

Czy może ktoś sprawdzić czy na tym hubie działa poprawnie usypianie dysku ? Na moim egzemplarzu co prawda działa, ale po jakimś czasie system się wysypuje/zawiesza i trzeba router resetować. Jak mi się uda to to wstawię loga z błędów jakie podaje polecenie dmesg.

10

(8 odpowiedzi, napisanych Oprogramowanie)

Dzięki. Już działa i skanuje smile. Zobaczymy jak skończy.

11

(8 odpowiedzi, napisanych Oprogramowanie)

Zainstalowałem starszą wersje samby, bo tej nowszej nie mogę dobrze skonfigurować neutral.
Przejdźmy teraz do minidlna. Teraz gdy je chce uruchomić mam taki błąd:

root@Gargoyle:~$ /etc/init.d/minidlna start
/usr/bin/minidlna: can't load library 'libavformat.so.52'

Patrzyłem i w /usr/lib i nie ma tam takiego pliku tylko libavformat.so.53. Tylko skąd wziąć 52 ?
Coś dzisiaj nic nie działa jak trzeba smile

12

(8 odpowiedzi, napisanych Oprogramowanie)

Przed killall:

  PID  PPID USER     STAT   VSZ %MEM %CPU COMMAND
 6489  6013 root     R     1380   5%   0% top
 5760     1 root     S    14608  50%   0% /usr/bin/minidlna
 5765  5764 root     S N  14608  50%   0% /usr/bin/minidlna
 5764  5760 root     S    14608  50%   0% /usr/bin/minidlna
 2949  2948 root     S     8272  28%   0% /usr/bin/transmission-daemon -g /mnt/
 2950  2948 root     S     8272  28%   0% /usr/bin/transmission-daemon -g /mnt/
 2947     1 root     S     8272  28%   0% /usr/bin/transmission-daemon -g /mnt/
 2948  2947 root     S     8272  28%   0% /usr/bin/transmission-daemon -g /mnt/
 6490  6485 root     S     4384  15%   0% /usr/sbin/smbd -D
 6485     1 root     S     4108  14%   0% /usr/sbin/smbd -D
 6488     1 root     S     2472   8%   0% /usr/sbin/nmbd -D
 1064     1 root     S     2092   7%   0% mount.ntfs-3g /dev/sda1 /mnt/sda1 -o
 1467     1 root     S     1480   5%   0% hostapd -P /var/run/wifi-phy0.pid -B
 2374     1 root     S     1392   5%   0% crond -c /etc/crontabs -l 5
  381     1 root     S     1388   5%   0% syslogd -C16
 6013  6010 root     S     1388   5%   0% -ash
    1     0 root     S     1384   5%   0% init
  367     1 root     S     1384   5%   0% init
 2438     1 root     S     1380   5%   0% watchdog -t 5 /dev/watchdog
 6454  6451 root     S     1380   5%   0% -ash

I po:


 6499  6013 root     R     1376   5%   9% top
 5760     1 root     S    14608  50%   0% /usr/bin/minidlna
 5765  5764 root     S N  14608  50%   0% /usr/bin/minidlna
 5764  5760 root     S    14608  50%   0% /usr/bin/minidlna
 2949  2948 root     S     8272  28%   0% /usr/bin/transmission-daemon -g /mnt/
 2950  2948 root     S     8272  28%   0% /usr/bin/transmission-daemon -g /mnt/
 2947     1 root     S     8272  28%   0% /usr/bin/transmission-daemon -g /mnt/
 2948  2947 root     S     8272  28%   0% /usr/bin/transmission-daemon -g /mnt/
 6488     1 root     S     2472   8%   0% /usr/sbin/nmbd -D
 1064     1 root     S     2092   7%   0% mount.ntfs-3g /dev/sda1 /mnt/sda1 -o
 1467     1 root     S     1480   5%   0% hostapd -P /var/run/wifi-phy0.pid -B
 2374     1 root     S     1392   5%   0% crond -c /etc/crontabs -l 5
  381     1 root     S     1388   5%   0% syslogd -C16
 6013  6010 root     S     1388   5%   0% -ash
    1     0 root     S     1384   5%   0% init
  367     1 root     S     1384   5%   0% init
 2438     1 root     S     1380   5%   0% watchdog -t 5 /dev/watchdog
 6043  6042 root     S     1380   5%   0% -ash
 6454  6451 root     S     1380   5%   0% -ash
  383     1 root     S     1372   5%   0% klogd

Jeden został. I użytkownik nie powinien się nazywać nobody ? Kiedyś jak tak udostępniałem pliki to użytkownik nazywał się nobody. Było to w starszszej wersji samby.

13

(8 odpowiedzi, napisanych Oprogramowanie)

W uruchomionych procesach jest proces samby, więc jest uruchomiona. Poza tym pliki są udostępniane w sieci.

A co do minidlna to co można na to zaradzić ? Bo nie wiem co to oznacza.

14

(8 odpowiedzi, napisanych Oprogramowanie)

Witam, mam problem z działaniem samby i minidlna.
Sambe udało mi się już uruchomić, jednak  gdy próbuje ją zatrzymać to dostaje coś takiego:

root@Gargoyle:~$ /etc/init.d/samba stop
killall: /usr/sbin/smbd: no process killed

Konfig samby:

# Base server settings
config samba
    ## Override if desired, defaults to hostname
    #option 'name'            'OpenWrt'
    #option 'workgroup'        'Mshome'
    #option 'description'        'OpenWrt'

    ## Expose user home directories, defaults to off
    option 'homes'            '0'

    ## Override character set, default is UTF-8
    option 'charset'            'ISO-8859-1'

    ## Override listen interfaces & addresses,
    ## defaults to loopback and lan
    #list 'interface'        'loopback'
    #list 'interface'        'lan'
    #list 'interface'           '10.0.0.0/255.255.0.0'
    #list 'interface'        'eth0'

config sambashare
    option 'name'            'sda1'
    option 'path'            '/mnt/sda1'
    option 'read_only'        'no'
    option 'guest_ok'        'yes'
    option 'create_mask'    '0'
    option 'dir_mask'        '0'

    [global]
        netbios name = |NAME|
        workgroup = |Mshome|
        server string = |DESCRIPTION|
        syslog = 1
        encrypt passwords = true
        passdb backend = smbpasswd
        obey pam restrictions = yes
        socket options = TCP_NODELAY SO_SNDBUF=16384 SO_RCVBUF=16384 IPTOS_LOWDELAY
        display charset = |CHARSET|
        preferred master = yes
        os level = 20
        security = user
        map to guest = Bad User
        guest account = root
        smb passwd file = /etc/samba/smbpasswd
        interfaces = |INTERFACES|

Minidlna natomiast nie skanuje plików, mimo że folder jest prawidłowo wskazany i minidlna widnieje w uruchomionych procesach.

Log z minidlna:
[2012/03/04 15:34:37] minidlna.c:888: warn: Starting MiniDLNA version 1.1.0-cvs [SQLite 3.7.9].
[2012/03/04 15:34:37] minidlna.c:911: warn: Creating new database at /var/cache/minidlna/files.db
[2012/03/04 15:34:37] scanner.c:732: warn: Scanning /mnt
[2012/03/04 15:34:37] minidlna.c:989: warn: HTTP listening on port 8200
[2012/03/04 15:34:43] minidlna.c:154: warn: received signal 15, good-bye
[2012/03/04 15:35:31] minidlna.c:888: warn: Starting MiniDLNA version 1.1.0-cvs [SQLite 3.7.9].
[2012/03/04 15:35:31] minidlna.c:911: warn: Creating new database at /var/cache/minidlna/files.db
[2012/03/04 15:35:31] scanner.c:732: warn: Scanning /mnt
[2012/03/04 15:35:31] minidlna.c:989: warn: HTTP listening on port 8200
[2012/03/04 15:36:39] minidlna.c:154: warn: received signal 15, good-bye
[2012/03/04 15:36:48] minidlna.c:888: warn: Starting MiniDLNA version 1.1.0-cvs [SQLite 3.7.9].
[2012/03/04 15:36:48] minidlna.c:911: warn: Creating new database at /var/cache/minidlna/files.db
[2012/03/04 15:36:48] minidlna.c:989: warn: HTTP listening on port 8200
[2012/03/04 15:36:48] scanner.c:732: warn: Scanning /mnt
[2012/03/04 15:36:57] minidlna.c:154: warn: received signal 15, good-bye
[2012/03/04 15:37:33] minidlna.c:888: warn: Starting MiniDLNA version 1.1.0-cvs [SQLite 3.7.9].
[2012/03/04 15:37:33] minidlna.c:911: warn: Creating new database at /var/cache/minidlna/files.db
[2012/03/04 15:37:33] scanner.c:732: warn: Scanning /mnt
[2012/03/04 15:37:33] minidlna.c:989: warn: HTTP listening on port 8200
[2012/03/04 15:38:17] minidlna.c:816: error: MiniDLNA is already running. EXITING.
[2012/03/04 15:38:28] minidlna.c:154: warn: received signal 15, good-bye
[2012/03/04 15:38:30] minidlna.c:888: warn: Starting MiniDLNA version 1.1.0-cvs [SQLite 3.7.9].
[2012/03/04 15:38:30] minidlna.c:911: warn: Creating new database at /var/cache/minidlna/files.db
[2012/03/04 15:38:30] minidlna.c:989: warn: HTTP listening on port 8200
[2012/03/04 15:38:30] scanner.c:732: warn: Scanning /mnt
[2012/03/04 15:39:31] minidlna.c:154: warn: received signal 15, good-bye
[2012/03/04 15:39:36] minidlna.c:888: warn: Starting MiniDLNA version 1.1.0-cvs [SQLite 3.7.9].
[2012/03/04 15:39:36] minidlna.c:911: warn: Creating new database at /var/cache/minidlna/files.db
[2012/03/04 15:39:37] scanner.c:732: warn: Scanning /mnt
[2012/03/04 15:39:37] minidlna.c:989: warn: HTTP listening on port 8200
[2012/03/04 15:42:47] minidlna.c:154: warn: received signal 15, good-bye
[2012/03/04 15:42:52] minidlna.c:888: warn: Starting MiniDLNA version 1.1.0-cvs [SQLite 3.7.9].
[2012/03/04 15:42:52] minidlna.c:911: warn: Creating new database at /var/cache/minidlna/files.db
[2012/03/04 15:42:52] scanner.c:732: warn: Scanning /mnt
[2012/03/04 15:42:52] minidlna.c:989: warn: HTTP listening on port 8200

Minidlna to wersja od Cezarego - minidlna-cvs
Wersja Gargoyle - 1.5.4 (30752) by obsy

15

(321 odpowiedzi, napisanych Oprogramowanie)

@up
Już to poprawiłem wink

PS Cezary popraw godzinę na forum lol

16

(321 odpowiedzi, napisanych Oprogramowanie)

Działa, nawet spacji nie trzebe usuwać smile

Tylko co zrobić żeby mpd nie startował wyciszony ?

Edit: Już sobie poradziłem, tylko nie ma różnicy w głośności między 2% a 100%

17

(321 odpowiedzi, napisanych Oprogramowanie)

Plik oczywiście się tam znajduje, jednak gdy chcę go dodać do playlisty, to się nie da. Zaglądałem do pliku databse i wszystkie utwory, z folderu, gdzie mam muzykę są tam odnotowane ale, gdy chcę coś odtworzyć to tak jak by ich tam nie było.

Folder playlist już stworzyłem i wszystko wydaje mi się prawidłowo skonfigurowane, tylko mpd jakby nie widziało plików.

18

(321 odpowiedzi, napisanych Oprogramowanie)

Gdy próbuje uruchomić mpd wyskakuje mi:

root@Gargoyle:~$  /etc/init.d/mpd start
Simple mixer control 'PCM',0
  Capabilities: pvolume pswitch pswitch-joined penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 17152
  Mono:
  Front Left: Playback 40 [0%] [0.15dB] [off]
  Front Right: Playback 40 [0%] [0.15dB] [off]
Failed to bind to '[::]:6600': Failed to create socket: Address family not supported by protocol

lub:

root@Gargoyle:~$ /etc/init.d/mpd start
Simple mixer control 'PCM',0
  Capabilities: pvolume pswitch pswitch-joined penum
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 17152
  Mono:
  Front Left: Playback 40 [0%] [0.15dB] [off]
  Front Right: Playback 40 [0%] [0.15dB] [off]
playlist directory is not a directory: "/mnt/sda1/OpenWRT/mpd/playlists"
output: No "audio_output" defined in config file
output: Attempt to detect audio output device
output: Attempting to detect a alsa audio device
output: Successfully detected a alsa audio device

a gdy chcę dodać utwór:

root@Gargoyle:~$  mpc add Nero - Must Be The Feeling.mp3
error adding Nero: directory or file not found

Nie wiem jak to odpalić, żeby działało. Robiłem wszystko według tutoriala na tej stronie.

19

(26 odpowiedzi, napisanych Oprogramowanie)

U mnie też zawiesza się w tym samym momencie.

20

(1 odpowiedzi, napisanych Oprogramowanie)

Witam,
mam taki problem, że przycisk qss przestał mi funkcjonować na routerze TP-Link TL-WR1043ND z Gargoyle 1.3.13 (by obsy). Po wciśnięciu nie ma żadnej reakcji, również po przytrzymaniu nic się nie dzieje chociaż powinien się zrestartować. Dodam, że gdy router wstaje nie z extroota tylko z pamięci flash przycisk działa normalnie. Zdarzyło się to już drugi raz, wcześniej postawiłem extroota od nowa i problem zniknął, ale wolałbym znaleźć przyczynę i temu zapobiec, żebym nie musiał co dwa tygodnie stawiać od nowa system i konfigurować.

Z góry dzięki za rady.
Pozdrawiam

W markecie jest jeszcze dostępny program do zarządzania pyloadem i wiele innych takich jak klienci ftp, samba, ssh. Kilka programów jest opisanych eko.one.pl. Ja najczęściej używam transdroid i connectbot, nie muszę włączać co chwilę komputera, żeby coś sprawdzić.

22

(6 odpowiedzi, napisanych Oprogramowanie)

Co trzeba zrobić żeby wifi nie wyłączało się po wciśnięciu przycisku ? bo ustawiłem transmission na przycisku a wifi też się wyłącza, co mi jest niepotrzebne

23

(5 odpowiedzi, napisanych Oprogramowanie)

Nie pomyliłem się, bo najpierw sprawdzałem jak jest wykrywany dysk(teraz jest jako /dev/sda) i później sprawdzałem uuid.

24

(5 odpowiedzi, napisanych Oprogramowanie)

Poprostu przywróciłem standardowe montowanie urządzeń w openwrt, zrobiłem extroota na pendrive i wszystko działa, tylko dysku nie chce mi automatycznie montować. Skoro mam extroota to chyba powinienem mieć fstaba ? Dopiero zaczynam z openwrt i to jest moje pierwsze zetknięcie z linuxem, wiec moge pisać głupoty smile

25

(5 odpowiedzi, napisanych Oprogramowanie)

Witam,

Mam taki problem, że nie chcę mi openwrt montować automatycznie dysku. Z konsoli bezproblemowo się montuje za pomocą ntfs-3g, bo dysk jest sformatowany na ntfs. Openwrt to wersja z tej strony z nakładką GargoylePL, router to TP-Link 1043ND.

Ustawienia z sekcji mount w fstab:

config mount
    option 'target' '/mnt/sda1'
    option 'device' '/dev/sda1'
    option 'fstype' 'ntfs-3g'
    option 'options' 'rw'
    option 'enabled' '1'
    option 'uuid' '6E14ED3014ECFBC9'