Dzięki za tak szybka odpowiedź. Czyli pozostaje "Flash-MOD" na Winbond 25Q128 smile

Zrobiłem aktualizację w 4sztukach 1043ND z Gargoyle z wersji 1.10.0.3 (r49617) na Gargoyle 1.12.0.1 (73ff591c)
To routery moje, rodziny i znajomych. Po aktualizacji niestety na 3ch z nich pojawił się problem. Mianowicie praktycznie nie ma miejsca na dodatki. Jeden z routerów padł w trakcie aktualizacji, więc posiłkowałem się programatorem i sklonowałem zawartość sąsiada. Stąd wiem, że kość flash ma 8MB. Gdzie podziało się to miejsce?
Wszystkie aktualizowane bez zachowania ustawień i po pierwszym uruchomieniu jeszcze raz przywrócone do ustawień domyślnych (z menu - nie przyciskiem).
Sytuacja wygląda tak:
R1; 1043ND-v1 Pamięć wewnętrzna 768.000 KB ogółem, 488.000 KB wolne
R2; 1043ND-v1 Pamięć wewnętrzna 768.000 KB ogółem, 488.000 KB wolne (tu kość flash na bank 8MB!)
R3; 1043ND-v2 Pamięć wewnętrzna 768.000 KB ogółem, 484.000 KB wolne
R4; 1043ND-v4 Pamięć wewnętrzna 8.000 MB ogółem, 4.645 MB wolne - (tu jest wszystko cacy)

Dodatkowo: lista WOL ma taką wadę, że jak źle dodałem komputer w DHCP (źle skopiowany MAC-adres) to po jego poprawieniu na liście DHCP, w WOL nadal jest po staremu - czyli z błędem i nie działa sad

Czy jest jakaś opcja na ustawienie priorytetu dla radia internetowego żeby nie przycinało przy słabym łączu? Do czego powinny odnosić się wpisy? Dziwnym trafem zaczęło przycinać po aktualizacji smile

3

(16 odpowiedzi, napisanych Oprogramowanie)

Proszę o pomoc w ustaleniu konfigu dla EaxyBox 904 xDLS
Wgrany openwrt-19.07
Neostrada 20Mb/s
ADSL_2plus
Annex A/L

Obecny wynik:
root@EasyBOX:~# uci show network
network.loopback=interface
network.loopback.ifname='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.atm=atm-bridge
network.atm.vpi='1'
network.atm.vci='32'
network.atm.encaps='llc'
network.atm.payload='bridged'
network.atm.nameprefix='dsl'
network.dsl=dsl
network.dsl.annex='a'
network.dsl.tone='av'
network.dsl.line_mode='adsl'
network.dsl.ds_snr_offset='0'
network.lan=interface
network.lan.type='bridge'
network.lan.proto='static'
network.lan.ipaddr='192.168.1.1'
network.lan.netmask='255.255.255.0'
network.lan.ipv6='0'
network.lan.ifname='eth0.1' 'eth0.66'
network.lan_dev=device
network.lan_dev.name='eth0.1'
network.wan=interface
network.wan.ifname='dsl0'
network.wan.proto='pppoe'
network.wan.ipv6='0'
network.wan.metric='20'
network.wan.peerdns='0'
network.wan.dns='127.0.0.1'
network.wan.username='xxxxxxxx@neostrada.pl/ipv6'
network.wan.password='xxxxxxxx'
network.wan.keepalive='0'
network.wan.force_link='1'
network.wan.mtu='1525'
network.wan_dev=device
network.wan_dev.name='dsl0'
network.wan_dev.peerdns='0'
network.wan_dev.dns='127.0.0.1'
network.@switch[0]=switch
network.@switch[0].name='switch0'
network.@switch[0].reset='1'
network.@switch[0].enable_vlan='1'
network.@switch_vlan[0]=switch_vlan
network.@switch_vlan[0].device='switch0'
network.@switch_vlan[0].vlan='1'
network.@switch_vlan[0].ports='0 6t'
network.@switch_vlan[1]=switch_vlan
network.@switch_vlan[1].device='switch0'
network.@switch_vlan[1].vlan='2'
network.@switch_vlan[1].ports='4 6t'
network.@switch[1]=switch
network.@switch[1].name='switch1'
network.@switch[1].reset='1'
network.@switch[1].enable_vlan='1'
network.@switch_vlan[2]=switch_vlan
network.@switch_vlan[2].device='switch1'
network.@switch_vlan[2].vlan='1'
network.@switch_vlan[2].ports='0 1 2 3 6t'
network.inic_dev=device
network.inic_dev.name='eth0.3'
network.inic=interface
network.inic.proto='none'
network.inic.ifname='eth0.3'
network.@switch_vlan[3]=switch_vlan
network.@switch_vlan[3].device='switch0'
network.@switch_vlan[3].vlan='3'
network.@switch_vlan[3].vid='3'
network.@switch_vlan[3].fid='3'
network.@switch_vlan[3].ports='5 6t'
network.wlan_dev=device
network.wlan_dev.name='eth0.66'
network.guest_wlan_dev=device
network.guest_wlan_dev.name='eth0.71'
network.@switch_vlan[4]=switch_vlan
network.@switch_vlan[4].device='switch0'
network.@switch_vlan[4].vlan='4'
network.@switch_vlan[4].vid='66'
network.@switch_vlan[4].fid='4'
network.@switch_vlan[4].ports='5t 6t'
network.@switch_vlan[5]=switch_vlan
network.@switch_vlan[5].device='switch0'
network.@switch_vlan[5].vlan='5'
network.@switch_vlan[5].vid='71'
network.@switch_vlan[5].fid='5'
network.@switch_vlan[5].ports='5t 6t'
network.hilink=interface
network.hilink.proto='dhcp'
network.hilink.ifname='eth2'
network.hilink.ipv6='0'
network.hilink.metric='10'
network.hilink.delegate='0'
network.hilink.peerdns='1'
network.hilink.dns='192.168.8.1'
network.upcwifree=interface
network.upcwifree.proto='dhcp'
network.upcwifree.ipv6='0'
network.wwan=interface
network.wwan.proto='dhcp'
network.wwan.ifname='usb0'
network.wwan.ipv6='0'
network.umts=interface
network.umts.proto='3g'
network.umts.device='/dev/ttyUSB0'
network.umts.service='umts'
network.umts.apn='internet'
network.umts.dialnumber='*99***1#'
network.umts.ipv6='0'
network.umts.auto='0'
network.umts.metric='30'
network.PPTP=interface
network.PPTP.proto='pptp'
network.PPTP.server='pl02.vpnonline.eu'
network.PPTP.keepalive='0'
network.PPTP.auto='0'
network.PPTP.username='twoj login'
network.PPTP.password='twoje haslo'
network.TUN=interface
network.TUN.ifname='tun0'
network.TUN.proto='none'
network.TUN.delegate='0'
network.wg0=interface
network.wg0.proto='wireguard'
network.wg0.listen_port='55055'
network.wg0.addresses='10.9.0.1/24'
network.wg0.private_key='aNcfPPirZGQrgFDHw07dgRqoSnP/Kni45ITneZlFFng='
network.wg0.ipv6='0'
network.wg0.auto='0'
network.@wireguard_wg0[0]=wireguard_wg0
network.@wireguard_wg0[0].public_key='Axn5g0cb0eYEc8utzM/2FXZ0vSdIE8AwxmUGfQBwzEY='
network.@wireguard_wg0[0].route_allowed_ips='1'
network.@wireguard_wg0[0].allowed_ips='10.9.0.3/32'
network.@wireguard_wg0[0].persistent_keepalive='25'
network.@wireguard_wg0[0].description='android'
network.@wireguard_wg0[0].ipv6='0'
network.@wireguard_wg0[0].auto='0'
network.ipsec=interface
network.ipsec.ifname='ipsec0'
network.ipsec.proto='none'
network.ipsec.defaultroute='0'
network.ipsec.peerdns='0'
network.ipsec.ipv6='0'
network.ipsec.auto='0'

4

(4 odpowiedzi, napisanych Sprzęt)

9tysiecy napisał/a:

Najlepiej to kup oddzielny router DSL z trybem mostu a do niego już dowolny inny, bo z modemem to nie ma nic świeżego, a co jest to i tak nie jest idealne. I zaktualizuj to Gargoyle bo jest już 1.11, nie ma powodu do używania mocno przestarzałego 1.10

Poproszę o propozycję modelu. Teraz jest 20Mbs bo podobno inaczej się nie dało, ale jest opcja poprzez "zlecenie" wykonanie próby wyższej prędkości czyli 80Mbs. To w chwili gdybym korzystał z urządzeń Orange podobno wymusza wymianę Livebox 2.0 na inne urządzenie. Fajnie by było mieć swoje (jakie?) które zadziała w obu opcjach w trybie most wraz z moim routerem.
Aktualizację zrobię jak tylko uda się to zestawić.

Zuzia napisał/a:

Robię obrazy OpenWrt 19.07 dla Easybox 904 xDSL z Luci i obsługą łącz ADSL/VDSL

Jak się nie uda zestawić, przechodzę na OpenWrt smile

Dziękuję wszystkim za odpowiedzi

5

(4 odpowiedzi, napisanych Sprzęt)

Witam. Jak w temacie. Po kilku latach korzystania z usług pewnej sieci kablowej, której sygnał odbierałem z ichniego modemu przez port WAN, przyszedł czas na "chwilowe" korzystanie z usług Orange (umowa bezterminowa). Dali mi starego Liveboxa 2.0 z opcją, że mogę to zamienić na swoje urządzenie. Dla mnie najlepszy byłby jakiś TP-Link z Gargoyle: 1.10.0.3 (r49617) lub wyższym.
Opisywane w "poradniku kupującego" TP-LINK TD-W8970 i TP-LINK TD-W8980 nie występują w wyszukiwarce obrazów do pobrania.
TP-Link - fajnie by było
Gargoyle - koniecznie! (argumenty: przyzwyczajenie, radio internetowe, GUI, ...)
Ewentualnie modem DLS na USB ale szybszy niż Thomson SpeedTouch 330 lub Sagem F@ST 800 USB, które to ciągną max 8Mb/s
Livebox'a nie da się ustawić w tryb modemu jak w urządzeniu z sieci kablowej... sad
Obecna wykupiona prędkość to 20Mb/s (faktyczna to ~23Mb/s).

6

(7 odpowiedzi, napisanych Oprogramowanie)

OK; zrobiłem (prawie wszystko) tak jak napisał @ad2014. Mam przypisane stałe IP do wszystkich znanych mi urządzeń w domu i teraz lista "Połączone urządzenia" nie zawiera nic mi nieznanego. Dodatkowo hasło zmienione. Zobaczymy za parę dni. Jeśli znowu będzie problem to przytnę zakres DHCP. Mimo wszystko "Książka adresowa" to byłoby COŚ. W końcu sama nazwa mówi, że Mac-adres to adres smile

7

(7 odpowiedzi, napisanych Oprogramowanie)

Witam serdecznie. Działy się dziwne rzeczy więc włączyłem sobie w końcu Filtrowanie adresów MAC. Wypełniłem listę MAC adresów i powiem szczerze, że taka "sucha" lista dwuznaków przedzielonych dwukropkami nic mi nie mówi. Nie wiem jakie urządzenie kryje się pod daną pozycją.
Fajnie jakby była jakaś "książka adresowa" MAC adresów i wszelkie operacje w gargulcu robilibyśmy opierając się na tej właśnie książce. Czy jest taka opcja, żeby to jakoś dodać?

W weekend spróbuję, ale fajnie by było wyklikać a później zrobić kopię pliku. Chyba, że można zrobić kopię do łatwego przywracania niezależnie od tego jak dojdę do oczekiwanych rezultatów?

Przyznam się, że nie dam rady ręcznie... sad
Ale jestem gotów zapłacić za wersję GUI smile

Zrobiłem wg wskazówek i na "głównym" WiFi drugiego routera można się połączyć z netem. Jednak gościnna sieć drugiego po wpisaniu hasła informuje, że "brak połączenia z internetem" i w szczegółach adres z cyklu 169.254.....
Przypadkiem odkryłem, że przestawienie opcji "izolacja klientów sieci bezprzewodowej" na  "wyłączony" daje na gościnnej dostęp do internetu, jednak nadal klienta izoluje. Po co jest więc taka opcja?
Po wyjaśnieniu tej kwestii i kilku dniach testów wstawię ładny graficzny poradnik.

Witam.
Jest sobie lokal a w nim router 1043ND z Gargoyle 1.9.2.3 (spisuje się znakomicie) i dwiema sieciami: główną i gościnną (izolacja klientów). Tyle, że mury są na tyle grube, że nie da się tak ustawić routera by wszędzie był dobry zasięg. Próbowałem zrobić jak na obrazku, tyle że po połączeniu z dowolną siecią z routera2 (model i soft jak wyżej) nie ma internetu.
Połączenie pierwszego przez PPPoE przez login i hasło (stałe zewnętrzne IP). Do drugiego routera idzie kabel LAN i zależnie od wybranej opcji w najlepszym wypadku kończy się jak wyżej.
Generalnie chodzi o to, by mieć 2 routery z takimi samymi sieciami i hasłami i przez połączenie z dowolnym routerem z siecią główną móc np drukować z drukarki sieciowej.
Robiłem dawno temu podobne udostępnianie, ale sieci wtedy się nie widziały (nie było takiej konieczności), teraz to konieczność.

https://images90.fotosik.pl/30/ea4aae83b08933e4med.jpg

Nie będę się kłócił w sprawie dubla. Wszelkie ślady moich błędów na szczęście są zatarte smile
Co do wyglądu przycisków i omyłkowego kasowania stacji - czy dobrze myślę, żeby usunąć kasowanie, lub zmienić funkcję (byłoby 2 razy "graj") w pliku iradio.js ??
Na razie bez podpowiedzi nic już nie grzebię...

Dzięki za odzew. Jak na mój gust nie było dubli. Zrestartowałem do domyślnych, zrobiłem przez ssh TYLKO:
opkg update
opkg install plugin gargoyle-iradio
i działa smile poza jednym problemem - przyciski nie są "graficzne", tylko ramki. Z rozpędu można kasować stacje zamiast je włączać. Restart nie pomaga.
https://images83.fotosik.pl/1042/20ab15423ce47146med.png
Rozumiem, że w tej sytuacji każdy dodatek który nie będzie chciał wejść przez www też tylko przez SSH?
opkg install opkg - wcześniej zrobiłem tylko dlatego, że tak było w innej podpowiedzi smile
przepraszam za kłopot smile

zacząłem od nowa; reset to ustawień fabrycznych, upgrade do 1.10.0.3 i przez ssh:
opkg update
opkg install opkg
i przy próbie instalacji iradio:

root@Gargoyle:~# opkg install plugin-gargoyle-iradio.ipk
Package kmod-via-rhine version 3.18.75-1-b1ac4f12c02f91ac95ab7ec9f3ad1eb3 has no valid architecture, ignoring.
Collected errors:
* opkg_conf_parse_file: Duplicate src declaration (chaos_calmer_base http://downloads.openwrt.org/chaos_calm … ges/base). Skipping.
* opkg_conf_parse_file: Duplicate src declaration (chaos_calmer_packages http://downloads.openwrt.org/chaos_calm … packages). Skipping.
* opkg_conf_parse_file: Duplicate src declaration (chaos_calmer_routing http://downloads.openwrt.org/chaos_calm … /routing). Skipping.
* opkg_conf_parse_file: Duplicate src declaration (chaos_calmer_telephony http://downloads.openwrt.org/chaos_calm … elephony). Skipping.
* opkg_conf_parse_file: Duplicate src declaration (chaos_calmer_management http://downloads.openwrt.org/chaos_calm … nagement). Skipping.
* parse_from_stream_nomalloc: Missing new line character at end of file!
* gz_close: Unzip process killed by signal 9.

* wfopen: plugin-gargoyle-iradio.ipk: No such file or directory.
* pkg_init_from_file: Failed to extract control file from plugin-gargoyle-iradio.ipk.
root@Gargoyle:~#

próba instalacji tego pakietu przez www kończy się krótkim mignięciem ekranu, potem długo nic i pojawia się lista pakietów, gdzie ten pakiet nadal widnieje jako niezainstalowany, ale w świetle tego co powyżej to chyba bez znaczenia smile

Jak w temacie - nie instaluje mi pakietów (było odświeżenie listy); zaznaczam pakiet, niby on się ładuje ale po zakończeniu "instalacji" nadal widnieje jak niezainstalowany; Bardzo długo ładuje się stronka .../plugins.sh
Pakiety z jakimi miałem problem to głownie iradio i moduły zależne (gdy próbowałem instalować przez putty). Nie daje się zainstalować również m.in: "Management buttons on login page";
W którymś momencie router "stracił" całą listę źródeł i nawet w okienku "aktualizacja" (firmware) dawał komunikat o błędzie, że nie może sprawdzić aktualizacji.
Wziąłem drugi 1043nd (zapasowy smile i na oryginalny soft od razu wersję: 1.10.0.3; powróciły źródła pakietów, ale i tak nie można ich zainstalować sad
Czy da się korzystać z wersji 1.10.0.3 na tym sprzęcie?
Po powrocie do 1.6.2.2 nie da się odświeżać listy pakietów (tzn nic to nie daje)

16

(401 odpowiedzi, napisanych Oprogramowanie)

Dziękuję serdecznie. Działa!

17

(401 odpowiedzi, napisanych Oprogramowanie)

Przez WinSCP zalogowałem się jako root i z pliku www/iradio.sh usunąłem linijkę, coś jak ta w instrukcji:
"eval $( gargoyle_session_validator -c ..."
Może niekoniecznie wyglądała ona tak samo w tej wersji gargulca - nie wiem bo nie mam do porównania, musiałbym przywrócić ustawienia (nie zrobiłem kopiii sad Natomiast usunąłem wszystko od początku do końca (całą linijkę).
Radio działa, ale da się włączyć/wyłączyć/przełączyć na inne źródło jedynie po zalogowaniu.
Opcja bez logowania była super, bo żona sobie z komórki wchodziła przez ulubione i jednym kliknięciem zmieniała lub wznawiała jak czasem samo padło...
Jak już pisałem w wersji 1.6 dałem radę sam, tu niestety potrzebuję pomocy!

18

(401 odpowiedzi, napisanych Oprogramowanie)

Witam.
Mam problem po upgrade gargulca i ponownym zainstalowaniu karty dźwiękowej i pluginu iradio mam problem bo nie da się włączać i wyłączać radia przez stronkę bez logowania. Włączenie i wyłączenie mimo spreparowania pliku iradio jest możliwe tylko po zalogowaniu.
Bardzo by mi to ułatwiło życie gdyby udało się to przywrócić
Czy jest jakaś różnica w instrukcji między wersją 1.6 a wersją 1.9 ??