1

(11 odpowiedzi, napisanych Oprogramowanie)

Poszukaj u "wujka G" pod hasłem ESP8266 RS485, chyba znajdzie się sporo gotowców.


Pozdrawiam
M.K.

2

(13 odpowiedzi, napisanych Oprogramowanie)

TD-W8970 V1.2 - OpenWrt Chaos Calmer 15.05.1 r49294 / LuCI for-15.05 branch (git-16.110.26779-c0ae328)


link: port:0 link:down
        link: port:1 link:down
        link: port:2 link:down
        link: port:3 link:down
        link: port:4 link:up speed:1000baseT full-duplex auto
        link: port:5 link:down
        link: port:6 link:up speed:1000baseT full-duplex auto

W TD-W8970 pomogła edycja pliku „options” w /etc/ppp/
zmiana parametrów :  lcp-echo-failure,  lcp-echo-interval
Mój plik po edycji wygląda tak:

#debug
logfile /dev/null
noipdefault
noaccomp
nopcomp
nocrtscts
lock
maxfail 0
lcp-echo-failure 256
lcp-echo-interval 6

Kiedyś już o tym pisałem wink

4

(16 odpowiedzi, napisanych Oprogramowanie)

TP-Link TD-W8970
Neostrada ADSL2+ (Annex A) Opcja 20480

Line State: showtime_tc_sync [0x801]
Line Speed: 19.204 Mb/s / 980 Kb/s
Line Attenuation: 15.1 dB / 7.8 dB
Noise Margin: 6.3 dB / 7.4 dB

network.loopback=interface
network.loopback.ifname='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.globals.ula_prefix='fd24:8df8:6a8e::/48'
network.lan=interface
network.lan.force_link='1'
network.lan.type='bridge'
network.lan.proto='static'
network.lan.ipaddr='192.168.1.1'
network.lan.netmask='255.255.255.0'
network.lan.ifname='eth0.1'
network.lan.macaddr='14:cc:20:ac:89:4e'
network.lan.delegate='0'
network.lan.ipv6='0'
network.guest=interface
network.guest.proto='static'
network.guest.ipaddr='10.10.10.1'
network.guest.netmask='255.255.255.0'
network.guest.delegate='0'
network.guest.ipv6='0'
network.@switch[0]=switch
network.@switch[0].name='switch0'
network.@switch[0].reset='1'
network.@switch[0].enable_vlan='1'
network.@switch_vlan[0]=switch_vlan
network.@switch_vlan[0].device='switch0'
network.@switch_vlan[0].vlan='1'
network.@switch_vlan[0].ports='0 2 4 5 6t'
network.wan=interface
network.wan._orig_ifname='nas0'
network.wan._orig_bridge='false'
network.wan.proto='pppoa'
network.wan.delegate='0'
network.wan.encaps='vc'
network.wan.atmdev='0'
network.wan.vci='35'
network.wan.vpi='0'
network.wan.username='xxx@neostrada.pl'
network.wan.password='xxx'
network.wan.pppd_options='holdoff 6'
network.wan.ipv6='0'
network.wan.peerdns='0'
network.wan.dns='208.67.220.220 208.67.222.222'
network.dsl=vdsl
network.dsl.annex='a'
network.dsl.firmware='/lib/firmware/vdsl.bin'
network.dsl.tone='av'
network.dsl.xfer_mode='atm'

5

(86 odpowiedzi, napisanych Oprogramowanie)

@hanti

hanti napisał/a:

zauwazylem ze dioda DSL po jakims czasie przestaje swiecic (w /etc/config/system mam ustawione pppoa-wan i dioda internet dziala, uaktywnia sie kilka minut po uruchomieniu routera a przy okazji dioda DSL gasnie

O to mi chodziło wink

MK

Na CC nie sprawdzałem, chwilowo "jadę" na BB i tam działa bez problemów wink

MK

Na forum Openwrt.org pojawił się opis dotyczący wyświetlania nazw klientów podłączonych przez wifi w panelu „Luci”
https://forum.openwrt.org/viewtopic.php?id=52340

Sprawdzone na TD-W8970 BB Luci – działa wyśmienicie smile

MK

8

(86 odpowiedzi, napisanych Oprogramowanie)

Tak się zastanawiam, dlaczego bez żadnych kombinacji u mnie ten problem nie występował od ponad 3 miesięcy?
Może żle kombinujemy i problem tkwi gdzie indziej?

Potwierdzam , ostatni obraz BB od kolegi lmp11 pracował bez żadnych problemów z diodą "DSL" wink
Sekcja "atm" nie występuje w mojej konfiguracji, więc to nie to,  tak jak wspomniałem złe działanie diody "dsl" eksperymentalnie wymusiłem stosując konfig @hanti - przy stosowanej prze zemnie konfiguracji wszystko działa OK!

MK

9

(86 odpowiedzi, napisanych Oprogramowanie)

Ja trochę inaczej wykorzystuję sygnalizację w routerze i przy takiej konfiguracji „led_dsl” działa bezbłędnie.:

config led 'led_internet'
    option name 'internet'
    option sysfs 'internet'
    option trigger 'netdev'
    option default '0'
    option mode 'tx rx'
    option dev 'wlan0-1'

config led 'led_dsl'
    option name 'dsl'
    option sysfs 'dsl'
    option default '0'

config led 'led_wps'
    option name 'wps'
    option sysfs 'wps'
    option default '0'
    option trigger 'netdev'
    option mode 'tx rx'
    option dev 'wlan0-2'

config led
    option default '0'
    option name 'wifi'
    option sysfs 'ath9k-phy0'
    option trigger 'netdev'
    option dev 'wlan0'
    option mode 'link tx rx'

W celach naukowych sprawdziłem Twój konfig i faktycznie jest jakaś zależność między diodą „led_dsl” a „led_internet” tak jak to opisałeś. Zauważyłem jeszcze że wystarczy jakakolwiek zmiana ustawień w/w diod w „Luci” i dioda „DSL” gaśnie.
Jednak tak jak wspomniałem na początku, przy moim konfigu sygnalizacja LED działa bez zastrzeżeń wink

Pozdrawiam
MK

10

(86 odpowiedzi, napisanych Oprogramowanie)

Zaraz minie czwarty dzień ciągłej i bezawaryjnej pracy smile

 ----------------------------------------------------------------
 |                                                              |
 | OpenWrt Chaos Calmer (r46177)                                |
 | Build time: 2015-07-05 21:58 CEST                            |
 |                                                              |
 | Cezary Jackiewicz (obsy), http://eko.one.pl                  |
 |                                                              |
 ----------------------------------------------------------------
 | Machine: TP-LINK TD-W8970                                    |
 | Uptime: 3d, 21:52:20                                         |
 | Load: 0.08 0.03 0.05                                         |
 | Flash: total: 2.1MB, free: 1.8MB, used: 11%                  |
 | Memory: total: 58.6MB, free: 37.8MB, used: 35%               |
 | WAN: 8x.2x.1x.1xx, proto: pppoa                              |
 | LAN: 192.168.1.1                                             |
 | radio0: mode: ap, ssid: xxx, channel: 13, conn: 2            |
 | radio0: mode: ap, ssid: xxxx, channel: 13, conn: 8           |
 | radio0: mode: ap, ssid: xxxxx, channel: 13, conn: 3          |
 ----------------------------------------------------------------

Jestem bardzo zadowolony z tej wersji OpenWrt !
CC Luci bez IPv6

Pozdrawiam
MK

11

(86 odpowiedzi, napisanych Oprogramowanie)

No i kolejny upgrade:

        _______                     ________        __
       |       |.-----.-----.-----.|  |  |  |.----.|  |_
       |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
       |_______||   __|_____|__|__||________||__|  |____|
                |__| W I R E L E S S   F R E E D O M

 ----------------------------------------------------------------
 |                                                              |
 | OpenWrt Chaos Calmer (r46177)                                |
 | Build time: 2015-07-05 21:58 CEST                            |
 |                                                              |
 | Cezary Jackiewicz (obsy), http://eko.one.pl                  |
 |                                                              |
 ----------------------------------------------------------------
 | Machine: TP-LINK TD-W8970                                    |
 | Uptime: 0d, 00:07:39                                         |
 | Load: 0.06 0.66 0.47                                         |
 | Flash: total: 2.1MB, free: 1.8MB, used: 11%                  |
 | Memory: total: 58.6MB, free: 36.3MB, used: 38%               |
 | WAN: 8x.2x.1xx.5x, proto: pppoa                              |
 | LAN: 192.168.1.1                                             |
 | radio0: mode: ap, ssid: xxx, channel: 13, conn: 0          |
 | radio0: mode: ap, ssid: xxxx, channel: 13, conn: 0    |
 | radio0: mode: ap, ssid: xxxxx, channel: 13, conn: 0        |
 ----------------------------------------------------------------


root@OpenWrt:~# df -h
Filesystem                Size      Used Available Use% Mounted on
rootfs                    2.1M    236.0K      1.8M  11% /
/dev/root                 4.3M      4.3M         0 100% /rom
tmpfs                    29.3M    516.0K     28.8M   2% /tmp
/dev/mtdblock3            2.1M    236.0K      1.8M  11% /overlay
overlayfs:/overlay        2.1M    236.0K      1.8M  11% /
tmpfs                   512.0K         0    512.0K   0% /dev



root@OpenWrt:~# /etc/init.d/dsl_control status
Chipset:                Lantiq-VRx Unknown
Line State:             UP [0x801: showtime_tc_sync]
Data Rate:              19.336 Mb/s / 980 Kb/s
Line Attenuation:       15.1dB / 7.7dB
Noise Margin:           6.3dB / 7.4dB
Line Uptime:            5m 24s

Wygląda że wszystko OK! Zapiernicza jak marzenie wink

Co do "daemon.err uhttpd[2842]: sh: write error: Broken pipe" to jednak dalej występuje, nie chodziło tu o brakujące pliki sad
Jednak widzę że jest zgłoszone na dev.openwrt.org.
W sumie to w niczym nie przeszkadza, pojawia się tylko przy korzystaniu z "Luci" a że Luci używam sporadycznie czasem "rada nadzorcza" chce zerknąć wink więc to "olewam" smile

MK

12

(86 odpowiedzi, napisanych Oprogramowanie)

Super - upgrade zrobię ok południa - teraz full klientów.
Oczywiście zdam relację, zdaję sobie sprawę że nie masz tego routera na stanie i dlatego staram się dzielić wszelkimi spostrzeżeniami.

MK

13

(86 odpowiedzi, napisanych Oprogramowanie)

daemon.err uhttpd[2842]: sh: write error: Broken pipe

Problem polegał na barku plików: uhttpd.key , uhttpd.crt  w katalogu /etc/ - problem rozwiązany wink


MK

14

(86 odpowiedzi, napisanych Oprogramowanie)

moll47u napisał/a:

Jeśli mam połączenie dla Netii zalecane na pppoa to zadziała na pppoe tak jak na neostradzie? (zmieniając dane do logowania of corse?)

Zadziała - kiedyś sprawdzałem z ciekawości (oczywiście twoje dane zamiast xxx):

config atm-bridge 'atm'
    option encaps 'llc'
    option payload 'bridged'
    option vci '35'
    option vpi '0'

config interface 'wan'
    option ifname 'nas0'
    option proto 'pppoe'
    option ipv6 '1'
    option macaddr '14:xxxxxxx'
    option username 'xxx@neostrada.pl'
    option password 'xxx'

config interface 'wan6'
    option ifname '@wan'
    option proto 'dhcpv6'

config vdsl 'dsl'
    option annex 'a'
    option firmware '/lib/firmware/vdsl.bin'
    option tone 'av'
    option xfer_mode 'atm'

MK

15

(86 odpowiedzi, napisanych Oprogramowanie)

Chodzi mi raczej o:
daemon.err uhttpd[2842]: sh: write error: Broken pipe

tak jak wspomniałem powtarza się co 30 minut w logu systemu.

MK

16

(86 odpowiedzi, napisanych Oprogramowanie)

Skutek walki o wywalenie ipv6

Czyli nie zwracać na to uwagi?

MK

17

(86 odpowiedzi, napisanych Oprogramowanie)

Moje obserwacje dotyczące najnowszego obrazu Luci (bez IPv6):

- Nie wyświetlają się informacje dotyczące WIFI - brakuje biblioteki: libiwinfo-lua - po doinstalowaniu wszystko OK!



- Log systemowy co 0.5h wywala coś takiego:

Sun Jul  5 19:38:21 2015 daemon.err uhttpd[2842]: sh: write error: Broken pipe
Sun Jul  5 19:38:21 2015 daemon.err uhttpd[2842]: sh: write error: Broken pipe
Sun Jul  5 19:38:21 2015 daemon.err uhttpd[2842]: sh: write error: Broken pipe
Sun Jul  5 19:38:21 2015 daemon.err uhttpd[2842]: sh: write error: Broken pipe
Sun Jul  5 19:38:21 2015 daemon.err uhttpd[2842]: sh: write error: Broken pipe
Sun Jul  5 19:38:21 2015 daemon.err uhttpd[2842]: sh: write error: Broken pipe
Sun Jul  5 19:38:21 2015 daemon.err uhttpd[2842]: sh: write error: Broken pipe
Sun Jul  5 19:38:21 2015 daemon.err uhttpd[2842]: sh: write error: Broken pipe
Sun Jul  5 19:38:21 2015 daemon.err uhttpd[2842]: sh: write error: Broken pipe
Sun Jul  5 19:38:21 2015 daemon.err uhttpd[2842]: sh: write error: Broken pipe

Poza tym wszystko działa jak należy.

MK

18

(86 odpowiedzi, napisanych Oprogramowanie)

Cezary napisał/a:

Testuj, zaktualizowałem.

Zaktualizowane smile

BusyBox v1.23.2 (2015-06-21 14:15:10 CEST) built-in shell (ash)


        _______                     ________        __
       |       |.-----.-----.-----.|  |  |  |.----.|  |_
       |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
       |_______||   __|_____|__|__||________||__|  |____|
                |__| W I R E L E S S   F R E E D O M

 ----------------------------------------------------------------
 |                                                              |
 | OpenWrt Chaos Calmer (r46163)                                |
 | Build time: 2015-07-04 20:59 CEST                            |
 |                                                              |
 | Cezary Jackiewicz (obsy), http://eko.one.pl                  |
 |                                                              |
 ----------------------------------------------------------------
 | Machine: TP-LINK TD-W8970                                    |
 | Uptime: 0d, 00:15:11                                         |
 | Load: 0.02 0.19 0.30                                         |
 | Flash: total: 2.1MB, free: 1.9MB, used: 11%                  |
 | Memory: total: 58.6MB, free: 37.4MB, used: 36%               |
 | WAN: 7x.18x.2x.x, proto: pppoa                               |
 | LAN: 192.168.1.1                                             |
 | radio0: mode: ap, ssid: xxx, channel: 13, conn: 0          |
 | radio0: mode: ap, ssid: xxxx, channel: 13, conn: 0    |
 | radio0: mode: ap, ssid: xxxxx, channel: 13, conn: 0        |
 ----------------------------------------------------------------



root@OpenWrt:~# df -h
Filesystem                Size      Used Available Use% Mounted on
rootfs                    2.1M    232.0K      1.9M  11% /
/dev/root                 4.0M      4.0M         0 100% /rom
tmpfs                    29.3M      1.4M     27.9M   5% /tmp
/dev/mtdblock3            2.1M    232.0K      1.9M  11% /overlay
overlayfs:/overlay        2.1M    232.0K      1.9M  11% /
tmpfs                   512.0K         0    512.0K   0% /dev

......................................................................


root@OpenWrt:~# /etc/init.d/dsl_control status
Chipset:                Lantiq-VRx Unknown
Line State:             UP [0x801: showtime_tc_sync]
Data Rate:              19.404 Mb/s / 980 Kb/s
Line Attenuation:       15.1dB / 7.8dB
Noise Margin:           6.4dB / 7.4dB
Line Uptime:            14m 7s

Śmiga jak marzenie, teraz test długoterminowy o ile nie zabraknie prądu - straszą burzami  yikes

Wielkie podziękowania Cezary za poświęcenie czasu na rozwijanie softu TD-W8970.

Pozdrowienia znad morza
MK

19

(86 odpowiedzi, napisanych Oprogramowanie)

Super, będzie oprogramowanie bliskie ideału !
Oczywiście natychmiast przetestuję poprawioną wersję:)

Pozdrawiam
MK

20

(86 odpowiedzi, napisanych Oprogramowanie)

„Wrzuciłem jeszcze raz obraz, tym razem nie usuwałem kmod-ipv6 3.18.17-1, luci-proto-ipv6 git-15.179.51004-cf2e3f6-1, tym razem kernel faktycznie nie wywala błędów.

Zauważyłem jeszcze coś takiego:
po zakończeniu połączenia z routerem przez „winscp” w sys logu pojawia się:

Sat Jul  4 17:45:29 2015 authpriv.info dropbear[6028]: Exit (root): Exited normally
Sat Jul  4 17:45:29 2015 authpriv.warn dropbear[6028]: Couldn't set SO_PRIORITY (Bad file descriptor)

I absolutnie się nie czepiam, po prostu dzielę się swoimi obserwacjami, dodam że nie ma to żadnego negatywnego wpływu na doskonałą pracę routera smile

Pozdrawiam
MK

Moje uczulenie nie dotyczy tylko IPv6, po prostu nigdy nie lubiłem zbędnych dodatków w sprzęcie pracującym na wolnym oprogramowaniu zawsze wolałem sam "dozbroić" i spersonalizować urządzenie smile
A z IPv6 jest akurat tak że wszyscy chcą wyposażać w ten dodatek swoje urządzenia (bo wypada) natomiast np "Orange" zaleca nie korzystać z tego "dobrodziejstwa"  wink

21

(86 odpowiedzi, napisanych Oprogramowanie)

 |                                                              |
 | OpenWrt Chaos Calmer (r46163)                                |
 | Build time: 2015-07-04 07:19 CEST                            |
 |                                                              |
 | Cezary Jackiewicz (obsy), http://eko.one.pl                  |
 |                                                              |
 ----------------------------------------------------------------
 | Machine: TP-LINK TD-W8970                                    |
 | Uptime: 0d, 00:28:34                                         |
 | Load: 0.00 0.01 0.13                                         |
 | Flash: total: 1.9MB, free: 1.6MB, used: 14%                  |
 | Memory: total: 58.6MB, free: 36.6MB, used: 37%               |
 | WAN: 83.21.12.141, proto: pppoa                              |

Luci
Cezary napisał/a:

Dzisiejsza nie ma i ipv6 i tej partycji.

Chyba jednak ipv6 zostało, ręcznie odinstalowałem pakiety mające w nazwie Ipv6.

Pojawiły się też takie komunikaty w logu kernela

[   57.532000] kmodloader: failed to stat /tmp/overlay/upper/lib/modules/3.18.17/gre.ko
[   57.548000] kmodloader: failed to stat /tmp/overlay/upper/lib/modules/3.18.17/ip6_tables.ko
[   57.556000] kmodloader: failed to stat /tmp/overlay/upper/lib/modules/3.18.17/ip6t_REJECT.ko
[   57.564000] kmodloader: failed to stat /tmp/overlay/upper/lib/modules/3.18.17/ip6table_filter.ko
[   57.576000] kmodloader: failed to stat /tmp/overlay/upper/lib/modules/3.18.17/ip6table_mangle.ko
[   57.580000] kmodloader: failed to stat /tmp/overlay/upper/lib/modules/3.18.17/ip6table_raw.ko
[   57.592000] kmodloader: failed to stat /tmp/overlay/upper/lib/modules/3.18.17/ip_gre.ko
[   57.600000] kmodloader: failed to stat /tmp/overlay/upper/lib/modules/3.18.17/ipv6.ko
[   57.608000] kmodloader: failed to stat /tmp/overlay/upper/lib/modules/3.18.17/nf_conntrack_ipv6.ko
[   57.616000] kmodloader: failed to stat /tmp/overlay/upper/lib/modules/3.18.17/nf_defrag_ipv6.ko
[   57.624000] kmodloader: failed to stat /tmp/overlay/upper/lib/modules/3.18.17/nf_log_ipv6.ko
[   57.632000] kmodloader: failed to stat /tmp/overlay/upper/lib/modules/3.18.17/nf_reject_ipv6.ko
[   57.664000] kmodloader: failed to stat /tmp/overlay/upper/lib/modules/3.18.17/pptp.ko
[   62.856000] block: attempting to load /tmp/jffs_cfg/upper/etc/config/fstab

Poza tym chyba wszystko OK smile

Edit:
W logu pojawiło się coś takiego:

Sat Jul  4 12:17:08 2015 authpriv.info dropbear[5375]: Exit (root): Exited normally
Sat Jul  4 12:17:54 2015 daemon.err uhttpd[2827]: sh: write error: Broken pipe
Sat Jul  4 12:17:54 2015 daemon.err uhttpd[2827]: sh: write error: Broken pipe
Sat Jul  4 12:17:54 2015 daemon.err uhttpd[2827]: sh: write error: Broken pipe
Sat Jul  4 12:17:54 2015 daemon.err uhttpd[2827]: sh: write error: Broken pipe
Sat Jul  4 12:17:54 2015 daemon.err uhttpd[2827]: sh: write error: Broken pipe
Sat Jul  4 12:17:54 2015 daemon.err uhttpd[2827]: sh: write error: Broken pipe
Sat Jul  4 12:17:54 2015 daemon.err uhttpd[2827]: sh: write error: Broken pipe
Sat Jul  4 12:17:55 2015 daemon.err uhttpd[2827]: sh: write error: Broken pipe
Sat Jul  4 12:17:55 2015 daemon.err uhttpd[2827]: sh: write error: Broken pipe
Sat Jul  4 12:17:55 2015 daemon.err uhttpd[2827]: sh: write error: Broken pipe
Sat Jul  4 12:17:55 2015 daemon.err uhttpd[2827]: sh: write error: Broken pipe
Sat Jul  4 12:17:55 2015 daemon.err uhttpd[2827]: sh: write error: Broken pipe
Sat Jul  4 12:17:55 2015 daemon.err uhttpd[2827]: sh: write error: Broken pipe

22

(86 odpowiedzi, napisanych Oprogramowanie)

pimowo napisał/a:

W jaki sposób wyrzucić wszystko co związane z IPv6 i DHCPv6?

http://eko.one.pl/forum/viewtopic.php?id=11500

23

(86 odpowiedzi, napisanych Oprogramowanie)

Dokładnie, sporo osób pewnie się waha obawiając się "schodów" przy przejściu z oryginału na OpenWrt.
Ja kupiłem TD-W8970 z pełną premedytacją w celu natychmiastowej przesiadki na oprogramowanie alternatywne
i nie rozczarowałem się, wręcz przeciwnie, uważam ten zakup za mój "deal" roku, kosztował mnie 189zł - nówka w sklepie smile

MK

24

(86 odpowiedzi, napisanych Oprogramowanie)

Ja nie używam IPv6, wręcz odinstalowałem wink

25

(86 odpowiedzi, napisanych Oprogramowanie)

Może jeszcze dla "odchudzenia" usunąć z ewentualnych przyszłych obrazów IPv6 i DHCPv6, na dzień dzisiejszy mała przydatność oprócz bardzo specyficznych zastosowań a w razie potrzeby zawsze można doinstalować wink

Pozdrawiam
MK