1

(8 odpowiedzi, napisanych Sprzęt)

bajka działa super, tak samo jak na routerze vectra, Dzięki!

2

(8 odpowiedzi, napisanych Sprzęt)

a jest szansa zrobić coś z wifi? na 5GHz max to 87mb/s. Ten sam telefon podłączony pod router vectry osiąga 280mb/s.

3

(8 odpowiedzi, napisanych Sprzęt)

Zrobiłem update. Nawet bez włączania flow offload jest już 300mb. Dziękuje za pomoc!

ps do czego potrzebne jest flow offload?

4

(8 odpowiedzi, napisanych Sprzęt)

sorry nie napisałem sprawdzam po kablu.

Gargoyle PL 1.9.2.4 (b7989e6)                                
OpenWrt Chaos Calmer 15.05.1 (r49484) 

faktycznie mam starą wersję, nie da rady na tej wersji coś zrobić? ewidentnie router wczytuje wejście WAN jako 100mb.

ps. nie było mnie parę ładnych lat na forum a Cezary jak zawsze pomocny, dzięki wielkie!

5

(8 odpowiedzi, napisanych Sprzęt)

Cześć jest właśnie po aktualizacji prędkości internetu od vectra z 100 na 300mb/s. Nie wiem czemu ale router nie radzi sobie z takimi prędkościami, maks co zobaczyłem to 112mb/s. Może coś powinienem zmienić w ustawieniach?

cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd95:1814:e0d9::/48'

config interface 'lan'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ifname 'eth0.1'
        option dns '8.8.8.8 8.8.4.4'

config interface 'wan6'
        option ifname 'eth1'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'
        option blinkrate '2'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5t'

config switch_port
        option device 'switch0'
        option port '1'
        option led '6'

config switch_port
        option device 'switch0'
        option port '2'
        option led '9'

config switch_port
        option device 'switch0'
        option port '5'
        option led '2'

config interface 'wan'
        option ifname 'eth1'
        option proto 'dhcp'
        option ipv6 '0'
        option peerdns '0'
        option dns '8.8.8.8 8.8.4.4'
swconfig dev switch0 show
Global attributes:
        enable_learning: 1
        enable_vlan: 1
        enable_vlan4k: 0
        blinkrate: 2
        max_length: 1
Port 0:
        mib: Port 0 MIB counters
IfInOctets                          : 24070
EtherStatsOctets                    : 24070
EtherStatsUnderSizePkts             : 0
EtherFragments                      : 0
EtherStatsPkts64Octets              : 74
EtherStatsPkts65to127Octets         : 11
EtherStatsPkts128to255Octets        : 23
EtherStatsPkts256to511Octets        : 11
EtherStatsPkts512to1023Octets       : 5
EtherStatsPkts1024to1518Octets      : 5
EtherOversizeStats                  : 0
EtherStatsJabbers                   : 0
IfInUcastPkts                       : 87
EtherStatsMulticastPkts             : 1
EtherStatsBroadcastPkts             : 41
EtherStatsDropEvents                : 0
Dot3StatsFCSErrors                  : 0
Dot3StatsSymbolErrors               : 0
Dot3InPauseFrames                   : 0
Dot3ControlInUnknownOpcodes         : 0
IfOutOctets                         : 45674
Dot3StatsSingleCollisionFrames      : 0
Dot3StatMultipleCollisionFrames     : 0
Dot3sDeferredTransmissions          : 0
Dot3StatsLateCollisions             : 0
EtherStatsCollisions                : 0
Dot3StatsExcessiveCollisions        : 0
Dot3OutPauseFrames                  : 0
Dot1dBasePortDelayExceededDiscards  : 0
Dot1dTpPortInDiscards               : 0
IfOutUcastPkts                      : 71
IfOutMulticastPkts                  : 66
IfOutBroadcastPkts                  : 117

        led: 2
        pvid: 1
        link: port:0 link:up speed:100baseT full-duplex txflow rxflow
Port 1:
        mib: Port 1 MIB counters
IfInOctets                          : 18625
EtherStatsOctets                    : 18625
EtherStatsUnderSizePkts             : 0
EtherFragments                      : 0
EtherStatsPkts64Octets              : 3
EtherStatsPkts65to127Octets         : 9
EtherStatsPkts128to255Octets        : 28
EtherStatsPkts256to511Octets        : 5
EtherStatsPkts512to1023Octets       : 15
EtherStatsPkts1024to1518Octets      : 2
EtherOversizeStats                  : 0
EtherStatsJabbers                   : 0
IfInUcastPkts                       : 58
EtherStatsMulticastPkts             : 4
EtherStatsBroadcastPkts             : 0
EtherStatsDropEvents                : 0
Dot3StatsFCSErrors                  : 0
Dot3StatsSymbolErrors               : 0
Dot3InPauseFrames                   : 0
Dot3ControlInUnknownOpcodes         : 0
IfOutOctets                         : 52307
Dot3StatsSingleCollisionFrames      : 0
Dot3StatMultipleCollisionFrames     : 0
Dot3sDeferredTransmissions          : 0
Dot3StatsLateCollisions             : 0
EtherStatsCollisions                : 0
Dot3StatsExcessiveCollisions        : 0
Dot3OutPauseFrames                  : 0
Dot1dBasePortDelayExceededDiscards  : 0
Dot1dTpPortInDiscards               : 0
IfOutUcastPkts                      : 75
IfOutMulticastPkts                  : 63
IfOutBroadcastPkts                  : 158

        led: 6
        pvid: 1
        link: port:1 link:up speed:1000baseT full-duplex txflow rxflow
Port 2:
        mib: Port 2 MIB counters
IfInOctets                          : 27522
EtherStatsOctets                    : 27522
EtherStatsUnderSizePkts             : 0
EtherFragments                      : 0
EtherStatsPkts64Octets              : 62
EtherStatsPkts65to127Octets         : 161
EtherStatsPkts128to255Octets        : 23
EtherStatsPkts256to511Octets        : 14
EtherStatsPkts512to1023Octets       : 4
EtherStatsPkts1024to1518Octets      : 0
EtherOversizeStats                  : 0
EtherStatsJabbers                   : 0
IfInUcastPkts                       : 208
EtherStatsMulticastPkts             : 24
EtherStatsBroadcastPkts             : 32
EtherStatsDropEvents                : 0
Dot3StatsFCSErrors                  : 0
Dot3StatsSymbolErrors               : 0
Dot3InPauseFrames                   : 0
Dot3ControlInUnknownOpcodes         : 0
IfOutOctets                         : 63909
Dot3StatsSingleCollisionFrames      : 0
Dot3StatMultipleCollisionFrames     : 0
Dot3sDeferredTransmissions          : 0
Dot3StatsLateCollisions             : 0
EtherStatsCollisions                : 0
Dot3StatsExcessiveCollisions        : 0
Dot3OutPauseFrames                  : 0
Dot1dBasePortDelayExceededDiscards  : 0
Dot1dTpPortInDiscards               : 0
IfOutUcastPkts                      : 157
IfOutMulticastPkts                  : 43
IfOutBroadcastPkts                  : 126

        led: 9
        pvid: 1
        link: port:2 link:up speed:1000baseT full-duplex txflow rxflow
Port 3:
        mib: Port 3 MIB counters
IfInOctets                          : 50551202
EtherStatsOctets                    : 50551202
EtherStatsUnderSizePkts             : 0
EtherFragments                      : 0
EtherStatsPkts64Octets              : 56348
EtherStatsPkts65to127Octets         : 7460
EtherStatsPkts128to255Octets        : 569
EtherStatsPkts256to511Octets        : 271
EtherStatsPkts512to1023Octets       : 432
EtherStatsPkts1024to1518Octets      : 30294
EtherOversizeStats                  : 0
EtherStatsJabbers                   : 0
IfInUcastPkts                       : 95279
EtherStatsMulticastPkts             : 16
EtherStatsBroadcastPkts             : 79
EtherStatsDropEvents                : 0
Dot3StatsFCSErrors                  : 0
Dot3StatsSymbolErrors               : 0
Dot3InPauseFrames                   : 0
Dot3ControlInUnknownOpcodes         : 0
IfOutOctets                         : 197468619
Dot3StatsSingleCollisionFrames      : 0
Dot3StatMultipleCollisionFrames     : 0
Dot3sDeferredTransmissions          : 6616
Dot3StatsLateCollisions             : 0
EtherStatsCollisions                : 0
Dot3StatsExcessiveCollisions        : 0
Dot3OutPauseFrames                  : 0
Dot1dBasePortDelayExceededDiscards  : 0
Dot1dTpPortInDiscards               : 0
IfOutUcastPkts                      : 149324
IfOutMulticastPkts                  : 51
IfOutBroadcastPkts                  : 79

        led: 5
        pvid: 1
        link: port:3 link:up speed:1000baseT full-duplex txflow rxflow
Port 4:
        mib: Port 4 MIB counters
IfInOctets                          : 0
EtherStatsOctets                    : 0
EtherStatsUnderSizePkts             : 0
EtherFragments                      : 0
EtherStatsPkts64Octets              : 0
EtherStatsPkts65to127Octets         : 0
EtherStatsPkts128to255Octets        : 0
EtherStatsPkts256to511Octets        : 0
EtherStatsPkts512to1023Octets       : 0
EtherStatsPkts1024to1518Octets      : 0
EtherOversizeStats                  : 0
EtherStatsJabbers                   : 0
IfInUcastPkts                       : 0
EtherStatsMulticastPkts             : 0
EtherStatsBroadcastPkts             : 0
EtherStatsDropEvents                : 0
Dot3StatsFCSErrors                  : 0
Dot3StatsSymbolErrors               : 0
Dot3InPauseFrames                   : 0
Dot3ControlInUnknownOpcodes         : 0
IfOutOctets                         : 0
Dot3StatsSingleCollisionFrames      : 0
Dot3StatMultipleCollisionFrames     : 0
Dot3sDeferredTransmissions          : 0
Dot3StatsLateCollisions             : 0
EtherStatsCollisions                : 0
Dot3StatsExcessiveCollisions        : 0
Dot3OutPauseFrames                  : 0
Dot1dBasePortDelayExceededDiscards  : 0
Dot1dTpPortInDiscards               : 0
IfOutUcastPkts                      : 0
IfOutMulticastPkts                  : 0
IfOutBroadcastPkts                  : 0

        led: ???
        pvid: 0
        link: port:4 link:down
Port 5:
        mib: Port 5 MIB counters
IfInOctets                          : 198069321
EtherStatsOctets                    : 198069321
EtherStatsUnderSizePkts             : 0
EtherFragments                      : 0
EtherStatsPkts64Octets              : 14502
EtherStatsPkts65to127Octets         : 4202
EtherStatsPkts128to255Octets        : 454
EtherStatsPkts256to511Octets        : 845
EtherStatsPkts512to1023Octets       : 309
EtherStatsPkts1024to1518Octets      : 129216
EtherOversizeStats                  : 0
EtherStatsJabbers                   : 0
IfInUcastPkts                       : 149500
EtherStatsMulticastPkts             : 22
EtherStatsBroadcastPkts             : 6
EtherStatsDropEvents                : 0
Dot3StatsFCSErrors                  : 0
Dot3StatsSymbolErrors               : 0
Dot3InPauseFrames                   : 0
Dot3ControlInUnknownOpcodes         : 0
IfOutOctets                         : 50975796
Dot3StatsSingleCollisionFrames      : 0
Dot3StatMultipleCollisionFrames     : 0
Dot3sDeferredTransmissions          : 19017
Dot3StatsLateCollisions             : 0
EtherStatsCollisions                : 0
Dot3StatsExcessiveCollisions        : 0
Dot3OutPauseFrames                  : 0
Dot1dBasePortDelayExceededDiscards  : 0
Dot1dTpPortInDiscards               : 0
IfOutUcastPkts                      : 95523
IfOutMulticastPkts                  : 45
IfOutBroadcastPkts                  : 152

        led: ???
        pvid: 1
        link: port:5 link:up speed:1000baseT full-duplex txflow rxflow auto
VLAN 1:
        info: VLAN 1: Ports: '01235t', members=002f, untag=000f, fid=0
        fid: 0
        ports: 0 1 2 3 5t

6

(38 odpowiedzi, napisanych Oprogramowanie)

tak tylko po włączeniu tego oprogramowania pokazuje się: "Please plug in your Photo Keychain using the provided USB cable and make sure the devices is in "UPDATE" mode."
po włączeniu urządzenia w Update mode nic się nie dzieje. nawet nie mogę go sformatować, w menadżerze dysku występuje jako dysk wymienny 2 MB i system plików RAW

7

(38 odpowiedzi, napisanych Oprogramowanie)

po instalacji płytki CD dostarczonej z brelokiem, w katalogu instalacyjnym jest plik decode-table.bin może to jest oryginalne firmware? jak to wgrać?

8

(38 odpowiedzi, napisanych Oprogramowanie)

tak tylko jak robiłem go kilka razy to wydaje mi się ze się podmieniał za każdym razem, prawda?

9

(38 odpowiedzi, napisanych Oprogramowanie)

no i chyba po breloku, nie da się nic z nim zrobić pod windows, pod linux hack kończy się błędem

Ok, just a sec...
./hackfw.sh: line 110: 20974 Naruszenie ochrony pamięci   (core dumped) LD_LIBRARY_PATH=./libst2205 ./setpic/setpic $1 test.png

macie jakiś pomysł czy brelok do kosza?

10

(38 odpowiedzi, napisanych Oprogramowanie)

próbowałem jeszcze kilka razy i tym razem coś takiego

Ok, just a sec...
./hackfw.sh: line 110: 20974 Naruszenie ochrony pamięci   (core dumped) LD_LIBRARY_PATH=./libst2205 ./setpic/setpic $1 test.png

11

(38 odpowiedzi, napisanych Oprogramowanie)

przełączyłem na Update, może ten plik libst2205.so.1 mam nieodpowiedni. Możesz wskazać miejsce skąd go pobrać?

12

(38 odpowiedzi, napisanych Oprogramowanie)

próbowałem jeszcze raz wgrać firmware z poziomu ubuntu tym razem z plikiem libst2205.so.1 w /lib i

Ok, just a sec...
Unable to get parm_block
Open failed!

13

(38 odpowiedzi, napisanych Oprogramowanie)

zrobiłem i znów błąd driver st2205
więc jeszcze raz postanowiłem zainstalować lcd4linux,
wykasowałem lcd4linux-custom i po rebocie routera

root@Gargoyle:~# opkg install [url]http://ecco.selfip.net/old/backfire/ar71xx/package[/url]
s/lcd4linux-custom_r1159-3.2_ar71xx.ipk
Downloading [url]http://ecco.selfip.net/old/backfire/ar71xx/packages/lcd4linux-custom_r1159-3.2_ar71xx.ipk[/url].
Installing lcd4linux-custom (r1159-3.2) to root...
Configuring lcd4linux-custom.
root@Gargoyle:~# mc
Warning: file /etc/mc/sfs.ini not found
Warning: cannot open /usr/lib/mc/extfs.d directory

root@Gargoyle:~#     chown root.root /etc/lcd4linux.conf
root@Gargoyle:~#     chmod 600 /etc/lcd4linux.conf
root@Gargoyle:~#     lcd4linux -F -f /etc/lcd4linux.conf
st2205: cannot open st2205 device /dev/sda
Error initializing driver st2205: Exit!

14

(38 odpowiedzi, napisanych Oprogramowanie)

proszę

root@Gargoyle:~# ls -al /lib/*
-rwxrwxr-x    1 root     root          7391 Mar 12  2013 /lib/ar71xx.sh
-rwxrwxr-x    1 root     root          7065 Oct 20  2012 /lib/functions.sh
-rwxr-xr-x    1 root     root         28968 Apr 19  2013 /lib/ld-uClibc-0.9.33.2.so
lrwxrwxrwx    1 root     root            21 Apr 27  2013 /lib/ld-uClibc.so.0 -> ld-uClibc-0.9.33.2.so
-rw-r--r--    1 root     root          6536 Apr 19  2013 /lib/libblobmsg_json.so
lrwxrwxrwx    1 root     root            21 Apr 27  2013 /lib/libc.so.0 -> libuClibc-0.9.33.2.so
-rwxr-xr-x    1 root     root         22852 Apr 19  2013 /lib/libcrypt-0.9.33.2.so
lrwxrwxrwx    1 root     root            20 Apr 27  2013 /lib/libcrypt.so.0 -> libcrypt-0.9.33.2.so
-rwxr-xr-x    1 root     root         12504 Apr 19  2013 /lib/libdl-0.9.33.2.so
lrwxrwxrwx    1 root     root            17 Apr 27  2013 /lib/libdl.so.0 -> libdl-0.9.33.2.so
-rw-r--r--    1 root     root         76936 Apr 19  2013 /lib/libgcc_s.so.1
-rwxr-xr-x    1 root     root         85244 Apr 19  2013 /lib/libm-0.9.33.2.so
lrwxrwxrwx    1 root     root            16 Apr 27  2013 /lib/libm.so.0 -> libm-0.9.33.2.so
-rwxrw-rw-    1 root     root           869 Jul  2  2012 /lib/libnsl-0.9.30.1.so
-rwxrw-rw-    1 root     root            18 Mar 30  2012 /lib/libnsl.so.0
-rwxr-xr-x    1 root     root         78652 Apr 19  2013 /lib/libpthread-0.9.33.2.so
lrwxrwxrwx    1 root     root            22 Apr 27  2013 /lib/libpthread.so.0 -> libpthread-0.9.33.2.so
-rw-r--r--    1 root     root         75044 Apr 19  2013 /lib/librpc.so
-rwxr-xr-x    1 root     root         12524 Apr 19  2013 /lib/librt-0.9.33.2.so
lrwxrwxrwx    1 root     root            17 Apr 27  2013 /lib/librt.so.0 -> librt-0.9.33.2.so
-rwxr-xr-x    1 root     root        355503 Apr 19  2013 /lib/libuClibc-0.9.33.2.so
-rw-r--r--    1 root     root         22144 Apr 19  2013 /lib/libubox.so
-rw-r--r--    1 root     root         15328 Apr 19  2013 /lib/libubus.so
-rwxr-xr-x    1 root     root         32424 Apr 19  2013 /lib/libuci.so
-rwxr-xr-x    1 root     root          4036 Apr 19  2013 /lib/libutil-0.9.33.2.so
lrwxrwxrwx    1 root     root            19 Apr 27  2013 /lib/libutil.so.0 -> libutil-0.9.33.2.so

/lib/config:
drwxrwxr-x    2 root     root            29 Apr 27  2013 .
drwxr-xr-x    1 root     root          4096 Mar 15 11:49 ..
-rw-rw-r--    1 root     root          3646 Oct 20  2012 uci.sh

/lib/firewall:
drwxr-xr-x    2 root     root           198 Apr 27  2013 .
drwxr-xr-x    1 root     root          4096 Mar 15 11:49 ..
-rw-r--r--    1 root     root          2296 Apr 19  2013 config.sh
-rw-r--r--    1 root     root          2765 Apr 19  2013 core.sh
-rw-r--r--    1 root     root          1073 Apr 19  2013 core_forwarding.sh
-rw-r--r--    1 root     root          8138 Apr 19  2013 core_init.sh
-rw-r--r--    1 root     root          5788 Apr 19  2013 core_interface.sh
-rw-r--r--    1 root     root          3991 Apr 19  2013 core_redirect.sh
-rw-r--r--    1 root     root          2705 Apr 19  2013 core_rule.sh
-rw-r--r--    1 root     root          6992 Apr 19  2013 fw.sh
-rw-r--r--    1 root     root           172 Apr 19  2013 uci_firewall.sh

/lib/firmware:
drwxr-xr-x    2 root     root             3 Apr 27  2013 .
drwxr-xr-x    1 root     root          4096 Mar 15 11:49 ..

/lib/firstboot:
drwxrwxr-x    2 root     root           405 Apr 27  2013 .
drwxr-xr-x    1 root     root          4096 Mar 15 11:49 ..
-rw-rw-r--    1 root     root           115 Oct 20  2012 05_firstboot_skip
-rw-rw-r--    1 root     root           932 Oct 20  2012 10_determine_parts
-rw-rw-r--    1 root     root           356 Oct 20  2012 10_no_fo_clear_overlay
-rw-rw-r--    1 root     root           261 Oct 20  2012 10_reset_has_mini_fo
-rw-rw-r--    1 root     root           262 Oct 20  2012 20_has_mini_fo
-rw-rw-r--    1 root     root           325 Oct 20  2012 20_no_fo_mount_jffs
-rw-rw-r--    1 root     root           287 Oct 20  2012 20_reset_clear_jffs
-rw-rw-r--    1 root     root           225 Oct 20  2012 30_is_rootfs_mounted
-rw-rw-r--    1 root     root           212 Oct 20  2012 30_no_fo_pivot
-rw-rw-r--    1 root     root           228 Oct 20  2012 30_reset_copy_rom
-rw-rw-r--    1 root     root           361 Oct 20  2012 40_copy_ramoverlay
-rw-rw-r--    1 root     root           365 Oct 20  2012 40_no_fo_copy_ramoverlay
-rw-rw-r--    1 root     root           383 Oct 20  2012 50_pivot
-rw-rw-r--    1 root     root           224 Oct 20  2012 99_10_no_fo_cleanup
-rw-rw-r--    1 root     root           498 Oct 20  2012 99_10_with_fo_cleanup

/lib/functions:
drwxr-xr-x    1 root     root          4096 Apr 30  2013 .
drwxr-xr-x    1 root     root          4096 Mar 15 11:49 ..
-rw-r--r--    1 root     root          6588 Apr 27  2013 block.sh
-rw-rw-r--    1 root     root          3045 Oct 20  2012 boot.sh
-rw-r--r--    1 root     root          1092 Apr 27  2013 extmount.sh
drwxr-xr-x    1 root     root          4096 Apr 27  2013 fsck
-rw-r--r--    1 root     root           794 Apr 27  2013 fsck.sh
-rw-r--r--    1 root     root          2650 Apr 27  2013 mount.sh
-rw-rw-r--    1 root     root          3358 Oct 20  2012 network.sh
-rw-rw-r--    1 root     root          3488 Oct 20  2012 service.sh
-rw-rw-r--    1 root     root          4252 Oct 20  2012 uci-defaults.sh

/lib/lua:
drwxr-xr-x    2 root     root            30 Apr 27  2013 .
drwxr-xr-x    1 root     root          4096 Mar 15 11:49 ..
-rw-r--r--    1 root     root         11504 Apr 19  2013 ubus.so

/lib/modules:
drwxr-xr-x    1 root     root          4096 Feb 15 09:49 .
drwxr-xr-x    1 root     root          4096 Mar 15 11:49 ..
drwxr-xr-x    1 root     root          4096 Mar 14 19:47 3.3.8

/lib/netifd:
drwxr-xr-x    3 root     root           100 Apr 27  2013 .
drwxr-xr-x    1 root     root          4096 Mar 15 11:49 ..
-rwxrwxr-x    1 root     root          2381 Dec 16  2012 dhcp.script
-rwxr-xr-x    1 root     root          6801 Jan 29  2013 netifd-proto.sh
-rwxr-xr-x    1 root     root           238 Apr 19  2013 ppp-down
-rwxr-xr-x    1 root     root           649 Apr 19  2013 ppp-up
drwxr-xr-x    2 root     root            57 Apr 27  2013 proto

/lib/network:
drwxr-xr-x    2 root     root            49 Apr 27  2013 .
drwxr-xr-x    1 root     root          4096 Mar 15 11:49 ..
-rwxrwxr-x    1 root     root          1607 Oct 20  2012 config.sh
-rw-r--r--    1 root     root           284 Apr 19  2013 switch.sh

/lib/preinit:
drwxr-xr-x    1 root     root          4096 Apr 30  2013 .
drwxr-xr-x    1 root     root          4096 Mar 15 11:49 ..
-rw-r--r--    1 root     root            25 Apr 27  2013 00_extroot.conf
-rw-rw-r--    1 root     root           111 Oct 20  2012 02_default_set_state
-rw-rw-r--    1 root     root           105 Oct  5  2012 03_preinit_do_ar71xx.sh
-rw-rw-r--    1 root     root           176 Oct  5  2012 05_enable_reset_button_ar71xx
-rw-rw-r--    1 root     root           193 Oct 20  2012 05_mount_skip
-rw-rw-r--    1 root     root           813 Oct  5  2012 05_set_iface_mac_ar71xx
-rw-rw-r--    1 root     root           153 Oct  5  2012 05_set_preinit_iface_ar71xx
-rw-rw-r--    1 root     root           353 Oct 20  2012 10_check_for_mtd
-rw-rw-r--    1 root     root           576 Oct 20  2012 10_essential_fs
-rw-rw-r--    1 root     root           365 Oct 20  2012 10_indicate_failsafe
-rw-rw-r--    1 root     root          1191 Oct 20  2012 10_indicate_preinit
-rw-rw-r--    1 root     root           344 Oct 20  2012 20_check_jffs2_ready
-rw-rw-r--    1 root     root           786 Oct 20  2012 20_device_fs_mount
-rw-rw-r--    1 root     root          1027 Oct 20  2012 30_device_fs_daemons
-rw-rw-r--    1 root     root          2084 Oct 20  2012 30_failsafe_wait
-rw-rw-r--    1 root     root           188 Oct 20  2012 40_init_shm
-rw-rw-r--    1 root     root           301 Oct 20  2012 40_mount_devpts
-rw-rw-r--    1 root     root           498 Oct 20  2012 40_mount_jffs2
-rw-rw-r--    1 root     root           258 Oct 20  2012 40_run_failsafe_hook
-rw-rw-r--    1 root     root           518 Oct 20  2012 41_merge_overlay_hooks
-rw-rw-r--    1 root     root           766 Oct 20  2012 50_choose_console
-rw-r--r--    1 root     root          2274 Apr 27  2013 50_determine_usb_root
-rw-rw-r--    1 root     root           282 Oct 20  2012 50_indicate_regular_preinit
-rw-r--r--    1 root     root          1630 Apr 27  2013 55_determine_extroot_sysupgrade
-rw-rw-r--    1 root     root           196 Oct 20  2012 60_init_hotplug
-rw-r--r--    1 root     root           802 Apr 27  2013 60_pivot_usb_root
-rw-rw-r--    1 root     root           247 Oct 20  2012 70_initramfs_test
-rw-rw-r--    1 root     root           327 Oct 20  2012 70_pivot_jffs2_root
-rw-rw-r--    1 root     root           192 Oct 20  2012 80_mount_root
-rw-rw-r--    1 root     root           265 Oct 20  2012 90_init_console
-rw-rw-r--    1 root     root           240 Oct 20  2012 90_mount_no_jffs2
-rw-rw-r--    1 root     root           311 Oct 20  2012 90_restore_config
-rw-rw-r--    1 root     root           380 Oct 20  2012 99_10_failsafe_login
-rw-rw-r--    1 root     root           207 Oct 20  2012 99_10_mount_no_mtd
-rw-rw-r--    1 root     root           379 Oct 20  2012 99_10_run_init

/lib/upgrade:
drwxr-xr-x    1 root     root          4096 Mar 28  2012 .
drwxr-xr-x    1 root     root          4096 Mar 15 11:49 ..
-rw-rw-r--    1 root     root          5014 Oct  5  2012 allnet.sh
-rw-rw-r--    1 root     root          4995 Apr 25  2013 common.sh
-rw-rw-r--    1 root     root          4107 Oct  5  2012 dir825.sh
drwxr-xr-x    1 root     root          4096 Mar 28  2012 keep.d
-rw-rw-r--    1 root     root          6269 Nov 25  2012 openmesh.sh
-rwxrwxr-x    1 root     root          5950 Mar 12  2013 platform.sh

/lib/wifi:
drwxr-xr-x    2 root     root            89 Apr 27  2013 .
drwxr-xr-x    1 root     root          4096 Mar 15 11:49 ..
-rw-r--r--    1 root     root          9860 Apr 19  2013 hostapd.sh
-rw-r--r--    1 root     root         16763 Apr 27  2013 mac80211.sh
-rw-r--r--    1 root     root          4427 Apr 19  2013 wpa_supplicant.sh

15

(38 odpowiedzi, napisanych Oprogramowanie)

dwa plik libnsl.so.0 i libnsl-0.9.30.1.so przekopiowałem do routera, do katalogu /lib nadal błąd

root@Gargoyle:~#     lcd4linux -F -f /etc/lcd4linux.conf
lcd4linux: '/lib/libnsl.so.0' is not an ELF file
lcd4linux: can't load library 'libnsl.so.0'

16

(38 odpowiedzi, napisanych Oprogramowanie)

rozpakowałem plik http://ecco.selfip.net/old/backfire/ar7 … ar71xx.ipk i tam z katalogu /lib wkopiowałem plik na router do /lib
czy to jakoś inaczej trzeba zrobić?

17

(38 odpowiedzi, napisanych Oprogramowanie)

nie działa, rozumiem że bez tej biblioteki nie odpalę tego breloka?

root@Gargoyle:~#     lcd4linux -F -f /etc/lcd4linux.conf
lcd4linux: '/lib/libnsl.so.0' is not an ELF file
lcd4linux: can't load library 'libnsl.so.0'

18

(38 odpowiedzi, napisanych Oprogramowanie)

jesteś Wielki nie dość że znasz się na temacie to jeszcze potrafisz zgadywać wink

dobra przez z mękę z instalacja tego lcd, teraz brakuje biblioteki lcd4linux: can't load library 'libnsl.so.0' szukam w "internetach" ale nie mogę znaleźć pliku który by działał, może ktoś pomóc?

19

(38 odpowiedzi, napisanych Oprogramowanie)

Przepraszam ale jakbym umiał to zrobić to nie prosiłbym Cię o pomoc. Niestety nie jestem biegły w linux itp. Czy mogę prosić o pomoc w tej sprawie? Ciebie bądź kogoś kto wie jak to wykonać?

20

(38 odpowiedzi, napisanych Oprogramowanie)

poczytałem na forum i widzę że kilka osób ma z tym problem, Cezary możesz napisać jakieś howto jak wkompilować ten driver

21

(38 odpowiedzi, napisanych Oprogramowanie)

dobrze w takim razie zmieniłem konfig pliku lcd4linux na Twój z  tematu http://eko.one.pl/?p=openwrt-lcd4linux i teraz

root@Gargoyle:~#     lcd4linux -F -f /etc/lcd4linux.conf
drv_init(st2205) failed: no such driver
Error initializing driver st2205: Exit!

czemu tak przecież zainstalowałem st2205tool

22

(38 odpowiedzi, napisanych Oprogramowanie)

faktycznie po doinstalowaniu libgd-dev zadziałało, przebieg instalacji poniżej i błąd na końcu,

root@ania-ubuntu:/home/ania/Pobrane/st2205tool# ./hackfw.sh /dev/sdb
Interactive script to hack the firmware of your keychain photo
player.
Message written.

Ok, first off all, we're going to backup the firmware and memory of your
device to fwimage.bak and memimage.bak. Please save fwimage.bak, you
need it to flash a newer version into your unit.
Found existing fwimage.bak, moving to fwimage.bak.old
..
..............................................................
Making a working copy...
Looking for a known device profile...
hack/m_coby_dp151 ...
...nope.
hack/m_coby_dp151_v8 ...
...nope.
hack/m_dealextreme_sku5218 ...
...nope.
hack/m_dealextreme_sku5218_new ...
...nope.
hack/m_dig-291 ...
We have a match!
Requirements OK, we can try to hack the device. Proceed? (yes/no)
yes
Patching fw...

Uploading fw
Firmware update! If unsure, press ctrl-C NOW!
Too late. Commencing firmware update...
..
Firmware upgraded. Un- and replug USB connection to restart device.


All done. To test, disconnect the device and when it has rebooted, connect
it again, go into 'update mode' and press enter. To quit, use ctrl-c.

Ok, just a sec...
./setpic/setpic: error while loading shared libraries: libst2205.so.1: cannot open shared object file: No such file or directory

po włączeniu     lcd4linux -F -f /etc/lcd4linux.conf

root@Gargoyle:~#     lcd4linux -F -f /etc/lcd4linux.conf
drv_init(Image) failed: no such driver
Error initializing driver Image: Exit!

23

(38 odpowiedzi, napisanych Oprogramowanie)

a wiesz może czemu nie działa polecenie make

root@ania-ubuntu:/home/ania/Pobrane/st2205tool# make
make -C setpic
make[1]: Wejście do katalogu `/home/ania/Pobrane/st2205tool/setpic'
cc -g -Wall -I../libst2205   -c -o main.o main.c
main.c:25:16: fatal error: gd.h: Nie ma takiego pliku ani katalogu
 #include <gd.h>
                ^
compilation terminated.
make[1]: *** [main.o] Błąd 1
make[1]: Opuszczenie katalogu `/home/ania/Pobrane/st2205tool/setpic'
make: *** [setpic/setpic] Błąd 2
root@ania-ubuntu:/home/ania/Pobrane/st2205tool#

24

(38 odpowiedzi, napisanych Oprogramowanie)

Witam, mam pytanie jaką paczkę pobrać ze strony http://picframe.spritesserver.nl/wiki/i … /Main_Page żeby zhakować ten brelok? Patrzyłem na opis http://eko.one.pl/?p=openwrt-lcd4linux niestety nie ma tam podanej konkretnej ścieżki do pliku.

25

(419 odpowiedzi, napisanych Oprogramowanie)

Niestety u mnie nie działa sad
po włączeniu w gargoyle (1.5.9.9) "Internet Radio" pokazuje się komunikat
Unknown operation near line 18 of iradio.sh

plik /etc/config/iradio.sh jest pusty

Pomoże ktoś?