1

(29 odpowiedzi, napisanych Oprogramowanie)

Oj, przepraszam, jednak działa
Aplikacja na telefonie do skanowania sieci LAN mi błędnie wyszukiwała

2

(29 odpowiedzi, napisanych Oprogramowanie)

Dodałem reguły zgodnie z powyższą instrukcją. Możliwe że nie widzi mi urządzeń LAN przez to że działa po protokole TCP?
Czy sprawdzać inny powód?

3

(29 odpowiedzi, napisanych Oprogramowanie)

To jeszcze nieśmiało zapytam.
Żeby mieć dostęp do sieci LAN za serwerem (do urządzeń w sieci lokalnej) w adresacji 192.168.1.x wystarczy zastosować instrukcję poniżej czy cały serwer OpenVPN trzeba przekonfigurować z 10.8.0.x na 192.168.1.x?

Dostęp do sieci LAN za serwerem
Na serwerze OpenVPN definiujemy jaką trasę ma wysłać do klienta, aby klient mógł się odwołać do sieci lokalnej serwera (zakładamy że serwer obsługuje sieć lan o adresacji 192.168.1.0/24):


    # uci add_list openvpn.home.push='route 192.168.1.0 255.255.255.0'
    # uci commit openvpn

Dodatkowo należy jeszcze dodać na serwerze do strefy VPN opcję masq 1 (w pliku /etc/config/firewall):


    config zone
        option name 'vpn'
        option input 'ACCEPT'
        option forward 'ACCEPT'
        option output 'ACCEPT'
        option network 'vpn'
        option masq '1'

Oraz dodajemy możliwość forwardu pakietów pomiędzy vpn a lan


    # uci add firewall forwarding
    # uci set firewall.@forwarding[-1].src='vpn'
    # uci set firewall.@forwarding[-1].dest='lan'
    # uci commit firewall

Zapisujmy całość i restartujemy router lub usługi:


    # /etc/init.d/openvpn restart
    # /etc/init.d/firewall reload

Pamiętajmy że może to sprawić niezły problem jeżeli klient ma drugą sieć (np. lan) o takiej samej adresacji. Należy wtedy zmienić zakres adresów serwera lub klienta (np. na 192.168.2.1). Należy też pamiętać, aby urządzenie w sieci lokalnej za serwerem miało poprawnie ustawiony gateway, inaczej możemy nie móc ani go pingować ani dostać się do jego zasobów.

4

(29 odpowiedzi, napisanych Oprogramowanie)

Ok, ruszyło na TCP

Jednak to był problem

Dzięki wielkie za pomoc

5

(29 odpowiedzi, napisanych Oprogramowanie)

xury napisał/a:

Czy aby na pewno dostawca udostępnił ci port TCP/UDP czy może tylko TCP?

Jak to sprawdzić najprościej ?

6

(29 odpowiedzi, napisanych Oprogramowanie)

Peer punkt końcowy
91.231.60.3:25102

7

(29 odpowiedzi, napisanych Oprogramowanie)

Jest to:

root@OpenWrt:~# iptables -v -L
Chain INPUT (policy ACCEPT 1532 packets, 528K bytes)
 pkts bytes target     prot opt in     out     source               destination
  142 11290 ACCEPT     all  --  lo     any     anywhere             anywhere             /* !fw3 */
 3656  830K input_rule  all  --  any    any     anywhere             anywhere             /* !fw3: Custom input rule chain */
  805 87862 ACCEPT     all  --  any    any     anywhere             anywhere             ctstate RELATED,ESTABLISHED /* !fw3 */
   44  2520 syn_flood  tcp  --  any    any     anywhere             anywhere             tcp flags:FIN,SYN,RST,ACK/SYN /* !fw3 */
 1303  212K zone_lan_input  all  --  br-lan any     anywhere             anywhere             /* !fw3 */
   16  1820 zone_wan_input  all  --  pppoe-wan any     anywhere             anywhere             /* !fw3 */
    0     0 zone_wg_input  all  --  wg0    any     anywhere             anywhere             /* !fw3 */

Chain FORWARD (policy DROP 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination
 488K  232M forwarding_rule  all  --  any    any     anywhere             anywhere             /* !fw3: Custom forwarding rule chain */
 488K  232M ACCEPT     all  --  any    any     anywhere             anywhere             ctstate RELATED,ESTABLISHED /* !fw3 */
  942  111K zone_lan_forward  all  --  br-lan any     anywhere             anywhere             /* !fw3 */
    0     0 zone_wan_forward  all  --  pppoe-wan any     anywhere             anywhere             /* !fw3 */
    0     0 zone_wg_forward  all  --  wg0    any     anywhere             anywhere             /* !fw3 */
    0     0 reject     all  --  any    any     anywhere             anywhere             /* !fw3 */

Chain OUTPUT (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination
  142 11290 ACCEPT     all  --  any    lo      anywhere             anywhere             /* !fw3 */
 2868  560K output_rule  all  --  any    any     anywhere             anywhere             /* !fw3: Custom output rule chain */
 2503  527K ACCEPT     all  --  any    any     anywhere             anywhere             ctstate RELATED,ESTABLISHED /* !fw3 */
    7  2296 zone_lan_output  all  --  any    br-lan  anywhere             anywhere             /* !fw3 */
  358 30704 zone_wan_output  all  --  any    pppoe-wan  anywhere             anywhere             /* !fw3 */
    0     0 zone_wg_output  all  --  any    wg0     anywhere             anywhere             /* !fw3 */

Chain forwarding_lan_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination

Chain forwarding_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination

Chain forwarding_wan_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination

Chain forwarding_wg_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination

Chain input_lan_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination

Chain input_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination

Chain input_wan_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination

Chain input_wg_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination

Chain output_lan_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination

Chain output_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination

Chain output_wan_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination

Chain output_wg_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination

Chain reject (3 references)
 pkts bytes target     prot opt in     out     source               destination
    7   335 REJECT     tcp  --  any    any     anywhere             anywhere             /* !fw3 */ reject-with tcp-reset
    9  1485 REJECT     all  --  any    any     anywhere             anywhere             /* !fw3 */ reject-with icmp-port-unreachable

Chain syn_flood (1 references)
 pkts bytes target     prot opt in     out     source               destination
   44  2520 RETURN     tcp  --  any    any     anywhere             anywhere             tcp flags:FIN,SYN,RST,ACK/SYN limit: avg 25/sec burst 50 /* !fw3 */
    0     0 DROP       all  --  any    any     anywhere             anywhere             /* !fw3 */

Chain zone_lan_dest_ACCEPT (5 references)
 pkts bytes target     prot opt in     out     source               destination
    7  2296 ACCEPT     all  --  any    br-lan  anywhere             anywhere             /* !fw3 */

Chain zone_lan_forward (1 references)
 pkts bytes target     prot opt in     out     source               destination
  942  111K forwarding_lan_rule  all  --  any    any     anywhere             anywhere             /* !fw3: Custom lan forwarding rule chain */
  942  111K zone_wan_dest_ACCEPT  all  --  any    any     anywhere             anywhere             /* !fw3: Zone lan to wan forwarding policy */
    0     0 zone_wg_dest_ACCEPT  all  --  any    any     anywhere             anywhere             /* !fw3: Zone lan to wg forwarding policy */
    0     0 ACCEPT     all  --  any    any     anywhere             anywhere             ctstate DNAT /* !fw3: Accept port forwards */
    0     0 zone_lan_dest_ACCEPT  all  --  any    any     anywhere             anywhere             /* !fw3 */

Chain zone_lan_input (1 references)
 pkts bytes target     prot opt in     out     source               destination
 1303  212K input_lan_rule  all  --  any    any     anywhere             anywhere             /* !fw3: Custom lan input rule chain */
    0     0 ACCEPT     all  --  any    any     anywhere             anywhere             ctstate DNAT /* !fw3: Accept port redirections */
 1303  212K zone_lan_src_ACCEPT  all  --  any    any     anywhere             anywhere             /* !fw3 */

Chain zone_lan_output (1 references)
 pkts bytes target     prot opt in     out     source               destination
    7  2296 output_lan_rule  all  --  any    any     anywhere             anywhere             /* !fw3: Custom lan output rule chain */
    7  2296 zone_lan_dest_ACCEPT  all  --  any    any     anywhere             anywhere             /* !fw3 */

Chain zone_lan_src_ACCEPT (1 references)
 pkts bytes target     prot opt in     out     source               destination
 1303  212K ACCEPT     all  --  br-lan any     anywhere             anywhere             ctstate NEW,UNTRACKED /* !fw3 */

Chain zone_wan_dest_ACCEPT (3 references)
 pkts bytes target     prot opt in     out     source               destination
    8   344 DROP       all  --  any    pppoe-wan  anywhere             anywhere             ctstate INVALID /* !fw3: Prevent NAT leakage */
 1292  141K ACCEPT     all  --  any    pppoe-wan  anywhere             anywhere             /* !fw3 */

Chain zone_wan_dest_REJECT (1 references)
 pkts bytes target     prot opt in     out     source               destination
    0     0 reject     all  --  any    pppoe-wan  anywhere             anywhere             /* !fw3 */

Chain zone_wan_forward (1 references)
 pkts bytes target     prot opt in     out     source               destination
    0     0 forwarding_wan_rule  all  --  any    any     anywhere             anywhere             /* !fw3: Custom wan forwarding rule chain */
    0     0 zone_lan_dest_ACCEPT  esp  --  any    any     anywhere             anywhere             /* !fw3: Allow-IPSec-ESP */
    0     0 zone_lan_dest_ACCEPT  udp  --  any    any     anywhere             anywhere             udp dpt:isakmp /* !fw3: Allow-ISAKMP */
    0     0 zone_wg_dest_ACCEPT  all  --  any    any     anywhere             anywhere             /* !fw3: Zone wan to wg forwarding policy */
    0     0 ACCEPT     all  --  any    any     anywhere             anywhere             ctstate DNAT /* !fw3: Accept port forwards */
    0     0 zone_wan_dest_REJECT  all  --  any    any     anywhere             anywhere             /* !fw3 */

Chain zone_wan_input (1 references)
 pkts bytes target     prot opt in     out     source               destination
   16  1820 input_wan_rule  all  --  any    any     anywhere             anywhere             /* !fw3: Custom wan input rule chain */
    0     0 ACCEPT     udp  --  any    any     anywhere             anywhere             udp dpt:bootpc /* !fw3: Allow-DHCP-Renew */
    0     0 ACCEPT     icmp --  any    any     anywhere             anywhere             icmp echo-request /* !fw3: Allow-Ping */
    0     0 ACCEPT     igmp --  any    any     anywhere             anywhere             /* !fw3: Allow-IGMP */
    0     0 ACCEPT     udp  --  any    any     anywhere             anywhere             udp dpt:8062 /* !fw3: wireguard */
    0     0 ACCEPT     all  --  any    any     anywhere             anywhere             ctstate DNAT /* !fw3: Accept port redirections */
   16  1820 zone_wan_src_REJECT  all  --  any    any     anywhere             anywhere             /* !fw3 */

Chain zone_wan_output (1 references)
 pkts bytes target     prot opt in     out     source               destination
  358 30704 output_wan_rule  all  --  any    any     anywhere             anywhere             /* !fw3: Custom wan output rule chain */
  358 30704 zone_wan_dest_ACCEPT  all  --  any    any     anywhere             anywhere             /* !fw3 */

Chain zone_wan_src_REJECT (1 references)
 pkts bytes target     prot opt in     out     source               destination
   16  1820 reject     all  --  pppoe-wan any     anywhere             anywhere             /* !fw3 */

Chain zone_wg_dest_ACCEPT (4 references)
 pkts bytes target     prot opt in     out     source               destination
    0     0 DROP       all  --  any    wg0     anywhere             anywhere             ctstate INVALID /* !fw3: Prevent NAT leakage */
    0     0 ACCEPT     all  --  any    wg0     anywhere             anywhere             /* !fw3 */

Chain zone_wg_forward (1 references)
 pkts bytes target     prot opt in     out     source               destination
    0     0 forwarding_wg_rule  all  --  any    any     anywhere             anywhere             /* !fw3: Custom wg forwarding rule chain */
    0     0 zone_wan_dest_ACCEPT  all  --  any    any     anywhere             anywhere             /* !fw3: Zone wg to wan forwarding policy */
    0     0 zone_lan_dest_ACCEPT  all  --  any    any     anywhere             anywhere             /* !fw3: Zone wg to lan forwarding policy */
    0     0 ACCEPT     all  --  any    any     anywhere             anywhere             ctstate DNAT /* !fw3: Accept port forwards */
    0     0 zone_wg_dest_ACCEPT  all  --  any    any     anywhere             anywhere             /* !fw3 */

Chain zone_wg_input (1 references)
 pkts bytes target     prot opt in     out     source               destination
    0     0 input_wg_rule  all  --  any    any     anywhere             anywhere             /* !fw3: Custom wg input rule chain */
    0     0 ACCEPT     all  --  any    any     anywhere             anywhere             ctstate DNAT /* !fw3: Accept port redirections */
    0     0 zone_wg_src_ACCEPT  all  --  any    any     anywhere             anywhere             /* !fw3 */

Chain zone_wg_output (1 references)
 pkts bytes target     prot opt in     out     source               destination
    0     0 output_wg_rule  all  --  any    any     anywhere             anywhere             /* !fw3: Custom wg output rule chain */
    0     0 zone_wg_dest_ACCEPT  all  --  any    any     anywhere             anywhere             /* !fw3 */

Chain zone_wg_src_ACCEPT (1 references)
 pkts bytes target     prot opt in     out     source               destination
    0     0 ACCEPT     all  --  wg0    any     anywhere             anywhere             ctstate NEW,UNTRACKED /* !fw3 */

8

(29 odpowiedzi, napisanych Oprogramowanie)

UDP, serwer Wireguard na porcie 8062, nie z LANu tylko z innej sieci
Brak połączenia

9

(29 odpowiedzi, napisanych Oprogramowanie)

Cezary napisał/a:

Ej, ale otworzyłeś 8062/udp, a ssh to tcp. Zmień na tcp i zrestartuj firewall.

Jest TCP

10

(29 odpowiedzi, napisanych Oprogramowanie)

Dostawca otworzył mi ten port bo mogę go przekierować na np. openmediavault

Chyba że blokuje samego wireguarda

11

(29 odpowiedzi, napisanych Oprogramowanie)

Ten fragment?


Chain zone_wan_input (1 references)
pkts bytes target     prot opt in     out     source               destination
   17  2175 input_wan_rule  all  --  any    any     anywhere             anywhere             /* !fw3: Custom wan input rule chain */
    0     0 ACCEPT     udp  --  any    any     anywhere             anywhere             udp dpt:bootpc /* !fw3: Allow-DHCP-Renew */
    0     0 ACCEPT     icmp --  any    any     anywhere             anywhere             icmp echo-request /* !fw3: Allow-Ping */
    0     0 ACCEPT     igmp --  any    any     anywhere             anywhere             /* !fw3: Allow-IGMP */
    0     0 ACCEPT     udp  --  any    any     anywhere             anywhere             udp dpt:8062 /* !fw3: wireguard */
    0     0 ACCEPT     all  --  any    any     anywhere             anywhere             ctstate DNAT /* !fw3: Accept port redirections */
   17  2175 zone_wan_src_REJECT  all  --  any    any     anywhere             anywhere             /* !fw3 */

12

(29 odpowiedzi, napisanych Oprogramowanie)

Dropbear postawiony na 8062

13

(29 odpowiedzi, napisanych Oprogramowanie)

A popatrz na lustrzany port który sobie przekieruję na raspberry w sieci LAN
91.231.*.*:25100

działa

14

(29 odpowiedzi, napisanych Oprogramowanie)

91.231.*.*:25102

15

(29 odpowiedzi, napisanych Oprogramowanie)

Zmieniłem port serwera na 8062 i nadal z zewnątrz się nie łączy.
VPN na pewno działa bo zmieniłem IP w aplikacji na telefonie na 192.168.1.1 i łączyłem się po sieci LAN, więc klucze są OK.
Co mogę jeszcze zmienić?

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdf5:9936:2b06::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device 'lan_eth0_1_dev'
        option name 'eth0.1'
        option macaddr 'a0:63:91:7d:23:bf'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'pppoe'
        option password 'xxxxxx'
        option ipv6 'auto'
        option username 'xxxxxxxxxxxxl'

config device 'wan_eth0_2_dev'
        option name 'eth0.2'
        option macaddr 'a0:63:91:7d:23:c0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'
        option ar8xxx_mib_type '0'
        option ar8xxx_mib_poll_interval '500'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 0t'

config interface 'wg0'
        option proto 'wireguard'
        option private_key 'MLABi2Oagb*********DRwbAXA='
        option listen_port '8062'
        list addresses '10.9.0.1/24'

config wireguard_wg0
        option public_key 'bAbL/XFWW***********0CefzS3vbX4='
        option route_allowed_ips '1'
        option persistent_keepalive '25'
        option description 'android'
        list allowed_ips '10.9.0.3/32'
root@OpenWrt:~# cat /etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

config rule
        option src 'wan'
        option target 'ACCEPT'
        option proto 'udp'
        option dest_port '8062'
        option name 'wireguard'

config zone
        option name 'wg'
        option input 'ACCEPT'
        option forward 'ACCEPT'
        option output 'ACCEPT'
        option masq '1'
        option network 'wg0'

config forwarding
        option src 'wg'
        option dest 'wan'

config forwarding
        option src 'wan'
        option dest 'wg'

config forwarding
        option src 'wg'
        option dest 'lan'

config forwarding
        option src 'lan'
        option dest 'wg'

16

(29 odpowiedzi, napisanych Oprogramowanie)

Witam
Mam problem z połączeniem
Mój dostawca nie udostępnia mi bezpośrednio IP z portem tylko mam IP z portem zewnętrznym x.x.x.x:25102 który wpada u mnie na WAN na port 8062.

Serwer uruchamiam na routerze 192.168.1.1 i nasłuchuje dla uproszczenia na porcie 25102

Postępuję zgodnie z instrukcją https://eko.one.pl/?p=openwrt-wireguard ale nie mogę się połączyć. Prawdopodobnie brakuje mi jakiegoś przekierowania na firewallu. Jakiego?

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdf5:9936:2b06::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device 'lan_eth0_1_dev'
        option name 'eth0.1'
        option macaddr 'a0:63:91:7d:23:bf'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'pppoe'
        option password 'HASLO'
        option ipv6 'auto'
        option username 'LOGIN'

config device 'wan_eth0_2_dev'
        option name 'eth0.2'
        option macaddr 'a0:63:91:7d:23:c0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'
        option ar8xxx_mib_type '0'
        option ar8xxx_mib_poll_interval '500'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 0t'

config interface 'wg0'
        option proto 'wireguard'
        option private_key 'OEm/j/386M7S*********0rxmIyodlxPnU='
        option listen_port '25102'
        list addresses '10.9.0.1/24'

config wireguard_wg0
        option public_key 'bAbL/XFWWT1**************3vbX4='
        option route_allowed_ips '1'
        list allowed_ips '0.0.0.0/0'
        option persistent_keepalive '25'
        option description 'android'

root@OpenWrt:~# cat /etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

config zone
        option name 'wg'
        option input 'ACCEPT'
        option forward 'ACCEPT'
        option output 'ACCEPT'
        option masq '1'
        option network 'wg0'

config forwarding
        option src 'wg'
        option dest 'wan'

config forwarding
        option src 'wan'
        option dest 'wg'

config forwarding
        option src 'wg'
        option dest 'lan'

config forwarding
        option src 'lan'
        option dest 'wg'

config redirect
        option src 'wan'
        option src_dport '8062'
        option target 'DNAT'
        option name '8062'
        option dest_ip '192.168.1.1'
        option dest 'lan'
        option dest_port '25102'

config rule
        option src 'wan'
        option target 'ACCEPT'
        option proto 'tcp'
        option dest_port '25102'
        option name 'wireguard_wan'

W moim przypadku była delikatna burza bez żadnych głośnych grzmotów
Na stronie https://www.lightningmaps.org sprawdziłem dokładny czas i lokalizację wyładowania(duże zbliżenie pokazuje czas)  a na centrali alarmowej czas kiedy przestał działać router
Całe okablowanie mam wewnątrz tylko jedna skrętka nieekranowana wychodzi na kamerkę na zewnątrz. Kamerka zamontowana pod blaszaną podbitką i podejrzewam że to spowodowało uszkodzenie
Zasilanie energetyczne jest napowietrzne, tylko dojście do domu jest ziemią, internet światłowodowy więc po nim nie przejdzie nic

Witam
Prawdopodobnie burza uszkodziła mi sprzęt. Upaliło mi 2 wejścia LAN na routerze i od tego czasu przestał działać moduł LAN przy centrali alarmowej Satel ETHM-1, ale nie do końca.
Na kilku routerach i zwykłym switchu nie ma żadnego połączenia - brak świecącej diody LED na routerze, na ETHM-1 bardzo krótko błyska żółta dioda
Przyciąłem w patchcordzie pary niebieskie i brązowe zostawiając pomarańczowe i zielone i bez zmian.

Tak wyglądają diody na ETHM po podłączeniu do routera TP LINK MR-3020 i Netgear WNDR4300 oba z OpenWRT
https://www.youtube.com/watch?v=kxoc7MroOdo

Tak na kilku innych bez OpenWRT
https://www.youtube.com/watch?v=6OOOlH4gGUk

Dodam że nie na każdym routerze z OpenWRT działa. Na HG553 nie działa

Macie jakiś pomysł czemu tak jest ?

19

(6 odpowiedzi, napisanych Oprogramowanie)

Po kablu

20

(6 odpowiedzi, napisanych Oprogramowanie)

Może źle się wyraziłem:
wykresy są ale bez transferu z kamer, na poziomie 6 kbit/s

21

(6 odpowiedzi, napisanych Oprogramowanie)

Luci 18.06

22

(6 odpowiedzi, napisanych Oprogramowanie)

Witam
Mam TL-WR740N w trybie accessPoint bez routingu z podłączonymi 2 kamerami IP do portów LAN z przesyłem obrazu 24h
Chciałem na wykresie zobaczyć jak tam z obciążeniem procesora i przesyłem danych
O ile realtime load pokazuje mi średnio na poziomie np. 1.1 to wykres traffic nie przedstawia na żadnej zakładce przesyłu danych z kamer.
Co jest nie tak ?

23

(11 odpowiedzi, napisanych Oprogramowanie)

A pytanie:
Czy mając 2 takie terminale mogę je połączyć kablem światłowodowym i zrobić część sieci LAN po światłowodzie ?
Zrobić coś ala media konwerter?

24

(5 odpowiedzi, napisanych Debian Mini HowTo)

Typ partycji przeszkadza mi w tym ze windows nie widzi plików
Podłączyłem dysk tym razem do routera przez kieszeń. Zamontowałem partycję ale plików brak
Jak moge jednoznacznie stwierdzić czy już "po ptokach" czy może da się odzyskać dane z niego?

25

(5 odpowiedzi, napisanych Debian Mini HowTo)

Albo miałem jednak fat a nie NTFSa albo robię coś nie tak
Czy w fdisk nie łatwiej byłoby zmienić parametry partycji?

Aktualnie FDISK pokazuje mi takie parametry:
Command (m for help): p
Disk /dev/sda: 111.8 GiB, 120034123776 bytes, 234441648 sectors
Disk model: CT120BX500SSD1
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xbd2d5c5e

Device     Boot Start       End   Sectors   Size Id Type
/dev/sda1        2048 234436544 234434497 111.8G 87 NTFS volume set

Może zmienię tylko typ partycji funkcją "t   change a partition type"

Chodzi mi tylko o dane na dysku który podepnę przez kieszeń i skopiuję w windowsie