1

(5 odpowiedzi, napisanych Debian Mini HowTo)

Próbowałeś testować transfery po ftp/sambie? Ze sprzętowym SATA propozycja całkiem ciekawa.

2

(5 odpowiedzi, napisanych Oprogramowanie)

Nadanie publicznego IP 5 PLN, stałego 10 PLN. Opłata jednorazowa. Byłem tak samo zdziwiony brakiem zewnętrznego IP, telefon do biura obsługi rozwiązał sprawę.

3

(256 odpowiedzi, napisanych Termometr)

Index.php powinien być w katalogu /www/meteo . Nie masz przypadkiem bezpośrednio w /www ?

4

(554 odpowiedzi, napisanych Oprogramowanie)

Tyle, że na Gingerbread nie bangla. Przy instalacji wypluwa "Wystąpił błąd podczas parsowania pakietu"

5

(554 odpowiedzi, napisanych Oprogramowanie)

Prośba do Cezarego - możesz udostępnić źródła do kompilacji apki na androida? Mam już eclipse, prostą apkę z zegarkiem analogowym już też stworzyłem, ale na włożenie obsługi ssh już nie mam pomysłu i podstaw teoretycznych. Czytałem nawet http://www.helloandroid.pl/2011/04/lekc … e-ssh.html ale dalej czarna magia. Chciałbym lekko przerobić Twoją apkę do włączania przekaźnika podpiętego pod diodę w 1043 i jedyna droga to chyba reverse engeneering...

PS - są jakieś przeszkody, żeby to skompilować dla 2.3.5 ?

6

(2 odpowiedzi, napisanych Oprogramowanie)

Odpowiem sobie więc sam smile

Wystarczyło do skryptu dodać cd $katalog. Nie mam pojęcia dlaczego działa, ale działa. PS - "grep ?" pokazuje wszystkie pliki z ogonkami. Ls chyba dalej nie radzi sobie z polskimi czcionkami, stąd obejście.

W razie gdyby ktoś, kiedyś (przy okazji w nazwach zamienia " " na "_" i pokazuje w logach że usunął ęął itd.):

#!/bin/sh

katalog=/mnt/hdd/samba/uploads

cd $katalog

for i in $katalog/* ; do mv "$i" "${i//\ /_}" ; done

for i in `ls $katalog | grep ? `
do
mv $i `echo "$i" | sed 's/ą/a/; s/ó/o/; s/ł/l/; s/ć/c/; s/ę/e/; s/ś/s/; s/ż/z/; s/ź/z/; s/ń/n/; s/Ą/A/; s/Ó/O/; s/Ł/L/; s/Ć/C/; s/Ę/E/; s/Ś/S/; s/Ż/Z/; s/Ź/Z/; s/Ń/N/'`
logger "W katalogu "$katalog" zmieniono nazwe pliku z "$i" na "`echo "$i" | sed 's/ą/a/; s/ó/o/; s/ł/l/; s/ć/c/; s/ę/e/; s/ś/s/; s/ż/z/; s/ź/z/; s/ń/n/; s/Ą/A/; s/Ó/O/; s/Ł/L/; s/Ć/C/; s/Ę/E/; s/Ś/S/; s/Ż/Z/; s/Ź/Z/; s/Ń/N/'`" "
done

Witam,

Pytanie jak w temacie. Postawiłem droopy oraz napisałem skrypt, który synchronizuje dane wrzucone na niego z ftp. Problem polega na tym, że przez droopy'ego są czasami wrzucane pliki ze spacjami w nazwie (z czym sobie poradziłem) i polskimi znakami. Jak pozbyć się polskich ogonków? Próbowałem sedem, tr (tr "ĘęÓ󥹌śŁłŻżŹźĆćŃń" "EeOoAaSsLlZzZzCcNn") , iconv (nie znajduje go, mimo zainstalowania libiconv-full i libiconv) bez powodzeń. Jakieś pomysły ?

http://eko.one.pl/?p=openwrt-transmission#konfiguracja

uci set transmission.@transmission[0].umask=0

9

(13 odpowiedzi, napisanych Oprogramowanie)

Witam,

Dziś zaktualizowałem Gargoyle z 1.5.10.1 do 1.5.10.14 bez zachowania ustawień. Skonfigurowałem na nowo extroota i próbuję przenieść dane o zużyciu. Po przekopiowaniu starych plików z /usr/data/bwmon wykresy dalej pokazują tylko dane od aktualizacji. Po uruchomieniu. Po uruchomieniu /tmp/bw_backup/do_bw_backup.sh sytuacja j/w. Należy skopiować jeszcze jakiś plik?

Zawartość /usr/data/bwmon

bdist4-download-day-31.bw    total4-download-7200-359.bw
bdist4-upload-day-31.bw      total4-upload-7200-359.bw
bdist5-download-month-12.bw  total5-download-day-365.bw
bdist5-upload-month-12.bw    total5-upload-day-365.bw

10

(15 odpowiedzi, napisanych Oprogramowanie)

Działają smile Może ktoś sprawdzi jak się ma przechwytywanie obrazu, mój aparat tego nie obsługuje. Ale aparat wykrywa poprawnie, błędami nie sypie i zdjęcia na zamontowany dysk ściąga.

11

(15 odpowiedzi, napisanych Oprogramowanie)

Rozwiązanie czasowe: https://forum.openwrt.org/viewtopic.php … 30#p179130 smile

12

(254 odpowiedzi, napisanych Oprogramowanie)

WDR3600 przez większy RAM i szybszy procesor ma szansę być bardziej stabilny ? Ew. Zyxel NSA310 ?

13

(254 odpowiedzi, napisanych Oprogramowanie)

Do stempla daty właśnie. Nie mam libgd z wkompilowanymi czcionkami.

14

(254 odpowiedzi, napisanych Oprogramowanie)

Próbowałem - rozmywa krawędzie.

Generalnie chodzi mi o to, żeby zrobić jedno zdjęcie na godzinę ze stemplem daty. Chwilowo używam do tego skryptu, który uruchamia motion i je ubija po 100 sekundach. Konfigurowane zgodnie z http://eko.one.pl/?p=openwrt-webcam. Średnio co drugi raz resetuje router. Ktoś ma sensowniejszy pomysł ? Ewentualnie libgd z wkompilowanym FreeType ?

15

(254 odpowiedzi, napisanych Oprogramowanie)

zaspany napisał/a:

mr3020+ Tracer Rock.
Czasami Tracer się zacina.

Taką http://images.okazje.info.pl/p/komputer … rocket.jpg ? Na jakiej maksymalnej rozdzielczości pracujesz? Mi notorycznie resetuje router na Gargoyle r36810 (1043 + extroot + 512MB SWAP) przy 1280x720

16

(6 odpowiedzi, napisanych Oprogramowanie)

Bingo! Po raz kolejny dziękuję smile

17

(6 odpowiedzi, napisanych Oprogramowanie)

Zrobione, dalej autostartuje, kamera świeci, po wejściu w http://192.168.1.1:8080/stream.html jest obraz.

18

(6 odpowiedzi, napisanych Oprogramowanie)

Dziękuję za odpowiedź. Skłoniłem się jednak do mjpg-streamer. Wydaje mi się, że mniej obciąża procesor przy podobnej jakości streamingu + od razu Java itd.

Aaaale...nie może być za łatwo. Mjpg-streamer autostartuje. Przy zmianie mjpg-streamer.core.enabled=0 nie daje się go później uruchomić poleceniem /etc/init.d/mjpg-streamer start. Oczywiście /etc/init.d/mjpg-streamer enable nie wykonałem, dałem nawet disable. Da się go jakoś zmusić do nieautostartowania ? Bo jedyne, co mi teraz przychodzi do głowy to ubić go w cronie.

19

(6 odpowiedzi, napisanych Oprogramowanie)

Witam,

Próbuję zrestartować usługę motion w celu wczytania nowej konfiguracji, polecenie z tematu nie działa (-ash: /etc/init.d/motion: not found)

Jedyny sposób, który udaje mi się wymyślić, to kill [id_procesu]

Istnieje jakaś łatwiejsza droga ?

Witam,

Problem wygląda następująco: samba skonfigurowana, działa, dysk podmontowany na Win7, próba otwarcia avi Bestplayerem/Allplayerem kończy się kilkuminutowym wczytywaniem pliku. W jego trakcie nie ma odczytu z dysku. Po wczytaniu przewijanie działa płynnie, problemy się kończą.

Kiedy otwierać w WMP/Media Player Calssic - długiego wczytywania nie ma.

Poza tym - przy odtwarzaniu na Androidzie (MoBoPlayer, zasoby zamontowane przez CiFS) player wysypuje się po 2-3 minutach odtwarzania. Na MiniDLNA idealnie.

Wszystkie foldery po drodze chmod 777. OpenWrt Attitude Adjustment 12.09-beta2

config samba
        option 'name'                   'OpenWrt'
        option 'workgroup'              'WORKGROUP'
        option 'description'            'OpenWrt'
        option 'homes'                  '0'
        option 'charset'                'UTF-8'

config sambashare
        option 'name'                   'prywatny'
        option 'path'                   '/mnt/hdd/samba'
        option 'read_only'              'no'
        option 'create_mask'            '0700'
        option 'dir_mask'               '0700'
        option 'guest_ok'               'yes'
        option 'users'                  'frmn'

Ktoś, coś?

Problem brzmi - po reboocie WR1043ND z zainstalowanym exrootem (http://eko.one.pl/forum/viewtopic.php?id=1062), Sambą i transmission nie wykrywa dysku zewnętrznego podłączonego przez HUB. Po wydaniu polecenia df -h widać tylko pena i partycje na nim. Po odłączeniu dysku i ponownym podłączeniu wszystko działa. Ktoś ma jakiś pomysł?

Dzięki smile

Jeszcze jedno:

Próbuję się dobrać do diody USB, jak tu http://openrouter.info/forum/viewtopic. … &t=511. Niestety po próbie instalacji

opkg install http://ecco.selfip.net/backfire/ar71xx/packages/kmod-ledtrig-usbdev_2.6.32.27-1cj_ar71xx.ipk 

uzyskuję

Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-ledtrig-usbdev:
 *      kernel (= 2.6.32.27-1cj) *
 * opkg_install_cmd: Cannot install package kmod-ledtrig-usbdev.

Help...

Dzięki za błyskawiczną odpowiedź smile

Napisałem więc skrypt w katalogu /etc/hotplug.d/button/touch


#!/bin/sh
if [ "$ACTION" = "pressed" ]; then
if [ "$BUTTON" = "BTN_1" ]; then
if [ -f /etc/init.s/samba ]; then
      /etc/init.d/samba stop
fi
  fi
fi

Ale coś po przyciśnięciu samba dalej działa...

EDIT:

Victoria smile literówka przy init.s

Jeszcze jedno - jak ubić kilka usług?

Witam,

na openwrt.pl znalazłem skrypt:

Przed odłączeniem dysku należy upewnić się, że nie jest on wykorzystywany, i w szczególności, nie jest uruchomiony serwer amule. Można zrobić odpowiedni skrypt połączony pod przycisk SES (EZSetup w Asus WL-500gP). Wtedy, jeżeli chcemy odłączyć dysk wystarczy nacisnąć przycisk, odczekać kilka sekund i można go bezpiecznie odłączyć. Przykład takiego skryptu (do umieszczenia w katalogu /etc/hotplug.d/button pod nazwą 01-umount)


if [ "$BUTTON" = "ses" ] ; then
  if [ "$ACTION" = "pressed" ] ; then
    if [ -f /tmp/shared/bin/amule ]; then
      /tmp/shared/bin/amule stop
      umount /dev/sda1
      sleep 3
    fi
  fi
fi

4 pytania, by dostosować skrypt dla siebie:

Żeby zamknąć również sambę, zmodyfikować tak?:

if [ "$BUTTON" = "ses" ] ; then
  if [ "$ACTION" = "pressed" ] ; then
    if [ -f /tmp/shared/bin/amule ]; then
      /tmp/shared/bin/amule stop
      umount /dev/sda1
      sleep 3
    fi
if [ -f /tmp/shared/bin/samba]; then
      /tmp/shared/bin/samba stop
      umount /dev/sda1
      sleep 3
    fi
  fi
fi

Co oznacza parametr sleep 3 ?
Czy na WR1043ND zadziała, czy trzeba wprowadzić inny parametr dla $BUTTON?
Gdzie zapisać skrypt i jak włączyć autouruchamianie go przy starcie?

Z góry dzięki i przepraszam za ewentualną infantylność pytań, dopiero zaczynam z open-wrt smile