1

(3 odpowiedzi, napisanych Oprogramowanie)

Jest tylko jedna wersja .Co ciekawe ta sama płytka jest w R6260 ,R6850 i WAC124 .

2

(33 odpowiedzi, napisanych Oprogramowanie)

sam jestem uzytkownikiem minidlna od lat  . Uzywam własnego build'a 1.2.1 w którym mam wyłączone rozgłaszanie nowych treści i pare innych ulepszeń .  Na WD mycloud v2 dysk budzi sie jedynie jeśli połącze się z aplikacją .
jeśli mnie pamięć nie myli to było ten patch:

WDMyCloud:/mnt/shares/build/minidlna-1.2.1# diff -Naur upnpsoap.c.orig upnpsoap.c
--- upnpsoap.c.orig     2017-12-25 09:39:59.754441000 +0100
+++ upnpsoap.c  2017-12-25 11:06:34.534441000 +0100
@@ -1,3 +1,4 @@
+
 /* MiniDLNA project
  *
  * http://sourceforge.net/projects/minidlna/
@@ -1828,6 +1829,9 @@
                        goto search_error;
                }
        }
+       /* Search limit  */
+       totalMatches = 0;
+       RequestedCount = 0 - StartingIndex;
        ret = 0;
        __SORT_LIMIT
        orderBy = parse_sort_criteria(SortCriteria, &ret);

mogę podesłać źródełka i sobie porównasz co by można przetestować
ps. na sourceforge.net/p/minidlna masz pełno patchy i rozwiązań od społeczności .
edit: patch zamiast zwykłego diffa

3

(16 odpowiedzi, napisanych Oprogramowanie)

vdsl bridge + LAN ...
W tej konfiguracji W8970 podaje bridge po vlan2 i przyjmuje lan po vlan1 uzywając jednego przewodu wpinanego w port 4/Wan
Daje to możliwosc postawienia apka na W8970  lub czegoś po kablu. Router moze stać znacznie dalej będąc połaczony jedynie pojedynczym przewodem . Po stronie Routera na ktorym jest sesja PPPoE port WAN również musi być tagowany (np option ports '2t 6t') . Wada to niska wydajność ( 140/ 140Mbit ) z powodu skopanej obslugi sterownia ethernet na lantiq .

root@W8970:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd63:9d64:f6b2::/48'

config dsl 'dsl'
        option annex 'a'
        option tone 'av'
        option firmware '/lib/firmware/vdsl.bin'
        option xfer_mode 'ptm'
        option line_more 'vdsl'
        option ds_snr_offset '-25'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.3'
        option dns '192.168.1.2'
        option gateway '192.168.1.2'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'dslbridge'
        option ifname 'dsl0.35 eth0.2'
        option type 'bridge'

config device 'wan_dsl0_dev'
        option name 'dsl0'
        option macaddr 'f8:1a:xx:xx:xx:xx'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 2 4t 5 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4t 6t'

edit: poprawki

4

(2 odpowiedzi, napisanych Sprzęt)

zerknij na dokumentacje https://oldwiki.archive.openwrt.org/doc … loader/cfe
dodakowo sprawdz adresy routera , servera tftp uzywajac  nvram ,ifconfig no i ping po stronie PC  .Musza sie "widziec" by zaczac dalsza zabawe w odzyskiwanie

5

(5 odpowiedzi, napisanych Sprzęt)

bootloader nie jest nadpisywany przez skrypt . Wiec raczej zyje.
Problemem jest ze router ma wbudowane recovery (dual image) i probuje bootowac ze starego obrazu zamiast padavan
Idac na skroty .rozkrec router podepnij kabelek szeregowy  . wrzuc breed bootloader . Z Breed flashuj padavana .