1 (edytowany przez szwabek 2013-11-03 13:33:38)

Temat: iptv / multicast - internetia

Cześć,

Proszę o pomoc.
Przeczytałem już cały internet i nadal nie uzyskałem w pełni działającej konfiguracji.

Na kablu od operatora mam tagowany vlan1000 (chyba nie jest to tajemnicą, niektórzy bardzo unikają wchodzenia w szczegóły co daje isp).

Na routerze WR1043ND do portu 1 podłączam Netia Player'a, a pozostałe 3 porty to "zwykły" LAN.
eth0.1 - LAN
eth0.2 - WAN
eth0.1000 - IPTV

1. Działa TV, nie działają usługi internetowe
Jeżeli port 1 zrobię jako vlan1000 nietagowany, to działa mi TV. Na Netia Player mam takie funkcje jak program TV, opis programów, tvn player, ipla i inne usługi internetowe. W tej konfiguracji nie działają te usługi.

2. Działają usługi internetowe, nie działa TV
Jeżeli port 1 zrobię jako nietagowany LAN (vlan 1), jak pozostałe porty LAN, to działają usługi internetowe, a nie działa TV.

Moją konfigurację przeprowadzałem na podstawie:
http://eko.one.pl/forum/viewtopic.php?id=1309
http://eko.one.pl/forum/viewtopic.php?id=3400
http://wiki.openwrt.org/doc/howto/udp_multicast

Bardzo proszę o pomoc. Nie przedstawiam konfiguracji routera, bo na początek mam wrażenie, że takie info wystarczy.
Mam wrażenie, że moje pytanie sprowadza się do kwestii jak zrobić, żeby port 1 był w dwóch nietagowanych vlanach (vlan1 i vlan1000).


Dzięki:)

EDIT
Dzięki uprzejmości i pomocy użytkowników RPC i alossek udało mi się poprawić konfigurację i uruchomić pełną funkcjonalność. Jeżeli ktoś miał by podobny problem, to umieszczam poprawny config poniżej, żeby nie musieć przebijać się przez wszystkie posty.

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0.1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
        option macaddr '00:12:2a:xx:xx:xx'

config interface 'IPTV'
        option ifname 'eth0.1000'
        option proto 'dhcp'
        option defaultroute '0'
        option mtu '1496'
        option macaddr '00:12:2a:xx:xx:xx'
        option vendorid 'NETIASPOT'
        option metric '20'

config switch
        option name 'rtl8366rb'
        option reset '1'
        option enable_vlan '1'
        option enable_vlan4k '1'

config switch_vlan
        option device 'rtl8366rb'
        option vlan '1'
        option ports '1 2 3 4 5t'

config switch_vlan
        option device 'rtl8366rb'
        option vlan '2'
        option ports '0 5t'

config switch_vlan
        option device 'rtl8366rb'
        option vlan '1000'
        option ports '0t 5t'
root@OpenWrt:~# cat /etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'wan'
        option network 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config zone
        option name 'IPTV'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'IPTV'

config forwarding
        option src 'lan'
        option dest 'IPTV'

config rule
        option name 'Allow-DHCP-Renew-wan_iptv'
        option src 'IPTV'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option src 'IPTV'
        option proto 'igmp'
        option target 'ACCEPT'

config rule
        option src 'IPTV'
        option proto 'udp'
        option dest_ip '224.0.0.0/4'
        option target 'ACCEPT'

config rule
        option src 'IPTV'
        option proto 'udp'
        option dest 'lan'
        option dest_ip '224.0.0.0/4'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

config include 'miniupnpd'
        option type 'script'
        option path '/usr/share/miniupnpd/firewall.include'
        option family 'IPv4'
        option reload '1'
root@OpenWrt:~# cat /etc/config/igmpproxy
config igmpproxy
        option quickleave 1

config phyint
        option network IPTV
        option direction upstream
        list altnet 224.0.0.0/4
        list altnet 10.0.0.0/8
        list altnet 195.0.0.0/8
        list altnet 172.24.0.0/16
        list altnet 192.168.1.0/24
        list altnet 83.238.252.0/24

config phyint
        option network lan
        option direction downstream

Dodatkowo zainstalowałem upnp/natpmp wg instrukcji:
http://wiki.openwrt.org/doc/howto/upnp
http://advanxer.com/blog/2012/06/openwrt-upnp/

NetiaPlayer może być wpięty do dowolnego portu LAN na routerze. Docelowo ograniczę config, żeby TV działała jedynie na porcie pierwszym, poglądowy config:
https://forum.openwrt.org/viewtopic.php … 25#p167725
http://www.computerhilfen.de/hilfen-22-389919-0.html

Należy również ograniczyć podsieci w konfiguracji igmmproxy.

Enjoy!

EDIT - 03.11.2013
Wygląda na to, że jakiś czas temu netia poczyniła zmiany.. Requestując o adres dla int IPTV należy podać vendor ID = NETIASPOT

2

Odp: iptv / multicast - internetia

/etc/config/network jednak będzie potrzeby, poza tym daj wynik "route -n"

TP-Link TL-WR1043ND v1, 'LEDE' 17.01-SNAPSHOT' (r3371-79cd141)

3

Odp: iptv / multicast - internetia

szwabek napisał/a:

Mam wrażenie, że moje pytanie sprowadza się do kwestii jak zrobić, żeby port 1 był w dwóch nietagowanych vlanach (vlan1 i vlan1000).

Raczej nie zrobisz dwóch nietagowanych vlanów na jednym porcie.

TP-Link TL-WR1043ND v1, 'LEDE' 17.01-SNAPSHOT' (r3371-79cd141)

4

Odp: iptv / multicast - internetia

Cześć,

Jestem w pracy i mam przy sobie wyłącznie backup konfiguracji, więc poniżej /etc/config/network

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option ifname 'eth0.1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'

config interface 'wan'
    option ifname 'eth0.2'
    option proto 'dhcp'

config interface 'IPTV'
    option ifname 'eth0.1000'
    option proto 'dhcp'
    option metric '20'

config switch
    option name 'rtl8366rb'
    option reset '1'
    option enable_vlan '1'
    option enable_vlan4k '1'

config switch_vlan
    option device 'rtl8366rb'
    option vlan '1'
    option ports '2 3 4 5t'

config switch_vlan
    option device 'rtl8366rb'
    option vlan '2'
    option ports '0 5t'

config switch_vlan
    option device 'rtl8366rb'
    option vlan '1000'
    option ports '0t 1 5t'

Swoją drogą wczoraj próbowałem zaimplementować Twój config z linka powyżej, ale wydawał mi się on błędny, albo własnie jest w nim coś czego nie rozumiem, a rozwiąże moją zagwozdke... Masz int LAN (eth0.2), kóry jest wyłącznie nie tagowany na porcie 1.

Pozdrawiam.

5

Odp: iptv / multicast - internetia

szwabek napisał/a:

1. Działa TV, nie działają usługi internetowe
Jeżeli port 1 zrobię jako vlan1000 nietagowany, to działa mi TV. Na Netia Player mam takie funkcje jak program TV, opis programów, tvn player, ipla i inne usługi internetowe. W tej konfiguracji nie działają te usługi.

Skoro nie działają usługi, to może oznaczać także np. że idą one przez serwer proxy (wewnatrz sieci z vlan1000) i z jakiś powodów router nie widzi trasy do tego serwera. Jednym słowem jeśli Netia Player ma dostęp do usług z internetu (np. ipla, a nie program TV który może być dostarczany z serwera wewnątrz sieci vlan1000) to musi mieć wyjście na świat (być może przez proxy).

TP-Link TL-WR1043ND v1, 'LEDE' 17.01-SNAPSHOT' (r3371-79cd141)

6

Odp: iptv / multicast - internetia

Nie wiem właśnie jak działa Netia Player...
Tak jak pisałem, jeżeli wepnę go do LANu, to opisy programów i ipla/tvn player działa poprawnie.

Jeżeli użyję domyślnego routera od netii - Netia Spot, to niezależnie do którego portu wepnę Playera, TV działa i usługi internetowe na nim również. Netia Player dostaje wtedy adres IP z LAN. Tyle moge zobaczyć na box'owym routerku.

Moja powyższa konfiguracja powoduje działanie TV. Netia Player dostaje wtedy adres z puli 10.x.x.x - prześlę szczegóły ok 18.00.

Wydaje mi się, że muszę umieć wrzucić port 1 na routerze jako nietagowany vlan1000, bo tylko wtedy działa TV i jakoś dać mu wyjście na świat... Niestety nie mam zupełnie pojęcia w jaki sposób, jakim mechanizmem...

Pozdrawiam

7

Odp: iptv / multicast - internetia

Nie mialem z tym doczynienia ale zobacz jak to robi tp-link może to coś wyjaśni
http://www.tp-link.com.pl/article/?faqid=346

8

Odp: iptv / multicast - internetia

szwabek napisał/a:

Cześć,

Swoją drogą wczoraj próbowałem zaimplementować Twój config z linka powyżej, ale wydawał mi się on błędny, albo własnie jest w nim coś czego nie rozumiem, a rozwiąże moją zagwozdke... Masz int LAN (eth0.2), kóry jest wyłącznie nie tagowany na porcie 1.

Twoja konfiguracja wygląda na to że jest ok.

Co do mojego "howto" chyba był faktycznie tam jakiś błąd (teraz już poprawione, edit : 12:12, 13/06/2013),
(błąd pewnie wynikała z tego że w trakcie pisania i nanoszenia poprawek byłem z dala od pierwotnej koncepcji i konfiguracji)

TP-Link TL-WR1043ND v1, 'LEDE' 17.01-SNAPSHOT' (r3371-79cd141)

9

Odp: iptv / multicast - internetia

Próbuj też dowiedzieć się coś o adresach tych usług, tzn. w konfiguracji
gdy działa Ci TV (a nie masz usług internetowych) na routerze włącz jakiś sniffer i podglądaj pakiety (obstawiam że chodzą po http), zobacz do jakich serwerów próbuje się podłączyć Netia Player, potem spróbuj je pingować z routera z tej konfiguracji, następnie powtórz eksperyment gdy nie masz TV a działają Ci usługi. Monitoruj wówczas także "route -n" w obu tych przypadkach.

TP-Link TL-WR1043ND v1, 'LEDE' 17.01-SNAPSHOT' (r3371-79cd141)

10 (edytowany przez rpc 2013-06-14 01:08:23)

Odp: iptv / multicast - internetia

najlepiej było by się wpiąć jakimś hubem(może być byle co) i wyłapać pakiety co latają i gdzie z playera

a to nie powinno być jakoś tak ?

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option ifname 'eth0.1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'

config interface 'wan'
    option ifname 'eth0.2'
    option proto 'dhcp'

config interface 'IPTV'
    option ifname 'eth0.1000'
    option proto 'dhcp'
    option 'defaultroute' '0'
    option 'peerdns' '0'
    option metric '20'

config switch
    option name 'rtl8366rb'
    option reset '1'
    option enable_vlan '1'
    option enable_vlan4k '1'

config switch_vlan
    option device 'rtl8366rb'
    option vlan '1'
    option ports '2 3 4 5t'

config switch_vlan
    option device 'rtl8366rb'
    option vlan '2'
    option ports '0 1 5t'

config switch_vlan
    option device 'rtl8366rb'
    option vlan '1000'
    option ports '0t 1t 5t'

tutaj trzeba sobie zadać parę pytań. 
Czy netiaplayer może pracować bez routera poprawnie(pytanie raczej teoretyczne bo może być inne medium transmisji niż ethernet) ? Jeśli tak to w/w konfiguracja powinna działać.
Co daje netia spot na wyjściu eth1 tagowany vlan1000 czy nietagowany ? Czy daje również internet ?
Czy netiaplayer korzysta w ogóle z vlan1000 ? Czy potrzebuje portu tagowanego czy nie do poprawnej pracy. Może proxy ? A vlan1000 tylko jest dla playerów programowych na kompa.
Czy netiaplayer jest kontrolowany za pomocą swojego mac ?

Te wiadomości

11

Odp: iptv / multicast - internetia

najlepiej podłącz sobie netia spot z powrotem do niego podłącz laptopa do eth1 tego portu od iptv włącz wireshark i zobacz co lata. Czy są ramki tagowane czy nie czy na porcie na którym pracuje netia player jest internet czy nie, jakie adresy dostajesz i z jakiego zakresu, czy te adresy są z takiej samej sieci jak z pozostałych portów lan czy wifi z netia spot

Odpowiedzi na te pytania bardzo nam pomogą a tak to wróżenie z fusów

No i sprawdź najpierw czy na tym eth1 działa netiaplayer

12

Odp: iptv / multicast - internetia

rpc napisał/a:
config switch_vlan
    option device 'rtl8366rb'
    option vlan '2'
    option ports '0 1 5t'

config switch_vlan
    option device 'rtl8366rb'
    option vlan '1000'
    option ports '0t 1t 5t'

To raczej na pewno jest ŹLE.
Bo wówczas vlan1000 będzie tagowany na porcie 1, a raczej nie ma być.
poza tym na porcie 1 będzie nietagowane to co na wan weszło nietagowane (czyli pewnie internet).

TP-Link TL-WR1043ND v1, 'LEDE' 17.01-SNAPSHOT' (r3371-79cd141)

13 (edytowany przez szwabek 2013-11-03 13:39:09)

Odp: iptv / multicast - internetia

Cześć,

Udało mi sie w pracy wygrzebać huba i zacząłem sniffowanie:]

scenario1:
router - Netia Spot
na dowolnym porcie podłączam Netia Playera
na porcie obok wpięty jest hub i do niego mój laptop
ciekawostka(?): przy połączeniu router -- hub -- netia player : TV nie działa / uslugi internetowe nie działają

ponizej co wywachalem:

listening on eth0, link-type EN10MB (Ethernet), capture size 96 bytes
21:44:09.097695 00:04:30:5b:c3:2a > 01:00:5e:00:00:02, ethertype IPv4 (0x0800), length 60: 192.168.1.4 > 224.0.0.2: igmp leave 239.200.5.41
21:44:09.116189 00:12:2a:81:9a:41 > 01:00:5e:48:05:29, ethertype IPv4 (0x0800), length 1358: 195.191.9.41.62159 > 239.200.5.41.5041: UDP, length 1316
21:44:09.117489 00:12:2a:81:9a:41 > 01:00:5e:48:05:29, ethertype IPv4 (0x0800), length 60: 192.168.1.254 > 239.200.5.41: igmp query v2 [max resp time 10] [gaddr 239.200.5.41]
21:44:09.117929 00:12:2a:81:9a:45 > 01:00:5e:00:00:02, ethertype 802.1Q (0x8100), length 60: vlan 1000, p 6, ethertype IPv4, 10.4.45.218 > 224.0.0.2: igmp leave 239.200.5.41
21:44:17.798384 00:04:30:5b:c3:2a > 01:00:5e:7f:ff:fa, ethertype IPv4 (0x0800), length 349: 192.168.1.4.35149 > 239.255.255.250.1900: UDP, length 307
21:44:17.798437 00:04:30:5b:c3:2a > 01:00:5e:7f:ff:fa, ethertype IPv4 (0x0800), length 349: 192.168.1.4.35149 > 239.255.255.250.1900: UDP, length 307
21:44:24.294494 00:04:30:5b:c3:2a > 01:00:5e:7f:ff:fa, ethertype IPv4 (0x0800), length 346: 192.168.1.4.35153 > 239.255.255.250.1900: UDP, length 304
21:44:24.294643 00:04:30:5b:c3:2a > 01:00:5e:7f:ff:fa, ethertype IPv4 (0x0800), length 346: 192.168.1.4.35153 > 239.255.255.250.1900: UDP, length 304
21:44:24.588353 00:04:30:5b:c3:2a > 01:00:5e:48:05:29, ethertype IPv4 (0x0800), length 60: 192.168.1.4 > 239.200.5.41: igmp v2 report 239.200.5.41
21:44:35.284899 00:04:30:5b:c3:2a > 01:00:5e:00:00:02, ethertype IPv4 (0x0800), length 60: 192.168.1.4 > 224.0.0.2: igmp leave 239.200.5.41
21:44:35.304687 00:12:2a:81:9a:41 > 01:00:5e:48:05:29, ethertype IPv4 (0x0800), length 60: 192.168.1.254 > 239.200.5.41: igmp query v2 [max resp time 10] [gaddr 239.200.5.41]
21:44:35.305075 00:12:2a:81:9a:45 > 01:00:5e:00:00:02, ethertype 802.1Q (0x8100), length 60: vlan 1000, p 6, ethertype IPv4, 10.4.45.218 > 224.0.0.2: igmp leave 239.200.5.41
21:44:38.501495 00:04:30:5b:c3:2a > 01:00:5e:7f:ff:fa, ethertype IPv4 (0x0800), length 312: 192.168.1.4.35153 > 239.255.255.250.1900: UDP, length 270
21:44:38.501547 00:04:30:5b:c3:2a > 01:00:5e:7f:ff:fa, ethertype IPv4 (0x0800), length 312: 192.168.1.4.35153 > 239.255.255.250.1900: UDP, length 270

21:44:42.999353 00:04:30:5b:c3:2a > 01:00:5e:7f:ff:fa, ethertype IPv4 (0x0800), length 369: 192.168.1.4.35156 > 239.255.255.250.1900: UDP, length 327
21:44:42.999444 00:04:30:5b:c3:2a > 01:00:5e:7f:ff:fa, ethertype IPv4 (0x0800), length 369: 192.168.1.4.35156 > 239.255.255.250.1900: UDP, length 327
21:44:46.598781 00:04:30:5b:c3:2a > 01:00:5e:48:05:29, ethertype IPv4 (0x0800), length 60: 192.168.1.4 > 239.200.5.41: igmp v2 report 239.200.5.41
21:44:51.958695 00:04:30:5b:c3:2a > 01:00:5e:00:00:02, ethertype IPv4 (0x0800), length 60: 192.168.1.4 > 224.0.0.2: igmp leave 239.200.5.41
21:44:51.976706 00:12:2a:81:9a:41 > 01:00:5e:48:05:29, ethertype IPv4 (0x0800), length 1358: 195.191.9.41.62159 > 239.200.5.41.5041: UDP, length 1316
21:44:51.977110 00:12:2a:81:9a:41 > 01:00:5e:48:05:29, ethertype IPv4 (0x0800), length 1358: 195.191.9.41.62159 > 239.200.5.41.5041: UDP, length 1316
21:44:51.978059 00:12:2a:81:9a:41 > 01:00:5e:48:05:29, ethertype IPv4 (0x0800), length 60: 192.168.1.254 > 239.200.5.41: igmp query v2 [max resp time 10] [gaddr 239.200.5.41]
21:44:51.978453 00:12:2a:81:9a:45 > 01:00:5e:00:00:02, ethertype 802.1Q (0x8100), length 60: vlan 1000, p 6, ethertype IPv4, 10.4.45.218 > 224.0.0.2: igmp leave 239.200.5.41
21:44:52.239517 00:04:30:5b:c3:2a > 01:00:5e:7f:ff:fa, ethertype IPv4 (0x0800), length 357: 192.168.1.4.35156 > 239.255.255.250.1900: UDP, length 315
21:44:52.239619 00:04:30:5b:c3:2a > 01:00:5e:7f:ff:fa, ethertype IPv4 (0x0800), length 357: 192.168.1.4.35156 > 239.255.255.250.1900: UDP, length 315
21:45:00.627835 00:04:30:5b:c3:2a > 01:00:5e:7f:ff:fa, ethertype IPv4 (0x0800), length 357: 192.168.1.4.35156 > 239.255.255.250.1900: UDP, length 315
21:45:00.627889 00:04:30:5b:c3:2a > 01:00:5e:7f:ff:fa, ethertype IPv4 (0x0800), length 357: 192.168.1.4.35156 > 239.255.255.250.1900: UDP, length 315

21:45:21.309772 00:04:30:5b:c3:2a > 01:00:5e:7f:ff:fa, ethertype IPv4 (0x0800), length 357: 192.168.1.4.35159 > 239.255.255.250.1900: UDP, length 315
21:45:21.309831 00:04:30:5b:c3:2a > 01:00:5e:7f:ff:fa, ethertype IPv4 (0x0800), length 357: 192.168.1.4.35159 > 239.255.255.250.1900: UDP, length 315
21:45:32.669796 00:04:30:5b:c3:2a > 01:00:5e:48:05:29, ethertype IPv4 (0x0800), length 60: 192.168.1.4 > 239.200.5.41: igmp v2 report 239.200.5.41
21:45:33.397674 00:04:30:5b:c3:2a > 01:00:5e:7f:ff:fa, ethertype IPv4 (0x0800), length 349: 192.168.1.4.35159 > 239.255.255.250.1900: UDP, length 307
21:45:33.397780 00:04:30:5b:c3:2a > 01:00:5e:7f:ff:fa, ethertype IPv4 (0x0800), length 349: 192.168.1.4.35159 > 239.255.255.250.1900: UDP, length 307

21:45:33.790984 00:04:30:5b:c3:2a > 01:00:5e:7f:ff:fa, ethertype IPv4 (0x0800), length 312: 192.168.1.4.35162 > 239.255.255.250.1900: UDP, length 270
21:45:33.791036 00:04:30:5b:c3:2a > 01:00:5e:7f:ff:fa, ethertype IPv4 (0x0800), length 312: 192.168.1.4.35162 > 239.255.255.250.1900: UDP, length 270
21:45:37.259450 00:04:30:5b:c3:2a > 01:00:5e:00:00:02, ethertype IPv4 (0x0800), length 60: 192.168.1.4 > 224.0.0.2: igmp leave 239.200.5.41
21:45:37.278733 00:12:2a:81:9a:41 > 01:00:5e:48:05:29, ethertype IPv4 (0x0800), length 60: 192.168.1.254 > 239.200.5.41: igmp query v2 [max resp time 10] [gaddr 239.200.5.41]
21:45:37.279120 00:12:2a:81:9a:45 > 01:00:5e:00:00:02, ethertype 802.1Q (0x8100), length 60: vlan 1000, p 6, ethertype IPv4, 10.4.45.218 > 224.0.0.2: igmp leave 239.200.5.41
21:45:37.409822 00:04:30:5b:c3:2a > 01:00:5e:48:05:2a, ethertype IPv4 (0x0800), length 60: 192.168.1.4 > 239.200.5.42: igmp v2 report 239.200.5.42
21:45:43.796259 00:12:2a:81:9a:41 > 01:00:5e:00:00:01, ethertype IPv4 (0x0800), length 60: 192.168.1.254 > 224.0.0.1: igmp query v2
21:45:44.446240 00:12:2a:81:9a:41 > 01:00:5e:7f:ff:fa, ethertype IPv4 (0x0800), length 60: 192.168.1.254 > 239.255.255.250: igmp v2 report 239.255.255.250
21:45:46.739835 00:04:30:5b:c3:2a > 01:00:5e:00:00:02, ethertype IPv4 (0x0800), length 60: 192.168.1.4 > 224.0.0.2: igmp leave 239.200.5.42
21:45:46.759160 00:12:2a:81:9a:41 > 01:00:5e:48:05:2a, ethertype IPv4 (0x0800), length 60: 192.168.1.254 > 239.200.5.42: igmp query v2 [max resp time 10] [gaddr 239.200.5.42]
21:45:46.759548 00:12:2a:81:9a:45 > 01:00:5e:00:00:02, ethertype 802.1Q (0x8100), length 60: vlan 1000, p 6, ethertype IPv4, 10.4.45.218 > 224.0.0.2: igmp leave 239.200.5.42
21:45:46.890001 00:04:30:5b:c3:2a > 01:00:5e:48:05:29, ethertype IPv4 (0x0800), length 60: 192.168.1.4 > 239.200.5.41: igmp v2 report 239.200.5.41
21:45:47.780311 00:04:30:5b:c3:2a > 01:00:5e:7f:ff:fa, ethertype IPv4 (0x0800), length 357: 192.168.1.4.35162 > 239.255.255.250.1900: UDP, length 315
21:45:47.780363 00:04:30:5b:c3:2a > 01:00:5e:7f:ff:fa, ethertype IPv4 (0x0800), length 357: 192.168.1.4.35162 > 239.255.255.250.1900: UDP, length 315
21:45:48.756215 00:12:2a:81:9a:41 > 01:00:5e:00:00:02, ethertype IPv4 (0x0800), length 60: 192.168.1.254 > 224.0.0.2: igmp v2 report 224.0.0.2
21:45:52.519870 00:04:30:5b:c3:2a > 01:00:5e:00:00:02, ethertype IPv4 (0x0800), length 60: 192.168.1.4 > 224.0.0.2: igmp leave 239.200.5.41
21:45:52.539175 00:12:2a:81:9a:41 > 01:00:5e:48:05:29, ethertype IPv4 (0x0800), length 60: 192.168.1.254 > 239.200.5.41: igmp query v2 [max resp time 10] [gaddr 239.200.5.41]
21:45:52.539559 00:12:2a:81:9a:45 > 01:00:5e:00:00:02, ethertype 802.1Q (0x8100), length 60: vlan 1000, p 6, ethertype IPv4, 10.4.45.218 > 224.0.0.2: igmp leave 239.200.5.41
21:45:52.670162 00:04:30:5b:c3:2a > 01:00:5e:48:05:2d, ethertype IPv4 (0x0800), length 60: 192.168.1.4 > 239.200.5.45: igmp v2 report 239.200.5.45
21:45:54.750585 00:04:30:5b:c3:2a > 01:00:5e:7f:ff:fa, ethertype IPv4 (0x0800), length 349: 192.168.1.4.35162 > 239.255.255.250.1900: UDP, length 307
21:45:54.750638 00:04:30:5b:c3:2a > 01:00:5e:7f:ff:fa, ethertype IPv4 (0x0800), length 349: 192.168.1.4.35162 > 239.255.255.250.1900: UDP, length 307

21:45:54.751190 00:04:30:5b:c3:2a > 01:00:5e:7f:ff:fa, ethertype IPv4 (0x0800), length 369: 192.168.1.4.35165 > 239.255.255.250.1900: UDP, length 327
21:45:54.751270 00:04:30:5b:c3:2a > 01:00:5e:7f:ff:fa, ethertype IPv4 (0x0800), length 369: 192.168.1.4.35165 > 239.255.255.250.1900: UDP, length 327
21:45:57.600259 00:04:30:5b:c3:2a > 01:00:5e:00:00:02, ethertype IPv4 (0x0800), length 60: 192.168.1.4 > 224.0.0.2: igmp leave 239.200.5.45
21:45:57.619660 00:12:2a:81:9a:41 > 01:00:5e:48:05:2d, ethertype IPv4 (0x0800), length 60: 192.168.1.254 > 239.200.5.45: igmp query v2 [max resp time 10] [gaddr 239.200.5.45]
21:45:57.620027 00:12:2a:81:9a:45 > 01:00:5e:00:00:02, ethertype 802.1Q (0x8100), length 60: vlan 1000, p 6, ethertype IPv4, 10.4.45.218 > 224.0.0.2: igmp leave 239.200.5.45
21:45:57.770252 00:04:30:5b:c3:2a > 01:00:5e:48:05:29, ethertype IPv4 (0x0800), length 60: 192.168.1.4 > 239.200.5.41: igmp v2 report 239.200.5.41
21:46:01.620782 00:04:30:5b:c3:2a > 01:00:5e:7f:ff:fa, ethertype IPv4 (0x0800), length 349: 192.168.1.4.35165 > 239.255.255.250.1900: UDP, length 307
21:46:01.620837 00:04:30:5b:c3:2a > 01:00:5e:7f:ff:fa, ethertype IPv4 (0x0800), length 349: 192.168.1.4.35165 > 239.255.255.250.1900: UDP, length 307

21:46:01.621496 00:04:30:5b:c3:2a > 01:00:5e:7f:ff:fa, ethertype IPv4 (0x0800), length 369: 192.168.1.4.35168 > 239.255.255.250.1900: UDP, length 327
21:46:01.621561 00:04:30:5b:c3:2a > 01:00:5e:7f:ff:fa, ethertype IPv4 (0x0800), length 369: 192.168.1.4.35168 > 239.255.255.250.1900: UDP, length 327
21:46:07.760264 00:04:30:5b:c3:2a > 01:00:5e:00:00:02, ethertype IPv4 (0x0800), length 60: 192.168.1.4 > 224.0.0.2: igmp leave 239.200.5.41
21:46:07.779591 00:12:2a:81:9a:41 > 01:00:5e:48:05:29, ethertype IPv4 (0x0800), length 60: 192.168.1.254 > 239.200.5.41: igmp query v2 [max resp time 10] [gaddr 239.200.5.41]
21:46:07.780006 00:12:2a:81:9a:45 > 01:00:5e:00:00:02, ethertype 802.1Q (0x8100), length 60: vlan 1000, p 6, ethertype IPv4, 10.4.45.218 > 224.0.0.2: igmp leave 239.200.5.41
21:46:13.380750 00:04:30:5b:c3:2a > 01:00:5e:48:05:29, ethertype IPv4 (0x0800), length 60: 192.168.1.4 > 239.200.5.41: igmp v2 report 239.200.5.41
21:46:14.510897 00:04:30:5b:c3:2a > 01:00:5e:7f:ff:fa, ethertype IPv4 (0x0800), length 312: 192.168.1.4.35175 > 239.255.255.250.1900: UDP, length 270
21:46:14.510998 00:04:30:5b:c3:2a > 01:00:5e:7f:ff:fa, ethertype IPv4 (0x0800), length 312: 192.168.1.4.35175 > 239.255.255.250.1900: UDP, length 270
21:46:16.220848 00:04:30:5b:c3:2a > 01:00:5e:7f:ff:fa, ethertype IPv4 (0x0800), length 357: 192.168.1.4.35175 > 239.255.255.250.1900: UDP, length 315
21:46:16.220896 00:04:30:5b:c3:2a > 01:00:5e:7f:ff:fa, ethertype IPv4 (0x0800), length 357: 192.168.1.4.35175 > 239.255.255.250.1900: UDP, length 315
^C
110 packets captured
110 packets received by filter

gdzie (oczywiscie;)
192.168.1.4 - netia player
192.168.1.254 - netia spot (gateway)

scenario2:
router - OpenWrt
na porcie 1 podłączony jest Netia Player
TV działa, usługi internetowe nie działają

root@OpenWrt:~# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         87.99.47.1      0.0.0.0         UG    0      0        0 eth0.2
0.0.0.0         10.4.47.129     0.0.0.0         UG    20     0        0 eth0.1000
10.4.32.0       0.0.0.0         255.255.240.0   U     20     0        0 eth0.1000
87.99.47.0      0.0.0.0         255.255.255.0   U     0      0        0 eth0.2
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 br-lan
root@OpenWrt:~# cat /etc/config/network 

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option ifname 'eth0.1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'

config interface 'wan'
    option ifname 'eth0.2'
    option proto 'dhcp'
    option macaddr '00:12:2a:xx:xx:xx'

config interface 'IPTV'
    option ifname 'eth0.1000'
    option proto 'dhcp'
    option metric '20'

config switch
    option name 'rtl8366rb'
    option reset '1'
    option enable_vlan '1'
    option enable_vlan4k '1'

config switch_vlan
    option device 'rtl8366rb'
    option vlan '1'
    option ports '2 3 4 5t'

config switch_vlan
    option device 'rtl8366rb'
    option vlan '2'
    option ports '0 5t'

config switch_vlan
    option device 'rtl8366rb'
    option vlan '1000'
    option ports '0t 1 5t'

ciekawostka: jak usunę metrykę z IPTV, to nie działa mi internet w LAN

Teraz tcpdump (dokladnie ta sama skladnia) dla powyszej konfiguracji, gdy jestesmy na openwrt i dziala tylko TV (uslugi nie):

00:16:16.076527 94:0c:6d:ac:61:86 > 01:00:5e:00:00:01, ethertype IPv4 (0x0800), length 60: 0.0.0.0 > 224.0.0.1: igmp query v2
00:18:21.516915 94:0c:6d:ac:61:86 > 01:00:5e:00:00:01, ethertype IPv4 (0x0800), length 60: 0.0.0.0 > 224.0.0.1: igmp query v2

tcpdump -enni eth0 dst not 192.168.1.187 and not broadcast and not arp and src not 192.168.1.187 and src not 192.168.1.124 and dst not 192.168.1.124
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth0, link-type EN10MB (Ethernet), capture size 96 bytes
00:14:53.898871 6c:71:d9:1d:18:5f > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 168: fe80::c9dc:4a44:5cf9:c7f1.546 > ff02::1:2.547: dhcp6 solicit
00:15:25.899981 6c:71:d9:1d:18:5f > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 168: fe80::c9dc:4a44:5cf9:c7f1.546 > ff02::1:2.547: dhcp6 solicit
00:16:16.076527 94:0c:6d:ac:61:86 > 01:00:5e:00:00:01, ethertype IPv4 (0x0800), length 60: 0.0.0.0 > 224.0.0.1: igmp query v2
00:18:21.516915 94:0c:6d:ac:61:86 > 01:00:5e:00:00:01, ethertype IPv4 (0x0800), length 60: 0.0.0.0 > 224.0.0.1: igmp query v2
^[[B^[[B^[[B^[[B^[[B00:20:08.861657 6c:71:d9:1d:18:5f > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 168: fe80::c9dc:4a44:5cf9:c7f1.546 > ff02::1:2.547: dhcp6 solicit
00:20:08.876543 6c:71:d9:1d:18:5f > 33:33:00:00:00:16, ethertype IPv6 (0x86dd), length 90: fe80::c9dc:4a44:5cf9:c7f1 > ff02::16: HBH ICMP6, multicast listener report v2, 1 group record(s), length 28
00:20:08.881380 6c:71:d9:1d:18:5f > 33:33:00:00:00:16, ethertype IPv6 (0x86dd), length 90: fe80::c9dc:4a44:5cf9:c7f1 > ff02::16: HBH ICMP6, multicast listener report v2, 1 group record(s), length 28
00:20:08.881537 6c:71:d9:1d:18:5f > 33:33:00:00:00:16, ethertype IPv6 (0x86dd), length 90: fe80::c9dc:4a44:5cf9:c7f1 > ff02::16: HBH ICMP6, multicast listener report v2, 1 group record(s), length 28
00:20:08.885407 6c:71:d9:1d:18:5f > 33:33:00:00:00:16, ethertype IPv6 (0x86dd), length 90: fe80::c9dc:4a44:5cf9:c7f1 > ff02::16: HBH ICMP6, multicast listener report v2, 1 group record(s), length 28
00:20:08.886753 6c:71:d9:1d:18:5f > 33:33:00:01:00:03, ethertype IPv6 (0x86dd), length 94: fe80::c9dc:4a44:5cf9:c7f1.55571 > ff02::1:3.5355: UDP, length 32
00:20:09.297894 6c:71:d9:1d:18:5f > 33:33:00:01:00:03, ethertype IPv6 (0x86dd), length 94: fe80::c9dc:4a44:5cf9:c7f1.55571 > ff02::1:3.5355: UDP, length 32
00:20:09.313651 6c:71:d9:1d:18:5f > 33:33:ff:f9:c7:f1, ethertype IPv6 (0x86dd), length 78: :: > ff02::1:fff9:c7f1: ICMP6, neighbor solicitation, who has fe80::c9dc:4a44:5cf9:c7f1, length 24
00:20:09.313719 6c:71:d9:1d:18:5f > 33:33:00:00:00:02, ethertype IPv6 (0x86dd), length 62: fe80::c9dc:4a44:5cf9:c7f1 > ff02::2: ICMP6, router solicitation, length 8
00:20:09.313768 6c:71:d9:1d:18:5f > 33:33:00:00:00:16, ethertype IPv6 (0x86dd), length 130: fe80::c9dc:4a44:5cf9:c7f1 > ff02::16: HBH ICMP6, multicast listener report v2, 3 group record(s), length 68
00:20:09.813564 6c:71:d9:1d:18:5f > 33:33:00:00:00:16, ethertype IPv6 (0x86dd), length 110: fe80::c9dc:4a44:5cf9:c7f1 > ff02::16: HBH ICMP6, multicast listener report v2, 2 group record(s), length 48
00:20:09.860489 6c:71:d9:1d:18:5f > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 168: fe80::c9dc:4a44:5cf9:c7f1.546 > ff02::1:2.547: dhcp6 solicit
00:20:10.313626 6c:71:d9:1d:18:5f > 33:33:00:00:00:01, ethertype IPv6 (0x86dd), length 86: fe80::c9dc:4a44:5cf9:c7f1 > ff02::1: ICMP6, neighbor advertisement, tgt is fe80::c9dc:4a44:5cf9:c7f1, length 32
00:20:11.860450 6c:71:d9:1d:18:5f > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 168: fe80::c9dc:4a44:5cf9:c7f1.546 > ff02::1:2.547: dhcp6 solicit
00:20:13.313523 6c:71:d9:1d:18:5f > 33:33:00:00:00:02, ethertype IPv6 (0x86dd), length 70: fe80::c9dc:4a44:5cf9:c7f1 > ff02::2: ICMP6, router solicitation, length 16
00:20:15.860537 6c:71:d9:1d:18:5f > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 168: fe80::c9dc:4a44:5cf9:c7f1.546 > ff02::1:2.547: dhcp6 solicit
00:20:16.006565 6c:71:d9:1d:18:5f > 33:33:00:01:00:03, ethertype IPv6 (0x86dd), length 84: fe80::c9dc:4a44:5cf9:c7f1.54590 > ff02::1:3.5355: UDP, length 22
00:20:16.423135 6c:71:d9:1d:18:5f > 33:33:00:01:00:03, ethertype IPv6 (0x86dd), length 84: fe80::c9dc:4a44:5cf9:c7f1.54590 > ff02::1:3.5355: UDP, length 22
00:20:17.313557 6c:71:d9:1d:18:5f > 33:33:00:00:00:02, ethertype IPv6 (0x86dd), length 70: fe80::c9dc:4a44:5cf9:c7f1 > ff02::2: ICMP6, router solicitation, length 16
00:20:17.991702 6c:71:d9:1d:18:5f > 33:33:00:01:00:03, ethertype IPv6 (0x86dd), length 84: fe80::c9dc:4a44:5cf9:c7f1.50364 > ff02::1:3.5355: UDP, length 22
00:20:18.407607 6c:71:d9:1d:18:5f > 33:33:00:01:00:03, ethertype IPv6 (0x86dd), length 84: fe80::c9dc:4a44:5cf9:c7f1.50364 > ff02::1:3.5355: UDP, length 22
00:20:23.860622 6c:71:d9:1d:18:5f > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 168: fe80::c9dc:4a44:5cf9:c7f1.546 > ff02::1:2.547: dhcp6 solicit
00:20:26.957250 94:0c:6d:ac:61:86 > 01:00:5e:00:00:01, ethertype IPv4 (0x0800), length 60: 0.0.0.0 > 224.0.0.1: igmp query v2
00:20:29.431883 6c:71:d9:1d:18:5f > 33:33:00:01:00:03, ethertype IPv6 (0x86dd), length 89: fe80::c9dc:4a44:5cf9:c7f1.57595 > ff02::1:3.5355: UDP, length 27
00:20:29.845535 6c:71:d9:1d:18:5f > 33:33:00:01:00:03, ethertype IPv6 (0x86dd), length 89: fe80::c9dc:4a44:5cf9:c7f1.57595 > ff02::1:3.5355: UDP, length 27
00:20:39.861082 6c:71:d9:1d:18:5f > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 168: fe80::c9dc:4a44:5cf9:c7f1.546 > ff02::1:2.547: dhcp6 solicit
00:20:47.695984 6c:71:d9:1d:18:5f > 33:33:00:01:00:03, ethertype IPv6 (0x86dd), length 89: fe80::c9dc:4a44:5cf9:c7f1.53356 > ff02::1:3.5355: UDP, length 27
00:20:48.119695 6c:71:d9:1d:18:5f > 33:33:00:01:00:03, ethertype IPv6 (0x86dd), length 89: fe80::c9dc:4a44:5cf9:c7f1.53356 > ff02::1:3.5355: UDP, length 27
00:21:11.861820 6c:71:d9:1d:18:5f > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 168: fe80::c9dc:4a44:5cf9:c7f1.546 > ff02::1:2.547: dhcp6 solicit
00:22:29.443660 6c:71:d9:1d:18:5f > 33:33:00:00:00:16, ethertype IPv6 (0x86dd), length 90: fe80::c9dc:4a44:5cf9:c7f1 > ff02::16: HBH ICMP6, multicast listener report v2, 1 group record(s), length 28
00:22:29.450674 6c:71:d9:1d:18:5f > 33:33:00:01:00:03, ethertype IPv6 (0x86dd), length 94: fe80::c9dc:4a44:5cf9:c7f1.53045 > ff02::1:3.5355: UDP, length 32
00:22:29.801165 6c:71:d9:1d:18:5f > 33:33:ff:f9:c7:f1, ethertype IPv6 (0x86dd), length 78: :: > ff02::1:fff9:c7f1: ICMP6, neighbor solicitation, who has fe80::c9dc:4a44:5cf9:c7f1, length 24
00:22:29.801396 6c:71:d9:1d:18:5f > 33:33:00:00:00:02, ethertype IPv6 (0x86dd), length 62: fe80::c9dc:4a44:5cf9:c7f1 > ff02::2: ICMP6, router solicitation, length 8
00:22:29.801435 6c:71:d9:1d:18:5f > 33:33:00:00:00:16, ethertype IPv6 (0x86dd), length 110: fe80::c9dc:4a44:5cf9:c7f1 > ff02::16: HBH ICMP6, multicast listener report v2, 2 group record(s), length 48
00:22:29.863562 6c:71:d9:1d:18:5f > 33:33:00:01:00:03, ethertype IPv6 (0x86dd), length 94: fe80::c9dc:4a44:5cf9:c7f1.53045 > ff02::1:3.5355: UDP, length 32
00:22:29.949405 6c:71:d9:1d:18:5f > 33:33:00:01:00:03, ethertype IPv6 (0x86dd), length 84: fe80::c9dc:4a44:5cf9:c7f1.63587 > ff02::1:3.5355: UDP, length 22
00:22:29.952196 6c:71:d9:1d:18:5f > 33:33:00:01:00:03, ethertype IPv6 (0x86dd), length 84: fe80::c9dc:4a44:5cf9:c7f1.57302 > ff02::1:3.5355: UDP, length 22
00:22:30.285536 6c:71:d9:1d:18:5f > 33:33:00:00:00:16, ethertype IPv6 (0x86dd), length 90: fe80::c9dc:4a44:5cf9:c7f1 > ff02::16: HBH ICMP6, multicast listener report v2, 1 group record(s), length 28
00:22:30.285590 6c:71:d9:1d:18:5f > 33:33:00:00:00:16, ethertype IPv6 (0x86dd), length 90: fe80::c9dc:4a44:5cf9:c7f1 > ff02::16: HBH ICMP6, multicast listener report v2, 1 group record(s), length 28
00:22:30.286929 6c:71:d9:1d:18:5f > 33:33:00:01:00:03, ethertype IPv6 (0x86dd), length 94: fe80::c9dc:4a44:5cf9:c7f1.60949 > ff02::1:3.5355: UDP, length 32
00:22:30.301541 6c:71:d9:1d:18:5f > 33:33:00:00:00:16, ethertype IPv6 (0x86dd), length 110: fe80::c9dc:4a44:5cf9:c7f1 > ff02::16: HBH ICMP6, multicast listener report v2, 2 group record(s), length 48
00:22:30.364071 6c:71:d9:1d:18:5f > 33:33:00:01:00:03, ethertype IPv6 (0x86dd), length 84: fe80::c9dc:4a44:5cf9:c7f1.63587 > ff02::1:3.5355: UDP, length 22
00:22:30.366051 6c:71:d9:1d:18:5f > 33:33:00:01:00:03, ethertype IPv6 (0x86dd), length 84: fe80::c9dc:4a44:5cf9:c7f1.57302 > ff02::1:3.5355: UDP, length 22
00:22:30.723140 6c:71:d9:1d:18:5f > 33:33:00:01:00:03, ethertype IPv6 (0x86dd), length 94: fe80::c9dc:4a44:5cf9:c7f1.60949 > ff02::1:3.5355: UDP, length 32
00:22:30.800848 6c:71:d9:1d:18:5f > 33:33:00:00:00:01, ethertype IPv6 (0x86dd), length 86: fe80::c9dc:4a44:5cf9:c7f1 > ff02::1: ICMP6, neighbor advertisement, tgt is fe80::c9dc:4a44:5cf9:c7f1, length 32
00:22:30.813199 6c:71:d9:1d:18:5f > 33:33:00:00:00:16, ethertype IPv6 (0x86dd), length 90: fe80::c9dc:4a44:5cf9:c7f1 > ff02::16: HBH ICMP6, multicast listener report v2, 1 group record(s), length 28
00:22:31.131397 6c:71:d9:1d:18:5f > 33:33:00:00:00:16, ethertype IPv6 (0x86dd), length 90: fe80::c9dc:4a44:5cf9:c7f1 > ff02::16: HBH ICMP6, multicast listener report v2, 1 group record(s), length 28
00:22:31.131446 6c:71:d9:1d:18:5f > 33:33:00:00:00:16, ethertype IPv6 (0x86dd), length 90: fe80::c9dc:4a44:5cf9:c7f1 > ff02::16: HBH ICMP6, multicast listener report v2, 1 group record(s), length 28
00:22:31.133181 6c:71:d9:1d:18:5f > 33:33:00:01:00:03, ethertype IPv6 (0x86dd), length 94: fe80::c9dc:4a44:5cf9:c7f1.59836 > ff02::1:3.5355: UDP, length 32
00:22:31.301206 6c:71:d9:1d:18:5f > 33:33:00:00:00:16, ethertype IPv6 (0x86dd), length 110: fe80::c9dc:4a44:5cf9:c7f1 > ff02::16: HBH ICMP6, multicast listener report v2, 2 group record(s), length 48
00:22:31.551910 6c:71:d9:1d:18:5f > 33:33:00:01:00:03, ethertype IPv6 (0x86dd), length 94: fe80::c9dc:4a44:5cf9:c7f1.59836 > ff02::1:3.5355: UDP, length 32
00:22:31.756569 94:0c:6d:ac:61:86 > 01:00:5e:00:00:01, ethertype IPv4 (0x0800), length 60: 0.0.0.0 > 224.0.0.1: igmp query v2
00:22:32.443742 6c:71:d9:1d:18:5f > 33:33:00:00:00:16, ethertype IPv6 (0x86dd), length 90: fe80::c9dc:4a44:5cf9:c7f1 > ff02::16: HBH ICMP6, multicast listener report v2, 1 group record(s), length 28
00:22:32.456368 6c:71:d9:1d:18:5f > 33:33:00:00:00:16, ethertype IPv6 (0x86dd), length 90: fe80::c9dc:4a44:5cf9:c7f1 > ff02::16: HBH ICMP6, multicast listener report v2, 1 group record(s), length 28
00:22:32.456797 6c:71:d9:1d:18:5f > 33:33:00:01:00:03, ethertype IPv6 (0x86dd), length 94: fe80::c9dc:4a44:5cf9:c7f1.64312 > ff02::1:3.5355: UDP, length 32
00:22:32.465994 6c:71:d9:1d:18:5f > 33:33:00:01:00:03, ethertype IPv6 (0x86dd), length 89: fe80::c9dc:4a44:5cf9:c7f1.50447 > ff02::1:3.5355: UDP, length 27
00:22:32.801439 6c:71:d9:1d:18:5f > 33:33:00:00:00:16, ethertype IPv6 (0x86dd), length 90: fe80::c9dc:4a44:5cf9:c7f1 > ff02::16: HBH ICMP6, multicast listener report v2, 1 group record(s), length 28
00:22:32.848538 6c:71:d9:1d:18:5f > 33:33:00:01:00:03, ethertype IPv6 (0x86dd), length 84: fe80::c9dc:4a44:5cf9:c7f1.53894 > ff02::1:3.5355: UDP, length 22
00:22:32.848583 6c:71:d9:1d:18:5f > 33:33:00:01:00:03, ethertype IPv6 (0x86dd), length 84: fe80::c9dc:4a44:5cf9:c7f1.59725 > ff02::1:3.5355: UDP, length 22
00:22:32.863616 6c:71:d9:1d:18:5f > 33:33:00:01:00:03, ethertype IPv6 (0x86dd), length 94: fe80::c9dc:4a44:5cf9:c7f1.64312 > ff02::1:3.5355: UDP, length 32
00:22:32.879206 6c:71:d9:1d:18:5f > 33:33:00:01:00:03, ethertype IPv6 (0x86dd), length 89: fe80::c9dc:4a44:5cf9:c7f1.50447 > ff02::1:3.5355: UDP, length 27
00:22:33.254341 6c:71:d9:1d:18:5f > 33:33:00:01:00:03, ethertype IPv6 (0x86dd), length 84: fe80::c9dc:4a44:5cf9:c7f1.59725 > ff02::1:3.5355: UDP, length 22
00:22:33.256019 6c:71:d9:1d:18:5f > 33:33:00:01:00:03, ethertype IPv6 (0x86dd), length 84: fe80::c9dc:4a44:5cf9:c7f1.53894 > ff02::1:3.5355: UDP, length 22
00:22:33.287136 6c:71:d9:1d:18:5f > 33:33:00:00:00:16, ethertype IPv6 (0x86dd), length 90: fe80::c9dc:4a44:5cf9:c7f1 > ff02::16: HBH ICMP6, multicast listener report v2, 1 group record(s), length 28
00:22:33.287194 6c:71:d9:1d:18:5f > 33:33:00:00:00:16, ethertype IPv6 (0x86dd), length 90: fe80::c9dc:4a44:5cf9:c7f1 > ff02::16: HBH ICMP6, multicast listener report v2, 1 group record(s), length 28
00:22:33.287272 6c:71:d9:1d:18:5f > 33:33:00:01:00:03, ethertype IPv6 (0x86dd), length 94: fe80::c9dc:4a44:5cf9:c7f1.53129 > ff02::1:3.5355: UDP, length 32
00:22:33.301703 6c:71:d9:1d:18:5f > 33:33:00:00:00:16, ethertype IPv6 (0x86dd), length 90: fe80::c9dc:4a44:5cf9:c7f1 > ff02::16: HBH ICMP6, multicast listener report v2, 1 group record(s), length 28
00:22:33.707517 6c:71:d9:1d:18:5f > 33:33:00:01:00:03, ethertype IPv6 (0x86dd), length 94: fe80::c9dc:4a44:5cf9:c7f1.53129 > ff02::1:3.5355: UDP, length 32
00:22:33.800855 6c:71:d9:1d:18:5f > 33:33:00:00:00:02, ethertype IPv6 (0x86dd), length 70: fe80::c9dc:4a44:5cf9:c7f1 > ff02::2: ICMP6, router solicitation, length 16
00:22:37.801555 6c:71:d9:1d:18:5f > 33:33:00:00:00:02, ethertype IPv6 (0x86dd), length 70: fe80::c9dc:4a44:5cf9:c7f1 > ff02::2: ICMP6, router solicitation, length 16
00:22:41.832588 6c:71:d9:1d:18:5f > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 168: fe80::c9dc:4a44:5cf9:c7f1.546 > ff02::1:2.547: dhcp6 solicit
00:22:42.832447 6c:71:d9:1d:18:5f > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 168: fe80::c9dc:4a44:5cf9:c7f1.546 > ff02::1:2.547: dhcp6 solicit
00:22:44.832765 6c:71:d9:1d:18:5f > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 168: fe80::c9dc:4a44:5cf9:c7f1.546 > ff02::1:2.547: dhcp6 solicit
00:22:48.832834 6c:71:d9:1d:18:5f > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 168: fe80::c9dc:4a44:5cf9:c7f1.546 > ff02::1:2.547: dhcp6 solicit
00:22:56.832953 6c:71:d9:1d:18:5f > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 168: fe80::c9dc:4a44:5cf9:c7f1.546 > ff02::1:2.547: dhcp6 solicit
00:22:59.436003 6c:71:d9:1d:18:5f > 33:33:00:01:00:03, ethertype IPv6 (0x86dd), length 89: fe80::c9dc:4a44:5cf9:c7f1.65074 > ff02::1:3.5355: UDP, length 27
00:22:59.848595 6c:71:d9:1d:18:5f > 33:33:00:01:00:03, ethertype IPv6 (0x86dd), length 89: fe80::c9dc:4a44:5cf9:c7f1.65074 > ff02::1:3.5355: UDP, length 27
00:23:12.833119 6c:71:d9:1d:18:5f > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 168: fe80::c9dc:4a44:5cf9:c7f1.546 > ff02::1:2.547: dhcp6 solicit
00:23:44.833984 6c:71:d9:1d:18:5f > 33:33:00:01:00:02, ethertype IPv6 (0x86dd), length 168: fe80::c9dc:4a44:5cf9:c7f1.546 > ff02::1:2.547: dhcp6 solicit
00:24:37.036642 94:0c:6d:ac:61:86 > 01:00:5e:00:00:01, ethertype IPv4 (0x0800), length 60: 0.0.0.0 > 224.0.0.1: igmp query v2

14 (edytowany przez rpc 2013-06-14 01:20:37)

Odp: iptv / multicast - internetia

hmm dziwne że poprzez haba nie chce działać a na laptopie masz internet poprzez haba jak głównym routerem jest netia spot ?


i drugie pytanie
czy netia player działa poprawnie na dowolnym porcie lan w netia spot ?
znaczy czy są wszystkie funkcję

co to za hab ? Mam wrażenie że nie chciał gadać na 10 mega netiaplayer smile Masz może jakiegoś switcha zarządzalnego aby jednak przechwycić ruch ?

@allosek:
czemu twierdzisz że jest źle ? Czemu ma być nietagowany ?
Przyjrzyj się logom. Jakby ruch na netia spot był nietagowany to by ramek vlan1000 nie było a jak są to znaczy że jednak jest tagowany i netia player podaje na port ethernet jednocześnie ruch tagowany i nie

ja bym się jednak upierał przy mojej konfiguracji

@szwabek:
weź jednak moją konfigurację (trochę ją poprawiłem w sekcji IPTV)
ten adres MAC na porcie wan jak rozumiem to adres netia spot ?
do tego zmodyfikuj /etc/config/dhcp dodaj sekcję

config dhcp IPTV
option interface        IPTV
option ignore   1

pokaż logi

swconfig dev rtl8366rb vlan 1 show
swconfig dev rtl8366rb vlan 2 show
swconfig dev rtl8366rb vlan 1000 show
route -n
ip route show
ifconfig

oraz wireshek z haba podłączonego do 1043
ale zrób tak że włącz wireshark/tcpdump na openwrt a potem dopiero netiaplayer aby złapać wszystko łącznie z dhcp

15

Odp: iptv / multicast - internetia

brak mi pełnych logów z netia spot szkoda sad

16

Odp: iptv / multicast - internetia

rpc napisał/a:

@allosek:
czemu twierdzisz że jest źle ? Czemu ma być nietagowany ?
Przyjrzyj się logom. Jakby ruch na netia spot był nietagowany to by ramek vlan1000 nie było a jak są to znaczy że jednak jest tagowany i netia player podaje na port ethernet jednocześnie ruch tagowany i nie

ja bym się jednak upierał przy mojej konfiguracji

Ja się nie upieram, chciałem wywnioskować dlatego że kolega "szwabek" napisał cyt. "Jeżeli port 1 zrobię jako vlan1000 nietagowany, to działa mi TV. ", stąd mój wniosek że powienien być nietagowany.
Poza tym pisałem to nie mając logów.

TP-Link TL-WR1043ND v1, 'LEDE' 17.01-SNAPSHOT' (r3371-79cd141)

17

Odp: iptv / multicast - internetia

@szwabek:
Nie miałem do czytania z TV od Netia, ale popraw mnie jeśli źle pisze:
1. zadaje się że Netia Player możesz podłączyć tylko pod konkretny port (jeden lub dwa) aby wszystko działało (TV i usługi) ?
2. Na pozostałych działa Ci tylko internet ? a jak podłączysz Netia Player to działają tylko usługi ?
3. Internet Ci nie działa na porcie na którym działa Netia Player ?

Jeśli tak jest mój wniosek jest taki,
a) na portach gdzie działa Ci TV i usługi - masz :
- nietagowany Vlan1000 to by tłumaczyło "vlan1000 nietagowany, to działa mi TV"
- opcja 1 (gdybanie): oraz tagowany jakiś vlan gdzie jest internet (trochę to bez sensu, bo lepiej by było aby vlan1000 został tagowany a internet nietagowany - ale kto wie może tak se utrudnili), to by tłumaczyło 3)
- opcja 2 (gdybanie): wyjście do usług masz przez http proxy (zdefiniowane w netia player), ale z jakiś powodów gdy robisz to na openwrt netia player nie widzi trasy do tego proxy (dlatego nie masz usług), to by tłumaczyło 3)
b) na portach gdzie nie działa Ci TV ale działają lub nie usługi Netai Player - masz :
- nietagowany internet
- tagowany vlan1000 - bo to wynika z logów
- (gdybanie dot. http proxy)
usługi Netia Player działają (jeśli działają to znaczy że jeśli jest http proxy jest widoczne w obu podsieciach vlan1000 i tej nietagowanej), jeśli nie działają to znaczy że http proxy jest widoczne tylko z podsieci z vlan1000.

Ogólnie moje gdybania biorą się z tego że ja mam dokładnie tak u siebie, choć nie mam tego od Netii.

Pozdrawiam!

TP-Link TL-WR1043ND v1, 'LEDE' 17.01-SNAPSHOT' (r3371-79cd141)

18

Odp: iptv / multicast - internetia

Panowie,

Dzięki za tak wiele odp i sugestii.

@rpc:

1. Przy podłączeniu netia spot -- hub -- netia player do huba był również połączony mój komp. Ja internet miałem. BYćmożenie chciał gaadć na 10mb... wink

2. Na każdym zportów netia spota działa TV/usługi. Zauważcie, że tam netia player dostaje adres z LAN

2. Właśnie zaimplementowałem Twój config.
Nastawe /ect/config/dhcp mam od początku mojej zabawy.
Próbowałem już wcześniej takiej konfiguracji - bez sukcesu. Nie działa TV, nie działająusługi sieciowe.

3. Tak jak pisałem. Jeżeli zmodyfikuję config na poniższy:

config switch_vlan
    option device 'rtl8366rb'
    option vlan '1'
    option ports '1 2 3 4 5t'

config switch_vlan
    option device 'rtl8366rb'
    option vlan '2'
    option ports '0 5t'

config switch_vlan
    option device 'rtl8366rb'
    option vlan '1000'
    option ports '0t 1t 5t'

To nie działa TV, ale działają usługi internetowe.
Poniżej logi przy tej nastawie:

root@OpenWrt:~# swconfig dev rtl8366rb vlan 1 show
VLAN 1:
        info: VLAN 1: Ports: '12345t', members=003e, untag=001e, fid=0
        fid: 0
        ports: 1 2 3 4 5t
root@OpenWrt:~# swconfig dev rtl8366rb vlan 2 show
VLAN 2:
        info: VLAN 2: Ports: '05t', members=0021, untag=0001, fid=0
        fid: 0
        ports: 0 5t
root@OpenWrt:~# swconfig dev rtl8366rb vlan 1000 show
VLAN 1000:
        info: VLAN 1000: Ports: '0t1t5t', members=0023, untag=0000, fid=0
        fid: 0
        ports: 0t 1t 5t
root@OpenWrt:~# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         87.99.47.1      0.0.0.0         UG    0      0        0 eth0.2
10.4.32.0       0.0.0.0         255.255.240.0   U     20     0        0 eth0.1000
87.99.47.0      0.0.0.0         255.255.255.0   U     0      0        0 eth0.2
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 br-lan
root@OpenWrt:~# ip route show
-ash: ip: not found
root@OpenWrt:~# ifconfig
br-lan    Link encap:Ethernet  HWaddr 94:0C:6D:AC:61:86
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6055 errors:0 dropped:57 overruns:0 frame:0
          TX packets:7070 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:886871 (866.0 KiB)  TX bytes:6004584 (5.7 MiB)

eth0      Link encap:Ethernet  HWaddr 94:0C:6D:AC:61:86
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:19192 errors:0 dropped:4 overruns:59765 frame:0
          TX packets:10065 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:6981979 (6.6 MiB)  TX bytes:5817126 (5.5 MiB)
          Interrupt:4

eth0.1    Link encap:Ethernet  HWaddr 94:0C:6D:AC:61:86
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2663 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4314 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:282207 (275.5 KiB)  TX bytes:4833677 (4.6 MiB)

eth0.1000 Link encap:Ethernet  HWaddr 94:0C:6D:AC:61:86
          inet addr:10.4.42.44  Bcast:10.4.47.255  Mask:255.255.240.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4958 errors:0 dropped:11 overruns:0 frame:0
          TX packets:5 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:221472 (216.2 KiB)  TX bytes:1977 (1.9 KiB)

eth0.2    Link encap:Ethernet  HWaddr 00:12:2A:81:9A:40
          inet addr:87.99.47.216  Bcast:87.99.47.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:11178 errors:0 dropped:29 overruns:0 frame:0
          TX packets:5745 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:6106876 (5.8 MiB)  TX bytes:940173 (918.1 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:16 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:3422 (3.3 KiB)  TX bytes:3422 (3.3 KiB)

wlan0     Link encap:Ethernet  HWaddr 94:0C:6D:AC:61:86
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3674 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3580 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:32
          RX bytes:733802 (716.6 KiB)  TX bytes:1382726 (1.3 MiB)

@alossek:
1. netiaplayer moge podłaczyc pod kazdy port netia spota i działa
3. internet działa na kazdym porcie netia spota

Resztę testów przeprowadzę ok 18.00, teraz muszę uciekać do roboty.

Pozdrawiam

19

Odp: iptv / multicast - internetia

@allosek: ja to rozumiem inaczej

szwabek napisał powyżej
"Jeżeli użyję domyślnego routera od netii - Netia Spot, to niezależnie do którego portu wepnę Playera, TV działa i usługi internetowe na nim również. Netia Player dostaje wtedy adres IP z LAN. Tyle moge zobaczyć na box'owym routerku."

co jest dla mnie jednoznaczne z tym, że
1)podłącza do dowolnego portu lan netia spot urządzenie netia player
2)na netia player dostaje takie same adresy lan jak pozostałe komputery + coś jeszcze ?? (czyli TV)

Dlatego bardzo bym prosił aby szwabek dokładnie określił czy
1)rzeczywiście netia player z netiaspot działa poprawnie na dowolnym porcie lan
2)jakie adresy(jeżli można podejrzeć) otrzymuje netia player
3)czy można pingować po adresie lan netia player z komputera?

no i koniecznie odpowiedzi na moje pytania poprzednie
czyli logi logi logi...

20

Odp: iptv / multicast - internetia

szwabek napisał/a:

1. Przy podłączeniu netia spot -- hub -- netia player do huba był również połączony mój komp. Ja internet miałem. BYćmożenie chciał gaadć na 10mb... wink

tak myślałem smile

szwabek napisał/a:

2. Na każdym zportów netia spota działa TV/usługi. Zauważcie, że tam netia player dostaje adres z LAN

czyli ergo vlan1000 jest przenoszony na dowolny port lan+wifi

szwabek napisał/a:

2. Właśnie zaimplementowałem Twój config.
Nastawe /ect/config/dhcp mam od początku mojej zabawy.
Próbowałem już wcześniej takiej konfiguracji - bez sukcesu. Nie działa TV, nie działająusługi sieciowe.

a czy działa internet na komputerze ? Jaki komputer otrzymuje adres (o ile go otrzymuje)?

szwabek napisał/a:

3. Tak jak pisałem. Jeżeli zmodyfikuję config na poniższy:

config switch_vlan
    option device 'rtl8366rb'
    option vlan '1'
    option ports '1 2 3 4 5t'

config switch_vlan
    option device 'rtl8366rb'
    option vlan '2'
    option ports '0 5t'

config switch_vlan
    option device 'rtl8366rb'
    option vlan '1000'
    option ports '0t 1t 5t'

To nie działa TV, ale działają usługi internetowe.

Pytanie jak wyżej jakie adresy otrzymuje komputer podpięty do tego portu ?

szwabek napisał/a:
root@OpenWrt:~# swconfig dev rtl8366rb vlan 1 show
VLAN 1:
        info: VLAN 1: Ports: '12345t', members=003e, untag=001e, fid=0
        fid: 0
        ports: 1 2 3 4 5t
root@OpenWrt:~# swconfig dev rtl8366rb vlan 2 show
VLAN 2:
        info: VLAN 2: Ports: '05t', members=0021, untag=0001, fid=0
        fid: 0
        ports: 0 5t
root@OpenWrt:~# swconfig dev rtl8366rb vlan 1000 show
VLAN 1000:
        info: VLAN 1000: Ports: '0t1t5t', members=0023, untag=0000, fid=0
        fid: 0
        ports: 0t 1t 5t

Wygląda na ok.

szwabek napisał/a:
root@OpenWrt:~# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         87.99.47.1      0.0.0.0         UG    0      0        0 eth0.2
10.4.32.0       0.0.0.0         255.255.240.0   U     20     0        0 eth0.1000
87.99.47.0      0.0.0.0         255.255.255.0   U     0      0        0 eth0.2
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 br-lan

poproszę dwa logi dla porównania z twojej konfiguracji i mojej

szwabek napisał/a:

root@OpenWrt:~# ip route show
-ash: ip: not found

brak zainstalowanego pakietu ip na razie pomińmy

Zróbmy jeszcze kilka testów.
Wireshark podłączony do netia spot i powiedz czy jednak pakiety vlan1000 nadal idą na dowolnym porcie ?
to te wpisy

21:44:09.117929 00:12:2a:81:9a:45 > 01:00:5e:00:00:02, ethertype 802.1Q (0x8100), length 60: vlan 1000, p 6, ethertype IPv4, 10.4.45.218 > 224.0.0.2: igmp leave 239.200.5.41

Tak patrzę na te logi i zaczynam się zastanawiać czy nie jest zrobione jakieś przekierowanie na netia spot
widać ewidentnie że od netiaplayer idą pakiety na adresy multicast po zakresie sieciowym LAN na nie po vlan1000
Hmm a może router nie powinien pobierać adresu ip dla vlan1000 bo zapiera go netia playerowi ?
Takie tylko głośno myślę
Szkoda że nie mam dostępu

Mam jeszcze jeden pomysł
Spróbuj tak.
Moja konfiguracja ta co jest internet a nie działa TV czyli

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option ifname 'eth0.1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'

config interface 'wan'
    option ifname 'eth0.2'
    option proto 'dhcp'

config interface 'IPTV'
    option ifname 'eth0.1000'
    option proto 'dhcp'
    option 'defaultroute' '0'
    option 'peerdns' '0'
    option metric '20'

config switch
    option name 'rtl8366rb'
    option reset '1'
    option enable_vlan '1'
    option enable_vlan4k '1'

config switch_vlan
    option device 'rtl8366rb'
    option vlan '1'
    option ports '2 3 4 5t'

config switch_vlan
    option device 'rtl8366rb'
    option vlan '2'
    option ports '0 1 5t'

config switch_vlan
    option device 'rtl8366rb'
    option vlan '1000'
    option ports '0t 1t 5t'

następnie wpisz z ręki na początek

ip route add 244.0.0.0/4 dev eth0.1000

iptables -I INPUT -p igmp -j ACCEPT
iptables -I FORWARD -i eth0.1000 -p udp -j ACCEPT
iptables -I INPUT -i eth0.1000 -d 239.2.0.0/16 -j ACCEPT

iptables -t filter -I INPUT -d 239.0.0.0/240.0.0.0 -i eth0.1000 -j ACCEPT
iptables -t filter -I INPUT -s 239.0.0.0/240.0.0.0 -i eth0.1000 -j ACCEPT
iptables -t filter -I FORWARD -d 239.0.0.0/240.0.0.0 -j ACCEPT
iptables -t filter -I FORWARD -s 239.0.0.0/240.0.0.0 -j ACCEPT
iptables -t mangle -I PREROUTING -d 239.0.0.0/240.0.0.0 -p udp -j TTL --ttl-inc 1
iptables -t nat -I POSTROUTING -o eth0.1000 -j MASQUERADE

i zobacz co się dzieje

I odwrotnie weź swoją konfigurację i sprawdź te wpisy.

21

Odp: iptv / multicast - internetia

rpc napisał/a:

@allosek: ja to rozumiem inaczej

szwabek napisał powyżej
"Jeżeli użyję domyślnego routera od netii - Netia Spot, to niezależnie do którego portu wepnę Playera, TV działa i usługi internetowe na nim również. Netia Player dostaje wtedy adres IP z LAN. Tyle moge zobaczyć na box'owym routerku."

co jest dla mnie jednoznaczne z tym, że
1)podłącza do dowolnego portu lan netia spot urządzenie netia player
2)na netia player dostaje takie same adresy lan jak pozostałe komputery + coś jeszcze ?? (czyli TV)

Masz rację, z drugiej strony zmyliło mnie to że

szwabek napisał/a:

Jeżeli port 1 zrobię jako vlan1000 nietagowany, to działa mi TV.

Wydaje mi się, że muszę umieć wrzucić port 1 na routerze jako nietagowany vlan1000, bo tylko wtedy działa TV i jakoś dać mu wyjście na świat...

dlatego pisałem że uważam Twoją konfiguracje za złą, ja obrałem po prostu inny tok myślenia,
nie miej mi tego za złe - zwłaszcza że wiesz o niebo więcej od mnie.

Pozdrawiam!

TP-Link TL-WR1043ND v1, 'LEDE' 17.01-SNAPSHOT' (r3371-79cd141)

22

Odp: iptv / multicast - internetia

Panowie, jest pewna rzecz która przyszła mi do głowy:

skoro :
1. w oryginalnym zestawie - adresy IP na Netia Player są z LAN (192.x.x.x)
2. w oryginalnym zestawie - działa TV
3. z Openwrt - działa TV gdy nietagowany VLAN 1000 (10.x.x.x)

to oznacza jedno: NETIA spot jest serwerem proxy dla igmp,
użyj pakietu igmpproxy i na bank zadziała

TP-Link TL-WR1043ND v1, 'LEDE' 17.01-SNAPSHOT' (r3371-79cd141)

23 (edytowany przez alossek 2013-06-14 10:13:19)

Odp: iptv / multicast - internetia

@szwabek:
zrób tak
1. instalujesz igmpproxy  (koniecznie AA, ze względu na  'IGMP snooping', http://eko.one.pl/forum/viewtopic.php?id=3400)
2. konfigurujesz tak jak miałeś pierwotną konfigurację
3. konfigurujesz igmpproxy (http://wiki.openwrt.org/doc/howto/udp_multicast)
4. NETIA playera wpinasz do portów LAN (2 3 4) potem ten 1 też sobie dołącz

i będzie działać. MUSI.

TP-Link TL-WR1043ND v1, 'LEDE' 17.01-SNAPSHOT' (r3371-79cd141)

24 (edytowany przez rpc 2013-06-14 10:21:01)

Odp: iptv / multicast - internetia

alossek napisał/a:

to oznacza jedno: NETIA spot jest serwerem proxy dla igmp,
użyj pakietu igmpproxy i na bank zadziała

Albo brak tylko odpowiedniego routingu bądź firewalla ale generalnie zgadzam się to dobry kierunek.
Inszo powiem szczerze ja na ich miejscu postawiłbym netiaplayer normalnie na vlan a pozostałe rzeczy na proxy.

Po drugie jaki cel miałoby przenoszenie vlan1000 na porty lan w netiaspot. Do czegoś musi to służyć. Trzeba się jeszcze nad tym pokłonić

25

Odp: iptv / multicast - internetia

alossek napisał/a:

dlatego pisałem że uważam Twoją konfiguracje za złą, ja obrałem po prostu inny tok myślenia,
nie miej mi tego za złe - zwłaszcza że wiesz o niebo więcej od mnie.

Jakbym pił to na piwo byśmy se poszli smile i po sprawie
I nie przeceniaj mnie zbytnio