76

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

Czyli nie korzystasz z openwrt. Kup cokolwiek co jest wpierane, np. jednego z tplinków i ustawisz, bo to jest sprawa programowa.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

77

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

Pytałem ponieważ czytając wątek ktoś napisał że brakuje mu pamięci,czyli jak napisałeś jeden z tplinków.
Dziękuje.

78

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

To zależy co będziesz miał uruchomione na routerze. Ogólna zasada - kupujesz najsilniejszy na jaki cię stać.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

79 (edytowany przez Zuzia 2018-02-10 01:13:38)

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

@Cezary
Który konkretnie z tych tanich Tp-Linków zmieści soft pod UPC Wi-Free? Bez kompilacji tylko tak, aby doinstalować co potrzebne.

Mam ochotę po latach zrobić jeszcze jedno podejście do tematu, bo w moim zasięgu pojawił się modem Compal dający, aż 10 Mb/s przez UPC Wi-Free.

Firmware z obsługą UPC Wi-Free i Eduroam: Link
EASYBOX 802, 803A, 904 DSL
D-LINK DWR-116 A2, DWR-118 A1, A2
TP-LINK TL-WR740ND v1, v2

80

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

Coś co ma min. 8MB flash. Używany 1043, wdr3600 itd.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

81

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

Dziękuję Cezary, poszukam któregoś z tych modeli.

Firmware z obsługą UPC Wi-Free i Eduroam: Link
EASYBOX 802, 803A, 904 DSL
D-LINK DWR-116 A2, DWR-118 A1, A2
TP-LINK TL-WR740ND v1, v2

82

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

Witam
Trochę odświeżę  temat ,otóż  zakupiłem  używanego TL-WR1043NDv2 i zgodnie z instrukcją
Zmieniając  jedynie oprog. na wersję v2 wgrałem  openwrt. ale niestety nie ma teraz GUI.
Próbowałem hard resetu nic to nie dało. Jakaś mała podpowiedź, ,byłbym wdzięczny.
Dziękuję
pozdrawiam

83

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

Może po prostu wgrałeś wersję która nie ma gui. Wgraj taką która ma gui. Jak wgrać ponownie masz w faq na górze tej strony.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

84

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

Dziękuje
Jeszcze jedno pytanie,prośba, mógłbyś Cezary wskazać odpowiednie do TL-WR1043NDv2 z GUI
pozdr.

85

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

Gargoyle: http://dl.eko.one.pl/gargoyle-pl/chaos_calmer/ar71xx/
Luci: http://dl.eko.one.pl/luci/lede/17.01-SN … x/generic/

1043 v2 w nazwie.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

86 (edytowany przez adamas 2018-02-18 20:57:40)

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

Po paru próbach udało się wgrać "Luci" Może to z wrażenia ale nie moge znaleść to co jest napisane w opisie-post nr72.
punkt 8 ( W Filter wpisz wpad, zakładke zmień na Available packages i zainstaluj wpad.)
Ale to jak już pisałem to z wrażenia ze udało mi się odpalić routerek.
Dziękuje Cezary
pozdr.

87

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

Witam wszystkich. Czy myślał ktoś kiedyś aby uzyskać za pomocą wi-free dostep do glownego routera z ktorego nadaje zwykle wifi +wi-free ?

Próbowałem, kombinowałem lecz nic z tego. Wiadomo ze jest to juz zadanie LEVEL HARD, ale jesli fizycznie korzystamy z tego samego urzadzenia (routera), ip wyjsciowe takze jest to samo, to napewno jakos da sie tam dostac. Moze ktos ma jakis pomysl ?

88

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

A po co chcesz to robić? Jak jest włączony dostęp do panelu z internetu to znając zewnętrzne IP możesz zobaczyć stronę logowania ale nie licz na admin/admin.

89

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

To że coś pracuje na tym samym urządzeniu nie oznacza że się wszystko łączy logicznie. Lokalne WiFi i dostęp do routera to jedno, a UPC Wi-Free to drugie. Nawet inaczej się logujesz do sieci (przy Wi-Free logujesz się do jakiegoś kerberosa (i to w skali globalnej, bo zalogujesz się wszędzie w Europie gdzie jest Wi-Free), a nie do lokalnych ustawień routera UPC). I z moich obserwacji wynika, że dostajesz całkiem inny adres IP. Np w jednym miejscu mam 89.64.x.x, a drugim 10.41.x.x... A do routera możesz dostać się z zewnątrz, jak sobie na nim przekierujesz port 80...

90 (edytowany przez Zuzia 2018-03-25 14:42:57)

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

woyoo napisał/a:

1.Pobierz
https://archive.openwrt.org/attitude_ad … actory.bin
2. Podlacz komputer na  WR1043N/ND v1 kablem
3. Zaloguj sie do routera do GUI (192.168.0.1)
4. W System Tools wejdz na Firmware upgrade i wgraj wczesniej pobrany plik.
5. Po wgraniu nowego oprogramowania zaloguj sie do GUI (192.168.1.1)
6. W zakladce System->Software znajdz na koncu "wpad-mini" - kliknij remove
7. Na gorze strony kliknij update lists (router musi miec dostep do internetu przez port wan)
8. W Filter wpisz wpad, zakladke zmien na Available packages i zainstaluj wpad.
9. Przejdz do zakladki Network -> Wifi
10. Kliknij Scan
11. Wybierz siec do ktorej chcesz sie podlaczyc
12. Na kolejnej stronie (przejdzie automatycznie) kliknij Submit
13. Na kolejnej stronie (przejdzie automatycznie) w Interface Configuration wybierz Wireless Security
14. Wybierz WPA2-EAP i kojeno w polach: Cipher auto, EAP-Metod PEAM, pomin, pomin, pomin, nazwa_usera UPC, haslo UPC
15. Save&Apply

W zakladce Network -> Wifi powinien polaczyc sie z siecia i powinna pojawic sie w associated stations

W zakladce Network -> Interfaces powinno zaciagnac ip dla tej sieci WWAN

Powinno sie polaczyc i dzialac poprawnie smile

Super opis, ale po zastosowaniu punktu 6, czyli usunięciu wpad-mini kolejny krok jest niemożliwy, bo błąd: "opkg_conf_load: Could not lock /var/lock/opkg.lock: Resource temporarily unavailable.". Mimo,  że wcześniej odświeżało listę pakietów, a Internet jest cały czas; połączenie WAN jest z kablówki i działa. Zniknęły z podglądu wszystkie zainstalowane pakiety.

Edycja1:
Próbuję ubić proces: "23744 root      4748 D    opkg --force-removal-of-dependent-packages --force-overwrite --nocase install wpad" przez kill -9 23744, ale nie da się.

Edycja2:
Ufff... Pomogło dopiero: rm  /var/lock/opkg.lock.

Edycja3:
Radość trwała krótko, bo tym razem: "Bad Gateway The process did not produce any response" i znowu trzeba ubić proces przez ssh. Zainstalować nie da się.

Edycja4:
opkg install wpad
Installing wpad (2015-03-25-1) to root...
Downloading http://downloads.openwrt.org/chaos_calm … antiq.ipk.
Collected errors:
* extract_archive: Cannot create symlink from ./usr/sbin/wpa_supplicant to 'wpad': No space left on device.
* pkg_write_filelist: Failed to open //usr/lib/opkg/info/wpad.list: No space left on device.
* opkg_install_pkg: Failed to extract data files for wpad. Package debris may remain!
* opkg_install_cmd: Cannot install package wpad.
* opkg_conf_write_status_files: Can't open status file //usr/lib/opkg/status: No space left on device.

Brak miejsca... Usunęłam już Transmission, nie wiem co jeszcze, żeby starczyło...

Edycja5:
Failsafe, Firstboot, instalacja wpad i mam  WPA2-EAP, jeszcze nie działa, ale wkrótce być może smile

------------
Edycja6:
DZIAŁA! big_smile
Wpad wyrzucony, zainstalowany wpa-supplicant oraz wpa-cli i hostapd (wymaga jako zależność), konfiguracja wygląda następująco:

cat /etc/config/dhcp
config dnsmasq
    option domainneeded    1
    option boguspriv    1
    option filterwin2k    0  # enable for dial on demand
    option localise_queries    1
    option rebind_protection 1  # disable if upstream must serve RFC1918 addresses
    option rebind_localhost 1  # enable for RBL checking and similar services
    #list rebind_domain example.lan  # whitelist RFC1918 responses for domains
    option local    '/lan/'
    option domain    'lan'
    option expandhosts    1
    option nonegcache    0
    option authoritative    1
    option readethers    1
    option leasefile    '/tmp/dhcp.leases'
    option resolvfile    '/tmp/resolv.conf.auto'
    #list server        '/mycompany.local/1.2.3.4'
    #option nonwildcard    1
    #list interface        br-lan
    #list notinterface    lo
    #list bogusnxdomain     '64.94.110.11'
    option localservice    1  # disable to allow DNS requests from non-local subnets

config dhcp lan
    option interface    lan
    option start     100
    option limit    150
    option leasetime    12h

config dhcp wan
    option interface    wan
    option ignore    1

config dhcp wwan
        option interface        wwan
        option ignore   1
cat /etc/config/wireless

config wifi-device 'radio0'
    option type 'mac80211'
    option hwmode '11g'
    option path 'pci0000:00/0000:00:0e.0'
    option htmode 'HT20'
    option country 'PL'
    option txpower '20'
    option disabled '0'
    option channel '11'

config wifi-iface
    option network 'wwan'
    option ssid 'UPC Wi-Free'
    option device 'radio0'
    option mode 'sta'
    option identity 'login'
    option password 'hasło'
    option encryption 'wpa2'
    option eap_type 'peap'
    option ca_cert '/lib/uci/upload/cbid.wireless.cfg033579.ca_cert'
    option auth 'MSCHAPV2'

Utworzył się  plik /var/run/wpa_supplicant-wlan0.conf

network={
    scan_ssid=1
    ssid="UPC Wi-Free"
    key_mgmt=WPA-EAP
    ca_cert="/lib/uci/upload/cbid.wireless.cfg033579.ca_cert"
    identity="login"
    phase2="MSCHAPV2"
    password="hasło"
    eap=PEAP
    proto=RSN
    bssid=AE:22:15:2A:13:09

https://zapodaj.net/images/1fa43ff9521ef.jpg
https://zapodaj.net/images/41c740b6dea4a.jpg


Plik z certyfikatem liberty_global.pem dostępny jest w sieci: http://www.mediafire.com/file/kcg66cggg … bal.pem.7z

Edycja7:
Na pełnym wpad również działa stabilnie. Trzeba tylko pamiętać o dodaniu certyfikatu oraz wpisu na końcu  /etc/config/dhcp:

config dhcp wwan
        option interface        wwan
        option ignore   1
Firmware z obsługą UPC Wi-Free i Eduroam: Link
EASYBOX 802, 803A, 904 DSL
D-LINK DWR-116 A2, DWR-118 A1, A2
TP-LINK TL-WR740ND v1, v2

91 (edytowany przez Zuzia 2018-11-29 22:44:36)

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

W OpenWRT 18.06 pojawiają czasem się problemy z UPC Wi-Free przy korzystaniu z pełnego Wpad. Trzeba go zamienić na hostapd i wpa_supplicant skompilowany z opcją wsparcia dla openssl i Disable timestamp check, czyli wracamy do punktu wyjścia.

Działająca konfiguracja /etc/config/wireless:

config wifi-iface
    option network 'upcwifree'
    option ssid 'UPC Wi-Free'
    option device 'radio1'
    option mode 'sta'
    option encryption 'wpa2'
    option eap_type 'peap'
    option auth 'EAP-MSCHAPV2'
    option bssid 'AE:22:15:E7:EB:F1' #to jest adres MAC routera nadającego UPC Wi-Free
    option identity 'TWOJ_LOGIN'
    option password 'TWOJE_HASLO'
    option disabled '0'

Edycja:
A tak wygląda dla LEDE, tutaj wpad daje jakoś radę. W zasadzie wystarczy usunąć wpad-mini, zainstalować wpad (oraz zlib i libopenssl) i działa konfiguracja jak poniżej, nie trzeba niczego specjalnie kompilować.

/etc/config/wireless

config wifi-iface
    option network 'upcwifree'
    option ssid 'UPC Wi-Free'
    option device 'radio0'
    option mode 'sta'
    option encryption 'wpa2'
    option eap_type 'peap'
    option auth 'EAP-MSCHAPV2'
    option identity Twój login'
    option password 'Twoje hasło'

/etc/config/network

config interface 'upcwifree'
    option proto 'dhcp'
    option delegate '0'
    option ipv6 '0'

/etc/config/firewall

config zone
    option name 'wan'
    option input 'REJECT'
    option output 'ACCEPT'
    option forward 'REJECT'
    option masq '1'
    option mtu_fix '1'
    option network 'wan wan6 upcwifree'

/etc/config/dhcp

config dhcp 'upcwifree'
    option interface 'upcwifree'
    option ignore '1'
Firmware z obsługą UPC Wi-Free i Eduroam: Link
EASYBOX 802, 803A, 904 DSL
D-LINK DWR-116 A2, DWR-118 A1, A2
TP-LINK TL-WR740ND v1, v2

92

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

woyoo napisał/a:

Witam,

1.Pobierz
https://archive.openwrt.org/attitude_ad … actory.bin
2. Podlacz komputer na  WR1043N/ND v1 kablem
3. Zaloguj sie do routera do GUI (192.168.0.1)
4. W System Tools wejdz na Firmware upgrade i wgraj wczesniej pobrany plik.
5. Po wgraniu nowego oprogramowania zaloguj sie do GUI (192.168.1.1)
6. W zakladce System->Software znajdz na koncu "wpad-mini" - kliknij remove
7. Na gorze strony kliknij update lists (router musi miec dostep do internetu przez port wan)
8. W Filter wpisz wpad, zakladke zmien na Available packages i zainstaluj wpad.
9. Przejdz do zakladki Network -> Wifi
10. Kliknij Scan
11. Wybierz siec do ktorej chcesz sie podlaczyc
12. Na kolejnej stronie (przejdzie automatycznie) kliknij Submit
13. Na kolejnej stronie (przejdzie automatycznie) w Interface Configuration wybierz Wireless Security
14. Wybierz WPA2-EAP i kojeno w polach: Cipher auto, EAP-Metod PEAM, pomin, pomin, pomin, nazwa_usera UPC, haslo UPC
15. Save&Apply

W zakladce Network -> Wifi powinien polaczyc sie z siecia i powinna pojawic sie w associated stations

W zakladce Network -> Interfaces powinno zaciagnac ip dla tej sieci WWAN

Powinno sie polaczyc i dzialac poprawnie smile

Witam  wszystkich. Postepuje zgodnie z ta instrukcja ale cos mi sie nei chce polaczyc. W stopce gui routera mam cos takiego "Powered by LuCI (git-15.248.30277-3836b45) / OpenWrt Chaos Calmer 15.05"
No i w korku 14 nie mam w EAP-Metod PEAM i nie moge polaczyc sie z Wi-Free. Z innymi sieciami sie laczy. Moze ktos mi pomoc?
https://imgur.com/a/uG4EHhb

93

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

Zainstalowałeś pełną wersję wpad?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

94 (edytowany przez patgaw 2018-11-26 23:47:54)

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

Oczywiscie wink
Bez niego nie bylo WPA2-EAP

95

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

Powinno być EAP MSCHAPV2, wystarczy przyjrzeć się obrazkom: http://chomikuj.pl/ZuzannaCK/ROUTERY/TP … R1043ND+v1
Pod Chaos Calmer może być problem w pobieraniem adresu, wtedy łączy, ale netu nie ma.

Firmware z obsługą UPC Wi-Free i Eduroam: Link
EASYBOX 802, 803A, 904 DSL
D-LINK DWR-116 A2, DWR-118 A1, A2
TP-LINK TL-WR740ND v1, v2

96

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

Zuzia napisał/a:

Powinno być EAP MSCHAPV2, wystarczy przyjrzeć się obrazkom: http://chomikuj.pl/ZuzannaCK/ROUTERY/TP … R1043ND+v1
Pod Chaos Calmer może być problem w pobieraniem adresu, wtedy łączy, ale netu nie ma.

Tak tez nie dziala ;/

97 (edytowany przez Zuzia 2018-11-27 17:36:46)

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

Do sprawdzenia /etc/config/wireless oraz logi po nieudanej próbie połączenia. Kilka postów wyżej podałam przepis na działająca konfigurację  pod Chaos Calmer...

Firmware z obsługą UPC Wi-Free i Eduroam: Link
EASYBOX 802, 803A, 904 DSL
D-LINK DWR-116 A2, DWR-118 A1, A2
TP-LINK TL-WR740ND v1, v2

98 (edytowany przez patgaw 2018-11-27 22:10:49)

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

Ok udalo sie. Okazalo sie ze siec wi free do ktorej sie laczylem byla popusta. A zeby bylo smieszniej ta siec jest moja. Telefon w tym samym pomieszczeniu polaczyl sie z inna siecia i dzialalo....
Teraz pytanie czy moge na tym samym routerze postawic wi fi do ktorego sie podlacze czy musze uzywac drugiego routera?

99

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

A jaki router masz? Generalnie  tak: http://eko.one.pl/?p=openwrt-sta#rozgas … przewodowo choć nie jest to polecane żeby tak pracowało.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

100 (edytowany przez Zuzia 2018-11-27 22:29:21)

Odp: OpenWRT 12.04 + Luci + UPC Wi-Free

patgaw napisał/a:

Ok udalo sie. Okazalo sie ze siec wi free do ktorej sie laczylem byla popusta. A zeby bylo smieszniej ta siec jest moja. Telefon w tym samym pomieszczeniu polaczyl sie z inna siecia i dzialalo....

Na tym polega usługa, można łączyć się z innymi routerami nadającymi Wi-Free, ale nie z tym, który dostałeś od UPC. Stąd w logach miałeś dostęp zabroniony.

patgaw napisał/a:

Teraz pytanie czy moge na tym samym routerze postawic wi fi do ktorego sie podlacze czy musze uzywac drugiego routera?

Jak masz w routerze drugie radio np. 5 GHz to tak można. A jeśli jest tylko jedno 2.4 GHz sprawa komplikuje się. Jeżeli masz router z portem usb można dołożyć drugą kartę WiFi i taka konfiguracja tez powinna działać. Robiłam coś takiego na kartach Mediateka i Realteka i dawało radę.

Firmware z obsługą UPC Wi-Free i Eduroam: Link
EASYBOX 802, 803A, 904 DSL
D-LINK DWR-116 A2, DWR-118 A1, A2
TP-LINK TL-WR740ND v1, v2