Temat: Mwan3 i problem z Rules

Witam, mam ustawiony mwan3 tak aby cały ruch szedł mi z radiówki wwan. Chciałem aby na dane ip w mojej sieci kierowany był internet z wan( gsm ). Mam wszystko ustawione ale ruch jest nadal kierowany jako default do wszystkich, proszę o sprawdzenie ustawień, dzieki.

Ustawienia Mwan3:

config rule 'https'
    option sticky '1'
    option dest_port '443'
    option proto 'tcp'
    option use_policy 'balanced'

config rule 'host100'
    option proto 'all'
    option use_policy 'wan_wwan'
    option src_ip '192.168.1.11'
    option sticky '1'

config rule 'default_rule'
    option dest_ip '0.0.0.0/0'
    option proto 'all'
    option sticky '0'
    option use_policy 'wwan_wan'

config policy 'wwan_wan'
    list use_member 'wwan_m1_w3'
    list use_member 'wan_m2_w2'
    option last_resort 'default'

config policy 'wan_wwan'
    list use_member 'wan_m1_w2'
    list use_member 'wwan_m2_w3'
    option last_resort 'default'

config policy 'wwan_only'
    list use_member 'wwan_m1_w3'
    option last_resort 'default'

config policy 'wan_only'
    list use_member 'wan_m1_w2'
    option last_resort 'default'

config policy 'balanced'
    list use_member 'wwan_m1_w3'
    list use_member 'wan_m1_w2'
    option last_resort 'default'

config globals 'globals'
    option local_source 'none'

config interface 'wwan'
    option enabled '1'
    option initial_state 'online'
    option family 'ipv4'
    list track_ip '8.8.8.8'
    list track_ip '208.67.220.220'
    option track_method 'ping'
    option reliability '2'
    option count '1'
    option size '56'
    option timeout '2'
    option interval '5'
    option failure_interval '5'
    option recovery_interval '5'
    option down '4'
    option up '8'
    option flush_conntrack 'never'

config interface 'wan'
    option enabled '1'
    option initial_state 'online'
    option family 'ipv4'
    list track_ip '8.8.8.8'
    list track_ip '208.67.220.220'
    option track_method 'ping'
    option reliability '1'
    option count '1'
    option size '56'
    option timeout '2'
    option interval '5'
    option failure_interval '5'
    option recovery_interval '5'
    option down '4'
    option up '8'
    option flush_conntrack 'never'

config member 'wwan_m1_w3'
    option interface 'wwan'
    option metric '1'
    option weight '3'

config member 'wwan_m2_w3'
    option interface 'wwan'
    option metric '2'
    option weight '3'

config member 'wan_m1_w2'
    option interface 'wan'
    option metric '1'
    option weight '2'

config member 'wan_m2_w2'
    option interface 'wan'
    option metric '2'
    option weight '2'


Ustawienia sieci:


config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fd6d:0faf:477e::/48'

config interface 'lan'
    option type 'bridge'
    option ifname 'eth1.1'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ip6assign '60'

config interface 'wan'
    option ifname 'eth0.2'
    option proto 'dhcp'
    option metric '20'

config interface 'wan6'
    option ifname 'eth0.2'
    option proto 'dhcpv6'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '1 2 3 4 6t'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '5 0t'

config interface 'wwan'
    option proto 'dhcp'
    option metric '10'

i ustawienia radiówki:

config wifi-device 'radio0'
    option type 'mac80211'
    option channel '36'
    option hwmode '11a'
    option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
    option htmode 'VHT80'
    option country 'US'
    option legacy_rates '1'

config wifi-iface 'default_radio0'
    option device 'radio0'
    option network 'lan'
    option mode 'ap'
    option ssid 'Lede'
    option encryption 'psk-mixed'
    option key 'xxxxxxxxxxxxxx'

config wifi-device 'radio1'
    option type 'mac80211'
    option hwmode '11g'
    option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
    option htmode 'HT20'
    option country 'US'
    option legacy_rates '1'
    option disabled '0'
    option channel '6'
    option txpower '30'

config wifi-iface 'default_radio1'
    option device 'radio1'
    option network 'lan'
    option mode 'ap'
    option key 'xxxxxxxxxxxxxx'
    option ssid 'Lede'
    option encryption 'psk2'

config wifi-iface
    option network 'wwan'
    option ssid 'TP-LINK_0CD6'
    option encryption 'psk2'
    option device 'radio1'
    option mode 'sta'
    option bssid '50:C7:BF:47:0C:D6'
    option key 'xxxxxxx'

2

Odp: Mwan3 i problem z Rules

W config rule 'host100' przestaw option use_policy na wan_only jeżeli to ten host.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

3

Odp: Mwan3 i problem z Rules

Już to próbowałem, niestety bez efektu.......

4

Odp: Mwan3 i problem z Rules

Więc spróbuj jeszcze raz, zrestartuj całość, jak nie działa - pokaż status z mwan3.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

5

Odp: Mwan3 i problem z Rules

przezuciłem rules na inne ip ale to bez znaczena, poprostu na tym urzadzeniu sprawdza sie mi lepiej siec. zamieniałem rowniez miejscami i teraz rules ustawilem u samej góry, zawsze robiłem restart.


Interface status:
interface wwan is error and tracking is active
interface wan is error and tracking is active

Current ipv4 policies:
balanced:
wan (40%)
wwan (60%)

wan_only:
wan (100%)

wan_wwan:
wan (100%)

wwan_only:
wwan (100%)

wwan_wan:
wwan (100%)


Current ipv6 policies:
balanced:
default

wan_only:
default

wan_wwan:
default

wwan_only:
default

wwan_wan:
default


Directly connected ipv4 networks:
127.0.0.0
192.168.0.0
192.168.1.0/24
192.168.3.2
192.168.0.109
192.168.3.255
127.0.0.1
192.168.0.255
127.0.0.0/8
224.0.0.0/3
192.168.1.255
192.168.1.1
192.168.0.0/24
192.168.3.0/24
192.168.1.0
192.168.3.0
127.255.255.255

Directly connected ipv6 networks:
fd6d:faf:477e::/64
ff00::/8
fe80::/64

Active ipv4 user rules:
   53  3254 S host100  all  --  *      *       192.168.1.11         0.0.0.0/0           
1404 78741 S https  tcp  --  *      *       0.0.0.0/0            0.0.0.0/0            multiport sports 0:65535 multiport dports 443
  810  230K - wwan_wan  all  --  *      *       0.0.0.0/0            0.0.0.0/0           

Active ipv6 user rules:
    0     0 S https  tcp      *      *       ::/0                 ::/0                 multiport sports 0:65535 multiport dports 443
    0     0 - wwan_wan  all      *      *       ::/0                 ::/0

6

Odp: Mwan3 i problem z Rules

a masz w obrazie pakiet ip-full?
czy dodałeś nowy wwan do firewalla?
dlaczego nie ustawiłeś dns-ów zgodnie z poradnikiem?

* WR1043v1 16MB@64MB * || * WT3020-16MB * || * Xiaomi Miwifi Mini *
* E3276 HiLink + RTL2832 + IT9135 + Siano + EC103 *

7

Odp: Mwan3 i problem z Rules

I dlaczego oba interfejsy nie chodzą...

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

8

Odp: Mwan3 i problem z Rules

zaraz wszytsko na nowo posprawdzam. ale łącza mi działają prawidłowo jak jedno odłącze drugie idzie i na odwrót.

9

Odp: Mwan3 i problem z Rules

Interface status:
interface wwan is error and tracking is active
interface wan is error and tracking is active

Nie wiem co ci działa prawidłowo ale mwan3 nie widzi aktywności tych interfejsów. Więc chyba nawet nie działa i wszystko leci na domyślnym routingu.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

10

Odp: Mwan3 i problem z Rules

Dzięki wielkie, poprawiłem i jest tak jak trzeba smile


Interface status:
interface wwan is online and tracking is active
interface wan is online and tracking is active

Current ipv4 policies:
balanced:
wan (40%)
wwan (60%)

wan_only:
wan (100%)

wan_wwan:
wan (100%)

wwan_only:
wwan (100%)

wwan_wan:
wwan (100%)


Current ipv6 policies:
balanced:
default

wan_only:
default

wan_wwan:
default

wwan_only:
default

wwan_wan:
default


Directly connected ipv4 networks:
127.255.255.255
192.168.0.109
192.168.1.1
192.168.0.255
127.0.0.0
192.168.1.0
192.168.3.255
127.0.0.0/8
192.168.1.255
127.0.0.1
192.168.3.0/24
192.168.1.0/24
192.168.0.0
224.0.0.0/3
192.168.3.0
192.168.3.2
192.168.0.0/24

Directly connected ipv6 networks:
fd6d:faf:477e::/64
fe80::/64

Active ipv4 user rules:
  190 14703 S https  tcp  --  *      *       0.0.0.0/0            0.0.0.0/0            multiport sports 0:65535 multiport dports 443
   71  4292 S host100  all  --  *      *       192.168.1.190        0.0.0.0/0           
   54  7583 - wwan_wan  all  --  *      *       0.0.0.0/0            0.0.0.0/0           

Active ipv6 user rules:
    0     0 S https  tcp      *      *       ::/0                 ::/0                 multiport sports 0:65535 multiport dports 443
  245 71419 - wwan_wan  all      *      *       ::/0                 ::/0

11

Odp: Mwan3 i problem z Rules

Cezary napisał/a:

Interface status:
interface wwan is error and tracking is active
interface wan is error and tracking is active

Nie wiem co ci działa prawidłowo ale mwan3 nie widzi aktywności tych interfejsów. Więc chyba nawet nie działa i wszystko leci na domyślnym routingu.

Właśnie ja takie coś miałem, ponieważ w pakiecie mwan3 a dokładnie w jego zależnościach nie ma ip-full.
Pakiet kompiluje się poprawnie, instaluje się poprawnie ale występują takie błędy jak "error" na interfejsach.
Niedawno założyłem temat o szybkość wprowadzania zmian w pakietach bo problem jest cały czas nie rozwiązany sad

* WR1043v1 16MB@64MB * || * WT3020-16MB * || * Xiaomi Miwifi Mini *
* E3276 HiLink + RTL2832 + IT9135 + Siano + EC103 *

12

Odp: Mwan3 i problem z Rules

Ktoś wie dlaczego w mwan3 jest konieczne wymuszenie adresów dnsów na wanach na inne, niezależne od naszych dostawców internetu? Taką informacje znalazłem w poradniku Cezarego

13

Odp: Mwan3 i problem z Rules

Ponieważ jak zostawisz dnsy określonego dostawcy to mogą one być nieosiągalne lub może być zablokowany dostęp do nich   z łącza drugiego dostawcy. Więc się nigdzie nie dostaniesz bo dnsy nie będą działać.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

14

Odp: Mwan3 i problem z Rules

Dzięki, teraz to ma sens.