101

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

Pewnie nie, bo i dlaczego miał by to robić.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

102

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

Chetnie przetestuje na TP-LINK TD-W8970 (lantiq/xrx200)

@Cezary mozna prosic o builda?

103

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

Nie, nie buduję lede dla lantiq.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

104

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

Tak z ciekawości, jest jakiś konkretny powód?

105

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

Że nie buduję? Nie mam sprzętu i nie używam go, więc nie mam na czym testować obrazów, a budowanie dla samego faktu budowania mija się z celem.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

106

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

Kolejna nowinka: https://forum.lede-project.org/t/netfil … at/10237/5

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

107

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

Cezary napisał/a:

Staruszek 1043v1 jest w stanie uzyskać ponad 500Mbps przepustowości przy natowaniu! Należy pamiętać że to były tylko testy, w rzeczywistym środowisku (wiele różnego ruchu, wielu klientów, wiele połączeń, różne rzeczy uruchomione na routerze) może być trochę mniej. Ale to i tak daje przyrost wydajności o ok 130%, co jest bardzo dobrym wynikiem.

Czy próbowałeś wykonać pomiar temperatury chipsetów, aby oszacować ryzyko spalenia?

108

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

Nie, żadnego pomiaru temperatury nie robiłem.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

109 (edytowany przez yabba235 2018-01-05 09:06:12)

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

Cezary, czy przypadkiem nie ma błędu z nazwie kernela w depency modułów fast i short ?
Musiałem je instalować z --force-depends, bo:

root@LEDE:~# opkg install kmod-fast-classifier kmod-shortcut-fe
Upgrading kmod-fast-classifier on root from 4.4.87-1 to 4.4.108-1...
Downloading http://dl.eko.one.pl/lede/17.01-SNAPSHO … neric/kmod                                                              s-4.4.108/kmod-fast-classifier_4.4.108-1_mips_24kc.ipk
Upgrading kmod-shortcut-fe on root from 4.4.87-1 to 4.4.108-1...
Downloading http://dl.eko.one.pl/lede/17.01-SNAPSHO … neric/kmod                                                              s-4.4.108/kmod-shortcut-fe_4.4.108-1_mips_24kc.ipk
Collected errors:
* satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-                                                              fast-classifier:
*      kernel (= 4.4.108-1-49fe7b7b90941ba34712ca3f8fae621c) *
* opkg_install_cmd: Cannot install package kmod-fast-classifier.
* satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-                                                              shortcut-fe:
*      kernel (= 4.4.108-1-49fe7b7b90941ba34712ca3f8fae621c) *
* opkg_install_cmd: Cannot install package kmod-shortcut-fe.

Oczywiśćie wszystko działa smile

wndr3700v2 OpenWRT  SNAPSHOT r8055-6e80dd58bb / LuCI Master (git-18.275.54026-a900014), modem fiber ZTE 660, NAS Qnap 453mini 3x3TB WD RED, net 250/25Mb/s, hackintosh

110

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

Nie, wszystko jest dobrze. Za to ty masz coś pomieszane w systemie to masz system z kernelem 4.4.87 a robisz upgrade modemów 4.4.108 - więc do innej wersji.

Jakim cudem to zrobiłeś? Upgrade starej wersji z extrootem?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

111

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

Cezary napisał/a:

Nie, wszystko jest dobrze. Za to ty masz coś pomieszane w systemie to masz system z kernelem 4.4.87 a robisz upgrade modemów 4.4.108 - więc do innej wersji.

Jakim cudem to zrobiłeś? Upgrade starej wersji z extrootem?


Nie, spokojnie ja ma dobrego kernela:

root@LEDE:~# uname -a
Linux LEDE 4.4.108 #0 Sat Dec 30 10:05:44 2017 mips GNU/Linux

Właśnie jestem po aktualizacji, tylko sie zdziwiłem przy instalowaniu modułów mam taki kwiatek smile

wndr3700v2 OpenWRT  SNAPSHOT r8055-6e80dd58bb / LuCI Master (git-18.275.54026-a900014), modem fiber ZTE 660, NAS Qnap 453mini 3x3TB WD RED, net 250/25Mb/s, hackintosh

112

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

Więc skąd w systemie po aktualizacji miałeś moduły w wersji 4.4.87?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

113

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

Cezary napisał/a:

Więc skąd w systemie po aktualizacji miałeś moduły w wersji 4.4.87?

Szczerze to nie wiem, pewnie coś się popsuło kiedy nie wystartował mi exroot.

Nieważne, teraz już wszystko hula smile

wndr3700v2 OpenWRT  SNAPSHOT r8055-6e80dd58bb / LuCI Master (git-18.275.54026-a900014), modem fiber ZTE 660, NAS Qnap 453mini 3x3TB WD RED, net 250/25Mb/s, hackintosh

114 (edytowany przez soulafein83 2018-01-29 12:35:53)

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

Mogę tylko powiedzieć, że po zmianie łącza z 100/20 na 300/300 poczułem potrzebę zmiany softu mojego wysłużonego tl wdr3600. Bo mimwo wszystko nie chciało być tak szybko jak powinno
Wgrałem najnowsze Luci Lede zamiast Gargoyle PL 1.9. Oczywiście mod też smile
Odczułem znaczącą poprawę ! Nawet Wifi dostało skrzydeł (szybkość pobierania co najmniej 2 krotnie smile choć już pędzę po nowy dłuższy kabel Ethernet bo wcześniej stacjonarka po wifi chodziła, a chce na maksa wykorzystać łącze.
Czekam teraz na Gargoyla najnowszego (chyba już z Chaos Calmer wycisnęli już wszystko) z FastPath i łatwiejszą (IMHO) konfiguracją niż Luci Lede...dzięki

115

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

U mnie jakby bez różnicy...średnio bandwitch 220Mbit
mam wdr4300 z lede - w logach fast sie podnosi.

Linux version 4.4.102 (cezary@eko.one.pl) (gcc version 5.4.0 (LEDE GCC 5.4.0 r3103-1b51a49) ) #0 Fri Dec 8 13:17:38 2017
root@LEDE:~# iperf3 -s
-----------------------------------------------------------
Server listening on 5201
-----------------------------------------------------------
Accepted connection from 192.168.77.54, port 60167
[  5] local 192.168.77.1 port 5201 connected to 192.168.77.54 port 60168
[ ID] Interval           Transfer     Bandwidth
[  5]   0.00-1.00   sec  21.3 MBytes   179 Mbits/sec
[  5]   1.00-2.01   sec  30.8 MBytes   256 Mbits/sec
[  5]   2.01-3.00   sec  25.5 MBytes   215 Mbits/sec
[  5]   3.00-4.00   sec  22.7 MBytes   191 Mbits/sec
[  5]   4.00-5.00   sec  24.2 MBytes   203 Mbits/sec
[  5]   5.00-6.00   sec  28.3 MBytes   237 Mbits/sec
[  5]   6.00-7.00   sec  27.2 MBytes   230 Mbits/sec
[  5]   7.00-8.00   sec  26.6 MBytes   223 Mbits/sec
[  5]   8.00-9.01   sec  28.4 MBytes   237 Mbits/sec
[  5]   9.01-10.00  sec  26.9 MBytes   227 Mbits/sec
[  5]  10.00-10.16  sec  4.75 MBytes   244 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  5]   0.00-10.16  sec  0.00 Bytes  0.00 bits/sec                  sender
[  5]   0.00-10.16  sec   267 MBytes   220 Mbits/sec                  receiver
-----------------------------------------------------------
Server listening on 5201
-----------------------------------------------------------
^Ciperf3: interrupt - the server has terminated
root@LEDE:~# iperf3 -c 192.168.77.54
Connecting to host 192.168.77.54, port 5201
[  4] local 192.168.77.1 port 42614 connected to 192.168.77.54 port 5201
[ ID] Interval           Transfer     Bandwidth       Retr  Cwnd
[  4]   0.00-1.05   sec  11.7 MBytes  93.2 Mbits/sec    0    130 KBytes
[  4]   1.05-2.00   sec  12.9 MBytes   114 Mbits/sec    0    130 KBytes
[  4]   2.00-3.00   sec  13.2 MBytes   111 Mbits/sec    0    130 KBytes
[  4]   3.00-4.00   sec  13.5 MBytes   113 Mbits/sec    0    130 KBytes
[  4]   4.00-5.00   sec  13.3 MBytes   112 Mbits/sec    0    141 KBytes
[  4]   5.00-6.00   sec  13.6 MBytes   114 Mbits/sec    0    149 KBytes
[  4]   6.00-7.00   sec  13.3 MBytes   111 Mbits/sec    0    149 KBytes
[  4]   7.00-8.00   sec  13.5 MBytes   113 Mbits/sec    0    149 KBytes
[  4]   8.00-9.00   sec  13.3 MBytes   111 Mbits/sec    0    149 KBytes
[  4]   9.00-10.00  sec  13.6 MBytes   114 Mbits/sec    0    149 KBytes
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth       Retr
[  4]   0.00-10.00  sec   132 MBytes   111 Mbits/sec    0             sender
[  4]   0.00-10.00  sec   132 MBytes   110 Mbits/sec                  receiver

iperf Done.

116

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

zapewne  źle robisz test 

local 192.168.77.1 port 5201 connected to 192.168.77.54 port 60168

stawiam  ze testujesz  iperf  router   iperf komputer do lan   
test  prawidłowy  : z WAN  do LAN    ( jeden komputer do  WAN   drugi do  LAN  )

117

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

ad2014 napisał/a:

zapewne  źle robisz test 

local 192.168.77.1 port 5201 connected to 192.168.77.54 port 60168

stawiam  ze testujesz  iperf  router   iperf komputer do lan   
test  prawidłowy  : z WAN  do LAN    ( jeden komputer do  WAN   drugi do  LAN  )

Ok, racja mój błąd.
Dzięki

118 (edytowany przez Jan89 2018-02-10 18:37:34)

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

Hej smile Choć śledzę już od jakiegoś czasu ten zacny portal i forum, to będzie mój pierwszy wpis smile Cześć wszystkim! smile

Tutaj jeszcze chyba nikt nie zgłaszał takiego problemu, ale chce się podzielić jego rozwiązaniem - komuś może się przydać.
Mam TP-Link TL-WDR4300 który po uruchomieniu z fast-classifier jest sprzętem nie do poznania jeśli chodzi o prędkość. Niestety ten moduł popsuł moje połączenia vpn site-to-site oparte na Strongswanie. Dodam że problem może dotyczyć też innych funkcjonalności, a rozwiązanie może być podobne.
W skrócie: fast-classifier wybiera połączenia do offloadingu (jak to nazwać po polsku? smile ) na podstawie tego co znajduje się w tabeli conntrack w systemie. Robi to dopiero jak po nawiązaniu połączenia przesłana zostanie jakaś liczba pakietów.
Okazuje się że w momencie gdy połączenia między moimi lokalnymi sieciami znalazły się w conntracku po po kilku sekundach połączenia tcp zamrażały się (mimo że ping ciągle działał). W związku z tym że conntracka potrzebujemy przeważnie tylko do realizowania połączeń LAN->WAN postanowiłem wyłączyć śledzenie połączeń dla moich sieci lokalnych. Tutaj conntrack nie jest potrzebny, wystarczą tabele routingu. Wyłączenie śledzenia można zrobić przy pomocy iptables (192.168.0.1 do adres routera):

iptables -t raw -A PREROUTING -m iprange --src-range 192.168.0.2-192.168.1.254 --dst-range 192.168.0.2-192.168.1.254 -j CT --notrack

Okazało się że to całkowicie rozwiązało problemy z moimi tunelami site-to-site przy włączonym fast classifierze:)
W większych szczegółach opisałem to w blogpoście:
https://taczanowski.net/strongswan-ipse … e-modules/

Pozdrawiam!:)

119

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

Jan89 napisał/a:

do offloadingu (jak to nazwać po polsku?

"Odciążanie"

Modem: Cisco EPC3008 (Multimedia)
Router: Tp-Link TL-WR1043ND
Soft: OpenWRT, Gargoyle 1.9.2.2 (r39585)

120

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

W wersji rozwojowej jest dostępny taki patch: https://github.com/openwrt/openwrt/comm … 551f0f2b98

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

121

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

1.Jak wrzucić tego patcha  do swojej kompilacji  ?
2.Czy nie będzie się to gryzło z fast patch ?
3.Czy  ta reguła do iptables  jest juz w tym zawarta czy potem trza ją dodać ?
4.Czy to jest może to o czym pisał @pepe2k

Odp: Nexx WT3020 vs WNDR4300 lub podobne
Cezary napisał/a:
I możesz się nie doczekać. Fastpath nie został dołączony do lede i jakoś nie ma jasnych wizji żeby tak się stało.

Nigdy nie zostanie dołączony, będzie co innego.

122

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

1. to już jest wrzucone. Musisz mieć system który na 4.14 działa, inaczej nie będzie działać.
2. nie, bo fastpatha przecież nie ma
3. na razie to pytanie jak to użyć
4. to jest to

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

123

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

TP-Link TL-WDR3600 v1 - bez modułów z włączonym SQM QoS nie wyrabiał przy łączu 120 MBit/10 MBit. Download oscylował w okolicy 80-90 MBit, obciążenie CPU koszmarne. Bez SQM wysyca oczywiście w pełni łącze UPC, ale wtedy ping rośnie do około 500ms.

Z fastpath jest ok, SQM trzyma pinga na poziomie bez fastpath i wyciąga tyle, ile ustawiłem w limicie download-u.

Innych testów nie robiłem, zależało mi na wykorzystaniu pełnej przepustowości łacza z włączonym SQM i teraz jest to możliwe.
Anomalii nie zauważyłem, ale poza Luci, upnp i modemem 3g nie mam innych rzeczy na routerze (żadnych VPN itp).

124 (edytowany przez miguelos 2018-05-10 13:45:12)

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

A czy ktos testowal netfilter offload ? :
https://forum.lede-project.org/t/netfil … -nat/10237

125

Odp: Test wydajności routera TP-LINK TL-WR1043NDv1 z GRO i SFE/fastpath

Zależy od platformy. Np. na mt7621 wykrzacza się kernel w niektórych momentach...

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.