Temat: Zmiana mocy radia Wifi

Witam
Sprzęt to TL-WR1043ND_V2 umiejscowiony na strychu,do pokonania Wifi ma 2 żelbetonowe stropy.Miałem wgrane  gargoyle-1.6.2.2 ,moc radia Wifi ustawiona na max coś około 25 dBm i wszystko hulało jak należy ale przyszła pora na zmianę  gargoyle.
Wgrałem gargoyle 1.10.0.1 no i zasięg się zmniejszył,na parterze nie jest już tak fajnie jak było(nie mówiąc już o piwnicy).
Poczytałem forum i w jednym z postów @Cezary pisze by:" w  /etc/config/wireless zmień country pl na us",u mnie to nie działa może dlatego że odnosiło się to do innego routera. Wygląda to tak:
Frequencies:
                        * 2412 MHz [1] (20.0 dBm)
                        * 2417 MHz [2] (20.0 dBm)
                        * 2422 MHz [3] (20.0 dBm)
                        * 2427 MHz [4] (20.0 dBm)
                        * 2432 MHz [5] (20.0 dBm)
                        * 2437 MHz [6] (20.0 dBm)
                        * 2442 MHz [7] (20.0 dBm)
                        * 2447 MHz [8] (20.0 dBm)
                        * 2452 MHz [9] (20.0 dBm)
                        * 2457 MHz [10] (20.0 dBm)
                        * 2462 MHz [11] (20.0 dBm)
                        * 2467 MHz [12] (disabled)
                        * 2472 MHz [13] (disabled)
                        * 2484 MHz [14] (disabled)
Po zmianie na PL kanał 12,13 są aktywne,czy jest możliwe zwiększenie mocy radja Wifi na gargoyle 1.10.0.1,jeżeli tak to może jakas podpowiedz co zmienić/dopisac/wykasować w pliku wireless bo sama zmiana option country 'PL' na 'US' nic nie daje.

   config wifi-device 'radio0'
    option type 'mac80211'
    option channel '11'
    option hwmode '11g'
    option path 'platform/qca955x_wmac'
    option htmode 'HT20'
    option disabled '0'
    option noscan '1'
    option country 'PL'

config wifi-iface 'ap_g'
    option device 'radio0'
    option network 'lan'
    option mode 'ap'
    option ssid 'Gargoyle'
    option encryption 'psk'
    option key 'password'
Dziękuje za pomoc i serdeczne dzięki za prace nad Gargoyle.
Pozdrawiam
Wiech

TL-WR1043ND V2 Gargoyle/WRT54GL Tomato

2

Odp: Zmiana mocy radia Wifi

Podobny temat tutaj https://eko.one.pl/forum/viewtopic.php?id=1099

TP-Link TL-WDR3600 v1.5 -  OpenWrt Chaos Calmer 15.05.1 with Luci +Microsoft LifeCam VX-3000
RaspberryPi 2 - OMV Stone Burner 2.0.15 +Creative SB Play +Medion OR24V +DVB-T Media-Tech MT4163  +MP00202AC +3xDS18B20 +HIH-4000-002 +MPXHZ6115A +Samsung SPF-85H +D-Link DUB-H7

3

Odp: Zmiana mocy radia Wifi

Usuń w ogóle opcję county i zrestartuj cały router. To będzie max ile ten sprzęt potrafi.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

4

Odp: Zmiana mocy radia Wifi

Wywaliłem cała linijkę county ale nie wiem po czym poznać czy się coś zmieniło bo mam takie coś:
login as: root
root@192.168.1.1's password:


BusyBox v1.23.2 (2017-10-10 19:58:00 CEST) built-in shell (ash)


             _____                             _
            |  __ \                           | |
            | |  \/ __ _ _ __ __ _  ___  _   _| | ___
            | | __ / _` | '__/ _` |/ _ \| | | | |/ _ \
            | |_\ \ (_| | | | (_| | (_) | |_| | |  __/
             \____/\__,_|_|  \__, |\___/ \__, |_|\___|
                              __/ |       __/ |
                             |___/       |___/

----------------------------------------------------------------
|                                                              |
| Gargoyle PL 1.10.0.1 (1e70343)                               |
| OpenWrt Chaos Calmer 15.05.1 (r49577)                        |
| Build time: 2017-10-28 07:40 CEST                            |
|                                                              |
| Cezary Jackiewicz (obsy), http://eko.one.pl                  |
|                                                              |
----------------------------------------------------------------
| Machine: TP-Link TL-WR1043N/ND v2                            |
| Uptime: 0d, 00:01:06                                         |
| Load: 0.95 0.34 0.12                                         |
| Flash: total: 896KB, free: 652KB, used: 27%                  |
| Memory: total: 59.6MB, free: 42.7MB, used: 28%               |
| WAN:                                                         |
| LAN: 192.168.1.1, leases: 0                                  |
| radio0: mode: ap, ssid: Gargoyle, channel: 11, conn: 0       |
----------------------------------------------------------------
root@Gargoyle:~# iw list
Wiphy phy0
        max # scan SSIDs: 4
        max scan IEs length: 2257 bytes
        max # sched scan SSIDs: 0
        max # match sets: 0
        Retry short limit: 7
        Retry long limit: 4
        Coverage class: 0 (up to 0m)
        Device supports AP-side u-APSD.
        Device supports T-DLS.
        Available Antennas: TX 0x7 RX 0x7
        Configured Antennas: TX 0x7 RX 0x7
        Supported interface modes:
                 * IBSS
                 * managed
                 * AP
                 * AP/VLAN
                 * WDS
                 * monitor
                 * mesh point
                 * P2P-client
                 * P2P-GO
                 * outside context of a BSS
        Band 1:
                Capabilities: 0x11ef
                        RX LDPC
                        HT20/HT40
                        SM Power Save disabled
                        RX HT20 SGI
                        RX HT40 SGI
                        TX STBC
                        RX STBC 1-stream
                        Max AMSDU length: 3839 bytes
                        DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: 8 usec (0x06)
                HT TX/RX MCS rate indexes supported: 0-23
                Frequencies:
                        * 2412 MHz [1] (20.0 dBm)
                        * 2417 MHz [2] (20.0 dBm)
                        * 2422 MHz [3] (20.0 dBm)
                        * 2427 MHz [4] (20.0 dBm)
                        * 2432 MHz [5] (20.0 dBm)
                        * 2437 MHz [6] (20.0 dBm)
                        * 2442 MHz [7] (20.0 dBm)
                        * 2447 MHz [8] (20.0 dBm)
                        * 2452 MHz [9] (20.0 dBm)
                        * 2457 MHz [10] (20.0 dBm)
                        * 2462 MHz [11] (20.0 dBm)
                        * 2467 MHz [12] (disabled)
                        * 2472 MHz [13] (disabled)
                        * 2484 MHz [14] (disabled)
        valid interface combinations:
                 * #{ managed } <= 2048, #{ AP, mesh point } <= 8, #{ P2P-client, P2P-GO } <= 1, #{ IBSS } <= 1,
                   total <= 2048, #channels <= 1, STA/AP BI must match, radar detect widths: { 20 MHz (no HT), 20 MHz, 40 MHz }

                 * #{ WDS } <= 2048,
                   total <= 2048, #channels <= 1, STA/AP BI must match
        HT Capability overrides:
                 * MCS: ff ff ff ff ff ff ff ff ff ff
                 * maximum A-MSDU length
                 * supported channel width
                 * short GI for 40 MHz
                 * max A-MPDU length exponent
                 * min MPDU start spacing
root@Gargoyle:~#

TL-WR1043ND V2 Gargoyle/WRT54GL Tomato

5

Odp: Zmiana mocy radia Wifi

iw reg get

pokaże 00 lub US zamiast PL

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

6

Odp: Zmiana mocy radia Wifi

Pokazało US:
login as: root
root@192.168.1.1's password:


BusyBox v1.23.2 (2017-10-10 19:58:00 CEST) built-in shell (ash)


             _____                             _
            |  __ \                           | |
            | |  \/ __ _ _ __ __ _  ___  _   _| | ___
            | | __ / _` | '__/ _` |/ _ \| | | | |/ _ \
            | |_\ \ (_| | | | (_| | (_) | |_| | |  __/
             \____/\__,_|_|  \__, |\___/ \__, |_|\___|
                              __/ |       __/ |
                             |___/       |___/

----------------------------------------------------------------
|                                                              |
| Gargoyle PL 1.10.0.1 (1e70343)                               |
| OpenWrt Chaos Calmer 15.05.1 (r49577)                        |
| Build time: 2017-10-28 07:40 CEST                            |
|                                                              |
| Cezary Jackiewicz (obsy), http://eko.one.pl                  |
|                                                              |
----------------------------------------------------------------
| Machine: TP-Link TL-WR1043N/ND v2                            |
| Uptime: 0d, 00:25:08                                         |
| Load: 0.07 0.02 0.00                                         |
| Flash: total: 896KB, free: 652KB, used: 27%                  |
| Memory: total: 59.6MB, free: 42.9MB, used: 27%               |
| WAN:                                                         |
| LAN: 192.168.1.1, leases: 0                                  |
| radio0: mode: ap, ssid: Gargoyle, channel: 11, conn: 0       |
----------------------------------------------------------------
root@Gargoyle:~# iw reg get
global
country US: DFS-FCC
        (2402 - 2472 @ 40), (N/A, 30), (N/A)
        (5170 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW
        (5250 - 5330 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW
        (5490 - 5730 @ 160), (N/A, 23), (0 ms), DFS
        (5735 - 5835 @ 80), (N/A, 30), (N/A)
        (57240 - 63720 @ 2160), (N/A, 40), (N/A)

phy#0
country US: DFS-FCC
        (2402 - 2472 @ 40), (N/A, 30), (N/A)
        (5170 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW
        (5250 - 5330 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW
        (5490 - 5730 @ 160), (N/A, 23), (0 ms), DFS
        (5735 - 5835 @ 80), (N/A, 30), (N/A)
        (57240 - 63720 @ 2160), (N/A, 40), (N/A)

global
country US: DFS-FCC
        (2402 - 2472 @ 40), (N/A, 30), (N/A)
        (5170 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW
        (5250 - 5330 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW
        (5490 - 5730 @ 160), (N/A, 23), (0 ms), DFS
        (5735 - 5835 @ 80), (N/A, 30), (N/A)
        (57240 - 63720 @ 2160), (N/A, 40), (N/A)

root@Gargoyle:~#
Mam rozumieć że teraz moc jest maksymalna dla tego sprzętu,czyli około 25 dBm  jak było na  gargoyle-1.6.2.2 ?

TL-WR1043ND V2 Gargoyle/WRT54GL Tomato

7

Odp: Zmiana mocy radia Wifi

Maksymalna dla sprzętu. A ile on ma konkretnie to już musisz sobie zobaczy w pomiarach fccid.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

8

Odp: Zmiana mocy radia Wifi

Bardzo dziękuje po testuje i zobaczę jak to chodzi.
Dzięki za wszystko i Szczęśliwego Nowego Roku Tobie i dla wszystkich forumowiczów.

TL-WR1043ND V2 Gargoyle/WRT54GL Tomato

9

Odp: Zmiana mocy radia Wifi

wybaczcie, że odgrzeje temat, ale o co chodzi z :

iw reg get
global
country RU: DFS-ETSI
        (2402 - 2482 @ 40), (N/A, 20), (N/A)
        (5170 - 5250 @ 80), (N/A, 20), (N/A), AUTO-BW
        (5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS, AUTO-BW
        (5650 - 5730 @ 80), (N/A, 30), (0 ms), DFS
        (5735 - 5835 @ 80), (N/A, 30), (N/A)
        (57000 - 66000 @ 2160), (N/A, 40), (N/A)

phy#1
country US: DFS-FCC
        (2402 - 2472 @ 40), (N/A, 30), (N/A)
        (5170 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW
        (5250 - 5330 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW
        (5490 - 5730 @ 160), (N/A, 23), (0 ms), DFS
        (5735 - 5835 @ 80), (N/A, 30), (N/A)
        (57240 - 63720 @ 2160), (N/A, 40), (N/A)

phy#0
country US: DFS-FCC
        (2402 - 2472 @ 40), (N/A, 30), (N/A)
        (5170 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW
        (5250 - 5330 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW
        (5490 - 5730 @ 160), (N/A, 23), (0 ms), DFS
        (5735 - 5835 @ 80), (N/A, 30), (N/A)
        (57240 - 63720 @ 2160), (N/A, 40), (N/A)

Mam ustawione RU, a mimo wszystko karty dzialaja w US ?

10

Odp: Zmiana mocy radia Wifi

iw reg set RU; wifi

zrób z konsoli i zobacz znów iw reg get. Jeżeli działa to zastanów się co zepsułeś w konfigu wireless.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

11

Odp: Zmiana mocy radia Wifi

ciagle to samo, konfig standardowy :

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'pci0000:01/0000:01:00.0'
        option htmode 'VHT80'
        option noscan '1'
        option channel '132'
        option disabled '0'
        option country 'RU'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'xxx'
        option encryption 'psk2+ccmp'
        option key 'xxx'
        option wpa_group_rekey '144000'
        option wps_pushbutton '0'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/qca955x_wmac'
        option channel '1'
        option noscan '1'
        option htmode 'HT40'
        option disabled '0'
        option country 'RU'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'xxx'
        option encryption 'psk2+ccmp'
        option key 'xxxx'
        option wpa_group_rekey '14400'
        option wps_pushbutton '0'

12 (edytowany przez Cezary 2018-05-11 14:16:27)

Odp: Zmiana mocy radia Wifi

Zrestartuj go. Jaki to router? I jaki obraz masz wgrany?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

13

Odp: Zmiana mocy radia Wifi

Archer C5, zrobie pozniej reboota, US chyba i tak lepszy. Z tego co widze, to DFS jest wszedzie

14

Odp: Zmiana mocy radia Wifi

Skąd masz obraz?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

15

Odp: Zmiana mocy radia Wifi

twoj ostatni obraz smile
Reboot (17.01-SNAPSHOT, r3876-efb6ca1)
Build time: 2018-04-20 18:47 CEST

16

Odp: Zmiana mocy radia Wifi

A czy w ogóle jest "RU" na liście w Openwrt?
bo na różnych innych stronach nie ma tego w opcjach:
https://w.wol.ph/2015/08/28/maximum-wif … r-country/
https://www.cisco.com/c/en/us/td/docs/w … cscod.html

* WR1043v1 16MB@64MB * || * WT3020-16MB * || * Xiaomi Miwifi Mini *
* E3276 HiLink + RTL2832 + IT9135 + Siano + EC103 *

17

Odp: Zmiana mocy radia Wifi

A co daje ten DFS?
U mnie kanaly bez tego DFS mają większą możliwą moc.

Archer C7 v2 Lede Luci

18

Odp: Zmiana mocy radia Wifi

DFS sam w sobie nic nie daje. Natomiast jeżeli masz ustawiony kanał z DFS to jeżeli sterownik wykryje coś na tym kanale (radar meteo) to od razu przełączy kanał na inny bo pasmo jesy wykorzystywane. W polsce masz używać DFS.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.