101

Odp: Plugin 3ginfo do gargoyle

Nie obsługuje  i nigdy nie obsługiwało. Możesz odczytać kilka modemów zmieniając device w konfigu i wołając 3ginfo.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

102

Odp: Plugin 3ginfo do gargoyle

Witam.
Wrzuciłem ten plugin do mojego 1043ND i niby wszystko działa ale w statusie mam Rozłączono mimo tego ze modem jest połączony i internet hula. Czy to jest przypadłość tego routera czy po prostu jest coś skopane w ustawieniach u mnie?? Modem E3131 bez hilink, fw openwrt 15.05.1

103

Odp: Plugin 3ginfo do gargoyle

uci show network
uci show 3ginfo
3ginfo-test

pokaż.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

104

Odp: Plugin 3ginfo do gargoyle

network.loopback=interface
network.loopback.ifname='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.globals.ula_prefix='fd16:34fd:72b6::/48'
network.lan=interface
network.lan.ifname='eth0.1'
network.lan.force_link='1'
network.lan.type='bridge'
network.lan.proto='static'
network.lan.ipaddr='192.168.1.1'
network.lan.netmask='255.255.255.0'
network.lan.ip6assign='60'
network.wan=interface
network.wan.ifname='eth0.2'
network.wan.proto='dhcp'
network.wan6=interface
network.wan6.ifname='eth0.2'
network.wan6.proto='dhcpv6'
network.@switch[0]=switch
network.@switch[0].name='switch0'
network.@switch[0].reset='1'
network.@switch[0].enable_vlan='1'
network.@switch_vlan[0]=switch_vlan
network.@switch_vlan[0].device='switch0'
network.@switch_vlan[0].vlan='1'
network.@switch_vlan[0].ports='1 2 3 4 5t'
network.@switch_vlan[1]=switch_vlan
network.@switch_vlan[1].device='switch0'
network.@switch_vlan[1].vlan='2'
network.@switch_vlan[1].ports='0 5t'
network.3G=interface
network.3G.proto='3g'
network.3G.device='/dev/ttyUSB0'
network.3G.service='umts'
network.3G.apn='internet'
network.3G.password='admin'
network.3G.dialnumber='*99***1#'
 

3g info


3ginfo.@3ginfo[0]=3ginfo
3ginfo.@3ginfo[0].http_port='81'
3ginfo.@3ginfo[0].language='pl'
3ginfo.@3ginfo[0].network='wan'
3ginfo.@3ginfo[0].device='/dev/ttyUSB2'

3ginfo test


+CSQ: 21,99
^CSNR: -71,-5
^SYSINFO:2,3,0,5,1,,9
+COPS: 0,2,"26003",2
+CREG: 2,1,"E61E","A4DC"
+CGREG: 2,1,"E61E","A4DC"
+CGEQNEG: 1,2,5440,21000,0,0,0,1500,"1E4","4E3",0,1000,3
DEVICE:huawei E3131
---------------------------------------------------------------
/dev/tty      /dev/ttyS11   /dev/ttyS15   /dev/ttyS5    /dev/ttyS9
/dev/ttyS0    /dev/ttyS12   /dev/ttyS2    /dev/ttyS6    /dev/ttyUSB0
/dev/ttyS1    /dev/ttyS13   /dev/ttyS3    /dev/ttyS7    /dev/ttyUSB1
/dev/ttyS10   /dev/ttyS14   /dev/ttyS4    /dev/ttyS8    /dev/ttyUSB2
---------------------------------------------------------------

T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480  MxCh= 1
B:  Alloc=  1/800 us ( 0%), #Int=  1, #Iso=  0
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0002 Rev= 3.18
S:  Manufacturer=Linux 3.18.23 ehci_hcd
S:  Product=EHCI Host Controller
S:  SerialNumber=ehci-platform
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  0mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   4 Ivl=256ms

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=480  MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=12d1 ProdID=1506 Rev= 1.02
S:  Manufacturer=HUAWEI
S:  Product=HUAWEI Mobile
C:* #Ifs= 5 Cfg#= 1 Atr=80 MxPwr=500mA
I:* If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=02 Prot=01 Driver=option
E:  Ad=81(I) Atr=03(Int.) MxPS=  64 Ivl=2ms
E:  Ad=82(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=4ms
I:* If#= 1 Alt= 0 #EPs= 1 Cls=ff(vend.) Sub=02 Prot=16 Driver=(none)
E:  Ad=83(I) Atr=03(Int.) MxPS=  64 Ivl=2ms
I:  If#= 1 Alt= 1 #EPs= 3 Cls=ff(vend.) Sub=02 Prot=16 Driver=(none)
E:  Ad=83(I) Atr=03(Int.) MxPS=  64 Ivl=2ms
E:  Ad=84(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=4ms
I:* If#= 2 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=02 Prot=03 Driver=option
E:  Ad=85(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=03(O) Atr=02(Bulk) MxPS= 512 Ivl=4ms
I:* If#= 3 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=02 Prot=02 Driver=option
E:  Ad=86(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=04(O) Atr=02(Bulk) MxPS= 512 Ivl=4ms
I:* If#= 4 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=(none)
E:  Ad=05(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=87(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
---------------------------------------------------------------
3ginfo.@3ginfo[0]=3ginfo
3ginfo.@3ginfo[0].http_port='81'
3ginfo.@3ginfo[0].language='pl'
3ginfo.@3ginfo[0].network='wan'
3ginfo.@3ginfo[0].device='/dev/ttyUSB2'

105

Odp: Plugin 3ginfo do gargoyle

Po prostu nie ustawiłeś tego. Sekcję modemu nazwałeś 3G a w samym 3ginfo jest domyślnie ustawiona sekcja wan

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

106

Odp: Plugin 3ginfo do gargoyle

Juz wszystko śmiga. Dzieki za pomoc smile

107 (edytowany przez intruder 2016-09-28 22:34:11)

Odp: Plugin 3ginfo do gargoyle

Gargoyle v1.9.1.1 wgrane niedawno po 1.6.2.2, gdzie miałem 3ginfo-text.

Teraz zainstalowałem "zwykłe" i Mozilla nie pokazuje mi nic na stronie 192.168.2.1, a tuż po instalacji normalnie przeglądałem parametry sieci.
W IE, gdy wezmę diagnozowanie mam komunikat: "Zdalne urządzenie lub zasób nie akceptuje połączenia. Konfiguracja urządzenia lub zasobu nie umożliwia akceptowania połączeń przy użyciu portu hosts2-ns."

Ostatni ruch jaki udało mi się zrobić to kliknąłem na CellID w HEX i mnie przeniosło zamiast na OpenCell na stronę modemu
i od tego momentu mam problem.

uci show network
network.loopback=interface
network.loopback.ifname='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.globals.ula_prefix='fd32:34bb:4abf::/48'
network.lan=interface
network.lan.ifname='eth1'
network.lan.force_link='1'
network.lan.type='bridge'
network.lan.proto='static'
network.lan.netmask='255.255.255.0'
network.lan.ip6assign='60'
network.lan.ipaddr='192.168.2.1'
network.lan.dns='208.67.222.222 208.67.220.220'
network.wan=interface
network.wan.proto='dhcp'
network.wan.ifname='eth2'
network.wan.ipv6='0'
network.wan.dns='208.67.222.222 208.67.220.220'
network.wan.peerdns='0'
network.wan6=interface
network.wan6.ifname='eth0'
network.wan6.proto='dhcpv6'
network.@switch[0]=switch
network.@switch[0].name='switch0'
network.@switch[0].reset='1'
network.@switch[0].enable_vlan='1'
network.@switch_vlan[0]=switch_vlan
network.@switch_vlan[0].device='switch0'
network.@switch_vlan[0].vlan='1'
network.@switch_vlan[0].ports='0 1 2 3 4'
network.@switch_vlan[1]=switch_vlan
network.@switch_vlan[1].device='switch0'
network.@switch_vlan[1].vlan='2'
network.@switch_vlan[1].ports='5 6'
uci show 3ginfo
3ginfo.@3ginfo[0]=3ginfo
3ginfo.@3ginfo[0].http_port='81'
3ginfo.@3ginfo[0].language='pl'
3ginfo.@3ginfo[0].network='wan'
3ginfo.@3ginfo[0].device='192.168.8.1'
 3ginfo test
+CSQ: 19,99
^SYSINFOEX:x,x,x,x,,x,"WCDMA (UMTS)",41,"WCDMA (UMTS)"
+COPS: 0,2,"26001",x
+CREG: 2,1,"wyciąłem","wyciąłem"
^LTERSRP:-,-
^CSNR: -78,-4
DEVICE:huawei E3372 HiLink
---------------------------------------------------------------
/dev/tty     /dev/ttyS10  /dev/ttyS13  /dev/ttyS2   /dev/ttyS5   /dev/ttyS8
/dev/ttyS0   /dev/ttyS11  /dev/ttyS14  /dev/ttyS3   /dev/ttyS6   /dev/ttyS9
/dev/ttyS1   /dev/ttyS12  /dev/ttyS15  /dev/ttyS4   /dev/ttyS7
---------------------------------------------------------------

T:  Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480  MxCh= 1
B:  Alloc=  0/800 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0002 Rev= 3.18
S:  Manufacturer=Linux 3.18.36 ehci_hcd
S:  Product=EHCI Host Controller
S:  SerialNumber=ehci-platform.1
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  0mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   4 Ivl=256ms

T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480  MxCh= 1
B:  Alloc=  1/800 us ( 0%), #Int=  1, #Iso=  0
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0002 Rev= 3.18
S:  Manufacturer=Linux 3.18.36 ehci_hcd
S:  Product=EHCI Host Controller
S:  SerialNumber=ehci-platform.0
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  0mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   4 Ivl=256ms

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=480  MxCh= 0
D:  Ver= 2.10 Cls=02(comm.) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=12d1 ProdID=14dc Rev= 1.02
S:  Manufacturer=HUAWEI_MOBILE
S:  Product=HUAWEI_MOBILE
C:* #Ifs= 3 Cfg#= 1 Atr=c0 MxPwr=  2mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=02(comm.) Sub=06 Prot=00 Driver=cdc_ether
E:  Ad=83(I) Atr=03(Int.) MxPS=  16 Ivl=2ms
I:* If#= 1 Alt= 0 #EPs= 2 Cls=0a(data ) Sub=06 Prot=00 Driver=cdc_ether
E:  Ad=82(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:* If#= 2 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
E:  Ad=84(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=03(O) Atr=02(Bulk) MxPS= 512 Ivl=125us
---------------------------------------------------------------
3ginfo.@3ginfo[0]=3ginfo
3ginfo.@3ginfo[0].http_port='81'
3ginfo.@3ginfo[0].language='pl'
3ginfo.@3ginfo[0].network='wan'
3ginfo.@3ginfo[0].device='192.168.8.1'

Co zrobić żeby ponownie móc podglądać parametry na 192.168.2.1:81? W tej chwili tylko zakładka mi się zmienia na 3G/4G.

108

Odp: Plugin 3ginfo do gargoyle

Nie mam pojęcia co mysli IE pod takim komunikatem.

Masz połączenie z internetem normalnie?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

109 (edytowany przez intruder 2016-09-28 23:02:09)

Odp: Plugin 3ginfo do gargoyle

Wszystko działa jak należy. Ten jak i poprzedni post pisałem z tego łącza.

Myślałem, że mi Adblock blokuje, ale po wyłączeniu ten sam efekt. IE zaś jest "goły".

Kaspersky wyłączony. MBAM też. I nic.

Żeby nie działało od początku - mógłbym sobie darować - jednak korzystałem z tego sposobu kilkadziesiąt minut normalnie.

110

Odp: Plugin 3ginfo do gargoyle

Uruchom z konsoli 3ginfo i zobacz czy będziesz miał postać tekstową. Jak tak - zobacz czy uhttpd masz uruchomiony w tle. Jeżeli tak - wyczyść cache przeglądarki i wbij się na ten adres i zobacz.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

111 (edytowany przez intruder 2016-09-28 23:20:18)

Odp: Plugin 3ginfo do gargoyle

Postać tekstową mam:

3ginfo
Status: Połączony
Czas polaczenia: 0d, 02:00:47
Przeslano danych: 64.2 MiB / 69.4 MiB
Operator: Plus
Tryb pracy: WCDMA (UMTS)
Sila sygnalu: 61%
Urzadzenie: huawei E3372 HiLink
MCC MNC: 260 01
LAC: wykasowałem
CID: wykasowałem
TAC: - (-)
CSQ: 19
RSSI: -75 dBm
RSCP: -78 dBm
Ec/IO: -4 dB
RSRP: - dBm
RSRQ: - dB
uhttpd
Error: No sockets bound, unable to continue

112

Odp: Plugin 3ginfo do gargoyle

To sam serwer uhttpd ci nie działa. Zrób jego restart

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

113 (edytowany przez intruder 2016-09-29 09:20:04)

Odp: Plugin 3ginfo do gargoyle

Po wpisaniu komendy zaczerpniętej stąd: https://wiki.openwrt.org/doc/uci/uhttpd

/etc/init.d/uhttpd restart

nic nie wypluło.

 netstat -nap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State            PID/Program name
tcp        0      0 0.0.0.0:111             0.0.0.0:*               LISTEN           1407/portmap
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN           16859/uhttpd
tcp        0      0 0.0.0.0:53              0.0.0.0:*               LISTEN           16211/dnsmasq
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN           1615/dropbear
tcp        0      0 0.0.0.0:443             0.0.0.0:*               LISTEN           16859/uhttpd
tcp        0    300 192.168.2.1:22          192.168.2.167:65312     ESTABLISHED      16576/dropbear
netstat: /proc/net/tcp6: No such file or directory
udp        0      0 0.0.0.0:53              0.0.0.0:*                                16211/dnsmasq
udp        0      0 0.0.0.0:67              0.0.0.0:*                                16211/dnsmasq
udp        0      0 0.0.0.0:111             0.0.0.0:*                                1407/portmap
udp        0      0 0.0.0.0:123             0.0.0.0:*                                1582/ntpd
netstat: /proc/net/udp6: No such file or directory
netstat: /proc/net/raw6: No such file or directory
Active UNIX domain sockets (servers and established)
Proto RefCnt Flags       Type       State         I-Node PID/Program name    Pat     h
unix  7      [ ]         DGRAM                      1791 1365/logd           /de     v/log
unix  2      [ ACC ]     STREAM     LISTENING        305 522/ubusd           /va     r/run/ubus.sock
unix  2      [ ]         DGRAM                     11877 8921/hostapd        /va     r/run/hostapd/wlan0
unix  2      [ ]         DGRAM                     11678 8625/netifd
unix  3      [ ]         STREAM     CONNECTED      11879 8921/hostapd
unix  3      [ ]         STREAM     CONNECTED       1793 1365/logd
unix  3      [ ]         STREAM     CONNECTED        307 1/procd
unix  2      [ ]         DGRAM                     11693 8625/netifd
unix  3      [ ]         STREAM     CONNECTED        308 522/ubusd           /va     r/run/ubus.sock
unix  2      [ ]         DGRAM                     12003 8921/hostapd
unix  2      [ ]         DGRAM                      2235 1615/dropbear
unix  3      [ ]         STREAM     CONNECTED      11594 522/ubusd           /va     r/run/ubus.sock
unix  2      [ ]         DGRAM                     22652 16211/dnsmasq
unix  3      [ ]         STREAM     CONNECTED       1794 522/ubusd           /va     r/run/ubus.sock
unix  3      [ ]         STREAM     CONNECTED      11880 522/ubusd           /va     r/run/ubus.sock
unix  2      [ ]         DGRAM                      1944 1407/portmap
unix  3      [ ]         STREAM     CONNECTED      11593 8625/netifd

114

Odp: Plugin 3ginfo do gargoyle

/etc/init.d/3ginfo start, bo to co zrobiłeś to tylko nasłuch zwykłego demona, nie procesu od 3ginfo.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

115

Odp: Plugin 3ginfo do gargoyle

Dziękuję, działa.

Zmodyfikowane WebUI potrafi jeszcze odczytać SINR czy też szerokość pasma. Da rade coś takiego dodać?

Piszę z komputera gdzie nie mam konta na 4PDA - jutro postaram się wrzucić obrazki jak to wygląda.

116

Odp: Plugin 3ginfo do gargoyle

Wykonaj

/usr/share/3ginfo/scripts/huawei_hilink.sh 192.168.8.1 debug 

i pokaz wynik. Tym razem nie wycinaj nic, jak nie chcesz wyświetlać tego na forum to wyślij mi mejlem.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

117

Odp: Plugin 3ginfo do gargoyle

Podaj adres to wyślę z CellID i resztą danych. Tylko już jutro, bo za chwilę wychodzę z domu.

118

Odp: Plugin 3ginfo do gargoyle

http://eko.one.pl/?p=kontakt

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

119

Odp: Plugin 3ginfo do gargoyle

SINR dawno dodałem do odczytu z hilinka. Zainstaluj sobie po prostu nową wersję.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.