51

Odp: TP-Link TD-W8980

Nie rób tego uploadu. Jak pojawia się napis "Hit any key to stop autoboot"  to naciśnij t i jesteś w bootloaderze.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

52 (edytowany przez Scotch 2016-06-15 20:23:14)

Odp: TP-Link TD-W8980

@ -pete-

Tam zwyczajnie nie ma instrukcji wgrywania OpenWrt...
Ten fragment dotyczy ratowania routera, po uszkodzeniu bootloadera...

Tak jak pisze Cezary niczego nie zwieraj i nie wrzucaj tego pliku!!!

Podłącz jedynie konwerter szeregowy i rób zgodnie z instrukcją dla W8970: http://eko.one.pl/?p=openwrt-tdw8970

Tu masz bardziej łopatologicznie: http://tplink-forum.pl/porady-serwisowe … /#msg20225

Oczywiście używasz pliku "...sysypgrade.image" dla Twojego routera...

P.S. Oczywiście wiesz o tym, że pod Openwrt nie działa WiFi 5GHz???

53

Odp: TP-Link TD-W8980

@ Cezary, @ Scotch
Dziękuję Panowie za pomoc, wygląda na to, że upload się powiódł - ruter odpowiada na pingi, mogę się na niego telnetować. Nie mogę się natomiast zalogować do interfejsu graficznego - zastanawiam się czy powinienem osobno doinstalować jakiś pakiet (Luici) ? Jeśli tak to prośba o wskazówkę.

załadowana wersja firmware'u: openwrt-15.05-lantiq-xrx200-TDW8980-sysupgrade.image

Jeszcze jedno pytanie - wskażcie mi proszę wersję Gargoyle, która będzie działała z TD-W8980.
---
P.S. Tak jestem świadomy braku 5MHz, ale priorytet to odpalenie modemu LTE/USB.

54

Odp: TP-Link TD-W8980

Jeżeli moje - to zainstalowałeś wersję bez gui. Nie przeczytałeś co obraz ma a czego nie.

Gargoyle nie ma na ten sprzęt.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

55

Odp: TP-Link TD-W8980

Twoje.

Co do Gargoyle, rozumiem.

Jest jakaś alternatywa dla uruchomienia tego sprzętu z obsługą modemu USB ?

56

Odp: TP-Link TD-W8980

Alternatywa? Po prostu wgraj sterowniki, podłącz i używaj, nie rozumiem pytania.

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

57

Odp: TP-Link TD-W8980

Po prostu nie miałem świadomości, że istnieje możliwość wgrania samych sterowników :-)
Modem to : Huawei E3372

Jeśli możesz to udziel mi proszę wskazówek jak to zrobić.

58

Odp: TP-Link TD-W8980

Przeczytaj: http://eko.one.pl/?p=openwrt-3g
http://eko.one.pl/forum/viewtopic.php?id=12021

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

59

Odp: TP-Link TD-W8980

@ Cezary
Dzięki za kolejne wskazówki.
Finalnie załadowałem obraz dla 8970 z LuCI - działa.

Niestety w dalszym ciągu nie mogę uruchomić modemu Huawei E3372 HL.
Zainstalowałem poniższe pakiety:

kmod-usb-core (3.18.23-1)
kmod-usb2 (3.18.23-1)
kmod-mii (3.18.23-1)
kmod-usb-net (3.18.23-1)
kmod-usb-wdm (3.18.23-1)
kmod-usb-net-cdc-ether (3.18.23-1)
wwan (2014-07-17-1)
comgt-ncm (0.32-25)
kmod-usb-serial (3.18.23-1)
kmod-usb-net-qmi-wwan (3.18.23-1)
kmod-usb-net-cdc-ether (3.18.23-1)
kmod-usb-serial-option_3.18.23-1
kmod-usb-serial-wwan_3.18.23-1
usb-modeswitch

/sys/kernel/debug/usb/devices:

T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480  MxCh= 1
B:  Alloc=  0/800 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0002 Rev= 3.18
S:  Manufacturer=Linux 3.18.23 dwc2_hsotg
S:  Product=DWC OTG Controller
S:  SerialNumber=1e101000.ifxhcd
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  0mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   4 Ivl=256ms

T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=480  MxCh= 0
D:  Ver= 2.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=12d1 ProdID=1f01 Rev= 1.02
S:  Manufacturer=HUAWEI_MOBILE
S:  Product=HUAWEI_MOBILE
S:  SerialNumber=0123456789ABCDEF
C:* #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=  2mA
I:* If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=(none)
E:  Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=125us

Widzę, że Driver=(none).
Widzę też Twoją instrukcję pod: http://eko.one.pl/forum/viewtopic.php?id=11470
ale tam pisałeś o modemie nie HL ?

Nie działa przy ustawieniu wan UMTS/GPRS ani w trybie karty sieciowej (HighLink).

Proszę o kolejną podpowiedź :-)

60

Odp: TP-Link TD-W8980

usbmode -s

Uruchom w konsoli

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

61

Odp: TP-Link TD-W8980

@ Cezary.

Zadziałało, okazało się, że pakiet usb-modeswitch był zainstalowany niepoprawnie, albo w całym zamieszaniu nie był zainstalowany. Po ponownej instalacji pakietu z jego zależnościami (librt, libusb) ruszyło.
Modem działa bez zarzutu, Internet dostępny po LAN.

Śliczne dzięki za pomoc.

Teraz walczę z radiem - czy 'niewidoczność' sieci wifi to kwestia tylko konfiguracji, czy może mieć znaczenie niekompatybilność SW---HW (openwrt-15.05-lantiq-xrx200-TDW8970-sysupgrade --- TD-W8980) ?

62

Odp: TP-Link TD-W8980

Openwrt ma domyślnie wyłączone wifi. Włączyłeś je?

Masz niepotrzebny router, uszkodzony czy nie - chętnie przygarnę go.

63

Odp: TP-Link TD-W8980

@-pete-
Po co ładowałeś image dla 8970???
Te modele różnią się właśnie radiem...

Mogłeś doinstalować Luci, lub wybrać np. kompilację Cezarego z Luci: http://dl.eko.one.pl/luci/chaos_calmer/ … rade.image

64

Odp: TP-Link TD-W8980

@ Cezary @Scotch
Miało być szybciej - była dobra lekcja :-)

Skończyło się na załadowaniu wskazanej kompilacji Cezarego z LuCI (nie znalazłem jej wcześniej)

Śmiga i buczy - będę testował.

Jeszcze raz dziękuję Wam za profesjonalną pomoc.
Pozdrawiam